Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: commando in identiek script werkt niet in Xubuntu maar wel in Bodhi  (gelezen 740 keer)

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Ik heb een simpel script gemaakt met een aantal commando’s dat ik al jaren gebruik. Werkt prima. Nou wilde ik er een commando aan toevoegen en dat zorgt voor de nodige onduidelijkheid.

Wat wil het geval. Het commando is om het programma Redshift (https://itsfoss.com/install-redshift-linux-mint/)  te laten starten te weten : redshift-gtk
Wanneer ik dit commando in de terminal ingeef op een Xubuntu 18.04 systeem, wordt het keurig uitgevoerd. Op een ouwe laptop heb ik Bodhi 5.1 (gebaseerd op Ubuntu 18.04)  geinstalleerd en wanneer ik het commando toevoeg aan het script, werkt dit ook perfect.
Echter, wanneer ik het commando toevoeg aan het script op het Xubuntu 18.04 systeem, wordt het niet uitgevoerd.
De logica ontgaat mij even helemaal :o. Wanneer het op Bodhi 5.1 werkt zou het toch ook op Xubuntu 18.04 moeten werken? Beide os-en draaien immers op dezelfde Ubuntu‘motor’ en het script is op beide systemen identiek.

Heeft iemand een idee hoe dit zou kunnen komen en hoe dit issue op te lossen?
Een boek doet het altijd...


Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: commando in identiek script werkt niet in Xubuntu maar wel in Bodhi
« Reactie #2 Gepost op: 2020/04/16, 20:36:06 »
Is het script wel "uitvoerbaar" ??
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een Dwarsligger uit 0166
Er is ook nog een andere hobby.

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: commando in identiek script werkt niet in Xubuntu maar wel in Bodhi
« Reactie #3 Gepost op: 2020/04/17, 12:37:00 »
Het zou wel helpen als je ons de foutmelding geeft die in Xubuntu verschijnt.

Er verschijnt helemaal geen foutmelding. Dat is het vreemde. Het script wordt gewoon uitgevoerd, echter het toegevoegde commando 'redshift-gtk' wordt op de een of andere manier overgeslagen.
Ik heb het ook al eens helemaal aan het begin van het script gezet ipv aan het eind waar het zich nu bevindt, maar dat maakt niets uit.
Wanneer ik precies datzelfde script in Bodhi 5.1 uitvoer, wordt voornoemd commando dus wel uitgevoerd.
Ron's vraag kan ik dus bevestigend beantwoorden.

Ik ben niet supertechnisch maar vind dit tamelijk merkwaardig. Ach ja, computers....theorie en praktijk. Het wil nog wel eens een beetje verschillen :).
Een boek doet het altijd...

Online peer

  • Lid
  • Steunpunt: Nee
Re: commando in identiek script werkt niet in Xubuntu maar wel in Bodhi
« Reactie #4 Gepost op: 2020/04/17, 13:21:08 »
Ik denk dat je tegenwoordig het command inclusief het volledige pad moet gebruiken in het script.
Open de terminal en typ:
redshift-gtkJe zie nu waarschijnlijk iets als: "/usr/bin/redshift-gtk" en waarschijnlijk nog wat mogelijkheden.
Dit is het commando inclusief het pad.
Test dit commando in de terminal en vervang dan het commando in je script door het gevonden commando.

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: commando in identiek script werkt niet in Xubuntu maar wel in Bodhi
« Reactie #5 Gepost op: 2020/04/18, 17:16:19 »
Je zie nu waarschijnlijk iets als: "/usr/bin/redshift-gtk" en waarschijnlijk nog wat mogelijkheden.

Helaas tref ik niet een dergelijk pad aan. Het commando werkt wel gewoon. Alleen dus niet in het script.

Wie o wie weet de oplossing, want ik begrijp het echt niet...
Een boek doet het altijd...

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: commando in identiek script werkt niet in Xubuntu maar wel in Bodhi
« Reactie #6 Gepost op: 2020/04/18, 17:23:38 »
Post dat script hier eens.

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: commando in identiek script werkt niet in Xubuntu maar wel in Bodhi
« Reactie #7 Gepost op: 2020/04/18, 17:31:07 »
Post dat script hier eens.

Het is een simpel scriptje en ik ben er absoluut niet bedreven in, maar het werkt (zonder redshift-gtk dus). Wellicht dat iets toch niet klopt :

#!/bin/bash

# Run the update command
sudo apt-get update && sudo apt-get -y upgrade

# Start Firefox
firejail firefox &

# Empty Trash
rm -rf ~/.local/share/Trash/*

# Empty Downloads
rm -r -f ~/Downloads/*

# Empty apt-get cache
sudo apt-get clean

# Start Redshift
redshift-gtk

fi
Een boek doet het altijd...

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: commando in identiek script werkt niet in Xubuntu maar wel in Bodhi
« Reactie #8 Gepost op: 2020/04/18, 17:58:44 »
Hoe, waar en wanneer start je dat script? Is je grafische omgeving al geheel geladen op het ogenblik dat dat commando aangeroepen wordt?

Die "fi" op het einde moet weg.

Offline nahjo

  • Lid
  • Steunpunt: Nee
Re: commando in identiek script werkt niet in Xubuntu maar wel in Bodhi
« Reactie #9 Gepost op: 2020/04/18, 18:01:34 »
Probeer eens

# Start Redshift
redshift-gtk &

dus die & toevoegen.

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: commando in identiek script werkt niet in Xubuntu maar wel in Bodhi
« Reactie #10 Gepost op: 2020/04/19, 10:57:14 »
Hoe, waar en wanneer start je dat script? Is je grafische omgeving al geheel geladen op het ogenblik dat dat commando aangeroepen wordt?

Die "fi" op het einde moet weg.
De grafische omgeving is idd al helemaal geladen voordat ik het script start. Ik open dan een terminal, geef de scriptnaam en wachtwoord.
Ik heb 'fi' weggehaald. Bedankt voor de tip. Ik dacht dat je altijd een script daarmee moest afsluiten? Dat hoeft -allang- niet meer begrijp ik? Overigens maakt het geen verschil voor wat betreft het redshift-gtk issue. Redshift start ook zonder 'fi' niet op.

Probeer eens

# Start Redshift
redshift-gtk &

dus die & toevoegen.


Gedaan, maar ook dit levert helaas niets op.
« Laatst bewerkt op: 2020/04/19, 11:02:51 door kfboerne »
Een boek doet het altijd...

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: commando in identiek script werkt niet in Xubuntu maar wel in Bodhi
« Reactie #11 Gepost op: 2020/04/19, 11:28:31 »
Hoe zie je dat redshift-gtk niet wordt uitgevoerd? Verschijnt het tray icoon niet? Dan zou er een foutmelding moeten zijn. Als je dan vlak daarna zelf het commando redshift-gtk ingeeft, dan verschijnt het tray icoon wel? Op zich is dat inderdaad onbegrijpelijk. Verplaats het commando eens naar boven, om de onwaarschijnlijke mogelijkheid dat één van de script commando's de uitvoering van redshift-gtk stoort, uit te sluiten?

Los daarvan: er zijn wel elegantere manieren om één en ander volautomatisch uit te voeren nadat je bent ingelogd dan telkens een terminal te openen en een script te starten.

"fi" dient om een "if" blok af te sluiten, en geeft dus in jou geval een foutmelding.

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: commando in identiek script werkt niet in Xubuntu maar wel in Bodhi
« Reactie #12 Gepost op: 2020/04/20, 16:42:34 »
Hoe zie je dat redshift-gtk niet wordt uitgevoerd? Verschijnt het tray icoon niet? Dan zou er een foutmelding moeten zijn. Als je dan vlak daarna zelf het commando redshift-gtk ingeeft, dan verschijnt het tray icoon wel? Op zich is dat inderdaad onbegrijpelijk. Verplaats het commando eens naar boven, om de onwaarschijnlijke mogelijkheid dat één van de script commando's de uitvoering van redshift-gtk stoort, uit te sluiten?

Icoon verschijnt idd niet na uitvoering van het script, maar wel na het commando in de terminal te hebben ingegeven. Nogmaals : dit geldt voor mijn Xubuntu 18.04 systeem. In mijn Bodhi 5.1 systeem (met dezelfde Ubuntu-motor!) wordt het script commando 'redshift-gtk' wel keurig uitgevoerd en verschijnt het icoon. Vandaar dat de logica mij volledig ontgaat :o.
Het verplaatsen van het commando naar boven had ik ook al geprobeerd, maar dat maakt geen verschil. Een foutmelding kan ik niet ontdekken.

Los daarvan: er zijn wel elegantere manieren om één en ander volautomatisch uit te voeren nadat je bent ingelogd dan telkens een terminal te openen en een script te starten.

Hier heb je m'n volledige aandacht Vanadium :)! Ik was al blij dat ik een simpel scriptje aan de praat kon krijgen om eea te automatiseren, maar wanneer dit soort zaken efficienter kunnen dan hoor ik dat graag. Ik moet je er wel op wijzen, dat ik - helaas - niet zoveel aanleg heb voor al te technische computerzaken, zoals programmeren. Verkeerde set hersens bij de montage denk ik ;). Ik zou zeggen brand los met je tips en alvast bedankt! Ben zeer benieuwd... (Wellicht dat daarvoor een ander topic moet worden aangemaakt??).
« Laatst bewerkt op: 2020/04/20, 16:52:40 door kfboerne »
Een boek doet het altijd...

Offline rico70

  • Lid
  • Steunpunt: Nee
Re: commando in identiek script werkt niet in Xubuntu maar wel in Bodhi
« Reactie #13 Gepost op: 2020/04/20, 16:50:25 »
Bij de MATE desktop kan je programma's automatisch laten starten via
System -> Preferences -> Personal -> Startup applications
Even zoeken dus binnen je menu's

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: commando in identiek script werkt niet in Xubuntu maar wel in Bodhi
« Reactie #14 Gepost op: 2020/04/20, 18:02:48 »
In XFCE:Menu > Instellingen > Sessie en Opstart
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een Dwarsligger uit 0166
Er is ook nog een andere hobby.

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: commando in identiek script werkt niet in Xubuntu maar wel in Bodhi
« Reactie #15 Gepost op: 2020/04/22, 16:50:11 »
Sessie & Opstart was mij al bekend. Echter alle commando's waarbij er online wordt gegaan mogen op mijn systeem pas uitgevoerd worden nadat andere software (betreffende mijn werk) eerst volledig is opgestart. Ik kan daar geen details over geven, maar zo is de situatie.

Wanneer ik de Sessie & Opstart opties gebruik, is er een gerede kans dat de daar ingegeven commando's opstarten voordat voornoemde werkgerelateerde software volledig is opgestart en dat is niet de bedoeling. Tenzij er een mogelijkheid bestaat om die commando's vertraagd te laten starten. Ik heb wel eens iets gehoord over het 'sleep' commando??

 
Een boek doet het altijd...

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: commando in identiek script werkt niet in Xubuntu maar wel in Bodhi
« Reactie #16 Gepost op: 2020/04/22, 16:58:24 »
Probeer dan het volgende:sh -c "sleep 10 && numlockx off"nu wordt er 10 seconden gewacht.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een Dwarsligger uit 0166
Er is ook nog een andere hobby.

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: commando in identiek script werkt niet in Xubuntu maar wel in Bodhi
« Reactie #17 Gepost op: 2020/04/24, 14:44:57 »
In Session & Startup bij 'Command' heb ik nu het volgende commando ingevoerd, maar er gebeurt niets :

sh -c "sleep 10 && numlockx off" redshift-gtk

Moet het andersom? Dus : redshift-gtk sh -c "sleep 10 && numlockx off"



Een boek doet het altijd...

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: commando in identiek script werkt niet in Xubuntu maar wel in Bodhi
« Reactie #18 Gepost op: 2020/04/24, 16:25:31 »
Het voorbeeld was voor het programma numlockx :lol:
Voor jouw toepassing is dat:sh -c "sleep 10 && redshift-gtk"Let op de spaties !
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een Dwarsligger uit 0166
Er is ook nog een andere hobby.

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: commando in identiek script werkt niet in Xubuntu maar wel in Bodhi
« Reactie #19 Gepost op: 2020/04/25, 15:31:34 »
Het voorbeeld was voor het programma numlockx :lol:
Voor jouw toepassing is dat:sh -c "sleep 10 && redshift-gtk"Let op de spaties !

Waar kan ik door de grond zakken :rolleyes:?

Heb het commando uitgeprobeerd, maar helaas geen resultaat. Was ik al bang voor. Zoals Vanadium al zei, is het onbegrijpelijk waarom Redshift niet wil starten op mijn Xubuntu systeem met betreffend commando. Ik ben nog net zo ver als bij de start van dit topic :'(
« Laatst bewerkt op: 2020/04/25, 15:47:13 door kfboerne »
Een boek doet het altijd...

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: commando in identiek script werkt niet in Xubuntu maar wel in Bodhi
« Reactie #20 Gepost op: 2020/04/25, 16:49:50 »
Ik ben nog net zo ver als bij de start van dit topic :'(
Mijn ervaring is, dat het in dit soort gevallen soms heel simpel is, maar dat we er over heen denken.

Zo heb ik ooit 3 dagen gezocht naar een fout, en kwam er toen achter dat er een ")" stond, waar een "}" hoort te staan.
Succes met zoeken...............
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een Dwarsligger uit 0166
Er is ook nog een andere hobby.