Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Debian testing segfault  (gelezen 731 keer)

Offline Nero

  • Lid
  • Steunpunt: Ja
Debian testing segfault
« Gepost op: 2016/02/21, 12:18:47 »
Ik draai Debian testing (squeeze) als voornaamste distributie. Sedert enige tijd krijg ik steeds een segfault in libc-2.21.so bij diverse toepassingen. Is daar reeds een work-around voor?

De fout doet zich voor met oa. libc-bin-2.21-4, -6 en -8.

Offline Theo1971

  • Lid
  • Steunpunt: Nee
Re: Debian testing segfault
« Reactie #1 Gepost op: 2016/02/21, 14:31:08 »
Squeeze (Debian 6) is al een aantal jaren geen testing meer en de ondersteuning loopt eind deze maand dan ook af.
Teveel computers en teveel distro's (Debian & Ubuntu based)

Offline softbart

  • Lid
  • Steunpunt: Nee
Re: Debian testing segfault
« Reactie #2 Gepost op: 2016/02/21, 21:11:34 »
voor de sources.list

deb http://archive.debian.org/debian/ squeeze main non-free contrib

groet,

Theo

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: Debian testing segfault
« Reactie #3 Gepost op: 2016/02/21, 23:21:33 »
Debian Squeeze (6) is stable geweest en opgevolgd door Wheezy (7) en Jessie (8). De huidige testing heet Stretch en zal over een of twee jaar stable v9 worden.
Ik stel voor dat je ofwel opwaardeert naar de huidige testing of huidige stable via installatie. Upgraden zou wel kunnen, maar duurt veel en veel langer.

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Debian testing segfault
« Reactie #4 Gepost op: 2016/02/22, 01:00:21 »
Missing van mij. Het is uiteraard stretch en geen squeeze. In de repo's heb ik zelfs stretch vervangen door testing.
« Laatst bewerkt op: 2016/02/22, 01:02:06 door Nero »

Offline softbart

  • Lid
  • Steunpunt: Nee
Re: Debian testing segfault
« Reactie #5 Gepost op: 2016/02/22, 12:16:04 »
Geen problemen ondervonden met stretch. Gebruik stretch op de oude IBM thinkpad t43

[optopic]

Ik gebruik nog squeeze voor de oude "WD white light NAS" met de armv5 chip.

Deze gehackt, volgens een howto, zie hier

groet,

theo

Offline grizzler

  • Lid
  • Steunpunt: Nee
Re: Debian testing segfault
« Reactie #6 Gepost op: 2016/02/22, 14:47:30 »
libc is de GNU C library, dus als daar echt een probleem in zit, kan je allerlei rare verschijnselen verwachten. Het is wel vreemd dat verschillende versies allemaal dezelfde foutmelding produceren. Dat maakt wat als eerste bij mij opkomt - het pakket libc6 opnieuw installeren - wat minder zinvol.

Ik gebruik al tijden Debian Testing (SolydX Enthusiast's Edition) en merk niets van segmentatiefouten. Bij welke applicaties gaat het met name mis?

Is de harde schijf van die machine nog wel helemaal in orde?

Welke desktopomgeving gebruik je overigens? Ik kan niet zeggen dat ik de nieuwe KDE (KF5/Plasma5) lekker stabiel vind...

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: Debian testing segfault
« Reactie #7 Gepost op: 2016/02/22, 19:23:15 »
Ik gebruik zelf ook Debian Testing (Stretch) op meerdere desktoppc's en notebooks zonder enig probleem. Wel altijd XFCE-desktopomgeving.
Heb even gezocht op de foutmelding en daaruit concludeer ik dat het het meest voorkomt bij 32-bit installaties en bij systemen met defecte pakketten. Dat laatste moet je altijd proberen te herstellen, want dat leidt steevast tot meer ellende...

Offline Theo1971

  • Lid
  • Steunpunt: Nee
Re: Debian testing segfault
« Reactie #8 Gepost op: 2016/02/22, 21:21:10 »
Zelf gebruik ik hier linuxbbq (Debian SID, unstable) en heb ook geen problemen. Eerlijkheid gebied wel te zeggen dat dit zeer minimalistische systemen zijn met alleen GTK2 voor Tint2, de rest zijn hoofdzakelijk terminal programma's. Ik denk dat het inderdaad handig is om je werkomgeving te vermelden.
Teveel computers en teveel distro's (Debian & Ubuntu based)

Offline softbart

  • Lid
  • Steunpunt: Nee
Re: Debian testing segfault
« Reactie #9 Gepost op: 2016/02/23, 08:52:38 »
Alle Debian's met XFCE.
Het netboekje Jessie stable.

groet,

Theo

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Debian testing segfault
« Reactie #10 Gepost op: 2016/02/24, 13:16:11 »
Op dezelfde laptop (Asus K95VJ) is een 'oudere' installatie van stretch. Beide installaties staan op dezelfde SSD, en hebben dezelfde basissoftware. Desktop in beide gevallen LXDE. Allebei bijgewerkt tot op vandaag. Op die oudere instantie heb ik deze fout ook niet. Enige verschil is dat daar veel meer software op staat, en deze gebruikt is voor het uittesten van diverse programma's. Resultaat is wel dat daar ook veel restanten van verwijderde soft op zit. Ik opteerde dus een goeie maand geleden voor een propere installatie vertrekkende van dezelfde mini-iso, en met hierop enkel hetgeen ik daadwerkelijk gebruik. En net op deze heb ik die segfault errors, waardoor enkele programma's,waaronder GThumb, niet starten.

De specs:$ inxi -Fzx
System:    Host: k95vj Kernel: 4.3.0-1-amd64 x86_64 (64 bit gcc: 5.3.1) Desktop: LXDE (Openbox 3.6.1)
           Distro: Debian GNU/Linux stretch/sid
Machine:   Mobo: ASUSTeK model: K95VJ v: 1.0 Bios: American Megatrends v: 234 date: 11/25/2014
CPU:       Quad core Intel Core i7-3630QM (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 19156
           clock speeds: max: 3400 MHz 1: 1220 MHz 2: 1357 MHz 3: 1406 MHz 4: 1227 MHz 5: 1203 MHz 6: 1200 MHz
           7: 1383 MHz 8: 2141 MHz
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GF108M [GeForce GT 635M] bus-ID: 01:00.0
           Display Server: X.Org 1.18.1 drivers: nouveau,intel (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 11.1.2 Direct Rendering: Yes
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.3.0-1-amd64
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 02:00.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k bus-ID: 03:00.0
           IF: wlan0 state: down mac: <filter>
Drives:    HDD Total Size: 1250.3GB (21.2% used) ID-1: /dev/sda model: HGST_HTS541010A9 size: 1000.2GB
           ID-2: /dev/sdb model: Samsung_SSD_840 size: 250.1GB
Partition: ID-1: / size: 32G used: 12G (38%) fs: ext4 dev: /dev/sdb7
           ID-2: /tmp size: 7.8G used: 19M (1%) fs: ext4 dev: /dev/sda8
Sensors:   System Temperatures: cpu: 51.0C mobo: 27.8C gpu: 44.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 187 Uptime: 4:43 Memory: 888.1/7865.6MB Init: systemd runlevel: 5 Gcc sys: 5.3.1
           Client: Shell (bash 4.3.421) inxi: 2.2.28

Offline grizzler

  • Lid
  • Steunpunt: Nee
Re: Debian testing segfault
« Reactie #11 Gepost op: 2016/02/24, 13:56:59 »
Merkwaardig. Aan de combinatie Stretch/glibc/applicaties kan het dus eigenlijk niet liggen, want dat werkt zowel op die oudere installatie als ook hier bij mij zonder problemen.

Ik heb geen ervaring met SSD, maar als ik dit zo lees vraag ik me toch af of die drive nog wel helemaal in orde is.