Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie  (gelezen 1170 keer)

Offline Beekhof

  • Lid
  • Steunpunt: Nee
Van fouten maken leer je het meest: Dual boot met Windows7&8 via GRUB2 van Ubuntu14.04.
W8 stond op eerste primaire partitie(ntfs)  en om dit te kunnen ”upgraden” naar W10 kwam ik op het idee om m.b.v. gparted die 1e partitie te verwijderen. Dat was onverstandig, gevolg: W7 (op 2e partitie) startte NIET meer op vanuit Grub opstart keuze scherm, wel bleef Ubuntu intact. 

Verklaring zou kunnen zijn dat bij de installatie van Ub14.04 de keuze was gemaakt om de bootloader te plaatsen op de HD, waardoor ook de MBR aan het begin van die 1e partititie.
Omdat ik nu juist deze 1e partitie verwijderd had was ook  boot flag foetsie, zoals gparted laat zien.

Remedie: Er zijn diverse manieren te vinden om Windows(7) weer op te starten (bv. Bootrec.exe /FixMbr), maar daarbij verliezen we ook Ubuntu.
Nu vond ik op internet volgende methode, om die verloren mbr weer terug te halen via mbr.bin in syslinux, d.m.v. het Terminal commando: sudo dd if=/usr/syslinux/mbr.bin of= /dev/dsa bs=512 count=1,
zie: http://ubuntuhandbook.org/index.php/tag/repair-mbr-in-ubuntu/.
Het is mij echter niet duidelijk of daarna Ubuntu nog wel aanwezig is?
Heeft iemand met genoemde methode ervaring?
Haalt Ubuntu bij zijn installatie de bootloader dan uit syslinux?

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #1 Gepost op: 2015/07/21, 09:46:51 »
Ik kan je niet helemaal volgen. Het wordt misschien wat duidelijker als je de pc opstart vanaf een Ubuntu LiveCD en dan mbv GParted een printje van de harde schijf plaatst hier op het forum.

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #2 Gepost op: 2015/07/21, 10:06:19 »
Dit is geen Linux probleem maar een Windows probleem. Windows houdt op zijn bootpartitie een bestand bij waarin de genummerde partities staan. Als je een partitie verwijdert, klopt de nummering in dat bestand niet meer en kan Windows niet meer booten. Compleet idioot en onnodig, maar meer dan waarschijnlijk bedoeld om je ervan te weerhouden iets anders te doen dan Microsoft van je wil.
Je kunt de partitienummering van Windows vanuit Linux probleemloos handmatig aanpassen. Zoek op Windows-gerelateerde fora over welk bestand je moet hebben en waar je dat vindt.

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #3 Gepost op: 2015/07/21, 10:15:02 »
Als aanvulling op wat Bloom zegt,
met boot-repair kan je dit oplossen (maar over het herstel win8 ben ik niet zeker):
     https://help.ubuntu.com/community/Boot-Repair

  download         http://sourceforge.net/projects/boot-repair-cd/files/
  uitleg                 http://sourceforge.net/p/boot-repair/home/Home/

Offline Beekhof

  • Lid
  • Steunpunt: Nee
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #4 Gepost op: 2015/07/21, 14:30:07 »
Dank, zal partitie tabel opsturen en bootrepair bestuderen.


Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #6 Gepost op: 2015/07/21, 14:52:11 »
.....  en herstelt een Windows die niet wil booten NIET.

Dat ben ik niet met je eens; eigen ervaring en info van de makers zelf
Citaat
Can recover access to any OS (Windows, MacOS, Linux..).    -  Bron: http://sourceforge.net/p/boot-repair/home/Home/

Maar de TS heeft vreemde dingen verwijderd op de schijf,
daarom vraag ik om een screenshot van de harde schijf, want nu is het koffiedik kijken.
« Laatst bewerkt op: 2015/07/21, 14:53:44 door EZ-man »

Offline Beekhof

  • Lid
  • Steunpunt: Nee
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #7 Gepost op: 2015/07/21, 22:12:16 »
In bijlage partitie overzicht van mijn ASUS-PC (P7P15 MoBo).
Ik had een hele tekst ingetikt, maar een te grote bijlage er bij gestopt. Reactie webbeheerder Forum Ubuntu.nl:   "Er is een fout opgetreden bij het versturen van dit bericht.
Het bericht is leeg". D.w.z. leeggemaakt, daar ben ik NIET zo blij mee!! Ik hoop dat die BUG verbeterd wordt, waardoor gewoon de tekst behouden blijft en er een kleinere bijlage bij te zetten valt.
 

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #8 Gepost op: 2015/07/21, 22:29:37 »
Kort samengevat :
Citaat
sdb1  ntfs   w7->10    leeg
sdb2  ntfs   w7        zeer vol
sdb5  swap   swap
sdb6  ext4   ubuntu    toekomst ;-)
leeg    -       -       55 GB

Dat praat een stuk makkelijker  ;)

Vragen:
 - Waar is de andere harde schijf sda  (want ik zie hier alleen sdb ) ?
 - Kan je Ubuntu opstarten ?
 - Kan je W7 opstarten ?
 - Wat moet er op de eerste partitie gebeuren ?
« Laatst bewerkt op: 2015/07/21, 22:34:34 door EZ-man »

Offline Beekhof

  • Lid
  • Steunpunt: Nee
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #9 Gepost op: 2015/07/21, 22:50:34 »
Klopt in die tekst stond dat aangegeven, die is echter weggehaald door ....? Het foute systeem programma op Ubunte.nl!!
Waarom niet gewoon melden dat de bijlage te groot is zodra de klant iets mee wil sturen en  weghalen van tekst is helemaal van de zotte.
Gewoon netjes communiceren, tekst laten staan en de klant de gelegenheid geven om kleinere jpg mee te sturen.

In die te grootte bijlage stond ook de 2e HD met Ub-home erop.
Inderdaad w7 bijna vol en w8 nu leeg, rechts stond nog flag zonder boot eronder.
Morgen zal ik alles nog eens opnieuw invoeren, nu ben te boos op de website beheerder.

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #10 Gepost op: 2015/07/21, 22:57:06 »
Morgen zal ik alles nog eens opnieuw invoeren, nu ben te boos op de website beheerder.

De grootte van de bijlage is beperkt tot 150 kb .

Tip: Als je plaatjes stuurt en die zijn te groot dan kan je die
        - oploaden naar een speciale site en een link plaatsen op dit forum.
        - of maak van het oorspronkelijke PNG plaatje een JPG

Voor tekst bestanden: gewoon een kladblok editor gebruiken en dan comprimeren
« Laatst bewerkt op: 2015/07/21, 22:58:45 door EZ-man »

Offline Joris Donders

  • Lid
  • Steunpunt: Ja
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #11 Gepost op: 2015/07/22, 08:37:35 »
In bijlage partitie overzicht van mijn ASUS-PC (P7P15 MoBo).
Ik had een hele tekst ingetikt, maar een te grote bijlage er bij gestopt. Reactie webbeheerder Forum Ubuntu.nl:   "Er is een fout opgetreden bij het versturen van dit bericht.
Het bericht is leeg". D.w.z. leeggemaakt, daar ben ik NIET zo blij mee!! Ik hoop dat die BUG verbeterd wordt, waardoor gewoon de tekst behouden blijft en er een kleinere bijlage bij te zetten valt.

Even een moderatorinsteek: dit is een automatisch gegenereerde foutmelding van de forumsoftware. Er is geen beheerder van het Forum die fysiek je beperkte in je acties.

Om deze perikelen aan te kaarten, nodig ik je zeker uit om in het onderdeel Forum een vraag of opmerking te maken; dan kunnen we even meekijken waar het foutloopt (mod's zijn helaas geen beheerders van het Forum).
Met vriendelijke groet,

het Forumteam/
Gubuntu 17.04 wegens verdwijnen Unity binnenkort

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #12 Gepost op: 2015/07/22, 09:10:33 »
Citaat
sdb1  ntfs   w7->10    leeg
sdb2  ntfs   w7        zeer vol
sdb5  swap   swap
sdb6  ext4   ubuntu    toekomst ;-)
leeg    -       -       55 GB
@Beekhof: omdat je in de toekomst in die eerste partitie opnieuw een Windows wil installeren, zou ik niks veranderen aan de bootinstellingen van de W7 op partitie 2 want dan start die niet meer op zodra je partitie 1 opnieuw in gebruik neemt. Ik raad aan op partitie 1 zolang een zo klein mogelijke WinXP of W7 te installeren, daarna zal de W7 op partitie 2 wel keurig opnieuw draaien. En dan werkt het ook nog nadat je W10 geïnstalleerd hebt.
Je weet ondertussen wel, neem ik aan, dat elke installatie van Windows zonder vragen een eigen bootrecord naar de harde schijf mee en zo Grub vernietigt. Grub moet dus altijd hersteld worden na een installatie van Windows. Je hoeft daarvoor Ubuntu niet opnieuw te installeren, gewoon SuperGrub of zoiets downloaden en dan kan het daarmee.
Volgens het schema is er momenteel nog geen Ubuntu geïnstalleerd, dan is er ook geen Grub en is er geen probleem. Maar als je Ubuntu zou installeren vooraleer je op partitie 1 Win10 installeert, dan zal Grub dus wel overschreven worden door Windows.

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #13 Gepost op: 2015/07/22, 10:00:21 »
Je weet ondertussen wel, neem ik aan, dat elke installatie van Windows zonder vragen een eigen bootrecord naar de harde schijf mee en zo Grub vernietigt. Grub moet dus altijd hersteld worden na een installatie van Windows.

@Bloom: Ja, Ubuntu heeft daarvoor een instructie gemaakt : Recovering Ubuntu After Installing Windows.
Opmerkelijk is dat men voor het herstel boot-repair adviseert (en niet SuperGrub).

@Beekhof: in plaats van een screenshot van Gparted (een plaatje) is het ook mogelijk inzicht te verkrijgen via een terminal commando:
parted -lDe uitvoer kan je kopieren en hier plaatsen.
« Laatst bewerkt op: 2015/07/22, 10:02:36 door EZ-man »

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #14 Gepost op: 2015/07/22, 10:29:25 »
parted -lDe uitvoer kan je kopieren en hier plaatsen.
Dat moet met sudo, anders vindt-ie hem niet.
En soms is GParted wel geïnstalleerd maar parted niet. In dat geval:
sudo apt-get install parted

Offline Beekhof

  • Lid
  • Steunpunt: Nee
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #15 Gepost op: 2015/07/23, 22:53:06 »
Prachtig met sudo parted -l is HET idee: bijlage slechts 11 kB, dit voor men volledig werkende Laptop met vlag "opstart" (=boot) wel er in.

Morgen komt de andere voor mijn desktop ASUS-PC, waarin "opstart" ontbreekt.

Offline Beekhof

  • Lid
  • Steunpunt: Nee
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #16 Gepost op: 2015/07/24, 10:38:29 »
Op 15-7-15 maakte ik een vervelende fout, op ASUS-PC, waardoor W7-Ult-UK niet meer opstartte vanuit Grub scherm (“Grub opstartlader”).

In juni 2014 heb ik op ASUS-pc een tweetal ntfs partities aangemaakt.
Op de 2e W7-Ult-UK, de 1e leeg gelaten en W8-PRO genoemd.
Deze naam heb ik gekozen om in later stadium hierop W8 daadwerkelijk te installeren.
Daar is het echter nooit van gekomen en bleef dus deze opslag vrij en let wel NTFS is toegankelijk voor zowel Windows als Linux! Daar heb ik in een later stadium gebruik van gemaakt om er backup data op te zetten.

De reden voor de keuze 2e partitie i.p.v. 1e heeft de volgende reden:
in eerste instantie heb ik gepoogd om de (oude) W7-Ult-UK over te zetten vanaf de bestaande HD naar een SSD m.b.v. Clonezilla. Nu eist CLZ om bij “create en restore” dezelfde x in /dev/sdx te gebruiken. Welnu W7-Ult-UK stond op de 2e partitie, samen met W7-Ult-NL op 1e (twee talen).

15-7-15 was ik van plan op de eerste partitie een extra W7 te zetten om later te laten upgraden door MS naar W10. Welnu de W8-PRO (59.88 GiB,ntfs) leek daarvoor een geschikt medium, maar bevatte inmiddels backupdata, ter grootte van 7,8 GB. Om deze reden heb ik deze gecopieerd naar een externe HD en daarna op normale wijze verwijderd ('delete folder').
Wie schets mijn verbazing: gparted zag die 7,7 GiB nog steeds aanwezig.

Daarop heb ik deze partititie verwijderd, dat lukte wel maar tevens was de bestaande flag boot foetsie. Als gevolg wilde W7-Ult-UK niet meer opstarten vanuit het “grub scherm”.
In diezelfde “Grub- opstartlader” startte Ubuntu 14.04 nog steeds probleenloos op.   


Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #17 Gepost op: 2015/07/24, 10:48:24 »
@Beekhof: gaat dit bericht « Reactie #16 Gepost op: Vandaag om 10:38:29 » om een andere pc?

TIP - Maak dan een nieuw topic aan, want anders ontstaat er verwarring, zowel bij jou als het forum.

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #18 Gepost op: 2015/07/24, 12:58:07 »
Nu eist CLZ om bij “create en restore” dezelfde x in /dev/sdx te gebruiken.
Lees eens de FAQ van Clonezilla. Je kan gewoon een partitie op een ander nummer zetten. Makkelijkste is om symbolic links te maken voor de verschillende partities. Enige vereiste is dat de doel partitie minstens even groot is als de bron.

Offline Beekhof

  • Lid
  • Steunpunt: Nee
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #19 Gepost op: 2015/07/24, 18:38:10 »
Antwoord aan EZ-man:  Dit gaat nog steeds over hetzelfde onderwer: NIET kunnnen opstarten van W7.
Ik begrijp je opm. je had gevraagd om partitie overzicht en die stuurde ik 2 stuks. Dit geeft verwarring, maar was bedoeld om aan te geven:
op Laptop staat wel een boot vlag en werkt prima.
Op ASUS-pc is GEEN bootvlag te zien, toch Ub werkt daarop prima, maar W7 wil NIET opstarten.

Antwoord aan Nero, dank voor inzicht in Clonezilla. Ik dacht zoiest maar wist niet hoe en weet ook niet met symbolic links om te gaan.

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #20 Gepost op: 2015/07/24, 18:53:19 »
Niet kunnen opstarten van windows 7 is op te lossen met Boot-Repair (ik herhaal mezelf)

Met boot-repair kan je dit oplossen:
     https://help.ubuntu.com/community/Boot-Repair

  download         http://sourceforge.net/projects/boot-repair-cd/files/
  uitleg                 http://sourceforge.net/p/boot-repair/home/Home/

Werkwijze:
 - download de ISO
 - branden op cd of usb
 - opstarten en programma volgen
na afsluiten is het gereed: win7 staat in GRUB-menu, onder Ubuntu

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #21 Gepost op: 2015/07/24, 19:34:14 »
TIP - instructies over Linux/Ubuntu : http://wiki.ubuntu-nl.org/Overig

Speciale aandacht voor:
 - grub2
 - inxi
 - tips & trucs
 - Gparted Live

Offline Beekhof

  • Lid
  • Steunpunt: Nee
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #22 Gepost op: 2015/07/24, 20:55:20 »
Hartelijk dank EZ-man, dit moet lukken, vooral ook met die uitleg over boot repair. Ik ga dit eens goed lezen.

Offline Beekhof

  • Lid
  • Steunpunt: Nee
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #23 Gepost op: 2015/07/25, 20:58:33 »
Boot-Repair toegepast met als resultaat dat nu wel een bootvlag staat bij /dev/sdb = 256GB, met op sdb6 Ub14.04.2 en GRUB2.
Jammer,  W7 wil nog steeds niet opstarten. In bijlages een kortere samenvatting van Boot-Info en de volledige volledige file, waarin toch wel interessante en leerzame informatie (zoals de inhoud van grub.cfg, parted -l en suggestie van/voor(?) reparatie), staat/is gezet op:
http://paste.ubuntu.com/11936378/

Offline EZ-man

  • Lid
  • Steunpunt: Nee
Re: W7 (op 2epartitie) start niet op vanuit GRUB na verwijderen 1e partitie
« Reactie #24 Gepost op: 2015/07/25, 21:21:59 »
Ik weet het niet, maar dit is toch duidelijk:
sdb2: _____________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 7/2008: NTFS
    Boot sector info:  According to the info in the boot sector, sdb2 starts
                       at sector 122880000. But according to the info from
                       fdisk, sdb2 starts at sector 125032448.
    Operating System:  Windows 7
    Boot files:        /bootmgr /Boot/BCD /Windows/System32/winload.exe
 __________________________________________________________________________

Ik zou die data schijf - sda -  eerst afkoppelen
Controleer de instellingen in bios: opstart volgorde ( you are the expert on the spot ) 
Speel met de instellingen van boot-repair, je kan ook windows herstellen - play with it
Als alles werkt die data schijf weer aankoppelen

AANVULLING :  zie   http://ubuntuforums.org/showthread.php?t=2205719 

Citaat
Grub does not correctly install to protective MBR of gpt partitioned drives to boot in BIOS mode unless you also have a tiny 1-2MB unformatted partition with the bios_grub flag. Use gparted to add that partition anywhere on drive and reinstall grub or use Boot-Repair to reinstall grub to MBR.

In a GPT partition map, the 31 kiB area after Master Boot Record where GRUB is usually embedded to, does not exist. When GRUB can't be embedded, its only option is to use blocklists, which are unreliable and discouraged. Thus, you must make a separate "BIOS boot partition" to hold core.img. BIOS Boot Partition only needs to be about 32 KiB in size, although in most cases make it 1 MiB because of partition alignment issues. It can be anywhere on drive and has no format.


IK denk dat je een instelling in bootrepair moet maken om een kleine ruimte te laten maken voor de eerste partitie.
« Laatst bewerkt op: 2015/07/25, 21:33:36 door EZ-man »