Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Geen grafische weergave  (gelezen 582 keer)

Offline MrMojorisin

  • Lid
    • rob70hoeben
  • Steunpunt: Nee
Geen grafische weergave
« Gepost op: 2014/07/19, 17:15:08 »
Hoi.

Gisteren Ubuntu 14.04 geinstalleerd op een nieuwe desktop met een AMD Radeon R7240.
Vandaag nog wat upgrades gedaan en dergelijke, na een vereiste reboot is grafisch alles weg.

Fatal screen error no screens found. 

Ik heb op het forum andere topics hierover gevonden en die opties geprobeerd, maar dan blijft hij gewoon hangen op het paarse scherm.
(https://sites.google.com/site/computertip/geenbeeld)
Ik kan niet opstarten met een oudere kernel.

Iemand tips voor deze vage shit?



Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: Geen grafische weergave
« Reactie #1 Gepost op: 2014/07/19, 17:27:50 »
Dat is een driverprobleem. De open source driver die in de nieuwere kernel zat kan kennelijk niet meer overweg met je chipset. Dat is wel eigenaardig vermits het om een recente chipset gaat.
Je redding is in dit geval het installeren van de gesloten broncode-driver van AMD.
Zie http://support.amd.com/en-us/kb-articles/Pages/Latest-LINUX-Beta-Driver.aspx
Deze driver versie 14.6 beta ondersteunt de AMD Radeon R7-reeks en dus ook jouw R7240 en specifiek Ubuntu 14.04.
Op deze webpagina vind je naast de beschrijving ook een downloadlink. Het bestand downloaden en de zip uitpakken op een usb-stick. Daarna de getroffen computer starten met de noodconsole (in het Grubmenu van Ubuntu beschikbaar). Dan krijg je een root terminal. Login en steek de usb-stick in. Wacht een tweetal seconden en dan zou de stick aangekoppeld moeten zijn in ofwel /media ofwel /mnt. Voer het .run-bestand op de usb-stick uit als root en dan zal de AMD-driver geïnstalleerd worden. Na afloop gewoon de computer rebooten (gewoon 'reboot' typen in de terminal) en dan zou je weer een grafisch scherm moeten hebben.

Offline MrMojorisin

  • Lid
    • rob70hoeben
  • Steunpunt: Nee
Re: Geen grafische weergave
« Reactie #2 Gepost op: 2014/07/19, 17:45:30 »
Bij voorbaat bedankt! Je schat mijn kunde met Ubuntu iets te hoog in denk ik. Ik heb nog een dual boot. Is dat dezelfde grub die jij bedoelt want ik krijg geen inlog.  Wel de optie recovery mode. Daarin kan ik wel "terugvallen op terminal met rootbevoegdheid". Ik weet niet of dat ook kan.
En bij voorbaat nog deze vragen, hoe kom ik in de goeie directory en run ik uberhaupt. *zucht*..ik moet nog veel leren.

groet, Rob

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: Geen grafische weergave
« Reactie #3 Gepost op: 2014/07/19, 19:10:31 »
Terugvallen op de terminal met rootbevoegdheid is de goeie.
Tik nadat je de prompt hebt gekregen eens
ls -ltr /media
steek daarna je usb-stick met het uitgepakte .run-bestand erin en voer na enkele seconden de hoger vermelde instructie opnieuw uit.
Je zou een extra regel moeten zien voor het usb-medium dat je hebt ingestoken. Die naam moet je hebben.
Ik ga hier even veronderstellen dat je in /media een naam USB0 ziet staan voor de ingestoken stick. Dat is met zekerheid iets anders bij jou, dus vul de naam die jij ziet staan in waar je hieronder USB0 ziet staan. Hou rekening met hoofd- en kleine letters, die maken verschil uit bij Linux.
sh -c /media/USB0/amd-driver-installer-14.20-x86.x86_64.run
En deze zou je door de installatieprocedure moeten heengeleiden.
Overigens kun je nadat je 'amd-' hebt ingetikt ook op de TAB-toets (naast de letter Q op je toetsenbord) drukken en dan vult hij de juiste naam van het bestand zelf aan.

Offline MrMojorisin

  • Lid
    • rob70hoeben
  • Steunpunt: Nee
Re: Geen grafische weergave
« Reactie #4 Gepost op: 2014/07/19, 19:48:50 »
Ik begrijp wat je bedoelt en wat de commando's inhouden, als ik    ls -ltr /media     intyp krijg ik de volgende regels:

totaal 4
drwxr-x---+ 2 root root 4096 jul 19  02:47 robbie

Wat daarvan nou de naam van de Usb is weet ik niet, ik heb in ieder geval van alles ingevoerd op de plek van Usb0 in de commandoregel.
Kan ik niet met cd/ naar de directory, zoals vroeger in DOS?

Offline MrMojorisin

  • Lid
    • rob70hoeben
  • Steunpunt: Nee
Re: Geen grafische weergave
« Reactie #5 Gepost op: 2014/07/19, 19:55:12 »
Oh nee..die regel is gewoon mijn systeem.
Nee, ik zie geen tweede regel komen waar de naam van de Usb staat.

Offline MrMojorisin

  • Lid
    • rob70hoeben
  • Steunpunt: Nee
Re: Geen grafische weergave
« Reactie #6 Gepost op: 2014/07/19, 21:16:37 »
Ik heb andere usbsticks geprobeerd, ext. Hd, andere poorten maar hij ziet ze gewoon niet. Is er nog een ander oplossing of een workaround?

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Geen grafische weergave
« Reactie #7 Gepost op: 2014/07/19, 21:45:58 »
Een andere mogelijkheid die je in  recovery mode hebt, is in het Recovery Menu te kiezen voor Resume normal boot. Dan wordt de VESA driver geladen, en zou in principe altijd grafisch beeld moeten opleveren, al is dat waarschijnlijk in een lagere resolutie. Dan zou je kunnen checken via System Settings > Software & Updates > Additional Drivers/Systeeminstellingen > Software & Updates > Extra stuurprogramma's of daar drivers worden aangeboden. 

Als dat niet werkt, zou je kunnen wachten op 24 juli. Dan wordt de eerste puntuitgave Ubuntu 14.04.1 uitgebracht https://wiki.ubuntu.com/TrustyTahr/ReleaseSchedule
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: Geen grafische weergave
« Reactie #8 Gepost op: 2014/07/19, 21:52:58 »
Je kunt eventueel in de rootterminal het volgende proberen:
fdisk -l
Dat levert een lijst op van alle gevonden schijven en partities.
De usb-drive is normaal de laatste in de lijst.
Je ziet dan zoiets als dit:
   Device Boot      Start         End      Blocks   Id  System
/dev/sdf1   *          32    31264767    15632368    c  W95 FAT32 (LBA)
Ik ga voor het volgende ervanuit dat jouw driveletter ook f is. Indien niet, vervang je sdf hieronder door sd met de juiste driveletter erachter.
We gaan handmatig de usb-drive aankoppelen:
mkdir /media/usb
mount /dev/sdf1 /media/usb
Als er foutmeldingen verschijnen, zul je die hier even moeten posten.
Normaal zou dat gewoon terug moeten komen met een terminalprompt zonder foutmelding.
Nu kun je wel het volgende doen:
sh -c /media/usb/amd-driver-installer-14.20-x86.x86_64.run
en dat zou dan nu wel moeten werken.

Offline MrMojorisin

  • Lid
    • rob70hoeben
  • Steunpunt: Nee
Re: Geen grafische weergave
« Reactie #9 Gepost op: 2014/07/19, 22:26:05 »
Ik zie die Usb dan wel staan. Na mkdir /media/usb  zegt hij: kan map niet aanmaken: Bestandssysteem is alleen-lezen.

Offline MrMojorisin

  • Lid
    • rob70hoeben
  • Steunpunt: Nee
Re: Geen grafische weergave
« Reactie #10 Gepost op: 2014/07/19, 22:36:56 »
@Jolo Dank voor de tip maar ook dan blijft hij hangen en start verder niet op.

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Geen grafische weergave
« Reactie #11 Gepost op: 2014/07/19, 22:51:03 »
Opstarten met de livecd,
file downloaden en op je hd zetten, waar je met je root login bij kunt komen,
Ook de file uitvoerbaar maken,
dan opstarten met je root/textmode, dan file starten,
soms moet je nog ./ ervoor zetten, dan start deze wel.

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: Geen grafische weergave
« Reactie #12 Gepost op: 2014/07/19, 23:19:10 »
Ik zie die Usb dan wel staan. Na mkdir /media/usb  zegt hij: kan map niet aanmaken: Bestandssysteem is alleen-lezen.
Ah ja, dat was ik vergeten.
Doe dan eerst
mount -o remount,rw /
en dan de andere instructies.

Offline MrMojorisin

  • Lid
    • rob70hoeben
  • Steunpunt: Nee
Re: Geen grafische weergave
« Reactie #13 Gepost op: 2014/07/19, 23:52:30 »
De installatie werkt nu, maar het probleem is met deze driver niet opgelost, het is en blijft een zwart scherm. Ik ga de verschillende opties tijdens de installatie van de driver nog even langs. Ontzettend bedankt voor je hulp!

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Geen grafische weergave
« Reactie #14 Gepost op: 2014/07/20, 09:33:20 »
Als je via de recovery mode weer naar de rootterminal gaat, dan zou je de /var/log/Xorg.0.log kunnen kopiëren naar een usb-stick. Die je dan vervolgens kopieert naar de pc, waarvan af je de berichten post. Omdat zo een Xorg.0.log nogal groot kan zijn, pak je die in als .zip of .gz alvorens je 'm als bijlage meestuurt met je volgende bericht. Wellicht dat we dan zouden kunnen zien, wat er fout ging.

Als dat niet lukt, probeer dan vanuit die rootterminal
cat /var/log/Xorg.0.log | grep EE [Enter]

Eventueel zou je ook nog kunnen controleren of de fglrx driver wordt geladen.
lsmod | grep fglrx [Enter]

en

dmesg | grep fglrx [Enter]

Zodat je de output(s) daarvan kunt posten, in je volgende bericht.
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline MrMojorisin

  • Lid
    • rob70hoeben
  • Steunpunt: Nee
Re: Geen grafische weergave
« Reactie #15 Gepost op: 2014/07/20, 15:17:17 »
Hallo "allemaal".
Ik hou niet van opgeven en ik heb tot vanmorgen half zeven geprobeerd wat ik kon. Ik kreeg de driver gewoon niet geinstalleerd.
Mijn systeem is net nieuw en ik heb geen zin om vanaf het begin al te moeten werken met een installatie die op mij toch wat "labiel" overkomt.
Dus heb ik Ubuntu opnieuw geinstalleerd, zonder Windows. Na de eerste updates heb ik de driver goed kunnen installeren en liep mijn systeem stabiel en rustig.  Liep zeg ik inderdaad, want nu net valt ineens mijn internet eruit en wat ik nu zie is dat niet meteen op te lossen met het modem resetten of dat soort kindertrucjes.  Zucht,...ik word er een beetje moedeloos van. Was ik maar bij 12.04 blijven hangen. Maar goed, ik ga een nieuwe thread openen om dit op te lossen.
Allemaal bedankt voor jullie tips en meedenken, dat waardeer ik enorm.
Rob.


Offline MrMojorisin

  • Lid
    • rob70hoeben
  • Steunpunt: Nee
Re: Geen grafische weergave
« Reactie #17 Gepost op: 2014/07/20, 17:51:43 »
Lenovo H530-00298

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: Geen grafische weergave
« Reactie #18 Gepost op: 2014/07/20, 20:26:54 »
Deze ken ik niet, maar Canonical heeft een goede samenwerking met Lenovo om te zorgen dat Ubuntu er normaal probleemloos op draait.
Probeer eventueel eens een alternatief: Linux Mint. Soms doet die het wel waar Ubuntu het vertikt.

Offline MrMojorisin

  • Lid
    • rob70hoeben
  • Steunpunt: Nee
Re: Geen grafische weergave
« Reactie #19 Gepost op: 2014/07/20, 21:47:00 »
Dank voor je suggestie Bloom, misschien ga ik dat nog wel een keer doen. Ik heb altijd genoten van 12.04 en ook nu, na de nieuwe installatie en oplossing van het probleem met de grafische driver, vind ik dat 14.04 heerlijk rustig draait. Natuurlijk baal ik van het haperen van de wired verbinding maar ik vond nog een oude Sweex Wifi-dongel en die deed het meteen. (Terwijl hij het onder 12.04 nooit heeft gedaan)
Ik kan dus nu eerst een tijdje vooruit en kijken hoe 14.04 werkt op langere termijn.