Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: X-server  (gelezen 2165 keer)

SwOx

  • Gast
X-server
« Gepost op: 2007/03/22, 14:12:39 »
Wederom een poging ondernomen om Ubuntu te installeren. Alles verloopt vlot maar nog steeds niet grafisch. Mijn X-server is verkeerd geconfigureerd. ik had al ergens gelezen hem handmatig te configureren met xorgcfg of xorgconfig, maar deze commandos staan er niet tussen.
Enige hulp gevraagd.

Heb een ATI-radeon grafische kaart

Pensacola

  • Gast
X-server
« Reactie #1 Gepost op: 2007/03/22, 14:22:24 »
probeer eens sudo dpkg-reconfigure xserver-xorg en laat alles op de standaard waarden staan

Offline wutnubu

  • Lid
  • Steunpunt: Nee
X-server
« Reactie #2 Gepost op: 2007/03/22, 14:22:52 »
Doe eens:

sudo dpkg-reconfigure xserver-xorg

Succes


Heh alweer te traag met tikken

Offline Jelle

  • Lid
  • Steunpunt: Nee
X-server
« Reactie #3 Gepost op: 2007/03/22, 14:23:11 »
Even wat gekopieerd uit een ander topic. Ik had hetzelfde probleem, ook met een ATI kaart.


Intalleer in tekst modus. Wanneer het is geïnstalleerd haal je de cd eruit en start op in recovery mode. Je komt dan in een terminal (als root, dus sudo e.d is niet nodig).

Daar doe je:

cd /etc/X11
cp xorg.conf xorg.conf.old (een spatie na cp, en na de eerste conf; hiermee maak je een backup van xorg.conf)

dan: dpkg-reconfigure xserver-xorg (1 spatie, na reconfigure)

Je komt dan in een configuratie programma voor X (muis, toetsenbord, beeldscherm) Daar laat je alles zoals voorgesteld, BEHALVE de grafische driver. Dit is het tweede scherm waar je komt.
Hier staat ATI. Ga naar beneden en verander in VESA. Doorloop verder het hele verhaal met enter op wat wordt voorgesteld. (soms moet je met de rechter pijltjestoets zorgen dat YES of NEXT oid rood wordt. Dat merk je wel, want als je dat niet doet gebeurt er niets als je enter toetst)

Plotseling sta je dan weer in de terminal (het configuratiescherm blijft gewoon staan, overigens)
Daar kun je uitloggen met ctl alt del (of als je niet kunt wachten doe je startx)

Mocht het nu nog niet werken, dan moet je nog speciale bootparameters meegeven, zoals acpi=off. Hiervoor druk je in GRUB op e en voegt de bootparameter toe achter de regel die je ziet. Bij mij was dit niet nodig.

Deze info komt van https://help.ubuntu.com/6.10 en dan uit het gedeelte extracts from the Official Ubuntu Book, typical problems.

Offline Jelle

  • Lid
  • Steunpunt: Nee
X-server
« Reactie #4 Gepost op: 2007/03/22, 14:24:16 »
LOL, 3 bijdragen in een halve minuut. :)

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
X-server
« Reactie #5 Gepost op: 2007/03/22, 14:38:06 »
Soms moet je de TAB-toets gebruiken in de vragenriedel......

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
X-server
« Reactie #6 Gepost op: 2007/03/22, 15:00:54 »
Wat is het voordeel van de VESA driver t.o.v. de ATI driver ?
Op mijn oude PC met ATI kaart (zo oud, dat er nog buizen inzitten ;)) gebruikt gewoon de ATI driver, is dat niet goed dan ?
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

SwOx

  • Gast
X-server
« Reactie #7 Gepost op: 2007/03/22, 15:12:06 »
Ok, heb dat alles gedaan, maar nog steeds geen grafische mnode als ik dan startx ingeef.

Hij geeft als error : no screens found. Hoe los ik dit op?

Hoe installeer ik in teksmode?? Er moet nog een partitie aangemaakt worden en alles. Wil liefst niet weer formatten, 4x is genoeg op 2 dagen :D

SwOx

  • Gast
X-server
« Reactie #8 Gepost op: 2007/03/22, 15:13:58 »
Ok, heb dat alles gedaan, maar nog steeds geen grafische mode als ik dan startx ingeef.

Hij geeft als error : no screens found. Hoe los ik dit op?

Hoe installeer ik in teksmode?? Er moet nog een partitie aangemaakt worden en alles. Wil liefst niet weer formatten, 4x is genoeg op 2 dagen :D

Indien grafische mode sffs toch werkt, volgt er dan een installatie? Zo ver ben ik nl nog niet geraakt. Want er staat in het engels start or install ubuntu, maar indien je nr nederlands gaat enkel start ubuntu

Offline Jelle

  • Lid
  • Steunpunt: Nee
X-server
« Reactie #9 Gepost op: 2007/03/22, 15:51:02 »
Citaat van: r0n.
Wat is het voordeel van de VESA driver t.o.v. de ATI driver ?
Op mijn oude PC met ATI kaart (zo oud, dat er nog buizen inzitten ;)) gebruikt gewoon de ATI driver, is dat niet goed dan ?
Oude PC, dus geen problemen. Op nieuwere PC's werkt de standaard ATI driver vaak niet. Gevolg: de live cd doet het niet en na installatie van de alternate cd wil X niet draaien.
Met de VESA driver krijg je dan wel een grafische omgeving. Vervolgens kun je op je gemak de closed source ATI driver via Synaptic installeren.

Offline Jelle

  • Lid
  • Steunpunt: Nee
X-server
« Reactie #10 Gepost op: 2007/03/22, 15:54:11 »
Citaat van: SwOx
Ok, heb dat alles gedaan, maar nog steeds geen grafische mode als ik dan startx ingeef.

Hij geeft als error : no screens found. Hoe los ik dit op?

Hoe installeer ik in teksmode?? Er moet nog een partitie aangemaakt worden en alles. Wil liefst niet weer formatten, 4x is genoeg op 2 dagen :D

Indien grafische mode sffs toch werkt, volgt er dan een installatie? Zo ver ben ik nl nog niet geraakt. Want er staat in het engels start or install ubuntu, maar indien je nr nederlands gaat enkel start ubuntu
Begijp ik goed dat de installatie überhaupt nog nooit gelukt is?
Dan heb ik je verkeerd begrepen. Ik dacht dat ubuntu al op je systeem stond, maar dat de grafische omgeving niet werkte.

Wanneer je nog moet installeren: gebruik de alternate cd, want de live cd zal bij jouw ATI kaart niet werken. Kies voor "installeer in tekst mode" en volg na installatie de instruktie uit mijn eerdere post.

SwOx

  • Gast
X-server
« Reactie #11 Gepost op: 2007/03/25, 18:52:54 »
Ok, ik heb ubuntu geinstalleerd in tekstmodus, allemaal zeer vlot verlopen.

Toen deed ik : sudo dpkg-reconfigure xserver-xorg
Alles laten staan buiten Driver op VESA te gezet. Erna deed ik startx, maar nu krijg ik helemaal nix meer? Mijn scherm gaat gewoon in standby?

Wat moet ik nu doen ??

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
X-server
« Reactie #12 Gepost op: 2007/03/25, 19:01:47 »
opnieuw sudo dpkg-reconfingure xserver-xorg uitvoeren en terug uw ATI driver selecteren.

NA EDIT: sudo dpkg-reconfigure xserver-xorg is het juiste commando.
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
X-server
« Reactie #13 Gepost op: 2007/03/25, 19:33:06 »
tikfoutje: reconfigure, geen reconfingure........  :-)

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
X-server
« Reactie #14 Gepost op: 2007/03/25, 20:30:10 »
Daarom dat er bij mij nooit wat gebeurde als ik het commando ingaf ... lol
post is aangepast.
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

SwOx

  • Gast
X-server
« Reactie #15 Gepost op: 2007/03/25, 22:40:43 »
Jama het probleem is, ik zie nix meer. Ik kies ubuntu om op te starten, en dan valt het scherm in standby en er valt nix te doen.

Kan er nu iemand helpen

SwOx

  • Gast
X-server
« Reactie #16 Gepost op: 2007/03/25, 23:49:29 »
Ik krijg als error : no screens found ???
Iemand eventueel enige raad wat te doen ??
heb Vesa terug naar ati gezet, en nu heeft ie de Xserver gedisabled.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
X-server
« Reactie #17 Gepost op: 2007/03/25, 23:58:54 »
Probeer eens een versiewissel. Dus installeer eens Ubuntu 6.06 i.p.v. 6.10, of omgekeerd.

Offline Jelle

  • Lid
  • Steunpunt: Nee
X-server
« Reactie #18 Gepost op: 2007/03/26, 08:55:49 »
Mogelijk werkt X pas wanneer je de closed source ATI driver hebt geïnstalleerd. Maar dat zal dan in de terminal moeten.

Wellicht dat iemand daarvoor de juiste terminal spreuken zou kunnen posten ?

En mocht je 6.06 hebben geïnstalleerd, vervang deze dan eens door 6.10. Wellicht is de hardwareherkenning dan net even beter.