Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Unstable  (gelezen 1157 keer)

Offline Bloom

  • Lid
  • Steunpunt: Ja
Unstable
« Gepost op: 2013/05/19, 13:14:08 »
Ik begin toch de nadelen te merken van Sid, of wat Debian "Unstable" noemt. Eind maart had ik immers voor LinuxBBQ Paardenrookvlees gekozen als opvolger van mijn ouwe getrouwe Ubuntu 10.04 'Lucid Lynx' die immers vanaf april geen updates meer krijgt. LinuxBBQ Paardenrookvlees is gebaseerd op Debian Sid (unstable, eigenlijk vanaf Siduction) maar dan met de MATE-desktop. Sinds de release van de nieuwe Debian Testing getiteld Jessie komen er nu ook weer volop nieuwe pakketten binnen in de unstable repo's. Wat ik nog niet wist, is dat nieuwe pakketten ook al in unstable terecht komen als de bibliotheken die ze nodig hebben, nog niet bijgewerkt zijn. Dat levert dan problemen op bij pakkettenupgrades, want als aptitude merkt dat de bibliotheken niet beschikbaar zijn deïnstalleert hij gewoon de applicaties of zelfs systeemonderdelen die die ontbrekende bibliotheken nodig hebben.
Voor wat ik doe prefereer ik eigenlijk een superstabiel systeem en geen experimenteel. Ik ga dus overstappen naar de nieuwe Debian Stable (Wheezy, die ik immers als de vorige testing al gebruikte op mijn oudere pc's) maar ik moet nog beslissen of dat met MATE of met XFCE wordt. Standaard installeert hij Gnome3 en die wil ik beslist niet! Na een paar maanden op oudere computers met XFCE en op nieuwe met MATE gewerkt te hebben, begin ik meer en meer XFCE te prefereren. Dat lijkt me stabieler en flukser dan MATE.

Offline Joris Donders

  • Lid
  • Steunpunt: Ja
Re: Unstable
« Reactie #1 Gepost op: 2013/05/20, 15:22:38 »
XFCE niets dan lof in ieder geval; Mate daarentegen is denk ik nog te jong om als stabiele omgeving te gebruiken, maar ook daar werkt men hard aan de winkel, maar helaas kan het in mijn ogen niet gebruikt worden als 'betrouwbare' omgeving.

Debian Unstable heb ik altijd gemeden; zelfs niet eens uitgetest.
Gubuntu 17.04 wegens verdwijnen Unity binnenkort

Offline Xelron X

  • Lid
  • Steunpunt: Nee
Re: Unstable
« Reactie #2 Gepost op: 2013/05/20, 17:46:20 »
Debian Unstable heb ik altijd gemeden; zelfs niet eens uitgetest.

Als u Ubuntu gebruikt hebt of nog steeds gebruikt dan heeft u Debian Unstable niet kunnen mijden. De versies van voor ubuntu 12.04 waren namelijk gebaseerd op Debian Unstable.
Tegenwoordig zijn de LTS versies gebaseerd op Debian Testing en de tussenversies zijn gebaseerd op Unstable.

De basis van Ubuntu is en blijft immers Debian dus heeft u toch met Debian Unstable gewerkt.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Unstable
« Reactie #3 Gepost op: 2013/05/20, 17:58:20 »
Debian Unstable heb ik altijd gemeden; zelfs niet eens uitgetest.

Als u Ubuntu gebruikt hebt of nog steeds gebruikt dan heeft u Debian Unstable niet kunnen mijden. De versies van voor ubuntu 12.04 waren namelijk gebaseerd op Debian Unstable.
Tegenwoordig zijn de LTS versies gebaseerd op Debian Testing en de tussenversies zijn gebaseerd op Unstable.

De basis van Ubuntu is en blijft immers Debian dus heeft u toch met Debian Unstable gewerkt.
Ha leuk, een wedstrijdje "spijkers op laag water zoeken"...  =D

Neeeee, want.... Ubuntu is geen Debian. Debian is slechts de grondstof / het halffabrikaat voor Ubuntu.

Dus Joris Donders heeft inderdaad nimmer Debian Unstable gebruikt.  Quod erat demonstrandum.

Offline Xelron X

  • Lid
  • Steunpunt: Nee
Re: Unstable
« Reactie #4 Gepost op: 2013/05/21, 00:38:26 »
U maakt er een wedstrijd van niet ik.

Daarom zei ik ook dat de basis van Ubuntu nog steeds Debian is wat u grondstof noemt. Dus diep in de kern is en blijft het een distributie gebaseerd op en een derivaat van Debian met Testing én Unstable als basis waar Ubuntu op verder bouwt.

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: Unstable
« Reactie #5 Gepost op: 2013/05/21, 11:08:05 »
XFCE niets dan lof in ieder geval;
Versie 4.08 (Xuby 12.04) is een hele stabiele, versie 4.10 (Xuby 12.10 / 13.04) vind ik vriendelijker, maar in Xuby 13.10 schijnen ze XFCE 4.12 te willen hebben.
Deze opa zit nu me trappelende voetjes van nieuwsgierigheid te wachten :lol:
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een Dwarsligger.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Unstable
« Reactie #6 Gepost op: 2013/05/21, 11:11:01 »
U maakt er een wedstrijd van niet ik.

Daarom zei ik ook dat de basis van Ubuntu nog steeds Debian is wat u grondstof noemt. Dus diep in de kern is en blijft het een distributie gebaseerd op en een derivaat van Debian met Testing én Unstable als basis waar Ubuntu op verder bouwt.


Maar het blijft toch anders qua updates e.d. Ubuntu borduurt voort met een vastgezet aantal pakketten (op een paar uitzonderingen als Firefox en Chromium na) en voert alleen bug-fix- en veiligheids-updates door. En wat doet Debian Unstable? (let ook op de naam 'Unstable')

Offline Xelron X

  • Lid
  • Steunpunt: Nee
Re: Unstable
« Reactie #7 Gepost op: 2013/05/21, 13:28:51 »
maar in Xuby 13.10 schijnen ze XFCE 4.12 te willen hebben.
Deze opa zit nu me trappelende voetjes van nieuwsgierigheid te wachten :lol:

Xfce 4.12 had afgelopen Maart moeten verschijnen. Zover ik weet hebben ze dit niet kunnen bewerkstelligen en houden ze zich niet meer aan een vast release schema maar volgen ze het "it will be released when we think it's ready" principe. Dus wanneer 4.12 vrij gegeven wordt en of deze in 13.10 komt is nog maar de vraag.

We blijven natuurlijk hopen van wel.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Unstable
« Reactie #8 Gepost op: 2013/05/21, 14:20:08 »
Laatste berichten die ik opvatte van Xfce-devs is dat het rond augustus verschijnt. Dat is rond of net na Ubuntu's feature freeze. Er is dus een kans dat het in 13.10 komt.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Unstable
« Reactie #9 Gepost op: 2013/05/21, 14:30:53 »
Laatste berichten die ik opvatte van Xfce-devs is dat het rond augustus verschijnt. Dat is rond of net na Ubuntu's feature freeze. Er is dus een kans dat het in 13.10 komt.
Als 't maar in 14.04 LTS zit.... Die tussenversies vind ik niet zo belangrijk meer.  =D

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Unstable
« Reactie #10 Gepost op: 2013/05/21, 14:33:09 »
Laatste berichten die ik opvatte van Xfce-devs is dat het rond augustus verschijnt. Dat is rond of net na Ubuntu's feature freeze. Er is dus een kans dat het in 13.10 komt.
Als 't maar in 14.04 LTS zit.... Die tussenversies vind ik niet zo belangrijk meer.  =D

Aan de ene kant ben ik het met je eens. Maar aan de andere kant: als 4.12 in 13.10 zit en daarna in 14.04 komt dan heb je het meest robuuste systeem ooit omdat 4.12 dan 2 Xubuntu-versies lang beproefd is :)

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Unstable
« Reactie #11 Gepost op: 2013/05/21, 14:43:38 »
Aan de ene kant ben ik het met je eens. Maar aan de andere kant: als 4.12 in 13.10 zit en daarna in 14.04 komt dan heb je het meest robuuste systeem ooit omdat 4.12 dan 2 Xubuntu-versies lang beproefd is :)
Klopt, ja....

Maar het zou niet zo heel erg veel uitmaken, want er is natuurlijk meer dan Xubuntu: Xfce is immers een bovenstrooms project, dat ten goede komt aan alle distro's.

Het zou me bijvoorbeeld niet verbazen als Mint 16 Xfce, die gebouwd zal worden op Ubuntu 13.10, een hogere Xfce-versie zal hebben dan Xubuntu 13.10. Hangt een beetje af van de verschijningsdatum. Ach ja, we zien wel....

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: Unstable
« Reactie #12 Gepost op: 2013/05/21, 15:37:08 »
Sinds de release van de nieuwe Debian Testing getiteld Jessie komen er nu ook weer volop nieuwe pakketten binnen in de unstable repo's. Wat ik nog niet wist, is dat nieuwe pakketten ook al in unstable terecht komen als de bibliotheken die ze nodig hebben, nog niet bijgewerkt zijn.
Dat had je kunnen weten..... ;) Ook Jessie gaat hiermee te maken krijgen de komende tijd. Na een half jaartje zijn de meeste bugs er wel uit na een nieuwe Stable. In het begin heb je behoorlijk handwerk nodig.
Laptops + werkstations: Debian Stable + backports, server Debian Stable.
Test-laptop: Debian Tesing/Unstable

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: Unstable
« Reactie #13 Gepost op: 2013/05/22, 21:45:12 »
Het gaat niet per se om bugs, meer om pakketten in omloop brengen zonder dat de vereiste bibliotheken bijgewerkt zijn. Dat is gewoon idioot en biedt geen enkel voordeel. De juiste aanpak zou zijn om pakketten alleen maar samen met de vereiste bibliotheekversies te distribueren. Wie nog gevaarlijker wil leven, kan tenslotte nog in de experimental repo terecht.
Overigens treedt dit specifieke probleem alleen op bij Sid/Unstable, niet bij Jessie/Testing.

Offline Xelron X

  • Lid
  • Steunpunt: Nee
Re: Unstable
« Reactie #14 Gepost op: 2013/05/23, 00:17:32 »
Bloom,

Als u bijvoorbeeld met Unstable werkt kan u natuurlijk ook safe upgrade gebruiken om problemen te voorkomen naar het schijnt en wat ik ervan begrepen heb. Dan zouden wij toch gewoon kunnen updaten/upgraden zonder dat de pakketten mee komen waarvan de vereiste bibliotheken nog niet bijgewerkt zijn. Of heb ik het daar misschien mis?
Mijn persoonlijke mening is dan ook, indien ik gelijk mocht hebben, dat mensen die al langere tijd Debian en zeker de Unstable tak gebruiken dit zouden moeten weten. Zolang we niet 100% zeker weten wat we doen is het beter om het te mijden.

Ik ben net pas begonnen mezelf het één en ander aan het leren over Debian dus ik weet ook niet alles 100% zeker en betreft het meer een logische beredenering wat ik zei. Ook zal ik zelf weg blijven van de Unstable tak, zelfs Testing en gebruik ik liever een stabiele uitgave van Debian tot ik wat meer geleerd heb over deze distributie.

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: Unstable
« Reactie #15 Gepost op: 2013/05/23, 09:19:04 »
Voor de duidelijkheid: ik werkte wel degelijk met safe-upgrade bij LinuxBBQ.