Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [ SOLVED ]Flashplayer, hoe nu verder.  (gelezen 2255 keer)

Offline kuifje09

  • Lid
[ SOLVED ]Flashplayer, hoe nu verder.
« Gepost op: 2013/04/20, 20:22:37 »
Al sinds  enige tijd tob ik wat af met de adobe flashplayer. Op vershillende fora wordt daar een mening over gespuid, en ik vraag me af wat de gedachte ( algemeen ) daarover is op dit forum. De laatse berichten over flashplayer zijn hier niet recent.
Allereerst, de Gnashplayer is niet  een 100%  vervanger voor de flashplayer. Dat mag duidelijk zijn, daar gaat de discussie niet over.
Maar, waarom kan je bij een nieuwe installatie van een oude distributie,  b.v. xubuntu 10.04, de flashplayer niet werkend krijgen. Dat moet ergens in de recente updates zitten, die er voor 10.04 niet meer zouden zijn?
Waarom werkt flash nog 100% op een ubuntu 11.10 systeem met Firefox 19.x en flashversie xx.275 wel.
Daar heb ik dus sinds een paar maanden alle updates onderdrukt, en nu uitgezet.

Als het daar wel werkt en in een nieuwe installatie met recente(?) updates niet meer, dan is er wat anders aan de hand dan het niet meer ondersteunen wat hier en daar wordt geroepen. Dit is in mijn ogen, en ben druk aan het zoeken naar de oorzaak, een opzettelijk uitschakelen op een voor mij nog niet gevonden nivo.
Kennelijk niet firefox en de plugins, maar dieper in het systeem.

Heeft iemend anders daar wellicht al naar gezocht en het antwoordt gevonden?  dat scheelt mij wat zoek en pruts werk, want dat is het wel.
« Laatst bewerkt op: 2013/04/21, 19:23:48 door kuifje09 »

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Flashplayer, hoe nu verder.
« Reactie #1 Gepost op: 2013/04/20, 20:45:32 »
Heb Flash Player in een volledig bijgewerkte Xubuntu 12.04, 12.10, Mint 13, Mint 14 en openSUSE 12.3. Deze Flash Player wordt regelmatig bijgewerkt met veiligheidsupdates.

Ik begrijp je probleem dus niet... Flash Player zou gewoon moeten werken bij jou. Met updates en al. Het is in elk geval beslist geen algemeen probleem voor iedereen....
« Laatst bewerkt op: 2013/04/20, 20:48:06 door Pjotr »

Offline kuifje09

  • Lid
Re: Flashplayer, hoe nu verder.
« Reactie #2 Gepost op: 2013/04/20, 20:49:28 »
Dat is dan vreemd. Na de recente updates gaat het overal mis. Al meerdere nieuwe installaties geprobeerd.
Wellicht een combinatie met de nouveau driver of juis de nvidia driver ?
Ik heb hier de nouveau draaien.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Flashplayer, hoe nu verder.
« Reactie #3 Gepost op: 2013/04/20, 20:52:56 »
Heb je ubuntu-restricted-extras al geïnstalleerd?

Offline kuifje09

  • Lid
Re: Flashplayer, hoe nu verder.
« Reactie #4 Gepost op: 2013/04/20, 21:14:02 »
Tja, meestal doe ik dat meteen, nu even niet. Maar het heeft niet geholpen. Dat is ook precies de discussie die ik elders tegenkom, het werkt niet meer, gebruik de gnashplayer maar.

Kan ik nog wat anders over het hoofd hebben gezien ?

O, dit nog,  het video scherm van de speler schakeld van zwart naar wit , afhankelijk van de muis lijkt het... maar meer niet.
« Laatst bewerkt op: 2013/04/20, 21:15:39 door kuifje09 »

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Flashplayer, hoe nu verder.
« Reactie #5 Gepost op: 2013/04/20, 21:18:24 »
Tja, je kunt nog Chrome installeren, dan heb je de nieuwste Flash Player. Ik ben zelf geen Chrome-fan maar voor jou helpt dat allicht.

Offline kuifje09

  • Lid
Re: Flashplayer, hoe nu verder.
« Reactie #6 Gepost op: 2013/04/20, 21:20:37 »
Wat chrome betreft ben ik ook niet enthousiast. Maar buitendat, ik wil graag flash weer aan de praat hebben in firefox.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Flashplayer, hoe nu verder.
« Reactie #7 Gepost op: 2013/04/20, 21:25:29 »
Welke Ubuntu-versie gebruik je eigenlijk? Want uit je eerste bericht maak ik op dat je 10.04 of 11.10 hebt? 10.04 wordt vanaf volgende maand niet meer ondersteund en 11.10 heeft ook niet heel lang meer te gaan... wellicht kun je 12.04 LTS proberen? Of als dat niet werkt 12.10 of 13.04?

Offline kuifje09

  • Lid
Re: Flashplayer, hoe nu verder.
« Reactie #8 Gepost op: 2013/04/20, 21:30:26 »
Ik werk nu even met xubuntu 10.04. Gewoon voor de test. Maar ik kom mijn beschreven probleem tegen in al mijn systemen die ik update / upgrade...

Offline kuifje09

  • Lid
Re: Flashplayer, hoe nu verder.
« Reactie #9 Gepost op: 2013/04/20, 22:20:16 »
Omdat ik er een beetje boos van wordt heb ik nu de libflashplayer.so hier allemaal neergezet:

/usr/lib/flash-plugin/libflashplayer.so
/usr/lib/mozilla/plugins/libflashplayer.so
/etc/alternatives/libflashplayer.so

Maar het mag allemaal niet baten. Ondanks dat firefox duidelijk aangeeft dat hij is geinstalleerd.

Offline Bobbie

  • Lid
  • Steunpunt: Nee
Re: Flashplayer, hoe nu verder.
« Reactie #10 Gepost op: 2013/04/20, 23:19:15 »
Ik werk nu even met xubuntu 10.04. Gewoon voor de test. Maar ik kom mijn beschreven probleem tegen in al mijn systemen die ik update / upgrade...

Oude systemen udate/upgrade, het beste is gewoon de 12.04 binnenhalen en lekker schoon installeren
https://sites.google.com/site/computertip/herinstallatie.

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: Flashplayer, hoe nu verder.
« Reactie #11 Gepost op: 2013/04/21, 01:46:11 »
Omdat ik er een beetje boos van wordt heb ik nu de libflashplayer.so hier allemaal neergezet:
/usr/lib/flash-plugin/libflashplayer.so
/usr/lib/mozilla/plugins/libflashplayer.so
/etc/alternatives/libflashplayer.so
Maar het mag allemaal niet baten. Ondanks dat firefox duidelijk aangeeft dat hij is geinstalleerd.

Probeer eens /usr/lib/flashplugin-nonfree/libflashplayer.so en /usr/lib/mozilla/plugins/flash-mozilla.so (ik werk wel met Debian, niet met Ubuntu).

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Flashplayer, hoe nu verder.
« Reactie #12 Gepost op: 2013/04/21, 06:42:43 »
Ubuntu 12,04 installeren en bij installatie, update's en multimedia(ubuntu restricted extra's) installeren.
Dan dit volgen en precies zo installeren, https://sites.google.com/site/computertip/multimedia
Dit is alles wat ik doe, en alles werkt.
Indien je teveel gaat installeren, dan gaat alles net slechter werken.

Welke cpu heb je?
Er was een intel cpu, waar de flash player niet mee werkt, zoek hier op.
Als je hier last van hebt, dan misschien Chromium Web Browser proberen.
« Laatst bewerkt op: 2013/04/21, 06:44:24 door jan11000 »

Offline kuifje09

  • Lid
Re: Flashplayer, hoe nu verder.
« Reactie #13 Gepost op: 2013/04/21, 13:08:39 »
Nou bedankt voor de reakties, maar het wil nog niet lukken.  Flash-scherm blijft wit-zwart-wit en stopt/ doet niets.
Vreemd dat dit steeds een probleem is.  Wel opmerkelijk dat nu ik de lib-file zelf op 3 plaatsen heb neergezet, de about:plugins in de prefs van flashplayer, de speler lib 2 * laat zien.  ( 2 * swf en 2 * spl )
Helaas ben ik er niet in geslaagd te achterhalen waar firefox denkt dat de plugins staan.
Een paar staan vermeld in de about:config, maar lang niet allemaal.

Overigens is dit een athlon cpu.   Maar ,  als ik Xubuntu 12.04 vers instaleer, zou de flashspeler gewoon moeten werken zeggen jullie?  Ook de interactieve flashspellen, of b.v. auto-sites, die hebben ook interactieve flash demo's etc.  Waarom dan niet op een verse installatie van Xubuntu 10.04  en eveneens niet op een ubuntu 12.04 ?
« Laatst bewerkt op: 2013/04/21, 13:12:29 door kuifje09 »

Offline erik1984

  • Lid
    • erik1984
  • Steunpunt: Nee
Re: Flashplayer, hoe nu verder.
« Reactie #14 Gepost op: 2013/04/21, 13:53:00 »
Wat is de uitkomst van
cat /proc/cpuinfo | grep sse2?
Misschien is je processor gewoon niet geschikt meer voor Flash onder Linux.

Offline kuifje09

  • Lid
Re: Flashplayer, hoe nu verder.
« Reactie #15 Gepost op: 2013/04/21, 15:46:50 »
cpuinfo processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 8
model name      : AMD Athlon(tm) XP 2200+
stepping        : 1
cpu MHz         : 1800.113
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow up
bogomips        : 3600.22
clflush size    : 32
cache_alignment : 32
address sizes   : 34 bits physical, 32 bits virtual
power management: ts

Niks over sse2 .

en de firefox crashreport over de flashplayer EMCheckCompatibility=true
ProductName=Firefox
Vendor=Mozilla
InstallTime=1366471843
Theme=classic/1.0
Notes=OpenGL: NVIDIA Corporation -- GeForce4 MX 460/AGP/SSE/3DNOW! -- 1.5.8 NVIDIA 96.43.17 -- texture_from_pixmap\n
Version=20.0
ReleaseChannel=release
ServerURL=https://crash-reports.mozilla.com/submit?id={ec8030f7-c20a-464f-9b0e-13a3a9e97384}&version=20.0&buildid=20130329043827
Add-ons=langpack-en-ZA%40firefox.mozilla.org:20.0,langpack-en-GB%40firefox.mozilla.org:20.0,ubufox%40ubuntu.com:2.6,%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D:20.0
BuildID=20130329043827
ProductID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}
CrashTime=1366490925
StartupTime=1366490925
ProcessType=plugin
PluginVersion=
PluginName=Shockwave Flash
PluginFilename=libflashplayer.so

Offline kuifje09

  • Lid
Re: Flashplayer, hoe nu verder.
« Reactie #16 Gepost op: 2013/04/21, 15:49:14 »
Overigens nog even dit,  Ik zal deze listings ook even doen op mijn andere athlon systeem. Even geduld a.u.b.

Is gebeurd en shocking...  Zelfde gegevens, maar helaas daar al gnash geinstalleerd.
Maar ook geen sse2    ook alleen maar sse.

Nog een extra...  mijn Intel-doos kent wel sse en sse2.


Nu rijst dus de vraag waar de update/upgrade fout gaat. Als sommige software sse2 nodig hebben, waarom wordt het dan geinstalleerd als die sse2 instructies daar helemaal niet bestaan?  Dit is echt belachelijk.

Maar... wellicht is er een oplossing?

Atlon Xp of iets dergelijks met SSE2 : Response: There are no socket A processors with SSE2 instructions.
« Laatst bewerkt op: 2013/04/21, 16:32:25 door kuifje09 »

Offline Marqeaux

  • Lid
  • Steunpunt: Nee
Re: Flashplayer, hoe nu verder.
« Reactie #17 Gepost op: 2013/04/21, 16:41:48 »
Dit probleem is al langer bekend op oudere AMD processoren. Lees er hier meer over...
http://forum.ubuntu-nl.org/software-en-configuratie/flash-probleem-73477/msg815143/#msg815143
I'm just a simple guy who uses open source software. What's your excuse?

Offline kuifje09

  • Lid
Re: Flashplayer, hoe nu verder.
« Reactie #18 Gepost op: 2013/04/21, 18:52:44 »
Die had ik nog net gezien. Maar er staat ook niet in waarom.  Wat is oud he?  Jammer dat ik de flashplayer niet even zelf kan compileren. Wel vraag ik me nu af waar ik nog meer problemen in kan verwachten?

Offline kuifje09

  • Lid
Re: Flashplayer, hoe nu verder.
« Reactie #19 Gepost op: 2013/04/21, 19:23:12 »
Okee, dat is dan weer duidelijk. De laatste flashplayers zijn fout gecompileerd. Of anders gezegd, er wordt gedacht dat iedereen zo langzamerhand wel een nieuwe PC heeft. Ik dus niet. En dat zal voorlopig ook niet gebeuren. De centen groeien niet in mijn tuin.

Maar de 11.1.102.63  flashspeler doet het dan weer wel, al is het met geklaag.  Zo lang die het doet ben ik blij. Ik gebruik hem niet op al mijn systemen, en zeker niet op de belangrijke systemen. Daar doe ik al helemaal niets met spellen enz.

Op dat bestandje ga ik dus even zitten.

Ik ben wel blij dat het niet de schuld is van welke buntu dan ook, maar van de flashbouwer.

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: [ SOLVED ]Flashplayer, hoe nu verder.
« Reactie #20 Gepost op: 2013/04/21, 19:25:49 »
Als ik zo deze site check Adobe Flash Crashes/Doesn't Load on Older Machines, dan lijkt het erop dat er geen goede oplossing beschikbaar is. Alleen die opmerking dat Windows hetzelfde probleem hebben, lijkt niet te kloppen. Zie bijvoorbeeld deze thread Adobe bug affects millions of AMD cpus without SSE2. Een quote hieruit
Citaat
The Windows version of the 11.2 Flash doesnt use SSE2 and thus these same systems are unaffected and Flash runs just fine, yet the Linux version with its SSE2 requirements wont run.
Ik heb dit kunnen verifiëren op de oude AthlonXP pc uit mijn onderschrift, die eveneens geen SSE2 ondersteund. En inderdaad op Windows XP blijkt Adobe Flash versie 11.7.700.169 gewoon te werken. Ofschoon het wel te zien is, dat deze met een AtlonXP 1700+ te langzaam is, voor een vloeiende weergave.


Zelf compileren van Adobe Flash is niet mogelijk. Want het is geen open bron software. Zie daarover Wikipedia http://nl.wikipedia.org/wiki/Adobe_Flash_Player
Een eventuele oplossing kan daarom alleen geleverd worden door Adobe.


« Laatst bewerkt op: 2013/04/21, 19:28:59 door jolo »
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline kuifje09

  • Lid
Re: [ SOLVED ]Flashplayer, hoe nu verder.
« Reactie #21 Gepost op: 2013/04/21, 19:45:46 »
Je zou toch zeggen dat het er wel moet zijn:

http://www.adobe.com/cfusion/search/index.cfm?loc=en_us&term=software%20source%20flashplayer&cat=all

Flash Player is the foundation of the next generation of the Adobe Flash Platform,
built on open technologies and open-source community participation. ... G.711
audio compression for telephony, H.264/AVC software encoding, and advanced ...

en wat de CPU betrefd:
Linux

    x86-compatibele processor van 2,33 GHz of sneller of Intel Atom-processor van 1,6 GHz of sneller voor netbooks
    Red Hat® Enterprise Linux® (RHEL) 5.6 of hoger (32-bits en 64-bits), openSUSE® 11.3 of hoger (32-bits en 64-bits), of Ubuntu 10.04 of hoger (32-bits en 64-bits)
    Mozilla Firefox 17 of Google Chrome
    512 MB RAM; 128 MB grafisch geheugen

Opmerking: Flash Player 11.2 is de laatst ondersteunde Flash Player-versie voor Linux. Adobe blijft beveiligingsupdates uitbrengen.

Maar wat mij betrefd is het opgelost hoor, iemand zit fout te compileren. Thats it. Hopelijk komt er wel een update om dit te corrigeren.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: [ SOLVED ]Flashplayer, hoe nu verder.
« Reactie #22 Gepost op: 2013/04/21, 20:09:47 »
@kuifje: Gebouwd op open source betekent niet dat het product ook open source moet zijn. Er zit DRM in Flash Player en dat kan gewoonweg niet worden geopensourced. Vandaar dus dat Flash Player closed source is.

Maar dat wil niet zeggen dat Adobe nooit broncode vrijgeeft. Ze hebben ook een paar open source-producten zoals bijv. Phonegap en Flex. Maar Flash Player kan gewoonweg niet open source worden gemaakt.

Offline kuifje09

  • Lid
Re: [ SOLVED ]Flashplayer, hoe nu verder.
« Reactie #23 Gepost op: 2013/04/24, 00:27:39 »
Toch nog even op onderzoek geweest op de adobe site. Wel even zoeken, maar als je HAL instaleerd zou het ook moeten werken, en met de laatste flashplayer. Wellicht is dat de betere keuze.
Alhoewel er dan mensen roepen dat HAL niet meer een aanbevolen programma is.
Overigens geld hetzelfde probleem voor windows instalaties. maar die heben geen HAL.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: [ SOLVED ]Flashplayer, hoe nu verder.
« Reactie #24 Gepost op: 2013/04/24, 01:02:37 »
HAL wordt niet meer gebruikt in Ubuntu.