Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: locatie home directory  (gelezen 838 keer)

Offline henkchr

  • Lid
  • Steunpunt: Nee
locatie home directory
« Gepost op: 2012/07/18, 12:42:40 »
Heb een ssd en een harddisk in mijn computer systeem

Waar kan ik nu het beste de home directory plaatsen ?..Nu heb ik ubuntu op de ssd geinstalleerd.

Als ik de home directory op de harddisk wil hebben moet ik dan opnieuw de installatie doen ?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: locatie home directory
« Reactie #1 Gepost op: 2012/07/18, 15:47:21 »
Ik zou de home lekker op de SSD laten staan, dan heb je de meeste snelheidswinst.


Offline henkchr

  • Lid
  • Steunpunt: Nee
Re: locatie home directory
« Reactie #2 Gepost op: 2012/07/18, 17:19:11 »
OK maar ik kies toch liever voor de harde schijf

mount /dev/sdb /home

leidt tot hetzelfde resultaat ?

« Laatst bewerkt op: 2012/07/18, 17:36:41 door henkchr »

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: locatie home directory
« Reactie #3 Gepost op: 2012/07/18, 17:59:45 »
Nee, je moet /home naar een partitie laten wijzen en niet naar een hele harddisk (zelfs al bevat die maar één partitie).
Koppel eerst de partitie aan waar /home op terecht zal komen en zorg dat je alle eigendomsrechten hebt
sudo mkdir /mnt/tijdelijk
sudo mount /dev/sdb1 /mnt/tijdelijk
sudo chown -R gebruiker:gebruiker /mnt/tijdelijk/
Kopieer dan eerst de inhoud van /home naar zijn nieuwe plaats:
rsync -vau --super /home/ /mnt/tijdelijk/Koppel nu het tijdelijke los en koppel de nieuwe /home aan:
sudo umount /mnt/tijdelijk
sudo rm -r /mnt/tijdelijk
sudo mount /dev/sdb1 /home
En vul daarna de nieuwe /home ook in in /etc/fstab zodat je systeem van bij het opstarten werkt met de correcte home.
sudo gedit /etc/fstab &en voeg deze regel toe:
/dev/sdb1                 /home               ext4    errors=remount-ro 0       1

Offline henkchr

  • Lid
  • Steunpunt: Nee
Re: locatie home directory
« Reactie #4 Gepost op: 2012/07/18, 20:38:01 »
hoe langer ik er naar kijk hoe minder ik er van snap  :|

moet er nog even bij zeggen dat er nu nog geen bestanden in de home map staan.
 
de harddisk is gemount en heeft nu als locatie:  /media

wat nu te doen .....




Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: locatie home directory
« Reactie #5 Gepost op: 2012/07/18, 20:42:22 »
Je hoeft eigenlijk alleen maar de instructies op te volgen.

Offline henkchr

  • Lid
  • Steunpunt: Nee
Re: locatie home directory
« Reactie #6 Gepost op: 2012/07/19, 19:18:50 »
OK  ik snap het vandaag gelukkig wel weer

maar klopt dit gedeelte van de code wel ?

sudo gedit /etc/fstab &

als ik dit in de terminal intik gebeurd er niks


Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: locatie home directory
« Reactie #7 Gepost op: 2012/07/19, 19:20:56 »
Er kan niet niks gebeuren. Ofwel er verschijnt een scherm, ofwel een foutmelding.

Offline henkchr

  • Lid
  • Steunpunt: Nee
Re: locatie home directory
« Reactie #8 Gepost op: 2012/07/19, 19:45:00 »
hij geeft 2708

Offline henkchr

  • Lid
  • Steunpunt: Nee
Re: locatie home directory
« Reactie #9 Gepost op: 2012/07/19, 20:02:59 »
sorry moest nog even als su inloggen ....


Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: locatie home directory
« Reactie #10 Gepost op: 2012/07/20, 00:13:34 »
Maar dat doet sudo juist voor je.

Offline henkchr

  • Lid
  • Steunpunt: Nee
Re: locatie home directory
« Reactie #11 Gepost op: 2012/07/20, 19:40:43 »

Heb alle stappen doorlopen en fstab ziet er nu zo uit :

staat de regel die ik moest toevoegen er zo goed in ?

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=4d66cfbf-92e0-4067-b2d4-2f66f562677a /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=4fced261-89b3-429b-83e8-00e8d3a8d8cc none            swap    sw              0       0
#/dev/sdb1                 /home               ext4    errors=remount-ro 0       1

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: locatie home directory
« Reactie #12 Gepost op: 2012/07/20, 20:28:47 »
Nu heb je de regel die je /home zou  moeten aankoppelen voorzien van een #, waardoor het een commentaarregel wordt. Waarom?

Offline henkchr

  • Lid
  • Steunpunt: Nee
Re: locatie home directory
« Reactie #13 Gepost op: 2012/07/20, 20:44:41 »
omdat het bij de rest ook staat , leek me wel zo logisch... =D :rolleyes:
ik ga em gelijk weghalen ..
overigens functioneert alles wel goed ondanks dat hekje

opende fstab net weer en wat blijkt ...dat hekje is verdwenen ...
« Laatst bewerkt op: 2012/07/20, 20:48:03 door henkchr »