Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: installatie op RAID lukt niet  (gelezen 1129 keer)

Offline rkerklaan

  • Lid
  • Steunpunt: Nee
installatie op RAID lukt niet
« Gepost op: 2012/05/08, 17:52:10 »
hoi hoi

Ik probeer een schone installatie te maken op een nieuwe RAID. 2 HDtjes er in, RAIDkaartje in het slot en opstarten maar. Er verschijnt een menu waarin je de RAIDs kunt configureren, ik kies mirror en OK, gaan met die banaan.
Met de live CD maak ik partities met gparted, Op de 1 of andere manier ziet hij beide HDś zelfstandig, maar ik herinner me van dat ik vroeger in Windows ook ooit eens een RAID had gemaakt en dat Partition Magic dit ook zo zag. Voor de zekerheid LiveCD er uit en reboot. RAID-menu volgt weer en hij geeft aan dat er geen nieuwe raid geco0nfigureerd kan worden omdat er geen vrije HD, s meer zijn en er al een RAID bestaat . . dat klopt . . .mooi.
Dan de Live CD er weer in en rebooten. Met Gparted 3 partities gemaakt, te weten OS, home en swap. (home wil ik op een andere partitie krijgen, hiervoor zijn tips ook welkom).
Als ik de installatie wil starten komt het scherm van de afbeelding en bij startten verschijnt:

er is geen basis bestandssysteem gedefinieerd, gelieve dit te herstellen vanuit het schijfindelingsmenu.
Het label van de des vbetreffende schijf is boot


Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: installatie op RAID lukt niet
« Reactie #1 Gepost op: 2012/05/08, 19:12:15 »
In het verleden was het zo, dat RAID alleen werd ondersteund door een aparte kernel, deze zat standaard in de server versie.
Probeer eens de server versie te installeren, je kunt de desktop altijd later toevoegen.
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

Offline rkerklaan

  • Lid
  • Steunpunt: Nee
Re: installatie op RAID lukt niet
« Reactie #2 Gepost op: 2012/05/08, 20:08:36 »
Hey Ron

Ik had nog een recent servertje liggen, dus dat kon ik snel uit proberen. De installatie ging vlot. Na de installatie kwam ik op een terminal-achtig scherm uit waar ik moest inloggen. Dat ging ook weer goed, maar er startte geen desktop, ik bleef in dat commanda-achtige scherm. Daar zal wel een opdracht voor zijn, maar die ken ik niet.
Toen een reboot met de live CD van de niet-server versie en ik kreeg weer de zelfde schermen met foutmeldingen toen ik m wilde installeren

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: installatie op RAID lukt niet
« Reactie #3 Gepost op: 2012/05/08, 20:41:31 »
ik bleef in dat commanda-achtige scherm. Daar zal wel een opdracht voor zijn, maar die ken ik niet.
sudo apt-get install ubuntu-desktop voor Unity
sudo apt-get install kubuntu-desktop voor KDE
sudo apt-get install xubuntu-desktop]/b] voor XFCE
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

Offline rkerklaan

  • Lid
  • Steunpunt: Nee
Re: installatie op RAID lukt niet
« Reactie #4 Gepost op: 2012/05/08, 21:33:32 »
Hey kanjer

Know we' re getting somewhere

De server is nu goed geinstalleerd en als ik gparted open (moest eerst even downloaden/installeren) dan geloof ik ook nog dat het systeem mn beide HD's als 1 ziet, zoals dat in een mirrir raid hoort (zie foto).
Echter wil ik de partitie van mn OS wat verruimen en moet die andere partitie (mijn toekomstige home) dus wat verkleind worden, maar die wil daar niet aan mee werken. Ook lijkt een swap me wel handig.
Als ik de balk op sda2 zet, dan krijg ik in de menubalk wel de resize/move mogelijkheid, maar als dat venster opent, dan kan ik geen aanpassingen maken.
Als ik de balk op sda5 zet, dan komt er niet eens een resize/move - mogelijkheid.

Moet ik sda2 en 5 eerst wissen en een nieuwe partitie maken of is er ergens een instellingkje die ik moet veranderen om die partitie toch te kunnen aanpassen ?

btw kan gparted uberhaupt wel raids aan, omdat hij standaard niet in de server versie zit, of heeft de server weer een verbeterde applicatie hier voor ?

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: installatie op RAID lukt niet
« Reactie #5 Gepost op: 2012/05/08, 21:49:35 »
Volgens mij, is het niet mogelijk om een partitie die gemount is te veranderen.
Die zal je moeten doen met een live CD, maar die ondersteunt weer geen raid (dacht ik).
Kan je niet een 10GB partitie maken, daar installeren en van daaruit de andere partitie aanpassen?

Sorry, maar ik heb geen ervaring met raid, op één installatie met 8.04 2 jaar geleden na :lol:
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

Offline Buzzin

  • Lid
  • Steunpunt: Nee
Re: installatie op RAID lukt niet
« Reactie #6 Gepost op: 2012/05/08, 22:37:35 »
Als ik een tip mag geven: raid kaart eruit en software raid van linux gebruiken.
Tenzij het een echte raid kaart is (maar dan zie je OS geen aparte schijven) kun je beter niet afhankelijk zijn van een zogenaamde fake-raid kaart. Deze maakt zijn raid namelijk deels aan in de drivers en is dus eigenlijk ook software raid.
Nadeel van Fake-raid: driver verandering kan betekenen dat het niet meer werkt.

Linux software raid geeft eigenlijk geen performance hit en werkt perfect.

Ik zal eens kijken of ik nog een howto heb liggen hier (heb het zelf vaak genoeg opgebouwd)
NOu eh...niet dus, maar de samenvatting:
Installeren met een server cd of de alternative install.
Bij het partitioneren op beide schijven dezelfde partities aanmaken (RAID1) en op de partities die daaruit komen kun je je filesystemen maken (voor boot, root, home etc)
Wat ik altijd doe: 3 raid partites: 1 voor /boot, 1 voor swap en 1 voor LVM....binnen LVM kun je dan weer alle andere partities maken....maar dat moet je zelf weten.
Daarna even grub installeren op beide schijven zodat als er 1 uitvalt je niet ineens niet meer kunt booten.
« Laatst bewerkt op: 2012/05/08, 22:44:06 door Buzzin »
Football: A battle between two teams of mindless thugs over scraps of coloured cloth. Usually accompanied by the spectacle of 22 overpaid primadonnas kicking a ball on a field.
DebianDevuan, KDE & OperaVivaldi addict, RedHat Engineer

Offline rkerklaan

  • Lid
  • Steunpunt: Nee
Re: installatie op RAID lukt niet
« Reactie #7 Gepost op: 2012/05/13, 19:55:01 »
het lukt nog niet

Bij schijfindeling heb ik de volgenden lijst:

RAID1 apparaat #0 - 493.9 GB Unknown
            #1                       493.9 GB         F    ext2        /boot
SCSI3 (0,0,0) (sda)  -   500,1 GB ATA ST500dm005  HD502
            #1 Primair        493.9 GB   B   K  raid
            # 5 logisch            6.2 GB         f   swap         swap
SCSI4 (0,0,0)  (sdb) -  500,1 GB ATA ST500dm005  HD502
            #1 Primair        493.9 GB   B   K  raid
            # 5 logisch            6.2 GB         f   swap         swap

en dan krijg ik: 'er is geen basisbestandssysteem gedefinieerd. gelieve dit te herstellen vanuit het schuifindelingsmenu"

en nu ?????

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: installatie op RAID lukt niet
« Reactie #8 Gepost op: 2012/05/13, 20:01:14 »
RAID-toestel 0 heeft kennelijk geen partitie en bevat een rechtstreeks in ext2 geformatteerd volume van maar liefst 493,3 GB dat toegewezen werd aan /boot. Er is dus helemaal geen rootsysteem (toegewezen aan /).
Er is dus duidelijk iets fout gegaan bij de indeling van de schijfruimte. Ik raad aan Linux hierop opnieuw te installeren. Zeg bij installatie gewoon dat hij RAID-toestel 0 moet gebruiken, formatteren in ext4 en koppelen aan /.

Offline rkerklaan

  • Lid
  • Steunpunt: Nee
Re: installatie op RAID lukt niet
« Reactie #9 Gepost op: 2012/05/13, 20:25:52 »
ik heb de raid in gesteld als ext4 en dan gaat de indeling inderdaad verder.

Eigenlijk was het mijn bedoeling ook om 2 partities te hebben op de raid (naast swap)  1 voor het OS en programma's en 1 als home.

kan ik dit naderhand nog veranderen ? . .anders ga ik nu terug en proberen alsnog extra partities te maken

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: installatie op RAID lukt niet
« Reactie #10 Gepost op: 2012/05/13, 20:30:36 »
Als je een aparte partitie voor home wil hebben, doe je dat beter nu tijdens de installatie dan achteraf, want dan vereist dat het verkleinen van de ene partitie om er een tweede aan toe te kunnen voegen.
Geef dan een partitie van ca. 10 tot 16 GB groot op in ext4 voor / en een partitie van de restomvang ook in ext4 voor /home. De swapruimte had je ook in de RAID mogen steken, maar zoals je het nu gedaan hebt kan het ook: de swapmechanismes van Linux hebben een eigen RAID-achtig systeem ingebouwd om alle swapruimtes op alle schijven te kunnen gebruiken.

Offline rkerklaan

  • Lid
  • Steunpunt: Nee
Re: installatie op RAID lukt niet
« Reactie #11 Gepost op: 2012/05/13, 20:32:23 »
ineens zie ik ook dat de 1e #5 een kleine letter f heeft voor swap en de 2e #5 een hoofdletter F . . .

ik weet niet of dat iets uit maakt


Offline rkerklaan

  • Lid
  • Steunpunt: Nee
Re: installatie op RAID lukt niet
« Reactie #13 Gepost op: 2012/05/13, 21:12:41 »
oeps . . even iets te enthausiast op wat knoppen gedrukt en de installatie begint al.

In  ieder geval ben ik weer wat stappen verder en kijk wel hoe ik dat later met home op los.

ben nu bezig met de verdere installatie . . bedankt voor je hulp al vast

straks loop ik wel tegen 2 pun tjes aan

1) Ik had ubuntu 11.04 toen er problemen ontstonden en ik moest er een nieuwe raid in heb gezet (2 HD's). Kan ik zo klakkeloos de oude home die ik nog heb van mn vorige installatie kopieren en werkt het dan allemaal weer (ik ben dus nu een server versie aan het installeren ipv desktop omdat alleen de server raid functionaliteit zou hebben, later zou ik daar dan weer een desktop over heen kunnen zetten).

2 hoe splits ik straks de raid op in 2 partities en maak van die nieuwe partitie mn home ?

Offline rkerklaan

  • Lid
  • Steunpunt: Nee
Re: installatie op RAID lukt niet
« Reactie #14 Gepost op: 2012/05/16, 11:26:52 »
oke . . .het lukt niet om met installatie partities te maken in de raid en de installatie was nog vers, dus dan maar alles er af en opnieuw beginnen.

Jawel hoor . . de server install C D er in (want ik wilde RAID en dat was me geadviseerd) en instellen van raid en partities aan brengen ging goed en het installeren lukte ook nog JOEPIEEEEE

vervolgens met sudo apt-get install ubuntu-desktop er een desktopje over heen gezet. Dat werd 10.04 en dat ga ik later wel bij werken.

Tijdens het instellen van de raid/partitioneren heb ik 3 partities gemaakt /boot /home en swap. Nu wilde ik met duso nautilus even kijken of die ene partitie ook echt al mn home is of dat ik nog ergens iets in moet stellen.

In nautilus krijg ik in de linker kolom (tree) de koppelingen naar home folder, file system en CD

in fstab staat:

/ was on /dev/md0 during installation  UUID=fhoHFUOEHfE /  ext4   errors=remount ro 0     1
/home was on /dev/md1 during installation UUID=skjfhafhashasa /home     ext4  defaults   0    2
swap was on /dev/md2 during installation  UUID=wrfhwekfhkwefsdfb none    swap   sw    0    0

betekend dit nu al dat als ik iets op sla in home, dat dit ook daadwerkelijk op de aparte partitie terecht kom ? ik vind linux hier een beetje onduidelijk in . . .als dit achter de rug is ga ik me echt eens verdiepen in die labels, mounting point, flags want voor mij is het nog abracadabra