Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Opgelost : Hoe Belgische on-lline belastingaangifte met Ubuntu 12.04 LTS 64.  (gelezen 9171 keer)

Offline den boete

  • Lid
  • Steunpunt: Nee
  • Surf naar : http://eid.belgium.be/nl/je_eid_gebruiken/de_eid-middleware_installeren/linux/
    en kies de link die past bij jouw systeem. (in mijn geval Ubuntu(64)/Debian(64).
  • Download de eID-software en de eID-viewer en open ze met Gdebi.
  • Voor installatie van de kaartleze type ACR38U (verdeeld door de overheid). Start 'Synaptic', zoekterm 'acr38'.
  • Installeer : libacr38u,  libacr38ucontrol0 en libacr38ucontrol-dev. Plug daarna de kaartlezer in.
  • Ga naar de 'Dash' en type 'eid', ja kan dan het programma van de kaartlezer starten. Steek je identiteitskaart in de lezer, en check of ze gezien wordt.
  • Mocht Firefox draaien, herstart die dan, er is namelijk een en ander geïnstalleerd dat bij een start van Firefox wordt opgenomen.
  • Wanneer je nu naar de site https://eservices.minfin.fgov.be/taxonweb/app/citizen/public/taxbox/home.do gaat, zou je moeten kunnen aanloggen met je identiteitskaart. Wanneer dat niet lukt, ga dan verder met onderstaande :
    • In Firefox : Bewerken-Voorkeuren-Geavanceerd-Encryptie-Beveiligingsapparaten : kijken of module 'Belgium eID PKCS#11' aanwezig is -> indien niet aanwezig :
    • Zoeken in pc naar bestand 'libbeidpkcs11.so', dit bestand is zeker nodig ! Gevonden in de map /usr/lib.
    • Daarna in Firefox : Bewerken-Voorkeuren-Geavanceerd-Encryptie-Beveiligingsapparaten-Laden-Nieuwe PKCS #11-module. Ik gaf de module de naam 'Belgium eID PKCS #11 Module' en navigeerde naar /usr/lib/libbeidpkcs11.so.
    • Nu zie ik de module 'Belgium eID PKCS#11'zitten in Firefox.
    • Aanloggen bij http://ccff02.minfin.fgov.be/taxonweb/app/citizen/public/taxbox/home.do zou nu moeten lukken : kaart in de kaartlezer, pincode indrukken en de zaak was in orde.
  • Uit beschrijvingen gevonden via internet deed ik achteraf ook volgende handeling, hoewel ik betwijfel of ze nodig zijn :
    • Bewerken, Voorkeuren, Geavanceerd, Encryptie, Certificaten bekijken.
    • Zoek het certificaat “Belgium Root CA” of “Belgium Root CA2”.
    • Bewerken, alle drie de opties aanvinken, OK.

    Hopelijk raken jullie hiermee op weg om de belastingen aan het duurste land ter wereld te schenken   :'(



Don't limit your challenges, challenge your limits.

Offline mhweb

  • Lid
  • Steunpunt: Nee
Bij mij is alles zoals beschreven, toch geraak ik met firefox niet ingelogd

Offline ionraedt

  • Lid
  • Steunpunt: Nee
mhweb
Heb je de instellingen van firefox aangepast  (eID-add on en authentificatie) ?
Als je nauwgezet en volledig  de instructies op site "eid.belgium.be" volgt
(http://eid.belgium.be/nl/je_eid_gebruiken/de_eid-middleware_installeren/linux/)
dan werkt eID versie 4.04 perfect met Ubuntu 12.04 en Firefox 13.
Ik heb wel de oude installatie (eID versie 3.5.2) volledig moeten verwijderen dmv synaptic
(verwijder alles dat je vind met searchterm BEID)
Ivo

Offline ionraedt

  • Lid
  • Steunpunt: Nee
Volledigheidshalve er nog aan toevoegen dat mijn kaartlezer een VASCO905eID.
Ga nu niet kijken naar de site van VASCO  (www.digipassforeID.be) want daar wordt ge gewoon op het verkeerde been gezet met uren tijverlies als gevolg. Volgens mij is die informatie  (wat betreft installatie voor Ubuntu)  al lang niet meer up-to-date
Dank U VASCO !

Ivo

Offline Bloom

  • Lid
  • Steunpunt: Ja
De Vasco DP905 kaartlezer wordt standaard herkend en ondersteund in Ubuntu. Je moet dus daarvoor niets extra installeren. Gewoon de BeID-middleware en de daarbij benodigde applicatiesoftware. Het libacr38u pakket moet geïnstalleerd zijn, maar daarbuiten niets met acr38 in de naam.

Offline ionraedt

  • Lid
  • Steunpunt: Nee
De VASCO 905 wordt idd standaard "herkend" door Ubuntu.
Het probleem zit in de eID software die standaard in de Ubuntu repositories zit (de BEID libs en viewer)
Het betreftt versie 3.5.2 die enkel werkt met 32 biits systemen.
Voor 64 bits Ubuntu (12.04 LTS 64) hebt u de eID versie 4.04 nodig (de .DEB kan u downloaden op site :
http://eid.belgium.be/nl/je_eid_gebruiken/de_eid-middleware_installeren/linux/
zoals hierboven uitvoerig uitgelegd (mijd de VASCO-site !!)

Hieronder een beetje literatuur van bugs.launchpad.net voor het geval u niet overtuigd bent :

1.
Bug Description

when I try to authentificate with my belgium eid card to this test site : http://www.test.eid.belgium.be/ firefox crash.
I use the digipass 905 from vasco.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: firefox 13.0+build1-0ubuntu0.12.04.1
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64

2.Chris Coulson (chrisccoulson) wrote on 2012-06-11:    #3

This is not a Firefox bug
affects:    firefox (Ubuntu) → beid (Ubuntu)


3.Launchpad Janitor (janitor) wrote on 2012-06-12:    #4

Status changed to 'Confirmed' because the bug affects multiple users.
Changed in beid (Ubuntu):
status:    New → Confirmed

3.
Christophe Beyls (christophe-beyls) wrote on 2012-06-13:    #5

I had the same bug using the beid packages from the Ubuntu repositories (v 3.5.2). Crashed under Chromium too.

I fixed it by uninstalling the current version (removing all *beid* packages) and installing the latest deb packages from the official EID website: http://eid.belgium.be/fr/utiliser_votre_eid/installer_le_logiciel_eid/linux/ (v. 4.0.4).

4.
Grummfy (grummfy) wrote on 2012-06-13:    #6

I confirm remove beid package and install version 4.0.4 resolved the bug.