Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [opgegeven] foutmeldingen bij updaten  (gelezen 2974 keer)

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
[opgegeven] foutmeldingen bij updaten
« Gepost op: 2011/10/09, 16:07:27 »
Hallo allemaal,

Ik draai Ubuntu 10.04 - Lucid Lynx.

Ik krijg foutmeldingen bij het binnenhalen van updates:

E: man-db: subproces installed post-installation script gaf een foutwaarde 1 terug
E: ufw: subproces installed post-installation script gaf een foutwaarde 1 terug
E: fdutils: subproces installed post-installation script gaf een foutwaarde 1 terug
E: linux-headers-2.6.32-34-generic: subproces installed post-installation script gaf een foutwaarde 2 terug
E: linux-headers-generic: vereistenproblemen - blijft ongeconfigureerd
E: samba: subproces installed post-installation script gaf een foutwaarde 1 terug
E: winbind: subproces installed post-installation script gaf een foutwaarde 1 terug
E: libpam-smbpass: subproces installed post-installation script gaf een foutwaarde 1 terug

Ik heb enorm liggen kl*t*n met samba, winbind en linux-image, omdat hij van de week aangaf dat die pakketten gebroken waren. Ondertussen geeft hij nu geen meldingen meer over gebroken pakketten, maar bij updates blijft hij wel foutmeldingen geven.

Hij heeft nu een halve kernel geinstalleerd, namelijk
linux-headers-2.6.32-34
linux-headers-2.6.32-34 generic

Ik zou toch zeggen, dat "linux-image-2.6.32-34" er ook bij hoort.

Maar wanneer ik die probeer te installeren, zegt hij dit:

E: /var/cache/apt/archives/linux-image-2.6.32-34-generic_2.6.32-34.77_i386.deb: subproces nieuw pre-installation script gaf een foutwaarde 1 terug.

Ik begin een vermoeden te krijgen, dat hij een kernel ziet, die nog helemaal niet geinstalleerd moet worden.....


Iemand een idee wat hier aan de hand is?
« Laatst bewerkt op: 2011/10/13, 22:52:49 door Steven Klein Haneveld »

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Re: foutmeldingen bij updaten
« Reactie #1 Gepost op: 2011/10/09, 18:57:54 »
- Repareer de gebroken pakketten eens in Synaptic pakketbeheer (werkbalk: gebroken pakketten repareren)

- vervolgens, nog steeds in Synaptic: maak de cache leeg:
http://sites.google.com/site/computertip/faq#TOC-A.-De-opslagplaats-van-de-oude-upda

- En vervang daarna eens je bronnenlijst:
http://sites.google.com/site/computertip/bronnen

(rechts staat de lijst voor 10.04)

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
Re: foutmeldingen bij updaten
« Reactie #2 Gepost op: 2011/10/09, 19:37:39 »
@ Pjotr,

- De eerste optie heb ik geprobeerd, maar zonder succes. Ik kreeg eigenlijk dezelfde foutmeldingen.
Tevens heb ik geprobeerd de pakketten te deïnstalleren in Synaptic - maar ook dat lukte niet (kreeg de melding, dat de gebroken pakketten eerst hersteld moesten worden).

- Cache heb ik leeg gemaakt - alleen wel vreemd als dat een verschil maakt, want hij gooit na installatie altijd alle bestanden weg.

- De bronnenlijst - kan dat een verschil maken? Ik vreesde het al.....
Ik heb enkele PPA's geïnstalleerd, o.a. van Firefox en Thunderbird.
Die heb ik eerder in het proces allemaal uitgevinkt. Daarna kreeg ik geen meldingen meer van gebroken pakketten en dergelijke.
Bij het weer aanvinken kreeg ik vanmiddag een update binnen, waarna de foutmeldingen weer terugkwamen.
De gebroken pakketten zijn echter niet meer gebroken. Er wordt echter ook niets geïnstalleerd.....

Ik zal de bronnenlijst een checken op verkeerde notaties.

En misschien de PPA's tijdelijk even uitvinken.....


EDIT:

Zo. Op zich kon ik geen rare dingen vinden,
maar ik heb toch de boel maar even vervangen door jouw lijstje, Pjotr.
Overigens NADAT ik je tip op je site had uitgevoerd, om eerst alle andere eventuele lijsten te verwijderen.

MAAR:
ik kijk nu in Synaptic bij de kernel-bestanden.
De nieuwste linux-image is NIET geïnstalleerd.

Welke kernel zou ik nu moeten hebben in Lucid Lynx?
« Laatst bewerkt op: 2011/10/09, 20:13:58 door Steven Klein Haneveld »

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: foutmeldingen bij updaten
« Reactie #3 Gepost op: 2011/10/09, 20:30:01 »
Welke kernel zou ik nu moeten hebben in Lucid Lynx?

2.6.32-34-generic

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
Re: foutmeldingen bij updaten
« Reactie #4 Gepost op: 2011/10/09, 20:32:33 »
2.6.32-34-generic

Dus toch.
Bedankt.


EDIT:

Helaas, de foutmeldingen blijven:

E: /var/cache/apt/archives/linux-image-2.6.32-34-generic_2.6.32-34.77_i386.deb: subproces nieuw pre-installation script gaf een foutwaarde 1 terug
Als ik die wegklik, kan ik bij Details nog een soort
terminal-scherm zien met foutmeldingen (zie bijlage).


Wat gaat er mis?

Ik heb deze bestanden aangevinkt om te installeren (in Synaptic):

linux-image
linux-image-generic
linux-image-2.6.32-34-generic

De headers zijn al geïnstalleerd.....
« Laatst bewerkt op: 2011/10/09, 20:43:11 door Steven Klein Haneveld »

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
Re: foutmeldingen bij updaten
« Reactie #5 Gepost op: 2011/10/10, 07:22:42 »
Vanmorgen kreeg ik dezelfde reeks foutmeldingen,
bij het installeren van een paar muziekspelers
(listen en exaille).

Iemand een idee wat er aan de hand zou kunnen zijn?

Alvast bedankt,
Steven

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: foutmeldingen bij updaten
« Reactie #6 Gepost op: 2011/10/10, 08:07:02 »
Probeer dit eens in de terminal (citaat van Profox ergens in een topic):
Citaat
Als er iets mis is met dpkg/apt-get dan kan je dit eens proberen:

sudo dpkg --configure -a

en/of

sudo apt-get -f install

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
Re: foutmeldingen bij updaten
« Reactie #7 Gepost op: 2011/10/10, 18:47:19 »
@ Heir4c,

Bedankt,

helaas heeft het niet geholpen.

De foutmeldingen blijven ongewijzigd.

Terminal-uitvoer:
kukeleku@desktopslk:~$ sudo dpkg --configure -a
Instellen van samba (2:3.4.7~dfsg-1ubuntu3.8) ...
debconf: DbDriver "config": could not open /var/cache/debconf/config.dat
dpkg: fout bij afhandelen van samba (--configure):
 subproces installed post-installation script gaf een foutwaarde 1 terug
Instellen van man-db (2.5.7-2ubuntu1) ...
debconf: DbDriver "config": could not open /var/cache/debconf/config.dat
dpkg: fout bij afhandelen van man-db (--configure):
 subproces installed post-installation script gaf een foutwaarde 1 terug
Instellen van fdutils (5.5-20060227-4) ...
debconf: DbDriver "config": could not open /var/cache/debconf/config.dat
dpkg: fout bij afhandelen van fdutils (--configure):
 subproces installed post-installation script gaf een foutwaarde 1 terug
Instellen van libpam-smbpass (2:3.4.7~dfsg-1ubuntu3.8) ...
debconf: DbDriver "config": could not open /var/cache/debconf/config.dat
dpkg: fout bij afhandelen van libpam-smbpass (--configure):
 subproces installed post-installation script gaf een foutwaarde 1 terug
Instellen van winbind (2:3.4.7~dfsg-1ubuntu3.8) ...
debconf: DbDriver "config": could not open /var/cache/debconf/config.dat
dpkg: fout bij afhandelen van winbind (--configure):
 subproces installed post-installation script gaf een foutwaarde 1 terug
Instellen van ufw (0.30pre1-0ubuntu2) ...
debconf: DbDriver "config": could not open /var/cache/debconf/config.dat
dpkg: fout bij afhandelen van ufw (--configure):
 subproces installed post-installation script gaf een foutwaarde 1 terug
Fouten gevonden tijdens behandelen van:
 samba
 man-db
 fdutils
 libpam-smbpass
 winbind
 ufw

kukeleku@desktopslk:~$ sudo apt-get -f install
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
De volgende pakketten zijn automatisch geïnstalleerd en zijn niet langer nodig:
  fakeroot libalut0 dkms libplib1 patch
U kunt deze verwijderen via 'apt-get autoremove'.
0 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd.
6 pakketten niet volledig geïnstalleerd of verwijderd.
Door deze operatie zal er 0B extra schijfruimte gebruikt worden.
debconf: DbDriver "config": could not open /var/cache/debconf/config.dat
Instellen van man-db (2.5.7-2ubuntu1) ...
debconf: DbDriver "config": could not open /var/cache/debconf/config.dat
dpkg: fout bij afhandelen van man-db (--configure):
 subproces installed post-installation script gaf een foutwaarde 1 terug
Instellen van ufw (0.30pre1-0ubuntu2) ...
debconf: DbDriver "config": could not open /var/cache/debconf/config.dat
dpkg: fout bij afhandelen van ufw (--configure):
 subproces installed post-installation script gaf een foutwaarde 1 terug
Instellen van fdutils (5.5-20060227-4) ...
debconf: DbDriver "config": could not open /var/cache/debconf/config.dat
dpkg: fout bij afhandelen van fdutils (--configure):
 subproces installed post-installation script gaf een foutwaarde 1 terug
Instellen van samba (2:3.4.7~dfsg-1ubuntu3.8) ...
debconf: DbDriver "config": could not open /var/cache/debconf/config.dat
dpkg: fout bij afhandelen van samba (--configure):
 subproces installed post-installation script gaf een foutwaarde 1 terug
Geen apport-rapport geschreven omdat MaxReports al bereikt is
                                                             Instellen van winbind (2:3.4.7~dfsg-1ubuntu3.8) ...
debconf: DbDriver "config": could not open /var/cache/debconf/config.dat
dpkg: fout bij afhandelen van winbind (--configure):
 subproces installed post-installation script gaf een foutwaarde 1 terug
Instellen van libpam-smbpass (2:3.4.7~dfsg-1ubuntu3.8) ...
Geen apport-rapport geschreven omdat MaxReports al bereikt is
                                                             debconf: DbDriver "config": could not open /var/cache/debconf/config.dat
dpkg: fout bij afhandelen van libpam-smbpass (--configure):
 subproces installed post-installation script gaf een foutwaarde 1 terug
Geen apport-rapport geschreven omdat MaxReports al bereikt is
                                                             Fouten gevonden tijdens behandelen van:
 man-db
 ufw
 fdutils
 samba
 winbind
 libpam-smbpass
E: Sub-process /usr/bin/dpkg returned an error code (1)
« Laatst bewerkt op: 2011/10/10, 18:49:19 door Steven Klein Haneveld »

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: foutmeldingen bij updaten
« Reactie #8 Gepost op: 2011/10/10, 19:18:46 »
Start eens op in recovery mode en kies daar dan voor de fix van de gebroken pakketten (denk wel dat dat nog aanwezig is.)
Kies ook daar voor de rootshell met internet verbinding en probeer daar de update en upgrade.
Je hoeft daar dus geen sudo voor de commando's te zetten, dus word het:
apt-get update && apt-get upgradeProbeer daar misschien ook eens de twee voorgaande commando's uit.
En doe ook misschien eens een autoremove en een clean:
apt-get autoremove && apt-get clean

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
Re: foutmeldingen bij updaten
« Reactie #9 Gepost op: 2011/10/10, 21:09:59 »
@ heir4c,

Ik waardeer je suggesties enorm, maar helaas.

Beide voorstellen heb ik precies zo uitgevoerd, maar ik krijg zelfs in de recoverymode dezelfde foutmeldingen, bij alle commando's en bij gebroken pakketten herstellen idem.

:-)))
Ik begon me ook al te vervelen met Ubuntu, maar ik geloof dat ik eindelijk wat verziekt heb, hahaha!

(zoals ze zeggen, altijd blijven lachen)

Misschien nog meer ideeën?

Eerlijk gezegd heb ik Google ook al geraadpleegd, maar ik krijg daar weinig hits op mijn foutmeldingen.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Re: foutmeldingen bij updaten
« Reactie #10 Gepost op: 2011/10/10, 22:16:24 »
is uw harde schijf vol?

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
Re: foutmeldingen bij updaten
« Reactie #11 Gepost op: 2011/10/13, 19:18:15 »
Vandaag weer updates gehad.

Sommige updates gaan wel goed, maar deze 3 gaan niet geïnstalleerd worden, met weer dezelfde foutmeldingen:

desktopcouch
python-desktopcouch
python-desktopcouch-records

Hij meld nu vooral problemen met tzdata. Vraag me niet waarom - is waarschijnlijk een afhankelijkheid.

Zucht, ik kan er slecht tegen, als ik er (zelf) niet uit kom.....

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: foutmeldingen bij updaten
« Reactie #12 Gepost op: 2011/10/13, 19:25:13 »
Raar, want hier hebben die pakketten zich wel degelijk geïnstalleerd.

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
Re: foutmeldingen bij updaten
« Reactie #13 Gepost op: 2011/10/13, 21:33:07 »
Kan het liggen aan het feit,
dat ik Ubuntu One niet laat opstarten
bij het opstarten van de pc?

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: foutmeldingen bij updaten
« Reactie #14 Gepost op: 2011/10/13, 21:44:51 »
Nog maar eens een probeersel:
Verwijder alles van die nieuw kernel via synaptic en door te kiezen voor "Volledige verwijdering". Daarna herladen en herstarten en terug updaten.

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
Re: foutmeldingen bij updaten
« Reactie #15 Gepost op: 2011/10/13, 22:52:08 »
Heir4c,

Je voorstel geprobeerd, maar helaas.
Het pakket tzdata geeft problemen en daardoor wordt er niets geïnstalleerd.
tzdata verwijderen lukt niet, want daarmee wordt vanalles en nogwat verwijderd.
samba etc. verwijderen (zie de pakketten in de geposte foutmeldingen) lukt ook niet, omdat hij ze gewoonweg niet wil verwijderen.
Herinstalleren van genoemde pakketten wil ook niet, ze lijken elkaar dwars te zitten.

Kortom: een aantal pakketten zorgt voor foutmeldingen, maar kunnen niet verwijderd of ge-herinstalleerd worden.

1+1=2
Dit gaat hem niet worden zo.
Ik zal Ubuntu gewoon opnieuw moeten installeren.

Het is niet mijn gewoonte op te geven, maar ik zie echt geen mogelijkheden. Ergens is iets beschadigd, maar ik heb geen flauwe notie waar ik zoeken moet.

Een ieder bedankt voor de hulp!

Groetend,

Steven

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: [opgegeven] foutmeldingen bij updaten
« Reactie #16 Gepost op: 2011/10/13, 23:23:57 »
Hier een topic waar ook de foutmelding in komt van "Fouten gevonden tijdens behandelen van":
http://forum.ubuntu-nl.org/software-en-configuratie/dpkg-error-bij-update/
Toen ook geen oplossing gevonden.

Zoek eens op het forum naar deze foutmelding, ik krijg hier 7 bladzijden zoekresultaten.