Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost]Eid.belgium via Firefox 6, 7 etc..  (gelezen 6757 keer)

Offline lacer

  • Lid
    • dDbJn3Y
  • Steunpunt: Ja
[Opgelost]Eid.belgium via Firefox 6, 7 etc..
« Gepost op: 2011/09/27, 17:59:08 »
Naar mijn Taxbox of naar mijn fiscaal dossier gaan lukt niet meer met het elektronisch identiteitskaart via de kaartlezer. In Firefox 3. ging het nog zonder problemen.
Via "My Minfin" krijg ik deze foutboodschap:
  • Fout tijdens het verbinden met ccff02.minfin.fgov.be.
    SSL-peer kon niet onderhandelen over een acceptabele set beveiligingsparameters.
    (Foutcode: ssl_error_handshake_failure_alert)

Via "Naar mijn aangifte" geeft deze foutmelding:
  • U gebruikt een navigator die niet wordt ondersteund. Dit kan fouten veroorzaken en wij raden u aan om een van de volgende navigatoren te gebruiken: Internet Explorer (32bits) (5.5, 6.0, 7.0, 8.0) of Firefox (>= 3.0).
En dit:
  • eID met dit browser wordt momenteel niet door de FOD Financien ondersteund. Gelieve een van de ondersteunde browsers te gebruiken.

Ik gebruik de laatste versie van FF. Zijn er landgenoten die dit probleem opgelost hebben ?
« Laatst bewerkt op: 2011/10/01, 14:43:30 door lacer »
1* Ubuntu Mate 16.04 + ElementaryOS + LM 13 op Dell 6000 laptop Intel Centrino 32bits
2* Ubuntu Mate 17.10 op Acer Aspire 7741z P6100 cpu 4GB ram
3* Ubuntu 14.04 + LM 13 + LM 17 + Ubuntu Budgie 18.04 op Toshiba Satellite A300 Intel Core2Duo T5550 4GB ram
4* Ubuntu Mate18.04 op Sont Vaio VPCEB4M1E Intel i3 M380 4 GB ram

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: Eid.belgium via Firefox 6.0.2
« Reactie #1 Gepost op: 2011/09/27, 18:25:34 »
De Belgische eID-sites lopen wat achter op de realiteit. Ze ondersteunen alleen Firefox 3.6x, geen 4, geen 5 en geen 6.
Je kunt het oplossen door gewoon een Ubuntu 10.04.3 met Firefox 3.6x te gebruiken voor dat soort toepassingen. Die wordt niet geüpgraded totdat de Belgische overheid eindelijk bijgebeend is. Kun je in een virtuele machine draaien, of op een ouwe pc die je nog ergens hebt staan. Of je kunt proberen een Firefox 3.6x bij te installeren in je huidige Ubuntu. Download het archief van de site van Mozilla en installeer dat onder je home-directory. Maak een nieuw Firefox profiel aan speciaal voor deze browser en je kunt op die manier kiezen welke browser je gebruikt zonder dat ze elkaar storen.
Je kunt eventueel ook de add-on Useragent RG gebruiken. Die heb ik niet zelf geprobeerd, maar hij stelt je in staat een Firefox 6 zich te laten melden aan websites als Firefox 3.6. Wellicht werkt het dan ook.

Offline lacer

  • Lid
    • dDbJn3Y
  • Steunpunt: Ja
Re: Eid.belgium via Firefox 6.0.2
« Reactie #2 Gepost op: 2011/09/27, 20:39:50 »
Bedankt Bloom voor de uitleg.
Nee, ik ga niet terug FF 3.6.17 installeren, in mijn huidige Ubuntu versie (10.04.2) zit naast FF 6.0.2 ook nog eens FF 9.a1 Nightly  ;).
Ik zal die add-on Useragent RG eens testen.
1* Ubuntu Mate 16.04 + ElementaryOS + LM 13 op Dell 6000 laptop Intel Centrino 32bits
2* Ubuntu Mate 17.10 op Acer Aspire 7741z P6100 cpu 4GB ram
3* Ubuntu 14.04 + LM 13 + LM 17 + Ubuntu Budgie 18.04 op Toshiba Satellite A300 Intel Core2Duo T5550 4GB ram
4* Ubuntu Mate18.04 op Sont Vaio VPCEB4M1E Intel i3 M380 4 GB ram

Offline lacer

  • Lid
    • dDbJn3Y
  • Steunpunt: Ja
Re: [Opgelost]Eid.belgium via Firefox 6.0.2
« Reactie #3 Gepost op: 2011/10/01, 14:42:32 »
Inderdaad, UserAgent RG10 heeft mij uit de nood geholpen  ^-^ Thanks !
1* Ubuntu Mate 16.04 + ElementaryOS + LM 13 op Dell 6000 laptop Intel Centrino 32bits
2* Ubuntu Mate 17.10 op Acer Aspire 7741z P6100 cpu 4GB ram
3* Ubuntu 14.04 + LM 13 + LM 17 + Ubuntu Budgie 18.04 op Toshiba Satellite A300 Intel Core2Duo T5550 4GB ram
4* Ubuntu Mate18.04 op Sont Vaio VPCEB4M1E Intel i3 M380 4 GB ram

Offline den boete

  • Lid
  • Steunpunt: Nee
Re: [Opgelost]Eid.belgium via Firefox 6, 7 etc..
« Reactie #4 Gepost op: 2011/10/30, 00:09:48 »
Is er iemand die EID in Ubuntu 11.10 (64 bit) reeds aan de praat kreeg ?
Don't limit your challenges, challenge your limits.

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: [Opgelost]Eid.belgium via Firefox 6, 7 etc..
« Reactie #5 Gepost op: 2011/10/30, 01:15:39 »
Zou op dezelfde manier moeten als bij vorige Ubuntu-versies, mits de useragent-aanpassing voor Firefox versies hoger dan 3.6x.

Offline den boete

  • Lid
  • Steunpunt: Nee
Re: [Opgelost]Eid.belgium via Firefox 6, 7 etc..
« Reactie #6 Gepost op: 2011/11/01, 22:00:10 »
Bedankt Bloom, toch werkt het nog niet bij mij.
Hierna een schets van mijn werkwijze en het aldus ontstane probleem :

In Firefox : Extra – Add-ons, typ in zoekvenster 'user agent'
Installeer dan 'User Agent RG 1,0' (of hoger)
Nu kan je in Firefox – Extra – UserAgent kiezen met welke versie van Firefox je wil draaien.
Start 'Synaptic', zoekterm 'acr38'.
Installeer :
libacr38u (installeert ook pcscd mee)
libacr38ucontrol-dev (installeert ook libacr38ucontrol0 en libpcsclite-dev mee)
Sluit 'Synaptic'
Start 'Ubuntu softwarecentrum', zoekterm 'bei'
Installeer 'Belgische eID'
Sluit 'Ubuntu softwarecentrum' en herstart de pc.
Start via 'dash' : 'Belgische eID'.
Language -> nederlands.
Opties -> zet kaartlezer op 'ACS ACR38U 00 00', normaal gezien staat die instelling  reeds goed.
Steek je identiteitskaart in de kaartlezer, druk dan Kaart-kaart lezen en geef toelating op het eventuele popupvenster.
Je identiteitsgegevens verschijnen nu op het scherm.
In Firefox :
Kies Extra-User agent-Firefox-3.6
Dan Extra-Add-ons-zoekterm 'eid' en de Add-on EID-België installeren.
Start Synaptic en installeer 'beid-tools'
Daarna pc herstarten.
Start Firefox, deze geeft de foutmelding :
Configuratie voor de Belgische elektronische identiteitskaart is mislukt. Is de eID Middleware geïnstalleerd ?
Wanneer ik daar kies om de Middleware te installeren, kom ik op een site van de overheid. Installatie van de Middleware die daar aangeboden wordt, leidt tot conflikten.
Niet installeren werkt ook niet, want dan zijn de certificaten “Belgium Root CA” of “Belgium Root CA2”. niet in Firefox geïnstalleerd, en dan zit de broodnodige file met de naam  libbeidpkcs11.so nergens op mijn pc.

Zijn er al mensen die verder staan ?
Don't limit your challenges, challenge your limits.

Offline lacer

  • Lid
    • dDbJn3Y
  • Steunpunt: Ja
Re: [Opgelost]Eid.belgium via Firefox 6, 7 etc..
« Reactie #7 Gepost op: 2011/11/01, 22:26:31 »
Ik had het zo gedaan:
via terminal:
sudo apt-get install libacr38u libacr38ucontrol0 libacr38ucontrol-dev beidgui pcscddan bestand installeren: http://eid.belgium.be/nl/Hoe_installeer_je_de_eID/Linux/index.jsp  
nadien .install.sh uitvoeren uit map
dan heropstarten met kaartlezer aangesloten
certificaten in firefox installeren en registreren met dit comando:
#register certificates in firefoxfirefox file:///usr/share/beid/beid-pkcs11-register.html

En natuurlijk nadien de User Agent moeten gebruiken ivm de recente Firefoxen  ;)
1* Ubuntu Mate 16.04 + ElementaryOS + LM 13 op Dell 6000 laptop Intel Centrino 32bits
2* Ubuntu Mate 17.10 op Acer Aspire 7741z P6100 cpu 4GB ram
3* Ubuntu 14.04 + LM 13 + LM 17 + Ubuntu Budgie 18.04 op Toshiba Satellite A300 Intel Core2Duo T5550 4GB ram
4* Ubuntu Mate18.04 op Sont Vaio VPCEB4M1E Intel i3 M380 4 GB ram