Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: 11.04: Boot niet zonder LAN kabel  (gelezen 1495 keer)

Offline ted.sluis

  • Lid
  • Steunpunt: Nee
11.04: Boot niet zonder LAN kabel
« Gepost op: 2011/05/08, 12:37:07 »
Ik heb een paar dagen terug mijn HP Pavilion hp dv7-4090eb ubuntu 10.10 geupgrade naar 11.04. Werkt allemaal prima, maar er is een vervelend ding: Zonder LAN kabel blijft de laptop hangen. Voordat het aanmeldscherm verschijnt, wordt het scherm zwart en er gebeurt niets meer.

Wanneer ik de laptop start in recovery mode zie ik tijdens het booten op het scherm dat het uiteindelijk stopt bij:
wlan0: becomes ready
wlan0: no IPv6 router present.

Als ik de wlan adapter uitschakel (met een functietoets) zie ik meteen effect op het scherm:
Wlan0: not ready
Als ik de wlan interface weer aanschakel dan zie ik op het scherm weer:
wlan0: becomes ready
wlan0: no IPv6 router present.
Hier blijft het dus op hangen.........

Met een ethernetkabel er in gaat het booten wel goed. Maar het duurt ongeveer 1 minuut langer voordat het loginscherm verschijnt in vergelijking met wat ik gewend was met ubuntu 10.10. (heb een snelle laptop met core i5 processor en SSD schijf die normaal in minder dan 20 seconden klaar met booten is).

Wanneer ik eenmaal het loginscherm op het scherm zie, kan ik de LAN kabel verwijderen. Eenmaal ingelogd werkt internet gewoon via wlan!

Wie kent dit probleem of weet wat er aan de hand kan zijn?

Wellicht van belang is dat ik een NFS share van een NAS box (192.168.1.244) mout in  /etc/fstab:
192.168.1.244:/Backup   /mnt/Backup nfs _netdev,rw,hard,intr 0 0

Alvast bedankt!

Ted
 

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: 11.04: Boot niet zonder LAN kabel
« Reactie #1 Gepost op: 2011/05/08, 16:16:39 »
Wellicht van belang is dat ik een NFS share van een NAS box (192.168.1.244) mout in  /etc/fstab:
192.168.1.244:/Backup   /mnt/Backup nfs _netdev,rw,hard,intr 0 0
Probeer eerst en vooral eens of het probleem zich nog voordoet wanneer je die regel tijdelijk uitschakelt (plaats er een #, commentaarteken, voor).

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: 11.04: Boot niet zonder LAN kabel
« Reactie #2 Gepost op: 2011/05/08, 16:54:21 »
Misschien IPv6 uitzetten(in je netwerk instellingen), ik weet alleen niet of dit kan.
Zoek eens met google.

Offline ted.sluis

  • Lid
  • Steunpunt: Nee
Re: 11.04: Boot niet zonder LAN kabel
« Reactie #3 Gepost op: 2011/05/09, 21:29:52 »
Citaat
Citaat van: ted.sluis op Gisteren om 12:37:07
Wellicht van belang is dat ik een NFS share van een NAS box (192.168.1.244) mout in  /etc/fstab:
192.168.1.244:/Backup   /mnt/Backup nfs _netdev,rw,hard,intr 0 0

Citaat van: vanadium , Gisteren om 16:16:39
Probeer eerst en vooral eens of het probleem zich nog voordoet wanneer je die regel tijdelijk uitschakelt (plaats er een #, commentaarteken, voor).

Ik heb het mounten van de nfs share uitgehekt in fstab, maar dat heeft helaas geen effect. Dit heeft dus niets met het probleem te maken.

Het uitzetten van IPv6 lukt me niet, maar ik zie in de log dat bij het booten met de LAN kabel ook de melding verschijnt "eth0:no IPv6 router present". Dan blijft het booten daar niet op hangen. Het lijkt me ook een hele logische melding, want er is immers geen IPv6 router in het netwerk. Maar als iemand een sugestie heeft hoe ik IPv6 kan uitzetten, dan wil ik het testen.


Offline jolo

  • Lid
  • Steunpunt: Nee
Re: 11.04: Boot niet zonder LAN kabel
« Reactie #4 Gepost op: 2011/05/14, 08:29:39 »
Maar als iemand een sugestie heeft hoe ik IPv6 kan uitzetten, dan wil ik het testen.
Check op http://www.ubuntugeek.com/how-to-disable-ipv6-in-ubuntu.html Method 3
Citaat
Edit /etc/default/grub file
gksudo gedit /etc/default/grub
[Enter]

Wijzig
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
in
GRUB_CMDLINE_LINUX_DEFAULT="ipv6.disable=1 quiet splash"
Update grub in het Terminalvenster
sudo update-grub
[Enter]
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline Buzzin

  • Lid
  • Steunpunt: Nee
Re: 11.04: Boot niet zonder LAN kabel
« Reactie #5 Gepost op: 2011/05/16, 12:38:42 »
Even snel inhaken: je hebt bij je NFS share staan: hard
Dat houd in dat het systeem compleet stopt op het moment dat de verbinding er niet is.....dat is dus een reden dat je dit probleem ziet (misschien niet de enige)
Je kunt dit beter op soft zetten, dan gaat hij gewoon verder als hij geen netwerk ziet.
Je kunt dat altijd nog even een 'sudo mount -a' geven zodra je wel weer netwerk hebt.

IPv6 kun je rustig aan laten staan tenzij je rare dingen wilt doen op het netwerk.
Vroeger zette ik het ook uit, tegenwoordig werkt alles prima, ook als je het niet gebruikt.
Maar het kan denk ik ook weinig kwaad om het uit te zetten.
« Laatst bewerkt op: 2011/05/16, 12:42:41 door Buzzin »
Football: A battle between two teams of mindless thugs over scraps of coloured cloth. Usually accompanied by the spectacle of 22 overpaid primadonnas kicking a ball on a field.
DebianDevuan, KDE & OperaVivaldi addict, RedHat Engineer

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: 11.04: Boot niet zonder LAN kabel
« Reactie #6 Gepost op: 2011/05/16, 12:51:01 »
Je kunt ook ipv 'hard' de opties 'auto,nobootwait' gebruiken. Dan probeert hij het bestandssysteem volautomatisch te mounten, maar wacht hij er niet op tijdens het booten. De desktopstart en zodra het volume gemount kan worden, verschijnt het. Werkt prima, ik gebruik dat voornamelijk voor Samba-volumes, maar voor NFS gaat het ook.

Offline ted.sluis

  • Lid
  • Steunpunt: Nee
Re: 11.04: Boot niet zonder LAN kabel
« Reactie #7 Gepost op: 2011/05/16, 16:34:34 »
Bedankt voor de reactie's.

Ik heb zonder IPv6 getest, zoals Jolo aangaf, maar het geeft geen vebetering:
Maar als iemand een sugestie heeft hoe ik IPv6 kan uitzetten, dan wil ik het testen.
Check op http://www.ubuntugeek.com/how-to-disable-ipv6-in-ubuntu.html Method 3
Citaat
Edit /etc/default/grub file
gksudo gedit /etc/default/grub
[Enter]

Wijzig
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
in
GRUB_CMDLINE_LINUX_DEFAULT="ipv6.disable=1 quiet splash"
Update grub in het Terminalvenster
sudo update-grub
[Enter]


Bedankt ook voor de opmerking over het auto mounten van het NFS volume in combinatie met de optie nowait. Maar ik had vanwege de bootproblemen het mounten van het NFS volume al eerder helemaal uitgeschakeld. NFS heeft dus niets te maken met mijn probleem.

Nog even een precieze omschrijving van het probleem: Nadat ik in het paarse Grub-menu voor Ubuntu kies, zie ik nog even een cursor knipperen op de zwarte achtergrond. Daarna wordt het scherm helemaal zwart. Er beurt helemaal niets meer. Met Ubuntu 10.10 duurde het booten minder dan 20 seconden (dankzij de SSD harddisk).
Met de netwerkkabel in de laptop lukt het booten wel, maar het duurt wel 1 minuut langer dan in met Ubuntu 10.10 gewend was voordat het loginvenster verschijnt. Wanneer na het verschijnen van het loginvenster de LAN kabel verwijderd wordt, werk alles normaal en snel.
« Laatst bewerkt op: 2011/05/16, 16:38:39 door ted.sluis »