Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: mounten NAS (opgelost)  (gelezen 1444 keer)

Offline redhank

  • Lid
  • Steunpunt: Nee
mounten NAS (opgelost)
« Gepost op: 2011/03/18, 14:06:34 »
Hallo ik heb een NAS en laat deze bij het opstarten mounten d.m.v. de volgende regel in fstab:

//opslag/Backups /media/opslag cifs credentials=/root/.mijncreds,rw,iocharset=utf8,dir_mode=0777,file_mode=0777  0 0>>/etc/fstab

Daarmee bereik ik alleen de map: Backups.

Ik heb echter ook een map: public

Weet iemand hoe ik de laatste map eveneens bij het mounten zichtbaar kan maken?

Alvast bedankt.
« Laatst bewerkt op: 2011/03/18, 19:05:47 door redhank »
OS: Ubuntu 16.04
RPi
Ubuntu Mate

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: mounten NAS
« Reactie #1 Gepost op: 2011/03/18, 15:28:08 »
Dat is een nieuwe mount, //opslag/Public.

Offline redhank

  • Lid
  • Steunpunt: Nee
Re: mounten NAS
« Reactie #2 Gepost op: 2011/03/18, 15:47:08 »
Dat heb ik geprobeerd met:

//opslag/public /media/opslag cifs credentials=/root/.mijncreds,rw,iocharset=utf8,dir_mode=0777,file_mode=0777  0 0>>/etc/fstab

maar alleen de laatste van deze twee regels blijkt dan te werken.
OS: Ubuntu 16.04
RPi
Ubuntu Mate


Offline redhank

  • Lid
  • Steunpunt: Nee
Re: mounten NAS
« Reactie #4 Gepost op: 2011/03/18, 17:42:07 »
Dan is de volgende vraag: Hoe ga ik dat doen?

De inhoud van mijn fstab staat hieronder:

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# mounten van home op Microstar
#192.168.1.5:/home /media/nfsserver nfs rsize=8192,wsize=8192,timeo=14,intr
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=88821d62-4913-43aa-9a55-a1bc6674886c /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=3d07a4d2-f692-471e-b8db-ab92727ffbc1 none            swap    sw              0       0
//opslag/Backups /media/opslag cifs credentials=/root/.mijncreds,rw,iocharset=utf8,dir_mode=0777,file_mode=0777  0 0>>/etc/fstab
#//opslag/public /media/opslag cifs credentials=/root/.mijncreds,rw,iocharset=utf8,dir_mode=0777,file_mode=0777  0 0>>/etc/fstab
OS: Ubuntu 16.04
RPi
Ubuntu Mate

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: mounten NAS
« Reactie #5 Gepost op: 2011/03/18, 18:13:18 »
# bij de laatste weghalen. # betekend deze regel wordt niet gebruikt.

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: mounten NAS
« Reactie #6 Gepost op: 2011/03/18, 18:33:52 »
Voor de tweede mount moet er wel een ANDER koppelpunt aangemaakt worden, dus bijvoorbeeld /media/public.

Offline redhank

  • Lid
  • Steunpunt: Nee
Re: mounten NAS
« Reactie #7 Gepost op: 2011/03/18, 18:37:15 »
Dat weet ik, maar ik heb # ervoor gezet, omdat zonder alleen de tweede regel werkte. Er is dus blijkbaar op die manier geen koppelpunt gemaakt. Opslag (mijn NAS) is al gemount in de eerste regel, maar dan verschijnt de map "public" niet.
OS: Ubuntu 16.04
RPi
Ubuntu Mate

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: mounten NAS
« Reactie #8 Gepost op: 2011/03/18, 18:52:36 »
Je hebt in beide lijnen hetzelfde koppelpunt /media/opslag gebruikt en dat is je fout. In de tweede lijn moet je een andere media-directory opgeven! En die '>>/etc/fstab' achteraan moet natuurlijk weg!

Offline redhank

  • Lid
  • Steunpunt: Nee
Re: mounten NAS
« Reactie #9 Gepost op: 2011/03/18, 19:04:47 »
Ik heb een ander koppelpunt gemaakt en nu werkt het. Het is mij nu ook duidelijk hoe.

Hartelijk dank voor de hulp.
OS: Ubuntu 16.04
RPi
Ubuntu Mate