Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Boot probleem na restore van clonezilla backup  (gelezen 1347 keer)

Offline cx1964

  • Lid
  • Steunpunt: Nee
Boot probleem na restore van clonezilla backup
« Gepost op: 2011/02/04, 09:58:13 »
Na de installatie het beeindigen van  mijn initiele installatie van Ubuntu 10.10 heb ik m.b.v. Clonezilla van Parted Magic 5.9 gemaakt. Het betrof de parititie waarop Ubuntu 10.10 op is geinstalleerd (sda5).
Tijdens de installatie heb ik meerdere keren mijn PC gereboot, wat goed ging.
De uitgangssitatie voor het terug zetten van de clonezilla backup was een werkende grub.
Ik maak trouwens al jaren gebruik van clonezille voor het maken van backups en hetr restoren van backups als er wat misgaat.

Na het terugzetten wilde mijn laptop niet meer starten.

Vervolgens heb ik de procedure (http://ubuntuforums.org/showthread.php?t=1581099) uitgevoerd.
Van deze procedure heb ik uitgevoerd:

From the Live CD optie
de stappen:
### Run these two commands only if you have a separate /boot partition
sudo mkdir /mnt/boot
sudo mount /dev/sda5 /mnt/boot
sudo mount /dev/sda5 /mnt
sudo grub-install --root-directory=/mnt /dev/sd5

Na deze stappen heb ik de machine gereboot

Waarna alleen de grub prompt (grub>) verschijnt.

Als ik het commando ls -l  geef zie ik:
"Device hd0: Partition table"
met 6  Partition hd0, xxx entries
xxx = {msdos7, msdos6, msdos5, msdos3, msdos2, msdos1}

msdos3, msdos2,msdos1 zijn ntfs partities die ik gebruik voor Windows7 (het is een dual boot systeem)

msdos7 geeft Filesystem type ext2 (wat vreemd is want ik had ext4 gebruikt voor de Linux installatie)
msdos5 geeft Filesystem type ext2 (wat vreemd is want ik had ext4 gebruikt voor de Linux installatie)
msdos6 geeft Unkown filesystem

Wie kan mij helpen?
Een herinstallatie van mijn machine betekend het weggooien van 3 dagen werk








 

Offline Ramana

  • Lid
  • Steunpunt: Nee
Re: Boot probleem na restore van clonezilla backup
« Reactie #1 Gepost op: 2011/02/04, 10:20:01 »
Zo te zien installeer je Grub in sda5, niet in MBR. Clonezilla heeft geprobeerd grub in MBR te zetten.

je kunt dit proberen:

sudo mount /dev/sda5 /mnt
sudo grub-install /dev/sda --root-directory=/mnt
sudo reboot

Offline cx1964

  • Lid
  • Steunpunt: Nee
Re: Boot probleem na restore van clonezilla backup
« Reactie #2 Gepost op: 2011/02/04, 10:28:25 »
bedankt voor de reactie

Maar ik heb nu alleen een grub prompt
Hoe kan ik bovengenoemde commando's geven?

Offline koos4401

  • Lid
  • Steunpunt: Nee
Re: Boot probleem na restore van clonezilla backup
« Reactie #3 Gepost op: 2011/02/04, 10:57:46 »
Als je dit gedaan hebt met knippen en plakken:From the Live CD optie
de stappen:
### Run these two commands only if you have a separate /boot partition
sudo mkdir /mnt/boot
sudo mount /dev/sda5 /mnt/boot
sudo mount /dev/sda5 /mnt
sudo grub-install --root-directory=/mnt /dev/sd5
heb je hier een probleem:
Citaat
sudo grub-install --root-directory=/mnt /dev/sd5
want volgens mij moet dat
sudo grub-install --root-directory=/mnt /dev/sda5 zijn.
Op 27-okt-2009 om 08.20 GMT geregistreerd als gebruiker nr.: 498523

Offline cx1964

  • Lid
  • Steunpunt: Nee
Re: Boot probleem na restore van clonezilla backup
« Reactie #4 Gepost op: 2011/02/04, 13:33:01 »
Ik heb zojuist uitgevoerd middels de livecd

sudo mkdir /mnt/boot
sudo mount /dev/sda5 /mnt/boot
sudo mount /dev/sda5 /mnt
sudo grub-install --root-directory=/mnt /dev/sda5

De eerste stappen gaan goed
Vervolgens krijg ik op 'sudo grub-install --root-directory=/mnt /dev/sda5' de boodschap:

warn: Attempting to install GRUB to a partitition instead of the MBR
This is a bad idea..
warn: Embedding is not possible.
GRUB can only be installed in this setup by using blocklists.
However, blocklists are UNRELIABLE and their use is discouraged..
error: if you really want blocklists, use --force

Wat moet ik nu doen?

Aanvullende info mbt mijn schijf indeling
Ik heb op disk de volgende partities staan:

sda1 Recovery disk van laptop
sda2 recovery disk van laptop
sda3 windows7 ntfs
sda4 extended parition met daar binnen:
         sda5 / van Ubuntu 10.10 in EXT4 formaat
         sda6 swap
         sda7 een eigen data partitie

Wat moet ik nu doen om de MBR geinstalleerd te krijgen?
En waar wordt de MBR dan geinstalleerd?
In de initiele installatie (gebruik makende van bovenstaande indeling) had ik de default installatie optie voor grub gebruikt. Toen de installatie werd uitgevoerd was Windows7 al geinstalleerd.
 




 

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: Boot probleem na restore van clonezilla backup
« Reactie #5 Gepost op: 2011/02/04, 13:39:13 »
Je moet GRUB in de MBR (master boot record) van de drive sda installeren.
sudo grub-install --root-directory=/mnt /dev/sda

Offline cx1964

  • Lid
  • Steunpunt: Nee
Re: Boot probleem na restore van clonezilla backup
« Reactie #6 Gepost op: 2011/02/04, 13:48:11 »
Als ik het commando

sudo grub-install --root-directory=/mnt /dev/sda

geef en vervolgens weer reboot

Is het grub weer hersteld en zie ik het boot menu weer :)

Bedankt voor de hulp