Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: POEDIT start niet  (gelezen 1801 keer)

Offline MRIG

  • Lid
    • Ger Siemerink
  • Steunpunt: Nee
POEDIT start niet
« Gepost op: 2010/08/17, 09:53:16 »
Wie weet raad? Ik heb UBUNTU 10.04 opnieuw geïnstalleerd.
Nu heb ik POEDIT geïnstalleerd en geherinstalleerd via softwarecentrum en synaptic pakketbeheer.
Wat ik ook doe POEDIT start niet(!) zichtbaar op.
Wel komt het icoontje in het menu toepassingen>ontwikkelingen.
Onder staat opstarten en het muis icoon verandert in een draaiend bolletje maar na enkele seconden stopt alles.
(NB ik heb dit eerder gehad met openshot video editor)
Er zit ergens iets fout maar wat???
Ik kan werken po files wel bewerken met gedit maar dat is niet de weg.

Offline schwarzproductions

  • Lid
    • Open Bron Blog
  • Steunpunt: Nee
Re: POEDIT start niet
« Reactie #1 Gepost op: 2010/08/17, 09:59:01 »
Kun je POEDIT eens opstarten via de terminal. Als er dan foutmelding komen kun je deze dan hier plaatsen.
Zo zouden we meer kunnen zien van wat hier aan de hand is.

Offline MRIG

  • Lid
    • Ger Siemerink
  • Steunpunt: Nee
Re: POEDIT start niet
« Reactie #2 Gepost op: 2010/08/17, 11:14:03 »
Beste Schwarzproductions,

Ik weet dit niet of ik het zo goed doe. Maar deze reactie krijg ik als ik poedit intik:

poedit: relocation error: poedit: symbol _ZN21wxMemoryFSHandlerBase19AddFileWithMimeTypeERK8wxStringPKvjS2_, version WXU_2.8 not defined in file libwx_baseu-2.8.so.0 with link time reference
root@ger-laptop:~#

mvg Ger
« Laatst bewerkt op: 2010/08/17, 11:18:50 door MRIG »

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
Re: POEDIT start niet
« Reactie #3 Gepost op: 2010/08/17, 11:18:38 »
Is er een reden waarom ge Poedit wilt opstarten als root? Doe dit eens als gewone gebruiker in de terminal.

Offline MRIG

  • Lid
    • Ger Siemerink
  • Steunpunt: Nee
Re: POEDIT start niet
« Reactie #4 Gepost op: 2010/08/17, 11:20:11 »
Beste Nunslaughter,

ger@ger-laptop:~$ poedit
poedit: relocation error: poedit: symbol _ZN21wxMemoryFSHandlerBase19AddFileWithMimeTypeERK8wxStringPKvjS2_, version WXU_2.8 not defined in file libwx_baseu-2.8.so.0 with link time reference
ger@ger-laptop:~$

mvg Ger

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: POEDIT start niet
« Reactie #5 Gepost op: 2010/08/17, 11:25:01 »
Zie https://bugs.launchpad.net/ubuntu/+source/poedit/+bug/613530
Het is dus geen bug in poedit, maar een fout bij de samenstelling van de pakketten.
Niet oplosbaar tenzij je alles hercompileert. Anders moet je wachten totdat er een nieuwe versie uitkomt en een nieuw pakket samengesteld wordt met (hopelijk) de juiste afhankelijkheden.

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
Re: POEDIT start niet
« Reactie #6 Gepost op: 2010/08/17, 11:25:32 »
Herinstalleer eens het pakketje libwxbase2.8-0 via Synaptic. Misschien dat dat helpt.

Edit: draait ge misschien al Ubuntu 10.10? Dat is waar het bugrapport dat Bloom postte over gaat.
« Laatst bewerkt op: 2010/08/17, 11:28:05 door Nunslaughter »

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: POEDIT start niet
« Reactie #7 Gepost op: 2010/08/17, 11:29:31 »
Ik denk dat hij moet downgraden.
De correcte versie waamee het werkt is 2.8.10.1-0ubuntu1 en in mijn Ubuntu 10.04 64-bits is die wel degelijk geïnstalleerd.
Met een 10.10 of zo zal vermoedelijk versie 2.8.10.1-1ubuntu1 geïnstalleerd raken en daarmee werkt het dus niet.

Offline MRIG

  • Lid
    • Ger Siemerink
  • Steunpunt: Nee
Re: POEDIT start niet
« Reactie #8 Gepost op: 2010/08/17, 11:31:23 »
herinstallatie gaf geen verbetering, helaas.

ger@ger-laptop:~$ poedit
poedit: relocation error: poedit: symbol _ZN21wxMemoryFSHandlerBase19AddFileWithMimeTypeERK8wxStringPKvjS2_, version WXU_2.8 not defined in file libwx_baseu-2.8.so.0 with link time reference
ger@ger-laptop:~$

Hercompileren? Kan ik dat?
Welk alternatief kunnen jullie eventueel adviseren voor Poedit (gedit vind ik  niet zo handig).

mvg Ger

Offline MRIG

  • Lid
    • Ger Siemerink
  • Steunpunt: Nee
Re: POEDIT start niet
« Reactie #9 Gepost op: 2010/08/17, 11:33:20 »
downgraden. In synaptic kom ik libwxbase 2.6.0 tegen, is dat de downgrade?

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: POEDIT start niet
« Reactie #10 Gepost op: 2010/08/17, 11:34:14 »
Doe eens apt-cache show libwxbase2.8-0|grep Version en wat zie je dan?

Met versie 2.6.0 zou het ook niet werken, versie 2.8.10.1-0 is vereist.

Offline MRIG

  • Lid
    • Ger Siemerink
  • Steunpunt: Nee
Re: POEDIT start niet
« Reactie #11 Gepost op: 2010/08/17, 11:36:22 »
ger@ger-laptop:~$ apt-cache show libwxbase2.8-0|grep Version
Version: 2.8.10.1-0ubuntu1.1
Version: 2.8.10.1-0ubuntu1
ger@ger-laptop:~$


Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: POEDIT start niet
« Reactie #12 Gepost op: 2010/08/17, 11:39:46 »
Die versie 2.8.10.1-0Ubuntu1.1 is de schuldige en moet je verwijderen. Dat kun je via Synaptic doen.

Offline MRIG

  • Lid
    • Ger Siemerink
  • Steunpunt: Nee
Re: POEDIT start niet
« Reactie #13 Gepost op: 2010/08/17, 11:44:44 »
Hoe heet dat pakket dan? Ik heb gezocht in synaptic zoekfunctie maar ik begrijp helaas niet wat je bedoelt.

Offline MRIG

  • Lid
    • Ger Siemerink
  • Steunpunt: Nee
Re: POEDIT start niet
« Reactie #14 Gepost op: 2010/08/17, 11:47:52 »
als ik kies voor verwijderen (libwxbase 2.8 ) wordt ook poedit en poedit-dbg verwijderd.  ???

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: POEDIT start niet
« Reactie #15 Gepost op: 2010/08/17, 11:51:35 »
Je zou libwxbase 2.8 tweemaal geïnstalleerd moeten zien: eentje met versie 2.8.10.1-0Ubuntu1 en eentje met versie 2.8.10-1.0Ubuntu1.1. Die laatste moet je verwijderen. Als hij dan poedit ook wil deïnstalleren, laat hem dan en installeer het dan gewoon opnieuw. Zolang versie 2.8.10.1-0Ubuntu1 aanwezig blijft zou de installatie van poedit de nieuwere versie niet moeten installeren vermits aan zijn vereisten al voldaan is.

Offline MRIG

  • Lid
    • Ger Siemerink
  • Steunpunt: Nee
Re: POEDIT start niet
« Reactie #16 Gepost op: 2010/08/17, 11:58:51 »
Helaas zie ik hem maar 1 keer staan. Ik heb intussen in synaptic drie onderdelen verwijderd.
In de terminal tik ik in en lees:
ger@ger-laptop:~$ apt-cache show libwxbase2.8-0|grep Version
Version: 2.8.10.1-0ubuntu1.1
Version: 2.8.10.1-0ubuntu1
ger@ger-laptop:~$

Ik begrijp het niet, vreemd.

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: POEDIT start niet
« Reactie #17 Gepost op: 2010/08/17, 12:04:42 »
Die apt-cache toont gewoon wat er beschikbaar is in de repository's, dus niet alleen wat geïnstalleerd is.
Als je de libwxbase gedeïnstalleerd hebt, kun je eens opnieuw in Synaptic zoeken naar de beschikbare pakketten en zoek of de versie 2.8.10.1-0Ubuntu1 beschikbaar is. Zo ja, installeer dan die en daarne poedit opnieuw.

Mocht alleen versie ...Ubuntu1.1 te zien zijn, dan moet je die dus niet hebben. Als je alleen die versie ziet, neem ik aan dat je werkt met Ubuntu 10.10 Maverick. In dat geval haal je best het juiste pakket uit de repository van Lucid, installeer dat en verhinder dan de upgrade naar 1.1 door upgrades uit te schakelen. Als er later een nieuwe poedit zou verschijnen, kun je proberen de upgrade naar 1.1 weer toe te laten.

Offline MRIG

  • Lid
    • Ger Siemerink
  • Steunpunt: Nee
Re: POEDIT start niet
« Reactie #18 Gepost op: 2010/08/17, 12:11:57 »
Beste Bloom ik probeer het later nog eens.
Nee, ik heb echt versie 10.04.
en intussen heb ik Gtranslator geïnstalleerd, die start gelukkig wel op.
Mijn hartelijke(!) dank voor je snelle reacties.

mvg Ger

Offline MRIG

  • Lid
    • Ger Siemerink
  • Steunpunt: Nee
Re: POEDIT start niet
« Reactie #19 Gepost op: 2010/08/17, 17:03:12 »
Ik diverse pogingen gedaan, krijg het niet Poedit niet voor elkaar.
Ik werk nu maar met Gtranslator poeditor.

Daarna creëer ik vanuit een terminal een *.mo bestand met het commando
msgfmt filename.po