Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: systeem start niet meer op na wijziging mounten 2e hdd  (gelezen 2397 keer)

Offline rene.haak

  • Lid
  • Steunpunt: Nee
systeem start niet meer op na wijziging mounten 2e hdd
« Gepost op: 2010/08/10, 11:42:52 »
L.S.

Ik ben sinds enkele maanden Ubuntu gebruiker, geheel naar tevredenheid, maar nu loop ik tegen een probleem aan en ik heb niet eerder iemand met een zelfde probleem op dit forum getroffen. Wellicht kan iemend mij hiermee helpen?

Nadat ik door middel van pysdm had geprobeerd mijn 2e hdd automatisch te "mounten" wil de PC (Ubuntu) niet meer opstarten. Ik kan via f2 bij het opstarten in de setup komen maar daar is niets vreemds te vinden. Bij opstarten krijg je eerst het openingsscherm van het systeem met de keuze mogelijkheid F2 en F12 daarna wordt het scherm zwart met een wit knipperende cursor in de rechter bovenhoek.
Is het mogelijke dit systeem nog aan de gang te krijgen? Ik had het juist allemaal naar mijn eigen smaak ingericht :-((

Bij voorbaat hartelijke dank voor mogelijke oplossing...

René

Offline Buzzin

  • Lid
  • Steunpunt: Nee
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #1 Gepost op: 2010/08/10, 12:26:05 »
Je kunt altijd even een live cd pakken en zo bij je bestanden komen.
Het lijkt erop alsof grub even de weg kwijt is...
krijg je nog wel een grub melding? (dan kun je op Esc drukken dacht ik, om bij het menu te komen)
Football: A battle between two teams of mindless thugs over scraps of coloured cloth. Usually accompanied by the spectacle of 22 overpaid primadonnas kicking a ball on a field.
DebianDevuan, KDE & OperaVivaldi addict, RedHat Engineer

Offline rene.haak

  • Lid
  • Steunpunt: Nee
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #2 Gepost op: 2010/08/10, 13:46:54 »
Hartelijk dank voor de snelle reactie. Nee, ik krijg niet meer dat een zwart scherm met een cursor. Ik ben inmiddels bezig met het branden van een nieuwe cd en hoop daar mee de zaak aan de praat te krijgen!
Ik zal me melden met de uitslag!

Hartelijke groet,

René

Phr3ak

  • Gast
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #3 Gepost op: 2010/08/10, 14:28:00 »
Even met de live cd opstarten, en dan de inhoud van:

/etc/fstab
Hier plakken, dan kunnen we even met je mee kijken :)

Offline rene.haak

  • Lid
  • Steunpunt: Nee
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #4 Gepost op: 2010/08/10, 15:09:38 »
Hallo,

Ik heb een cd gebrand en hiermee de zaak opgestart. dat gaat goed. Ik heb gekozen voor Ubuntu proberen, niet voor installeren dus.
wanneer ik dan terminal open en /etc/fstab intoets + enter krijg ik als antwoord: permission denied
Doe ik dit goed?

bvd en hg
René

Offline ivo

  • Lid
  • Steunpunt: Nee
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #5 Gepost op: 2010/08/10, 15:11:36 »
Hallo,

Ik heb een cd gebrand en hiermee de zaak opgestart. dat gaat goed. Ik heb gekozen voor Ubuntu proberen, niet voor installeren dus.
wanneer ik dan terminal open en /etc/fstab intoets + enter krijg ik als antwoord: permission denied
Doe ik dit goed?

bvd en hg
René

cat /etc/fstab

De output svp hier plakken.
There are only 10 types of people in the world; those who understand binary and those who don't.

Offline rene.haak

  • Lid
  • Steunpunt: Nee
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #6 Gepost op: 2010/08/10, 15:28:18 »
er kokmt dan het volgende uit:

ubuntu@ubuntu:-$ cat /etc/fstab
aufs / aufs rw 0 0
tempfs /tmp tempfs nosuid,nodev 0 0
/dev/sda5 swap swap defaults 00
ubuntu@ubuntu

René

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #7 Gepost op: 2010/08/10, 15:38:39 »
Je toont de fstab van de live-cd en het moet natuurlijk die van de harde schijf zijn.
Doe eens sudo fdisk -l zodat je kunt zien welke volumes er gevonden zijn.
Als de harde-schijfpartitie met Ubuntu erop als /dev/sda1 getoond wordt, moet je die eerst aankoppelen als de live-cd dat niet zelf gedaan heeft.
Eerst een koppelpunt aanmaken en dan de koppeling uitvoeren:
sudo mkdir /media/helsjief
sudo mount /dev/sda1 /media/helsjief
cat /media/helsjief/etc/fstab
:) (helsjief is Limburgs voor 'harde schijf')
De eerste regel van fstab moet zoiets zijn:
/dev/sda1       /               ext4    relatime,errors=remount-ro 0       1Indien dat ontbreekt, verklaart dat waarom je Ubuntu niet meer start.
Voeg deze regel er dan aan toe (moet mogelijk als gksudo gedit /media/helsjief/etc/fstab) en herstart je systeem.

Offline ivo

  • Lid
  • Steunpunt: Nee
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #8 Gepost op: 2010/08/10, 15:54:33 »
Je toont de fstab van de live-cd en het moet natuurlijk die van de harde schijf zijn.

Ja, stom, dat had ik ook kunnen bedenken toen ik het schreef.
Maar goed, jij bent inmiddels als de goede kant met hem opgegaan.
There are only 10 types of people in the world; those who understand binary and those who don't.

Offline rene.haak

  • Lid
  • Steunpunt: Nee
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #9 Gepost op: 2010/08/10, 16:02:20 »
Hallo Bloom,

E.e.a uitgevoerd. Er ontbrak inderdaad de regel /dev/sda1   /   ext4 enz.
heb vervolgens de code gksudo gedit /media/helsjief/etc/fstab ingegeven. hier kwam een reactie met een open schermpje met info. Vervolgens heb ik het systeem opnieuw opgestart....zonder resultaat....een zwart scherm met een knipperende cursor.
Wat kan fout gegaan zijn??

Groet,

René

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #10 Gepost op: 2010/08/10, 16:08:17 »
Wat bedoel je precies met "een reactie met een open schermpje"?
De editor gedit zou de inhoud van de fstab op je harde schijf moeten tonen. Vooraan moet je dan de regel die ik eerder vermeldde moeten invoegen. Als er foutmeldingen verschijnen, is het niet uitgevoerd en ontbreekt de regel natuurlijk nog steeds.
Dus wat verschijnt er precies in beeld als je
gksudo gedit /media/helsjief/etc/fstabuitvoert?

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #11 Gepost op: 2010/08/10, 16:20:59 »
kijk of er een backup file is van de fstab, en vergelijk deze met de actuele.(misschien oude terug plaatsen en dan werkt het).
Indien je iets wijzigt eerst een backup maken van je fstab.

Offline rene.haak

  • Lid
  • Steunpunt: Nee
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #12 Gepost op: 2010/08/10, 16:27:04 »
In het schermpje dat opent  staat het onderstaande:

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc                                       /proc           proc  nodev,noexec,nosuid       0  0 
# / was on /dev/sda1 during installation
UUID=a764ff56-06f5-4641-9b02-59b8ab5173e0  /               ext4  users,owner               0  1 
# swap was on /dev/sda5 during installation
UUID=57255751-2721-47a2-aaff-9828f760b6a0  none            swap  users,sw                  0  0 
/dev/fd0                                   /media/floppy0  auto  rw,user,noauto,exec,utf8  0  0 

Offline rene.haak

  • Lid
  • Steunpunt: Nee
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #13 Gepost op: 2010/08/10, 16:32:54 »
waar zou ik zoeken naar een eventuele back up van de fsatb?

Gr. Ren

Offline Buzzin

  • Lid
  • Steunpunt: Nee
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #14 Gepost op: 2010/08/10, 16:38:54 »
Citaat
UUID=a764ff56-06f5-4641-9b02-59b8ab5173e0  /               ext4  users,owner               0  1

Dat is de regel die je root partitie mount en waar het dus om gaat.
(of liever waar de anderen het over hebben)
Het UUID is 'uitwisselbaar' met de devicenaam (/dev/sda1)

Maar zelf denk ik eigenlijk dat grub gewoon niet meer in de MBR staat....tenminste, ik krijg altijd nog wel iets te zien van grub als die aanwezig is...

Even opzoeken welke partitie je nu gebruikt om te booten (kun je de uitvoer van "sudo fdisk -l" hier even posten?)
En dan grub installeren:
LET OP: wel de juiste getalletjes gebruiken, niet 'zo maar' overnemen....
grub
root (hd0,1)
setup (hd0)
In dit voorbeeld word de Tweede partitie van de eerste hardeschijf als boot partitie gebruikt (dell machine met speciale dell partitie)
'normaal' is dus hd0,0
Football: A battle between two teams of mindless thugs over scraps of coloured cloth. Usually accompanied by the spectacle of 22 overpaid primadonnas kicking a ball on a field.
DebianDevuan, KDE & OperaVivaldi addict, RedHat Engineer

Offline rene.haak

  • Lid
  • Steunpunt: Nee
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #15 Gepost op: 2010/08/10, 16:43:39 »
ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 40.1 GB, 40060403712 bytes
255 heads, 63 sectors/track, 4870 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000219da

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        4665    37469184   83  Linux
/dev/sda2            4665        4871     1649665    5  Extended
/dev/sda5            4665        4871     1649664   82  Linux swap / Solaris

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/sdb doesn't contain a valid partition table
ubuntu@ubuntu:~$

Offline Buzzin

  • Lid
  • Steunpunt: Nee
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #16 Gepost op: 2010/08/10, 16:58:38 »
Probeer eerst dit even voor de zekerheid:
sudo grub
(in grub: )
geometry (hd0,0)
daar moet zoiets uitkomen (met extra regels: )
drive 0x80: C/H/S = 60801/255/63, The number of sectors = 976773168, /dev/sda
   Partition num: 0,  Filesystem type is ext2fs, partition type 0x83

dan weet je zeker dat 0,0 de juiste schijf is.

Als dat zo is kun je hetgene doen wat ik net al aangaf:
(nog steeds in grub: )
root (hd0,0)
setup (hd0)
quit
Football: A battle between two teams of mindless thugs over scraps of coloured cloth. Usually accompanied by the spectacle of 22 overpaid primadonnas kicking a ball on a field.
DebianDevuan, KDE & OperaVivaldi addict, RedHat Engineer

Offline rene.haak

  • Lid
  • Steunpunt: Nee
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #17 Gepost op: 2010/08/10, 17:08:13 »
ziet er zo uit.... is dat goed gegaan??

       [ Minimal BASH-like line editing is supported.   For
         the   first   word,  TAB  lists  possible  command
         completions.  Anywhere else TAB lists the possible
         completions of a device/filename. ]

grub> geometry (hd0,0)
drive 0x80: C/H/S = 4870/255/63, The number of sectors = 78242976, /dev/sda
   Partition num: 0,  Filesystem type is ext2fs, partition type 0x83
   Partition num: 4,  Filesystem type unknown, partition type 0x82

grub> root (hd0,0)

grub> setup (hd0)
 Checking if "/boot/grub/stage1" exists... no
 Checking if "/grub/stage1" exists... no

Error 15: File not found

grub>



Offline Buzzin

  • Lid
  • Steunpunt: Nee
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #18 Gepost op: 2010/08/10, 17:22:09 »
Doh! eh nee  :(
(het moet wel hd0,0 zijn dus)

even vergeten dat /boot/grub dan goed moet zijn :(

Maar het feit dat hij zegt dat er geen grub aanwezig is geeft wel aan dat het daar mis zit.
(tenminste, zo ver ik weet)

Misschien dat je met supergrub disk een eind komt om het te fixen (ik ga er van uit dat je grub2 moet hebben)
Hopelijk heeft iemand hier daar een link naar, want ik weet zelf niet uit m'n hoofd waar je die kunt halen (al zal google best wel iets kunnen vinden)

Mogelijk zit er ook een optie op de Live cd? (ik heb zelf de live cd van ubuntu nooit gebruikt)
Football: A battle between two teams of mindless thugs over scraps of coloured cloth. Usually accompanied by the spectacle of 22 overpaid primadonnas kicking a ball on a field.
DebianDevuan, KDE & OperaVivaldi addict, RedHat Engineer


Offline rene.haak

  • Lid
  • Steunpunt: Nee
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #20 Gepost op: 2010/08/10, 17:45:31 »
dat geeft:

ubuntu@ubuntu:~$ subo blkid /dev/sda1
No command 'subo' found, did you mean:
 Command 'sudo' from package 'sudo' (main)
 Command 'sudo' from package 'sudo-ldap' (universe)
 Command 'subs' from package 'libsubtitles-perl' (universe)
subo: command not found
ubuntu@ubuntu:~$

Offline rene.haak

  • Lid
  • Steunpunt: Nee
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #21 Gepost op: 2010/08/10, 17:47:59 »
sorry, blijkt een type fout....

ubuntu@ubuntu:~$ sudo blkid /dev/sda1
/dev/sda1: UUID="a764ff56-06f5-4641-9b02-59b8ab5173e0" TYPE="ext4"
ubuntu@ubuntu:~$

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #22 Gepost op: 2010/08/10, 18:01:31 »
Okee, het serienummer van je harde-schijfpartitie is dezelfde als die in je fstab file staat. Dan hoef je daar niets meer aan te veranderen. Het is dan inderdaad het meest waarschijnlijk dat grub om zeep geholpen is.
Ubuntu 10.04 gebruikt normaal wel Grub2, en dan werken de hoger gegeven voorbeelden van bevelen niet.
Zorg eerst weer dat je van de live-cd gestart bent en dat het harde-schijfvolume aangekoppeld is met /media/helsjief.
Dan doe je het volgende:
sudo mount --bind /dev /media/heljsief/dev
sudo mount --bind /proc /media/helsjief/proc
sudo chroot /media/helsjief
Okee, nu sta je in root-mode op je harde-schijfpartitie.
Als je nog wat aan de grub-opties wil veranderen kan dat nu:
nano -w /etc/default/gruben als je klaar bent even bijwerken met
grub-updateDaarna grub2 installeren via:
grub-install /dev/sdaAls hier foutmeldingen verschijnen, probeer dan eerst
grub-install --recheck /dev/sdaNu alles ok? Dan gaan we alles weer afkoppelen en proberen te starten van de "helsjief":
exit
sudo umount /media/helsjief/dev
sudo umount /media/helsjief/proc
sudo umount /media/helsjief
sudo reboot
En hopelijk werkt je desktop dan weer.

Offline rene.haak

  • Lid
  • Steunpunt: Nee
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #23 Gepost op: 2010/08/10, 19:32:22 »
Ik heb alles doorgelopen als gevraagd maar waar het over grub gaat loopt het mis. na het rebooten weer het bekende zwarte scherm met cursor....is het misschien een optie om hulp op afstand toe doen??? Dat kan toch ook in Ubuntu??

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: systeem start niet meer op na wijziging mounten 2e hdd
« Reactie #24 Gepost op: 2010/08/10, 20:28:54 »
Hulp op afstand vereist dat je Ubuntu draait en er een internetverbinding is. Bovendien moet de Gnome desktop dan ook draaien.

Ik heb de exacte foutmeldingen van grub-install nodig!