Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: OpenTeacher: Overhoorprogramma voor Linux  (gelezen 101927 keer)

Offline lordnoid

  • Lid
  • Steunpunt: Nee
OpenTeacher: Overhoorprogramma voor Linux
« Gepost op: 2008/12/12, 22:00:47 »
Hallo Ubuntu-fanaten,
Er is veel vraag naar een overhoorprogramma voor Linux. Zoek maar op google naar "Teach2000 linux" ofzo, en zie de vele vragen. Om dit probleem op te lossen (en om zelf python/qt4 te leren) heb ik een overhoorprogramma geschreven dat ik OpenTeacher noem.
Hierbij streef ik naar een volwaardig Teach2000-alternatief voor Linux. Op het moment heeft het nog lang niet zoveel features als Teach2000, maar een begin is gezet.
OpenTeacher ondersteunt ook Teach2000(.t2k)- en WRTS(.wrts)-bestanden. Ik heb contact opgenoment met de ontwikkelaar van Teach2000 en hij is waarschijnlijk bereid de broncode vrij te geven van hoe Teach2000 zelf t2k-bestanden leest, om de compatibiliteit te maximaliseren.
OpenTeacher kan overweg met unicode, en kan daardoor ook griekse letters invoeren en overhoren. Ook houdt OpenTeacher je resultaten bij, en kan het je woordenlijst als .txt opslaan met tabs ertussen, zodat je bijvoorbeeld je lijst ook kan uitprinten om zo op papier verder te leren.
Er zijn veel docenten die hun leerlingen .t2k-bestanden geven. Om de onafhankelijkheid van Windows te verkleinen, lijkt het me een mooi idee om een goed alternatief neer te zetten voor Linux. Om een idee te geven van wat OpenTeacher nu ongeveer kan, hier twee screenshots (geupdate naar 1.0):


Op de screenshots is een Engelse versie te zien, maar als je systeemtaal is ingesteld op Nederlands zal er (met dank aan Tumie) een Nederlandse versie te zien zijn.
Ik heb een debian-package gemaakt dat werkt in Ubuntu 8.10.
Download .deb versie 1.0
Ook heb ik de sourcecode (in python en qt4 dus) beschikbaar gesteld:
Download .tar.gz versie 1.0
Er is ook een Mac-versie met dank aan SeySayux:
Download .dmg versie 1.0

Daarnaast is het project(je) ook approved op SourceForge:
http://www.sourceforge.net/projects/openteacher

Ik heb ook een projectpaginaatje opgezet en het project is ook te vinden op launchpad.

Aan degenen die het interesseert de vraag: Wat vinden jullie ervan? Werkt het? Bugs ontdekt? Welke features mis je nog? Zijn er ook mensen die veel van python en qt4 weten en dingen zien in de sourcecode die ik misschien niet zo handig heb geregeld? Ik hoor het allemaal graag!
Ik ben benieuwd naar de reacties :)

UPDATE met meest recente versies:
Project website: http://openteacher.org/
Laatste versie (3.x) : http://openteacher.org/download.html
Oudere versies: http://sourceforge.net/projects/openteacher/files/openteacher
« Laatst bewerkt op: 2013/03/29, 15:48:49 door lordnoid »

Offline eendje

  • Lid
  • Steunpunt: Nee
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #1 Gepost op: 2008/12/12, 22:19:38 »
Leuk idee!. Ik ga het de komende tijd eens gebruiken om wat Duitse woorden bij te spijkeren :) Ik heb alleen probleempje. Installeren gaat prima, maar bij het starten krijg ik de volgende foutmelding:

Citaat
rene@test-desktop:~$ openteacher
Traceback (most recent call last):
  File "/usr/share/openteacher/openteacher.py", line 506, in <module>
    myapp = OpenTeacher()
  File "/usr/share/openteacher/openteacher.py", line 46, in __init__
    self.ui.setupUi(self)
  File "/usr/share/openteacher/openteacher_ui.py", line 33, in setupUi
    self.invoerTekst = QtGui.QPlainTextEdit(self.layoutWidget)
AttributeError: 'module' object has no attribute 'QPlainTextEdit'
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

Offline lordnoid

  • Lid
  • Steunpunt: Nee
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #2 Gepost op: 2008/12/12, 22:28:08 »
Ai. Welke versie van Ubuntu, python en python-qt4 heb je?

Offline Thomas Berends

  • Lid
    • Mijn blog
  • Steunpunt: Nee
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #3 Gepost op: 2008/12/12, 23:46:24 »
Leuk idee!. Ik ga het de komende tijd eens gebruiken om wat Duitse woorden bij te spijkeren :) Ik heb alleen probleempje. Installeren gaat prima, maar bij het starten krijg ik de volgende foutmelding:

Citaat
rene@test-desktop:~$ openteacher
Traceback (most recent call last):
  File "/usr/share/openteacher/openteacher.py", line 506, in <module>
    myapp = OpenTeacher()
  File "/usr/share/openteacher/openteacher.py", line 46, in __init__
    self.ui.setupUi(self)
  File "/usr/share/openteacher/openteacher_ui.py", line 33, in setupUi
    self.invoerTekst = QtGui.QPlainTextEdit(self.layoutWidget)
AttributeError: 'module' object has no attribute 'QPlainTextEdit'
installeer de .deb, en dan toepassingen -> educatief.. staat hij daar neit??

Offline eendje

  • Lid
  • Steunpunt: Nee
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #4 Gepost op: 2008/12/13, 10:21:53 »
Ai. Welke versie van Ubuntu, python en python-qt4 heb je?

Ik gebruik Hardy met alle updates

Versies van bestanden:

Python: 2.5.2-0ubuntu1
Python-qt4: 4.3.3-2ubuntu4.1

@Tumie

Het programma staat inderdaad in het menu, maar als ik daar op klik gebeurt er niets, daarom heb ik het programma via de terminal gestart om te kijken wat er fout gaat en dat hier te melden, want ik denk dat die infromatie nuttiger is dan "hij doet het niet"
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

Offline lordnoid

  • Lid
  • Steunpunt: Nee
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #5 Gepost op: 2008/12/13, 10:38:06 »
Vreemd, ik heb dezelfde Python en Python-qt4 versie. Heb overigens 3 mensen bij wie het wel werkt dus ik vrees toch dat het probleem ergens aan jouw kant ligt :s
Aan de foutmelding te zien lijkt het alsof PyQt4 niet goed geinstalleerd is.

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #6 Gepost op: 2008/12/13, 10:55:36 »
Geweldig werk, lordnoid! Ik zal eens kijken wat er veranderd is t.o.v. de bèta die je me laatst stuurde ;)

Offline eendje

  • Lid
  • Steunpunt: Nee
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #7 Gepost op: 2008/12/13, 11:12:22 »
Vreemd, ik heb dezelfde Python en Python-qt4 versie. Heb overigens 3 mensen bij wie het wel werkt dus ik vrees toch dat het probleem ergens aan jouw kant ligt :s
Aan de foutmelding te zien lijkt het alsof PyQt4 niet goed geinstalleerd is.

Ik heb geen idee wat ik moet doen om het nu werkend te krijgen en blijkbaar heb jij ook geen richting voor mij. Ik hab Python-Qt al opnieuw geïnstalleerd maar dat helpt niet. Wat ik wel op de site van Troltech zag is dat 'QPlainTextEdit' pas bij versie 4.4 van Qt is geïmplementeerd, dus weet je zeker dat jij Qt 4.3.3 gebruikt?
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

Offline lordnoid

  • Lid
  • Steunpunt: Nee
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #8 Gepost op: 2008/12/13, 14:10:03 »
@Eendje:
Oh je hebt helemaal gelijk. Ik zag even het verschil niet tussen 4.4.3 en 4.3.3.. Ik heb dus 4.4.3 en daar zit wel QPlainTextEdit in. Wel jammer dat het nu niet op Hardy werkt :( Zal het in een volgende versie vervangen voor een widget die wel in 4.3 zit.
« Laatst bewerkt op: 2008/12/13, 14:12:17 door lordnoid »

Offline eendje

  • Lid
  • Steunpunt: Nee
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #9 Gepost op: 2008/12/13, 14:24:37 »
Even geduld dus :)
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #10 Gepost op: 2008/12/13, 14:58:07 »
Vreemd, want op Kubuntu 8.04 (Hardy) met KDE 4.1.2 werkt hij bij mij prima.

Overigens, bedankt voor dit programma :D Ik gebruikte Teach2000 eigenlijk nooit, en weet niet of ik dit wel ga gebruiken. Maar je weet het nooit :)

Offline lordnoid

  • Lid
  • Steunpunt: Nee
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #11 Gepost op: 2008/12/13, 15:04:03 »
Is waarschijnlijk omdat jij KDE 4.1.2 hebt, en die gebruikt wel Qt 4.4... Dus die heeft python-qt4 4.4.3 in de PPA erbij.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #12 Gepost op: 2008/12/13, 15:07:08 »
O ja, dat is ook zo :D

Eider

  • Gast
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #13 Gepost op: 2008/12/13, 15:49:57 »
Geweldig! Ik ga het dadelijk meteen voor je testen :)

*Edit:

Ik heb het geïnstalleerd en het werkt best goed!  O0

Paar dingen die me opvielen:
- Bij de foutmelding  "geen woorden ingevoerd" is de titel nog Fout7
- Ik krijg nog Engelse vragen bij vensters

- in de source code wordt Engels en Nederlands door elkaar gebruikt. Misschien is het handiger als alles in het Engels is? Of heb je een speciale reden dat de variabelen enzo in het Nederlands zijn :)?

Misschien kan ik wel helpen via Launchpad? :)
« Laatst bewerkt op: 2008/12/13, 15:57:54 door Eider »

Offline lordnoid

  • Lid
  • Steunpunt: Nee
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #14 Gepost op: 2008/12/13, 19:28:35 »
@Eider:
Bedankt voor je reactie :) Ik zal je puntjes zeker meenemen voor versie 1.0 :)
Die Engelse vragen had ik ook al gezien ja, en ook Engelse buttons. Ze zijn wel degelijk vertaald, maar om de een of andere reden komt dat er niet door. Ga ik nog naar kijken.
En inderdaad, het is veel beter als de hele sourcecode in het Engels is, en dat zal ik ook zeker gaan veranderen. Codesuggesties enzo kun je altijd naar me mailen.
Ik ben nog bezig met het opzetten van een goede project website.

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #15 Gepost op: 2008/12/14, 13:59:44 »
Kun je niet gewoon po-bestanden gebruiken, en die dan inladen?

Offline lordnoid

  • Lid
  • Steunpunt: Nee
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #16 Gepost op: 2008/12/14, 14:30:22 »
@Cumulus007: Ik gebruik het vertaalsysteem van Qt4. Daarbij maak je gebruik van een tooltje die een .ts bestand maakt van alle strings in je programma, Linguist om te vertalen, en dan sla je het op als .qm bestand. .qm is een binaire opslag waardoor het extreem snel kan worden geladen :)
Algoed, in het .ts bestand stond die Engelse dialoog wel, en die is ook vertaald naar het Nederlands, maar blijkbaar komt het er niet uit vreemd genoeg :S

Offline lordnoid

  • Lid
  • Steunpunt: Nee
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #17 Gepost op: 2008/12/14, 18:17:51 »
De broncode voor het inlezen van .t2k-bestanden is vrijgegeven door Teach2000.
http://www.codeplex.com/Teach2000/
Ik ga er mee aan de gang om dezelfde manier van inlezen in OpenTeacher te kunnen krijgen voor een zo goed mogelijke compatibiliteit.

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #18 Gepost op: 2008/12/14, 18:37:11 »
Was .t2k al een open formaat?

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #19 Gepost op: 2008/12/14, 20:23:19 »
Met Qt kun je ook als po opslaan hoor ;) Maar qm is sneller :)

.t2k was niet al een open formaat.

Offline Mij

  • Lid
  • Steunpunt: Nee

Offline lordnoid

  • Lid
  • Steunpunt: Nee
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #21 Gepost op: 2008/12/17, 19:23:02 »

Offline Mij

  • Lid
  • Steunpunt: Nee
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #22 Gepost op: 2008/12/17, 21:24:52 »
eerste patch verstuurd
nog nooit bzr gebruikt dus heb diff maar uit terminal gekopieerd

Offline lordnoid

  • Lid
  • Steunpunt: Nee
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #23 Gepost op: 2008/12/17, 22:26:25 »
eerste patch verstuurd
nog nooit bzr gebruikt dus heb diff maar uit terminal gekopieerd
Volgens mij kun je dan ook gewoon zoiets doen
bzr diff > bugfix.patchmaar weet ik niet 100% zeker :)

Offline Mij

  • Lid
  • Steunpunt: Nee
Re: OpenTeacher: Overhoorprogramma voor Linux
« Reactie #24 Gepost op: 2008/12/17, 22:43:30 »
eerste patch verstuurd
nog nooit bzr gebruikt dus heb diff maar uit terminal gekopieerd
Volgens mij kun je dan ook gewoon zoiets doen
bzr diff > bugfix.patchmaar weet ik niet 100% zeker :)
Ok, zal ik volgende keer eens kijken :)