Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Alle data "weg" na upgrade naar 8.10 (mijn fout of...?)  (gelezen 1224 keer)

Romald

  • Gast
Alle data "weg" na upgrade naar 8.10 (mijn fout of...?)
« Gepost op: 2008/11/17, 20:42:55 »
Hallo,

zoals het topic al laat raden, zit ik heel erg in de problemen.
Excuses voor de lange uitleg, maar ik vind dit heeel vreemd, dus erg de moeite waard om te melden. (Ik gebruik al 2 jaar Linux, ook op mijn werk en ben geen beginner meer)

Ik heb een upgrade gedaan van 8.10. Hierna was mijn partitie helemaal leeg, waar voorheen nog al mijn data opstond. Ik heb geen idee waar het mis is gegaan. Hopelijk kan iemand mij helpen om zo makkelijk mogelijk al mijn data terug te krijgen.
En vooral voorkomen dat anderen dit overkomt.
Alvast bedankt voor de hulp!!
Hieronder volgt een uitgebreide uitleg van wat ik heb gedaan:

Voordat ik begon met de herinstallatie had ik een prima "set-up", dual bootable windows 2000 met Ubuntu 8.04 op 2 harde schrijven:

/sda1: windows installatie (5Gb NTFS)
/sda2: ubuntu installatie, dus de root (5Gb ext3)
/sda3: ongeformatteerd
/sda4: data (180Gb ext3)

/sdb1: swap (1Gb)
/sdb2: /home directory (5Gb ext3)
/sdb3: data (480Gb ext3)

Niks bijzonders en werkt prima. Aangezien ik toch naar 8.10 wilde heb ik meteen windows 2000 vervangen door XP:
Windows XP cd'tje erin, beetje klikken en klaar!! Op dit moment was al mijn data nog bereikbaar via windows. (met het handige tooltje:
http://www.fs-driver.org/ kan je ext2 en ext3 vanuit windows benaderen: een aanrader!!) Ik heb zelfs direct software vanaf /sdb3 op windows geinstalleerd).

Hierna Ubuntu 8.10 cd'tje erin. Ik heb tijdens de installatie handmatig de partities toegewezen: swap partitie toegewezen, /home partitie aangewezen, /root partitie toegewezen(en format vinkje aangezet). De twee data partities aangewezen en twee mount punten ingevuld.
Verder beetje klikken en klaar!!

Toen ik hierna in ubuntu inlogde waren de twee data partities niet te zien. Hierna heb ik nietsvermoedend het commando gebruikt:
#sudo mount /dev/sda4 /media/sda4 en
#sudo mount /dev/sdb3 /media/sdb3

En de partities waren zichtbaar, maar tot mijn schik: LEEG!!!!!!!! Het enige wat nog over was waren de folders beginnend met een punt, dus de "hidden"-folders, zoals .trash-ronald. Hier zaten zelfs nog bestanden in. Maar voor de rest: leeg!!

Ik denk niet dat daadwerkelijk de data weg is, ik ben alleen de hele directory en file index kwijt, waardoor het ubuntu (en windows) denkt dat de partitie leeg is.

Ik ga zelf nog de mogelijkheden van tune2fs, e2fsck etc... verder uitzoeken. Recovery tools zoals Stellar zullen hopelijk wel mijn bestanden kunnen terugvinden, maar misschien niet originele bestandsnamen en directory structuur.

Mijn belankrijkste vraag is:
-Heeft iemand enig idee waar het fout is gegaan?
-Kan ik snel de directory structuur weer "terugtoveren"?

Voor zover ik weet heb ik niets vreemds gedaan. Ik ben al over op ubuntu sinds 7.04 en deze upgrade procedure dus al vaker gebruikt.

Alvast bedankt, Ronald.
P.s. mijn probleem lijkt een heel klein beetje op de volgende post:
http://forum.ubuntu-nl.org/index.php/topic,33947.msg327617.html#msg327617

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Alle data "weg" na upgrade naar 8.10 (mijn fout of...?)
« Reactie #1 Gepost op: 2008/11/17, 21:42:06 »
Niet perongeluk een vinkje gezet voor de /home? Dan wordt namelijk je partitie geformateerd. Voor de root / geeft het niet hierop komen de programma's, echter op je /home staan al je gegevens en instellingen. Geef eerst eens in de terminal het commando sudo fdisk -l (kleine L)
en post de uitkomst hier. Ga via Locaties naar je Persoonlijke map is echt alles weg? Klik is eens rechts in het witte deel, klik nu op Eigenschappen, wordt er een grote weergegeven?

Afhankelijk van je uitkomst kunnen we eventueel met testdisk of photorec in de weer om te proberen verloren partities of bestanden terug te halen. Probeer eerst bovenstaande.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: Alle data "weg" na upgrade naar 8.10 (mijn fout of...?)
« Reactie #2 Gepost op: 2008/11/17, 21:53:43 »
Hmz ??
Citaat
Hierna Ubuntu 8.10 cd'tje erin. Ik heb tijdens de installatie handmatig de partities toegewezen: swap partitie toegewezen, /home partitie aangewezen, /root partitie toegewezen(en format vinkje aangezet). De twee data partities aangewezen en twee mount punten ingevuld.
Verder beetje klikken en klaar!!
Denk dat het in het rode gebied fout is gegaan ??
Normaal gesproken formateer je alleen de root partitie.
Swap en home niet.
Toewijzen wel maar niet formateren.

Ik denk dat hij die nu ook geformateerd heeft namelijk en dus dat je de data kwijt bent.
NOTE: goede nieuws is wanneer je geen verdere acties onderneemt je die data redelijk goed terug kunt krijgen.

Even voor alle duidelijkheid zal ik het proberen uit te leggen.

Jij hebt netjes alle data op aparte partities staan, heel goed nix mee mis.

Maar toen je in Ubuntu bij je data wilden komen deed je dat waarschijnlijk niet altijd via nautilus ??
Je hebt waarschijnlijk de data partities gemount aan mappen in je Home.
Hierdoor ontstaat er een | oftewel een pipe van je /Home naar je data partities.
In Linux betekent aangekoppelde opslagruimte als 1 geheel, dus de data word 1 geheel met je /Home.
ondanks dat dit op een aparte partitie staat.

Wanneer jij nu je /Home formateerd worden ook de data partities geformateerd.

BTW. Ik speculeer nu alleen wat er gebeurd zou kunnen zijn.
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Romald

  • Gast
Re: Alle data "weg" na upgrade naar 8.10 (mijn fout of...?)
« Reactie #3 Gepost op: 2008/11/17, 22:41:38 »
Hierna Ubuntu 8.10 cd'tje erin. Ik heb tijdens de installatie handmatig de partities toegewezen: swap partitie toegewezen, /home partitie aangewezen, /root partitie toegewezen(en format vinkje aangezet). De twee data partities aangewezen en twee mount punten ingevuld.
Verder beetje klikken en klaar!!

(thnks voor de reply alvast)

Ik zal het iets duidelijker opschrijven:
-swap partitie toegewezen(format vinkje bestaat niet bij swap)
-aangegeven waar mijn /home partitie is
-root partitie toegewezen(en format vinkje aangezet)
-twee data partities aangewezen en twee mount punten ingevuld

Ik heb 100% zeker de twee data partities niet aangevinkt voor formatteren. En ook m'n /home niet. Zoals gezegd ben ik al van 7.04 naar 7.10 naar 8.04 op deze manier gegaan.

Mijn /home partitie is sowieso het probleem niet. Hij is nog helemaal intact. e-mail etc...etc...geen probleem. Het gaat dus alleen om de twee data partities.

Ik wil voorkomen dat ik aan de slag moet met testdisk o.i.d., want dan ben ik bang dat ik bestandsnamen kwijt ben. (Als het zover komt, gaat me dat wel lukken.)

Het mounten heb ik als volgt gedaan:
#cd /media
#mkdir sdb3
#sudo mkdir sdb3
#sudo mount /dev/sdb3 /media/sdb3
#sudo mkdir sda4
#sudo mount /dev/sda4 /media/sda4
(dit heb ik geknipt .bash_history)


#sudo fdisk -l geeft:

Schijf /dev/sda: 203.9 GB, 203928109056 bytes
255 koppen, 63 sectoren/spoor, 24792 cilinders
Eenheid = cilinders van 16065 * 512 = 8225280 bytes
Schijf-ID: 0x30ea30e9

 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sda1   *           1         653     5245191    7  HPFS/NTFS
/dev/sda2             654        1609     7679070   83  Linux
/dev/sda3            1610        2262     5245222+  83  Linux
/dev/sda4            2263       24792   180972225   83  Linux

Schijf /dev/sdb: 500.1 GB, 500107862016 bytes
255 koppen, 63 sectoren/spoor, 60801 cilinders
Eenheid = cilinders van 16065 * 512 = 8225280 bytes
Schijf-ID: 0x0000f28e

 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sdb1               1         131     1052226   82  Linux wisselgeheugen
/dev/sdb2             132         784     5245222+  83  Linux
/dev/sdb3             785       60801   482086552+  83  Linux


Groet, Ronald.
P.s. Als ik op "locaties->Persoonlijke Map" klinkt opent, geloof het of niet: Rhythmbox 0.11.6. Echt!!

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Alle data "weg" na upgrade naar 8.10 (mijn fout of...?)
« Reactie #4 Gepost op: 2008/11/17, 23:03:21 »
Om met het laatste te beginnen rechts klik op een map>klik op Eigenschappen>klik op het tabblad Openen met>Waarschijnlijk staat er Rhythmbox>Selecteer deze en klik op verwijderen> klik op toevoegen>Kies Map openen>klik Sluiten nu openen de mappen weer met Nautilus.
Nu snap ik het verhaal beter de data op de twee data partities kan je niet zien behoudens je verborgen bestanden. Je hebt ze niet geformatteerd, anders zouden de verborgen bestanden ook weg zijn. Kijk nu nog eens met Nautilus naar de mappen c.q bestanden kan je ze nu wel zien?
Zo niet zou dat wel heel vreemd zijn. Dan moet je toch eens testdisk installeren en het programma photorec wat daar in zit laten zoeken naar de bestanden. Iets beters weet ik niet op het moment, misschien een van de andere forum leden nog een geniale inval?

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: Alle data "weg" na upgrade naar 8.10 (mijn fout of...?)
« Reactie #5 Gepost op: 2008/11/17, 23:12:57 »
Enigste wat ik me zo snel kan bedenken is dat door de installatie die partitie's een andere UUID hebben gekregen ???
en dat je nu in "schijnbaar" verkeerde mappen te kijken.

Wat ik vreemd vind is dat je tijdens de installatie hebt aangegeven dat ze gemount moeten worden.
En achteraf mount je ze nogmaals.

Kijk eens in je menu.lst hoe het daar staat beschreven ?
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Romald

  • Gast
Re: Alle data "weg" na upgrade naar 8.10 (mijn fout of...?)
« Reactie #6 Gepost op: 2008/11/17, 23:28:29 »
...>Waarschijnlijk staat er Rhythmbox>
...wanneer is dat nou weer veranderd?? Weer een raadsel, maar je hebt wel gelijk  ^-^

...ik ben nog even aan het onderzoeken...

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Alle data "weg" na upgrade naar 8.10 (mijn fout of...?)
« Reactie #7 Gepost op: 2008/11/17, 23:36:33 »
Romald, wat ik uit dit topic begrijp (Ik ben een groentje en ben nog maar 5 maand bezig met linux/ubuntu) is dat je jezelf moeilijk maakt met die 'upgrade', want eigenlijk doe je geen upgrade maar een verse install. Upgraden kun je doen via de update manager (met de 'reguliere versies' aangevinkt in 'softwarebronnen') En alles gaat vanzelf, lui achterover in je zetel...  :)
Je schrijft dat je de partities toewijst, maar waarom? De partities zijn al ingedeeld van je vorige versie.
't Is maar even mijn gedacht schrijven hoor. Niets kwaad achter zoeken. ;)

Romald

  • Gast
Re: Alle data "weg" na upgrade naar 8.10 (mijn fout of...?)
« Reactie #8 Gepost op: 2008/11/17, 23:47:45 »
eigenlijk doe je geen upgrade maar een verse install
...ik weet 't, ik weet 't, maar een verse install vind ik fijner. Zie ook het topic: "[8.04 -> 8.10] Upgrade of herinstallatie?"
...en het kost ook niet veel tijd ( als er niets fout gaat tenminste :|)

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Alle data "weg" na upgrade naar 8.10 (mijn fout of...?)
« Reactie #9 Gepost op: 2008/11/17, 23:52:02 »
eigenlijk doe je geen upgrade maar een verse install
...ik weet 't, ik weet 't, maar een verse install vind ik fijner. Zie ook het topic: "[8.04 -> 8.10] Upgrade of herinstallatie?"
...en het kost ook niet veel tijd ( als er niets fout gaat tenminste :|)

Maar dan kan je beter (Er zijn er genoeg op het forum om ons eraan te herinneren  :) ) ...Jawel... :) Een backup doen.

Romald

  • Gast
Re: Alle data "weg" na upgrade naar 8.10 (mijn fout of...?)
« Reactie #10 Gepost op: 2008/11/17, 23:55:59 »
-twee data partities aangewezen en twee mount punten ingevuld
Okee, ik denk dat ik weet waar het fout gegaan is. Mijn /etc/fstab ziet er namelijk als volgt uit:

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda2
UUID=69123505-0bcc-4c9f-b645-94b505802d18 /               ext3    relatime,errors=remount-ro 0       1
# /dev/sda4
UUID=87017d49-bf76-4e03-b8da-3cbdf69d097c /dev/sda4       ext3    relatime        0       2
# /dev/sdb3
UUID=989e5321-0a05-4786-8b7f-fa6626f2f7a9 /dev/sdb3       ext3    relatime        0       2
# /dev/sdb2
UUID=80579895-62c8-4e58-9d49-eaf0c31e83b9 /home           ext3    relatime        0       2
# /dev/sdb1
UUID=cd970436-3389-4b22-8d38-ba4f6bacd313 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0


...en volgens mij heb ik dus "in een cirkeltje gemount" tijdens de installatieprocedure.
Als ik het verander in:
# /dev/sda4
UUID=87017d49-bf76-4e03-b8da-3cbdf69d097c /media/sdb3       ext3    relatime        0       2

...dan gaat 't natuurlijk een stuk beter. Maar het kwaad is inmiddels al geschied.
Zijn jullie het ermee eens dat dit de oorzaak kan zijn dat m'n partities leeg zijn geraakt?

Blijft nog de tweede vraag open: kan ik nog m'n hele file structuur "terugtoveren"?

Ronald.
« Laatst bewerkt op: 2008/11/18, 00:12:21 door Romald »

Romald

  • Gast
Re: Alle data "weg" na upgrade naar 8.10 (mijn fout of...?)
« Reactie #11 Gepost op: 2008/11/18, 00:10:20 »
...Bedtijd. Morgen maar weer verder.

Offline AptlyNamed

  • Lid
  • Steunpunt: Nee
Re: Alle data "weg" na upgrade naar 8.10 (mijn fout of...?)
« Reactie #12 Gepost op: 2008/11/18, 00:42:16 »
Ik hoop voor je dat je niks kwijt bent. Maar met partities en herinstalleren bezig gaan zonder eerst een backup te maken is niet slim.  Ik ben zelf het nodige kwijtgeraakt met dit soort acties.
« Laatst bewerkt op: 2008/11/18, 00:47:50 door AptlyNamed »

JimZ

  • Gast
Re: Alle data "weg" na upgrade naar 8.10 (mijn fout of...?)
« Reactie #13 Gepost op: 2008/11/18, 00:54:40 »
Testdisk is uitstekend in staat om "oude" partitietabellen terug te vinden.

Lijkt mij het proberen waard, testdisk zoekt (en vindt hopelijk) de zoekgeraakte partities, geeft duidelijk aan wat er gevonden is (grootte, bestandssysteem, begin en eind van de partitie) en laat het aan de gebruiker over of dat klopt en wat er verder mee moet gebeuren.

Dus komt dat lijstje overeen met de situatie zoals die was dan wordt de partitietabel herschreven en heb je ook zonder verdere handelingen je data terug (mits er nog geen nieuwe data naar die partitie zijn geschreven natuurlijk). Klopt het lijstje niet dan doe je zekerheidshalve niets en sluit je testdisk af en probeert wat anders.

Is dus vrij risicoloos en zeker het proberen waard.

Gr,
Jim