Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: "loop" probleem met Toshiba M300-P18 laptop  (gelezen 23501 keer)

kurtbe

  • Gast
"loop" probleem met Toshiba M300-P18 laptop
« Gepost op: 2008/09/17, 20:34:56 »
Beste mensen,
Vandaag de grote stap naar Ubuntu gewaagd en nu in zak en as gezeten. Ik heb 8.04 geïnstalleerd maar krijg geen enkele reactie naar internet (mét kabel: de Telenet aansluiting in België).  De hulpfiles geven geen oplossing (veel van die procedure klopt helemaal niet met wat ik in 8.04 te zien krijg), op dit forum ook geen oplossing gevonden.  
Ik vermoed, met nadruk op vermoed, dat ik met een "loop" probleem zit.  Het zou kunnen dat mijn LAN kaart niet aan gedreven wordt.  MAAR, en hier zit de loop: de hardware-test in Ubuntu heeft blijkbaar een inernetverbinding nodig om te kunnen werken en..... juist, ik raak niet op internet.  Dus om de LAN kaart te controleren moet ik op internet, en om op internet te raken moet ik LAN kaart controleren...
Ik zit dus hopeloos vast.  Kan één van jullie helpen om te voorkomen dat ik noodgedwongen weer naar Windows moet overstappen?
Via http://www.marvell.com/drivers/driverSearchResults.do;jsessionid=KkJ4LRLFxKT9bJdQY6hDF9TVw0LKSn6RBCxTyMj8rZTmnvB28Gqm!-659503748, zou ik MISSCHIEN een driver kunnen downloaden voor de Toshiba, maar ik ben niet zeker of het om de juiste driver gaat, en het downloaden vandie site lukte ook al niet.
Alvast bedankt...
Kurt

Beste mensen,
Omdat dit een lange thread is, geef ik in de eerste aanvraag meteen ook de oplossing. Je kan de hele thread lezen en nog eens flink lachen, maar voor zij die niet veel tijd hebben: hier de oplossing.
De Toshiba laptop bevat een Marvell 88E8040T netwerkkaart.  op de volgende manier kan ze onder Ubuntu 8.04 geactiveerd worden.
In een terminal (te openen onder 'toepassingen'/'hulpmiddelen'/'terminalvenster')
tik je eerst sudo modprobe sky2+enter

Daarna moet je 'sudo su -' typen zonder de (' )+enter
je zal ook je wachtwoord moeten invoeren.

Daarna elke regel van hieronder intypen en na elke regel een enter.  Je kan het ook makkelijker maken door het bestandje te copiëren dat door Leepesjee verder in deze thread gepost is.

#!/bin/bash
rmmod sky2
cd /lib/modules/`uname -r`/kernel/drivers/net
cp -p sky2.ko{,.orig}
perl -pe 's/\0\0\x6c\x43/\0\0\x55\x43/g' sky2.ko.orig > sky2.ko
echo sky2 >> /etc/modules
modprobe sky2

Nadat u de terminal sluit zou de netwerkkaart moeten opstarten.

Indien het niet meteen lukt, lees de thread dan door, je komt zeker tot de oplossing.
Succes!

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #1 Gepost op: 2008/09/17, 21:02:23 »
Splinternieuwe flaptop? Het kan zijn, dat het de kernel van Ubuntu 8.04 net iets te oud is voor je computer. De stuurprogramma's zitten namelijk in de kernel (hart van het systeem).

Eind oktober komt er een nieuwe Ubuntu 8.10, met een kernel die drie versies nieuwer is. Probeer intussen eens de alfaversie van 8.10? Let op: proefversie, nog stikvol fouten..... Beter niet installeren, maar alleen als LiveCD gebruiken.

Morgen (18-9) komt alfa 6 uit. Hou het Testforum in de gaten, wanneer het zover is:
http://forum.ubuntu-nl.org/forum/21

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #2 Gepost op: 2008/09/17, 21:20:27 »
Hallo kurtbe, om wat voor notebook gaat het? Enig idee wat voor netwerkkaart er in zit?

Offline leepesjee

  • Lid
  • Steunpunt: Nee
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #3 Gepost op: 2008/09/17, 22:18:02 »
Hallo kurtbe,
Gaat het toevallig om een Marvell Yukon 88E8040T (zit ook in mijn niewe Toshiba)? Dan heb je mazzel. Zie http://ohioloco.ubuntuforums.org/showpost.php?p=5285654&postcount=15 Werkte bij mij direct.

kurtbe

  • Gast
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #4 Gepost op: 2008/09/17, 22:20:36 »
type laptop in titel van thread? weet niet zeker welke netwerkkaart, maar die zit vermeld in de link naar de driver: Marvell voor zover dit zou juist zijn.
Bedankt, moet nu echter vlug verder werken, vandaar de telergamstijl...
Greets, Kurt

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #5 Gepost op: 2008/09/17, 23:04:18 »
M300 is de serienaam en daar zijn verschillende types van, om welke gaat het?

kurtbe

  • Gast
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #6 Gepost op: 2008/09/18, 02:05:15 »
Dag beste mensen,
Eerst en vooral doet het deugd om jullie reacties en betrokkenheid te krijgen en te voelen.  
Daarnaast moet ik eerst een rechtzetting doen, in mijn haast draaide ik de letters om: het gaat niet over een M300-P18, maar wél over een P300-18M.
Welke netwerkkaart daar inzit weet ik niet.  Op de Toshiba site vind ik een LAN driver voor mijn type toestel van het merk Marvell.  Maar er wordt geen type van die netwerkkaart vermeld.  (De driver zelf is bestemd voor Vista natuurlijk.)  Ik kijk even op de link van Leepesjee (OHIO etc.) en zie of ik wijzer wordt.
Tot straks!,
Kurt

kurtbe

  • Gast
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #7 Gepost op: 2008/09/18, 02:15:35 »
Zo, ben intussen even kijken wezen.  Ik weet dus niet zeker of het om dat typoe LAN kaart gaat.  Is er iemand die weet hoe ik dat kan te weten komen?
Bovendien moet ik ook nog vermelden dat ik een totale leek ben op Ubuntu/Linus vlak en dat "open a terminal and copy /paste " voor mij al even slikken is.  Copy/paste geen probleem, maar 'open a terminal'?  ...
Maar goed, dat is voor later, eerst te weten koemn welk type Marvell netwerkkaart er in de P300-18M zit.

kurtbe

  • Gast
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #8 Gepost op: 2008/09/18, 02:36:34 »
Na het lezen vande volledige thread die Leepesjee meldde, ben ik redelijk overtuigd dat ik inderdaad over dezelfde netwerkkaart beschik. Blijkbaar is er nu ook een kernel die de aanpassing bevat. zie:http://www.linuxhq.com/kernel/v2.6/26/drivers/net/sky2.c
Hoe doe ik het nu om dat op mijn systeem te krijgen?  Rekening houdend met het feit dat ik een complete leek ben, en dat dit de eerste keer zal zijn dat ik iets aanvang met Ubuntu.  Begin dus echt met het begin indien mogelijk. (waarschijnlijk iets in de trent van "duw op de aan-knop van uw computer" ;-)

Al bij voorbaat bedankt....

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #9 Gepost op: 2008/09/18, 09:23:57 »
Misschien kan leepesjee zijn gepatchte kernel module online zetten ergens zodat jij 'm kan downloaden en op de goeie plek kan zetten. Alhoewel het patchen zelf weinig voorstelt zie ik. Gooi maar wat balletjes op hoor :)

Mooi apparaat trouwens ;)

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #10 Gepost op: 2008/09/18, 09:40:13 »
Een terminal is een manier om de computer te bedienen via de opdrachtregel. In Ubuntu vind je de terminal onder Toepassingen > Hulpmiddelen > Terminalvenster.

kurtbe

  • Gast
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #11 Gepost op: 2008/09/18, 09:44:56 »
Bedankt voor het compliment AutoStatic.  Ikvond hem op Kapaza voor een zeer goede prijs.  200€ minder dan de adviesprijs.  Ik moet hem wél nog betalen.  Zo nieuw is ie nog.  Terug naar de inhoud: Kan ik niet iets aanvangen met die aangepast Linux kernel versie?  En zo ja, hoe doe ik dat dan?
http://www.linuxhq.com/kernel/v2.6/26/drivers/net/sky2.c
Groeten, Kurt

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #12 Gepost op: 2008/09/18, 10:15:05 »
De sky2 driver zit al standaard bij Ubuntu?

Doe eens het volgende in de terminal:

lsmod | grep sky2Zet de uitkomst van dit hier eens neer. Als er niks uitkomt, typ dan:

sudo modprobe -v sky2Er wordt om je wachtwoord gevraagd. Je zult geen sterretjes zien; dat hoort zo.

kurtbe

  • Gast
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #13 Gepost op: 2008/09/18, 10:28:25 »
Hi Cumulus, Bedankt om uit te leggen wat een terminal is.
De sky2 Standaard bij Ubuntu?  euh, neen denk het niet, maar wel bij Linux blijkbaar, of is dat hetzelfde?  Enfin, kijk even naar de link dan kom je op een Linux site terecht waar het allemaal op staat....

Ik heb intussen een poging ondernomen om de patch van Leesjepee te 'terminallen', maar dat gaat meteen fout.  
Dit zou ik moeten typen:

$ sudo su -
[type your password]
# rmmod sky2
# cd /lib/modules/`uname -r`/kernel/drivers/net
# cp -p sky2.ko{,.orig}
# perl -pe 's/\0\0\x6c\x43/\0\0\x55\x43/g' sky2.ko.orig > sky2.ko
# echo sky2 >> /etc/modules
# modprobe sky2

En dit is de realiteit:
Bij het openen van de terminal staat er al:
kurt@ubuntu-lap:~#
dan typ ik: $ sudo su -
dan enter ik en krijg:
[sudo] password for kurt: ik typ mijn paswoord na de dubbele punt en enter
ik krijg
root@ubuntu-lap:~#
ik typ rmmod sky2 en enter
ik krijg
ERROR: Module sky2 does not exist in /proc/modules
root@ubuntu-lap:~#

Voila, gedaan met de pret.
Wat doe ik verkeerd?

kurtbe

  • Gast
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #14 Gepost op: 2008/09/18, 10:41:58 »
Ik wil best je suggestie opvolgen van lsmod etc.  Maar ik vind niet op mijn klavier hoe je een recht streepje naar beneden typt.  (Bij god ik voel me plotseling dom.)

Offline eendje

  • Lid
  • Steunpunt: Nee
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #15 Gepost op: 2008/09/18, 10:52:20 »
Citaat van: kurtbe
Ik wil best je suggestie opvolgen van lsmod etc.  Maar ik vind niet op mijn klavier hoe je een recht streepje naar beneden typt.  (Bij god ik voel me plotseling dom.)
JE kunt ook gewoon de tekst van Cumulus kopiëren en daarna met met CTRL+SHIFT + v plakken in het terminal venster. Maak je ook geen typefouten ;)
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

kurtbe

  • Gast
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #16 Gepost op: 2008/09/18, 11:12:59 »
Ik vreesde al dat dit de reactie zou zijn.  Het probleem is dat ik met de laptop niet op internet raak, de kans dat ik deze berichten vanuit deze laptop naar hier stuur is dus behoorlijk klein.  Ik kan wel knippen en plakken in deze computer maar die draait dan wel onder WXP, en daar kan ik wél iets van.  En neem van mij aan dat XP dat plakken in zijn register NIET leuk zal vinden. Ik kan natuurlijk ook met een USB sleutel gaan goochelen, maar ik ben nog niet verder met Ubuntu dan dat ik de CD geïnstalleerd heb. Of de Usb poort reeds werkt is ook alweer de vraag.  Vandaar dat ik eerst en vooral op internet wil raken.  Dan kan ik daarna zelf overal oplossingen, pachtes, updates enz. zelf downloaden en installeren en moet ik jullie hier niet om de haverklap lastigvallen met alweer een ander probleem.  (Althans dat hoop ik)  Dat is ook de manier waarmee ik (bijna) alle problemen met microsoft oplos.  De keren dat ik daarvoor op een forum moet zijn op 1 hand te tellen, tenzij het is om een ander vooruit te helpen..

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #17 Gepost op: 2008/09/18, 11:48:33 »
Ik zou toch eerst bedraad de boel op orde proberen te krijgen.
En het pipe tekentje | zit boven de Enter knop op een US International toetsenbord.
Wat zegt Windows over het type wireless adapter?

kurtbe

  • Gast
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #18 Gepost op: 2008/09/18, 12:08:02 »
bedankt voor de reactie.
Windows zegt niets over de wireless adapter.  Ten eerste zit er geen wireless adapter op (deze verbinding met het forum loopt langs een totaal andere computer, een desktop) Ten tweede is mijn internet probleem met de laptop NIET wireless.  Het gaat over de LAN netwerkkaart ingebed op het moederbord om een KABEL verbinding te maken (TELENET in België). Tenslotte moet ik ook nog vermelden dat ik een Clean Install gedaan heb van Ubuntu.  Eerst alles formateren, daarna Ubuntu erop.  Op de laptop zit dus helemaal geen windows meer.  (Dat is ook de bedoeling: ik wil nagaan of ik helemaal window-loos kan worden)
Hopelijk heb ik hiermee alle informatie gegeven die jullie nodig hebben.
En, jammer genoeg, op geen één van mijn klavieren staat de 'pipe'.  Bovende de enter heb ik de backspace.
amaai, amaai..... zucht
en toch bedankt hoor...

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #19 Gepost op: 2008/09/18, 12:33:11 »
Ah, wéér niet goed gelezen :oops:
Wat betreft het | teken, op de foto staat ie wel:

Heb je een afwijkend toetsenbord? NL of Azerty?
En volgens de specificaties zit er inderdaad een Marvell 88E8040 onboard LAN kaart in.

kurtbe

  • Gast
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #20 Gepost op: 2008/09/18, 13:13:28 »
tja, op de foto wel.... Mijn Azerty heeft dat dus niet.  Wat wel mooi is dat de netwerkkaart nu bepaald is.  In NL is Toshiba dus vooruitstrevender dan in België, op Toshiba.be weten ze je alleen te vertellen dat het een Marvell is.  Verder geen type vermelding.  Bij Toshiba.nl zijn de gegevens duidelijk uitgebreider!
Maar wacht eens even, betaat die pipe uit 2 aparte lijntje boven elkaar?  Want die heb ik wél.  Weliswaar helemaal links op het klavier, maar dat maakt niet uit.  Ik zocht naar 1 volle lijn.

kurtbe

  • Gast
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #21 Gepost op: 2008/09/18, 13:28:28 »
ik probeer het straks even uit, maar heb eerts een paar uur werk te verzetten....
tot later....

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #22 Gepost op: 2008/09/18, 13:55:13 »
pipe is twee rechtopstaande lijntjes boven elkaar ja. En op de NL Toshiba site staat ook niks hoor, heb specificaties van een externe site.

kurtbe

  • Gast
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #23 Gepost op: 2008/09/18, 14:58:35 »
Ok, ik heb die pipe gevonden.  maar waarschijnlijk doe ik één en ander niet volgens de regels van de kunst.  Waarschijnlijk moet ik eerst dingen als wachtwoord, sudo edm. intypen.  Ik heb één en ander geprobeerd en dit is het resultaat:
eerste commando: niets
tweede commando: insmod /lib/modules/2.6.24-19-generic/kernel/drivers/net/sky2.ko
Kan je hier iets mee?

Offline DarkStar

  • Lid
    • Mijn persoonlijke website
  • Steunpunt: Nee
"loop" probleem met Toshiba M300-P18 laptop
« Reactie #24 Gepost op: 2008/09/18, 15:31:20 »
kurtbe, ik veronderstel dat je een azertje keyboard hebt. De '|' kan je dan ingeven door 'alt gr' + '1' in te drukken.
*edit* sorry, lees net dat je het al gevonden hebt...

° Bezoek mijn blog Digital (in)Sanity °