Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: De ene keer wel en de andere keer niet verbonden met Internet.  (gelezen 48320 keer)

Offline elspierre

  • Lid
  • Steunpunt: Nee
Dit item heb ik eerder(topic 30184) aan de orde gesteld echter zonder een  oplossing te krijgen.

Ik zit met een merkwaardig probleem. De ene keer wordt ik in Ubuntu wel met Internet verbonden en de andere keer weer niet. Als dit probleem niet wordt opgelost kan ik niet verder meer Ubuntu gebruiken en ben ik verder aan Windows uitgeleverd.

Ik heb een dualboot systeem met Windows XP en telkens voor ik Windows afsluit geef ik het commando ipconfig/ release om het ip adres vrij te krijgen hoewel dat niet strict nodig is bij mij. Onder Windows heb ik geen enkel probleem met de verbinding.

Ik heb een bedrade verbinding via een modem en een router. Via de router gaat een kabel naar een ATA (Analogische telefoon adapter) die ik voor Voipbuster gebruik en een kabel naar mijn PC. Ubunu is geconfigureerd als DHCP dus router geeft zelf IP adres, idem bij ATA.

Wat vooral raar is onder Ubuntu is dat wanneer hij niet verbindt toch zegt dat hij verbonden is . Ook het lichtje van de netwerkkaart brandt.

Soms wordt ik een week achter elkaar goed verbonden en daarna is het bijna elke keer weer mis.
Ik heb al van alles geprobeerd en ook de modem gereset.
Wie verlost mij van dit probleem zodat ik verder Ubuntu kan blijven gebruiken.
Bij voorbaat dank voor jullie hulp.
Pierre

Offline jan11000

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #1 Gepost op: 2008/08/12, 09:09:08 »
ipconfig/ release in windows hoef je dus echt niet te doen. Waarom denk je dat je dit moet doen?

Start eens/altijd vanuit een koude start naar ubuntu, gebeurd het niet verbinden dan ook.(pc uit, pc aan, dan alleeen naar ubuntu). Dit om te testen.

Netwerkkaart in ubuntu uitzetten en weer aanzetten wat gebeurd er dan(nadat hij geweigerd heeft).

Bij weigeren, de router 5 minuten uitzetten, en dan weer aanzetten, wat gebeurd er dan.

Offline elspierre

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #2 Gepost op: 2008/08/12, 09:19:18 »
Bedankt Jan,

Zoals ik eerder al zei hoef ik niet ipconfig/ release onder Windows te doen, voor alle zekerheid doe ik het meestal wel.

Ook als ik een koude start doe verbindt hij de ene keer wel en de andere keer niet.

Aangezien ik nu weer verbonden ben onder Ubuntu kan ik vraag 3 nu niet doen, komt later wel, idem vraag 4.
Bedankt zover,

Pierre

Offline Drummies

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #3 Gepost op: 2008/08/12, 09:59:11 »
elspierre

lees onderstaande link eens door misschien haal je info uit die van toepassing zijn om het probleem op te lossen

http://tille.garrels.be/training/ubuntu/ch12.html
Gestopt als aktief Forumlid 17/10/2011

Offline elspierre

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #4 Gepost op: 2008/08/12, 12:55:59 »
Dat Heb ik gedaan Drummies.

Als ik bij "systeem----beheer------netwerk---tablad verbindingen" kijk staat bij Netwerkinstellingen "Draadverbinding" geselecteerd met als adres DHCP.
Als ik dan bij eigenschappen kijk  staat er "Automatische configuratie DHCP"
Ik zou niet weten wat er fout is ingesteld en het merkwaardige is dat hij soms wel een week lang goed verbindt en dan weer de ene keer wel en de andere keer niet.
Wie weet het antwoord  op mijn probleem ? Het is m.i een Ubuntu softwareprobleem  of foute instelling want onder Windows werkt alles normaal.
Gaarne bereid tot nadere inlichtingen.
Pierre

Offline Peterbeter

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #5 Gepost op: 2008/08/12, 13:09:46 »
@drummies: bedankt voor handige link.
@elspierre: zal kijken of ik ook nog ergens wat vinden kan op je topic.
¨ik respecteer u zoals ik ben¨
Herman Brood

Offline elspierre

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #6 Gepost op: 2008/08/12, 13:43:30 »
Citaat van: elspierre
Bedankt Jan,

Zoals ik eerder al zei hoef ik niet ipconfig/ release onder Windows te doen, voor alle zekerheid doe ik het meestal wel.

Ook als ik een koude start doe verbindt hij de ene keer wel en de andere keer niet.

Aangezien ik nu weer verbonden ben onder Ubuntu kan ik vraag 3 nu niet doen, komt later wel, idem vraag 4.
Bedankt zover,

Pierre
Jan,
Ik ik niet verbonden ben, terwijl Ubuntu wel zegt dat ik verbonden ben en dan de netwerkkaart uitschakel en dan weer inschakel gebeurt er niets en ook niet als ik de router 5 minuten uitzet en dan weer aanzet gebeurt er ook niets.
Pierre

Offline elspierre

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #7 Gepost op: 2008/08/13, 10:31:25 »
Nog even een aanvulling, als ik verbonden ben en het commando geef ipconfig -a krijg ik het volgende te zien:

pierre@cp741319-a:~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:1f:c6:03:be:13  
          inet addr:192.168.2.104  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::21f:c6ff:fe03:be13/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:507 errors:0 dropped:1689103966 overruns:0 frame:0
          TX packets:550 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:477134 (465.9 KB)  TX bytes:107378 (104.8 KB)
          Interrupt:221 Base address:0xc000

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1286 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1286 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:64300 (62.7 KB)  TX bytes:64300 (62.7 KB)

Als ik niet verbonden ben terwijl Ubuntu zegt dat ik wel verbonden ben krijg ik bij dat commando te zien:

eth0      Link encap:Ethernet  HWaddr 00:1f:c6:03:be:13  
          inet6 addr: fe80::21f:c6ff:fe03:be13/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:4294967284 overruns:0 frame:0
          TX packets:0 errors:0 dropped:46 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:221 Base address:0xc000

eth0:avahi Link encap:Ethernet  HWaddr 00:1f:c6:03:be:13  
          inet addr:169.254.5.12  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:221 Base address:0xc000

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1375 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1375 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:69020 (67.4 KB)  TX bytes:69020 (67.4 KB)

Kan iemand hieruit misschien opmaken wat er fout gaat.

Zoals gezegd het probleem van niet verbonden zijn doet zich willekeurig voor.
De ene keer wel de andere keer niet. Maar Ubuntu zegt in beide gevallen dat ik verbonden ben.
Ik hoop dat jullie mijn probleem kunnen oplossen , anders kan ik niet langer met Ubuntu werken en ben ik aan Windows overgeleverd wat niet de bedoeling is.

Groeten,
Pierre

Offline elspierre

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #8 Gepost op: 2008/08/15, 09:20:05 »
Kan niemand iets opmaken uit het bovenstaande ?

Dan maar nog wat meer informatie:
Als  Ubuntu zegt dat ik verbonden ben terwijl ik niet verbonden ben en het commando geef:

 sudo /etc/init.d/networking stop krijg ik het volgende te zien|


pierre@cp741319-a:~$ sudo /etc/init.d/networking stop
[sudo] password for pierre:
 * Deconfiguring network interfaces...                                          There is already a pid file /var/run/dhclient.eth0.pid with pid 5862
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:1f:c6:03:be:13
Sending on   LPF/eth0/00:1f:c6:03:be:13
Sending on   Socket/fallback
DHCPRELEASE on eth0 to 192.168.2.1 port 67

Geef ik daarna het commando :sudo /etc/init.d/networking start
dan krijg ik te zien :


pierre@cp741319-a:~$ sudo /etc/init.d/networking start
 * Configuring network interfaces...                                            There is already a pid file /var/run/dhclient.eth0.pid with pid 134519072
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:1f:c6:03:be:13
Sending on   LPF/eth0/00:1f:c6:03:be:13
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 1
No DHCPOFFERS received.
No working leases in persistent database - sleeping

Kan iemand hieruit iets opmaken ?

Nogmaals bij windows word ik altijd verbonden , bij Ubuntu de ene keer wel de andere keer  niet terwijl Ubuntu wel altijd zegt dat ik verbonden ben.
Wie oh wie kan mij helpen want zo kan ik niet met Ubuntu werken. ?
Mijn andere Ubuntu PC die op dezelfde router zit geeft nooit problemen met verbinden. Zou het aan de netwerkkaart kunnen liggen?
Dat zou ik vreemd vinden want vaak wordt ik wel goed verbonden.
Pierre

Offline Drummies

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #9 Gepost op: 2008/08/15, 09:38:02 »
elspierre

heb je als eens geprobeerd om een vast ip adress in te geven,zie link

http://tille.garrels.be/training/ubuntu/ch12.html
Gestopt als aktief Forumlid 17/10/2011

Offline elspierre

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #10 Gepost op: 2008/08/15, 10:04:12 »
Nog niet Drummies, maar dat ga ik nu doen.
Even nog een vraag.
Ik moet het IP-adres van de gateway opgeven.Is dat hetzelfde als het broadcastadres of dat van de standaardroute ?
Zo niet hoe kom ik daar achter ?
Bedankt.
Pierre

Offline Drummies

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #11 Gepost op: 2008/08/15, 10:17:46 »
elspierre
gegevens volgens je eigen post


inet addr:192.168.2.104  Bcast:192.168.2.255  Mask:255.255.255.0
Gestopt als aktief Forumlid 17/10/2011

Offline elspierre

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #12 Gepost op: 2008/08/15, 10:29:13 »
Bedankt Drummies.
Als ik voor Ubuntu een vast IP-adres instel moet ik,-naar ik aanneem- dat ook doen voor Windows XP die als dualboot op dezelfde PC draait.
Bij voorbaat dank voor je hulp.
Pierre

Offline commandoline

  • LoCo-contact
    • marten-de-vries
    • Marten-de-Vries.nl
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #13 Gepost op: 2008/08/15, 10:39:10 »
Dat hoeft niet als het onder xp gewoon werkt.

Offline Gandyman

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #14 Gepost op: 2008/08/15, 10:54:27 »
Houd er ff rekening mee dat wanneer je de pc een vast IP adres geeft, dit adres buiten de DHCP range moet zitten.

Kijk dus eerst op je modem/router tot waar de DHCP IP adressen uitdeelt.

Stel dat is ingesteld op 192.168.2.100  t/m 192.168.2.145 ,
dan geef jij je pc het vast IP adres 192.168.2.146

(Doe dit dan hetzelfde als je in windo bent ! )

Bekijk tevens welke DNS servers je gebruikt in Windo en of in Ubuntu, want die krijg je ook niet meer doorgegeven van de DHCP van je modem/router.
Deze 2 moet je nu ook handmatig ingeven.
Dit is zelfs beter omdat alles nu wat sneller werkt.

BTW vind het een beetje raar dat hij af en toe geen IP adres krijgt van de DHCP ??
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline woteb

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #15 Gepost op: 2008/08/15, 11:03:18 »
Afgaand op jouw informatie zou jouw /etc/network/interfaces bestandje er zo uit moeten zien:

Citaat
auto eth0
iface eth0 inet static
Address  192.168.2.104
broadcast 192.168.2.255
network 192.168.2.0
netmask 255.255.255.0
gateway 192.168.2.1
Jij hebt een normaal private network adres (192.168.x.x), en daar hoort o.a. het network 192.168.2.0 en het broadcast 192.168.2.255 bij. Die heb ik voor jou toegevoegd. Om te kunnen internetten zou ik alleen je dns nameservers moeten weten. Dat is waarmee jouw provider werkt, maar zonder die dns servers zou jouw modem/router dat voor je moeten regelen. Dus wellicht werkt het zo ook.
Mocht je niet kunnen internetten, probeer dan eens een ander IP-adres voor jouw netwerkkaart, dus i.p.v. 192.168.2.104 iets anders, bijv. 192.168.0.105.

Dat je Windows met ipconfig/ releaseafsluit is wel degelijk goed als je met Ubuntu via dhcp werkt, omdat Windows dan dat netwerkadres voor zichzelf reserveert en houdt. En een ander besturingssysteem mag het dan zelf uitzoeken.

Wat je -OOK- kunt doen, is Windows op een vast adres laten lopen en Ubuntu met dhcp laten werken. Dan kun je bovenstaande gegevens voor Windows gebruiken, en laat je Ubuntu lekker op dhcp lopen. De omgekeerde wereld dus. Probeer dat eens zou ik zeggen.
Voor Windows ben je lekker snel klaar met een statisch adres. Alleen het IP adres invullen (het netmask vult WIndows voor je in, het gateway-adres opgeven (van je router, dus 192.168.2.1) en eventueel bij de dns servers dat routeradres ook opgeven + dat van je provider.

Eventueel, als je Ubuntu via een statisch adres wilt laten lopen, extra installeren de volgende pakketjes: sudo apt-get install dhcpcd resolvconfEN, niet vergeten, voor een vast IP adres, de raad van Gandyman opvolgen, dus een adres BUITEN de dhcp range...!!!
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline woteb

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #16 Gepost op: 2008/08/15, 11:09:48 »
Citaat van: Gandyman
BTW vind het een beetje raar dat hij af en toe geen IP adres krijgt van de DHCP ??
Ik niet, misschien per ongeluk niet vanuit Windows het IP-adres vrijgegeven? Windows is nu eenmaal op bepaald momenten wel eens wat 'hebberig'...... ;)
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline elspierre

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #17 Gepost op: 2008/08/15, 11:13:27 »
Drummies en Gandyman,
Bedankt,

Mijn kennis over routers en netwerken e.d is niet al te groot.
Ik heb mijn router nu zo ingesteld dat hij vanaf 192.168.2.103 DHCP adressen gaat uitdelen.
Wanneer ik in Ubuntu nu als vast IP-adres 192.168.2.101 ga instellen blijven dan de gevevens van De IP-gateway en het Subnetmask  (Bcast:192.168.2.255 Mask:255.255.255.0)  hetzelfde of veranderen die ook als ik 192.168.2.101 als vast IP-adres kies ?
De primaire en secundaire  DNS kan ik in mijn router opzoeken.
Ik begrijp van jou Gateway dat ik ook in Window een vast IP adres moet instellen als ik dat voor Ubuntu doe.
Pierre

Offline elspierre

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #18 Gepost op: 2008/08/15, 11:16:22 »
Citaat van: woteb
Citaat van: Gandyman
BTW vind het een beetje raar dat hij af en toe geen IP adres krijgt van de DHCP ??
Ik niet, misschien per ongeluk niet vanuit Windows het IP-adres vrijgegeven? Windows is nu eenmaal op bepaald momenten wel eens wat 'hebberig'...... ;)
Nee,
Want als ik in Windows gewerkt heb geef ik voor het afsluiten altijd het commando ipconfig/ release hoewel dat bij mij niet strikt nodig is.
Pierre

Offline woteb

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #19 Gepost op: 2008/08/15, 11:21:05 »
Dan kun je daar lekker een of meer nummers nummertje onder zitten, bijv. 192.168.2.100 (een mooi getal en makkelijk te onthouden).
Die andere adressen kun je als administratieve adressen beschouwen. Het  subnetmasker (255.255.255.0), de adressen x.x.x.1 en x.x.x.255 vertellen namelijk wat voor een netwerk het is... (even kort door de bocht). Daar hoef jij je dus nooit zorgen over te maken.
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline elspierre

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #20 Gepost op: 2008/08/15, 11:44:27 »
Drummies, Gandyman en Woteb,

Even alles samenvattend en uitgaande van bovenstaande.

Als ik in Ubuntu een vast IP-adres instel, gebruik ik de navolgende gegevens:

IP adres            192.168.2.100
Submask           255.255.255.0
IP gateway        192.168.2.255
Prim DNS          213.51.144.37
Sec DNS           213.51.129.37
In Windows hoef ik dan niets te veranderen.
Stel ik het zo goed in.
Bedankt voor de hulp.
Pierre

Offline woteb

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #21 Gepost op: 2008/08/15, 11:51:46 »
Gebruik dit maar:
auto eth0
iface eth0 inet static
Address  192.168.2.100
broadcast 192.168.2.255
network 192.168.2.0
netmask 255.255.255.0
gateway 192.168.2.1
dns-nameservers 192.168.2.1
dns-search 213.51.144.37,213.51.129.37

Deze gegevens gebruiken in het bestandje /etc/network/interfaces (met rootrechten aanpassen!!)

Misschien heeft Gandyman een andere mening...??
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline elspierre

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #22 Gepost op: 2008/08/15, 12:01:09 »
Woteb,
Nu staat er:

auto lo
iface lo inet loopback




iface eth0 inet dhcp

auto eth0

Dus als ik dat vervang door jouw gegevens dan heb ik een vast IP-adres in Ubuntu, hoef ik verder niets meer te doen en zou alles goed moeten werken ?
Bedankt,

Pierre

Offline woteb

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #23 Gepost op: 2008/08/15, 12:35:53 »
Klopt helemaal. Maar ik zou de bestaande instellingen van jouw eth0 kaartje uitschakelen door er een # voor te zetten. Dan moet er het volgende staan:

# iface eth0 inet dhcp
auto eth0
iface eth0 inet static
Address  192.168.2.100
broadcast 192.168.2.255
network 192.168.2.0
netmask 255.255.255.0
gateway 192.168.2.1
dns-nameservers 192.168.2.1
dns-search 213.51.144.37,213.51.129.37

Mocht het op de een of ander manier toch niet bevallen, dan zet je de # voor de regels van het statische adres, dus zo:

iface eth0 inet dhcp
auto eth0
#iface eth0 inet static
#Address  192.168.2.100
#broadcast 192.168.2.255
#network 192.168.2.0
#netmask 255.255.255.0
#gateway 192.168.2.1
#dns-nameservers 192.168.2.1
#dns-search 213.51.144.37,213.51.129.37

Die # voor de regels zorgen ervoor dat die regels worden uitgeschakeld. Eigenlijk zijn het commentaaraanduidingen, maar daar maken we handig gebruik van.
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline elspierre

  • Lid
  • Steunpunt: Nee
De ene keer wel en de andere keer niet verbonden met Internet.
« Reactie #24 Gepost op: 2008/08/15, 13:08:40 »
Woteb,

Hartelijk bedankt. Ik zal hier laten horen of het werkt maar ik moet nu effen weg.
Nog een vraag .
Als ik de tekst in  van het bestandje in "/etc enz"moet vervangen met rootrechten vraagt hij dan zelf naar het wachtwoord of moet ik dat anders doen.
Vergeef me deze vraag maar ik ben nog maar een leek in Ubuntu maar ik wil me er wel in bekwamen.
Nogmaals bedankt voor je hulp.
Pierre