Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Live CD booten resulteert in zwart scherm.  (gelezen 3465 keer)

EricM

  • Gast
Live CD booten resulteert in zwart scherm.
« Gepost op: 2008/01/03, 23:22:07 »
Gegevens CD:
Betreft ubuntu-7.10-desktop-amd64.iso
- Gebrand met Nero 5
- Verificatie: OK.

Gegevens Systeem:
Acer Aspire E360DC
- Processor: AMD Athlon X2 64 4200 Dual core
- Intern geheugen: 2048Mb DDR
- Video chipset: ATI Radeon x700HM SE

Procedure:
Booten vanaf CD, menu eerste scherm wordt getoond, vervolgens kiezen "Starten or install Ubuntu"
Resultaat:
- Loading Linux kernel
- Kernel alive
- Kernel direct mapping tables up to 100000000 @ 8000-d000 (kan me in het eerste getal een "0" hebben vergist)

Daarna zwart scherm
Starten met een andere schermresolutie of zelfs starten in een niet grafische mode geeft zelfde resultaat.

Analyse: ??
Bij voorbaat dank.

Offline joop905

  • Lid
  • Steunpunt: Nee
Live CD booten resulteert in zwart scherm.
« Reactie #1 Gepost op: 2008/01/03, 23:29:08 »
de video kaart kan wel eens het probleem zijn
probeer eens de Alternate install CD

Offline Erik_m

  • Lid
  • Steunpunt: Nee
Live CD booten resulteert in zwart scherm.
« Reactie #2 Gepost op: 2008/01/05, 03:42:24 »
Ander idee dat ik eerst zou proberen: ipv "starten of install ubuntu"  doe je "start ubuntu in safe graphics mode" (of bedoel je dat met niet grafische mode)

Eventueel even een andere ubuntu-cd wil ook weleens helpen, heb datzelfde probleem ook gehad en toen was de cd gewoon brak.

EricM

  • Gast
Live CD booten resulteert in zwart scherm.
« Reactie #3 Gepost op: 2008/01/06, 18:30:07 »
Heren, dank voor de suggesties; hier volgt een evaluatie.
De ubuntu-7.10-desktop-amd64.iso resulteert onder de volgende condities in zwart scherm:
- na starten default vanuit het Ubuntu keuze menu Start or install.....;
- na starten met het voor mijn systeem vereiste resolutie en kleurdiepte (F4 VGA);
- na het starten in Save graphics mode;
- na gebruik van F6, waarna ik na ESC op een commandprompt terecht kom en deze "enter".

Andere versie CD gebrand: ubuntu-7.10-desktop-i386.iso
- Resultaat na default starten vanuit het Ubuntu keuze menu "Start or install.....":
- - Linksrechts "horizontale (zand)loper" in beeld, Vervolgens loopt deze van links naar rechts vol;
- - Zwart scherm even met knipperende cursor;
- - Wit beeldscherm met zwarte balk op 20 procent van de beeldhoogte (zwarte balk blijft);
- - Kortstondig de Ubuntu desktop achtergrond in beeld;
- - Uiteindelijk een geblokt patroon over de dekstop achtergrond op scherm.
Wanneer dit scherm blijft staan, gaat het systeem uiteindelijk naar de energie besparende stand.

Na Reboot systeem en keuzemenu gestart in safe graphics mode:
- Ubuntu logo zichtbaar met een "horizontale (zand)loper".
- Linux bootinfo verschijnt
- - starting deferred execution schduler atd
- - starting periodic command schuduler crond
- - checking battery state...
- - running local bootscripts (/etc/rc.local)
- Vervolgens gaat het diplay een paar keer op zwart (geen video signaal)
- Daarna een melding: The display server has been shut donw about 6 times in the last 90 seconds. It is likely that something bad is going on. Waiting for 2 minutes before trying again.
Verdere actie biedt geen (andere) uitkomst.

Defect in de hardware sluit ik uit:
- onder Windows geeft het scherm nl. geen problemen;
- primair geeft Ubuntu ook geen problemen, grafisch menuscherm en logo is te zien.

Het lijkt er sterk op dat er onder Ubuntu Linux iets mis gaat bij de detectie van de video hardware, het scherm of dat er instellingen in de BIOS onjuist zijn.
Nadere systeem info:
Scherm Philips 190X6, 1280x1024, 32 bits;
Videokaart P&P Raedon 700 series met Video chipset: ATI Radeon x700HM SE;
BIOS: Phoenix Award WorksationBios, version 6.00  PG, Release date 1-19-2006.

Nb. De Alternate install cd nog niet uitgeprobeerd. Biedt deze mogelijkheden om specifiek drivers te laden?

Analyse: Suggesties meer dan welkom....

EricM

  • Gast
Live CD booten resulteert in zwart scherm.
« Reactie #4 Gepost op: 2008/01/06, 18:37:36 »
Bericht nr5 is foutief gepost bericht.
Bericht nr4 is van toepassing.

Offline mcgyver

  • Lid
  • Steunpunt: Nee
Live CD booten resulteert in zwart scherm.
« Reactie #5 Gepost op: 2008/01/06, 18:50:58 »
Was al eerder geadviseerd: probeer de alternate cd.

EricM

  • Gast
Live CD booten resulteert in zwart scherm.
« Reactie #6 Gepost op: 2008/01/08, 22:22:42 »
Middels de alternate CD kon vanuit een scherm in textmode worden geinstalleerd. Schijf kunnen partitioneren, dual bootable systeem gemaakt. Vanuit de bootmanager start Windows probleemloos op.
Echter wanneer Linux wordt geboot wordt ik wederom met een zwart scherm geconfronteerd.
Opstarten in recoverymode laadt het hele systeem zonder foutmeldingen. Alles [OK].
Vanaf de commandprompt het commando startx ingeven resulteert in een geblokt patroon over de dekstop achtergrond op scherm. Vrees dat ik aan een graphics driver installation zit.

Nu kan ik vanuit Windows wel het Internet op en heb gevonden: http://ati.amd.com/support/drivers/linux64/linux64-radeon.html
Twee vragen:
Kan ik nu onder windows een driver downloaden en een cd branden, of geeft dit problemen met het format?
Vanaf de Linux command prompt zullen drivers dan geinstalleerd moeten worden.
Valt dit nog onder installatie voor beginners of moet ik uitwijken naar een ander gremium? Indien zo, dan sluit ik deze draad.

Offline siegi

  • Lid
  • Steunpunt: Nee
Live CD booten resulteert in zwart scherm.
« Reactie #7 Gepost op: 2008/01/08, 22:31:15 »
Citaat van: EricM
Bericht nr5 is foutief gepost bericht.
Bericht nr4 is van toepassing.
Je kan je berichten ook aanpassen.  Door rechts onder je bericht op bewerken te klikken.

Opzich is dat gewoon de restricted driver van ati. Die is installeerbaar met restricted driver manager.
Maar je kan natuurlijk niet in de grafische mode.
Ik heb eigenlijk geen ervaring met ati kaartjes en hun drivers. Maar normaal moet gdm eigenlijk onder een soort veilige modus opstarten met de vesa driver.  Maar dit blijkt ook niet te werken.

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Live CD booten resulteert in zwart scherm.
« Reactie #8 Gepost op: 2008/01/09, 00:39:01 »
Ook in veilige modes kan je alles doen, net zoals je zou kunnen doen in een grafische omgeving.

Dus moeilijk doen met iets downloaden en op cd zetten is totaal niet nodig.
Je zou vanuit de veilige modes gewoon iets kunnen downloaden en dan naar een temp map gooien en van daaruit installeren.

Maar dit is vrij moeilijk en voor een beginner not done.

Goed we weten nu dat jouw ATI kaart behoorlijk tegenprutteld, dit is bekend van ATI, ook in Windows zijn het geen succes nummers.....
Maagoe

Je kan in veilige modes de volgende (toverformule) geven:
dpkg-reconfigure -phigh xserver-xorg
Nu krijg je een aantal vragen die je moet beantwoorden.
Op de meeste kan je gewoon doorklikken, maar bij je vga kaart moet je even opletten.
Ik heb geen idee hoe hij op >>vesa<< reageerd, normaal gesproken is dit de veiligste en werkt altijd, zij het niet zo mooi, maar dat is niet belangrijk nu, eerst beeld hebben.

Werkt dit nu nog niet naar behoren, simpel omdat Ubuntu niet jouw vga kaart kan detecteren, kan je met de hand de xorg.conf onder handen nemen...
Dit doe je met een soort kladblok zoals je in Windows hebt....

In veilige modes kan je alleen "vi" of "nano" gebruiken voor dit klusje.
Dit zijn vrij simpele proggies en wat je moet doen om te saven of te stoppen staat onderaan op de balk.

Goed bewerken van de xorg.conf

Met de opdracht:
sudo nano /etc/X11/xorg.conf
krijg je hem voor je neus.
(LET OP: "X11" is met de hoofdletter X)

Nu scrol je naar beneden tot je dit gedeelte ziet:
Citaat
Section "Device"
        Identifier      "Failsafe Device"
        Boardname       "vesa"
        Busid           "PCI:1:0:0"
        Driver          "radeon"
        Screen  0
        Option          "MergedFB"      "off"
EndSection

Section "Monitor"
        Identifier      "Failsafe Monitor"
        Vendorname      "Mitsubishi"
        Modelname       "Mitsubishi Diamond Plus 230SB"
        Horizsync       30.0-115.0
        Vertrefresh     50.0-160.0
Dit is van iemand anders dus bij monitor zou jouw merk moeten staan.
Echter je ziet hier staan bij >>>Boardname       "vesa"
Dat typ jij er ook in en sla het dan op.
Wanneer je nu typt:
sudo /etc/init.d/gdm start
Zou je weer normaal beeld moeten hebben.
Veelal mislukt het om de Xserver te starten en moet je rebooten.
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

EricM

  • Gast
Live CD booten resulteert in zwart scherm.
« Reactie #9 Gepost op: 2008/01/09, 22:32:07 »
Optie 1 - dpkg-reconfigure -phigh xserver-xorg:
het enige wat ik hier te zien kreeg was een menu waar ik de resolutie van de monitor kon instellen. Dit heb ik geselecteerd en vervolgens kwam ik weer op de command prompt. Toen sudo /etc/init.d/gdm start ingevoerd en waarempel kwam ik op een inlogscherm. (zichtbaar!)
Na inloggen echter weer met het "blokprobleem" geconfronteerd. Bood helaas geen oplossing.

Optie 2: bewerken van de xorg.conf
Bij "section Device" vond ik de volgende gegevens:
   Identifier        "ATI Technologies Inc RV410 [Radeon X700]"
   Driver            "ati"
   BusID            "PCI:3:0:0"
EndSection

Section "Monitor"
   Identifier       "Generic Monitor"
   Option           "DPMS"
   HorizSync       30-70
   VertRefresh    50-160
EndSection

Section "Screen"
   Identifier       "Default Screen"
   Device           "ATI Technologies Inc RV410 [Radeon X700]"
   Monitor          "Generic Monitor"
   DefaultDepth  24
EndSection

Omdat ik echter geen "Boardname" tegenkwam heb ik nog niets gewijzigd. Ik heb totaal geen verstand van dit soort configuraties en wil ergere problemen voorkomen.
Moet ik nu onder de sectie "Device"  Boardname "vesa" toevoegen??
Kijk ook even naar de BusID; de man pages had het over PCI:1:0:0 voor een AGP card.

Heel graag advies.

P.s. in nano is ^X Exit is dat wegschrijven van wijzigingen?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Live CD booten resulteert in zwart scherm.
« Reactie #10 Gepost op: 2008/01/09, 23:01:31 »
Dit is mijn xorg.conf is voor een Nvidia kaart maar op die plekken is het voor jou ATi kaart, het is maar een voorbeeld
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder3)  Wed Sep 12 14:30:30 PDT 2007

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath         "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Panasonic"
    HorizSync       30.0 - 70.0
    VertRefresh     50.0 - 180.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7600 GS"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "DynamicTwinView" "FALSE"
    Option         "metamodes" "1024x768_75 +0+0; 1024x768 +0+0; 800x600 +0+0; 640x480 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Als je dit doet dpkg-reconfigure xserver-xorg krijg je de volledige versie.
In Nano is ^O opslaan en ^X Exit
Vesa is een soort veilige modus, werkt meestal goed kan je later op je gemak de juiste kaart voor invoegen. En wat Gandyman zegt je kan ook reboot now intoetsen

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

EricM

  • Gast
Live CD booten resulteert in zwart scherm.
« Reactie #11 Gepost op: 2008/01/10, 00:44:45 »
Heren dankzij jullie ondersteuning heb ik één keer beeld gehad!  Zal proberen te reproduceren wat ik heb gedaan.
Probeer enigzins te begrijpen waar ik mee bezig ben, dus ook de manpage xorg.conf geraadpleegd.
Verder las ik op http://linux.die.net/man/4/vesa iets over vesa - Generic VESA video driver

Dit en met wat Gandyman vertelde toch maar de stoute schoenen aangetrokken en Bij "section Device" de regel Driver "Vesa" toegevoegd:
   Identifier        "ATI Technologies Inc RV410 [Radeon X700]"
   Driver            "ati"
   BusID            "PCI:3:0:0"
   Driver            "Vesa"
EndSection

Vervolgens met sudo /etc/init.d/gdm start de zaak geinitialiseerd.
Na een paar keer klapperen van het beeld en een melding dat de grafische kaart niet kon worden geinitialiseerd kreeg ik toch een zeer belabberde grafische mode te pakken en werd geconfronteerd met een video configuratie scherm.
Hier kon ik een video kaart en een beeldscherm (merk en type) selecteren.
De videocard daar heb ik een ATI Vesa voor gekozen
Mijn monitor stond er niet tussen, maar heb een type gekozen dat dat benadert.
Na OK klikken kwam het systeem uiteindelijk terug met een behoorlijke grafische interface.

Wel kreeg ik een foutmelding: Internal error failed to initialize HAL.
Dit zegt mij niet zoveel, maar ik kon 'm wegklikken.

Echter na rebooten en in normale mode opstarten was het resultaat wederom een zwart beeld.
In recovery mode opgestart en op de commandprompt starten met sudo /etc/init.d/gdm start geeft mijn monitor de melding: Cannot display this vidio mode, change computer display input to 1280x1024@60Hz. Kan echter het OSD menu van de monitor niet oproepen.

Het bestuderen van de xorg.conf liet een forse uitbreiding van gegevens zien, waarvan een extract volgt:

Section "Device"
  Identifier "Failsafe Device"
  Boardname ÄTI Radeon (vesa)"
  Busid "PCI:3:0:0
  Driver "vesa"
  Screen 0
  Vendorname "ATI"
EndSection

Section "Monitor"
  Identifier "Failsafe Monitor"
  Vendorname "Philips"
  Modelname "Philips 170C5 (17inch)"
  Horizsinc 30.0-82.0
  Vertrefresh 56.0-76.0
  modeline "1280.1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsnc +vsync
  gamma 1.0
EndSection

(Modeline regels staan er zeer veel in; heb er een als voorbeeld bijgezet).

Section "Screen"
   Identifier       "Default Screen"
   Device           "Failsafe Device"
   Monitor          "Failsafe Monitor"
   DefaultDepth  24
  SubSection "Display"
    Depth 24
    Virtual 1600 1200
    Modes "1280x1024@75"
  EndSubSection
EndSection

Er staan tal van modes genoemd in de subsection; heb er als voorbeeld een opgenomen.

Heb het vermoeden dat nu een andere resolutie (> 1280x1024) wordt aangestuurd.
Morgen verder - suggesties natuurlijk altijd welkom.

Groet,

Eric

Dataking

  • Gast
Live CD booten resulteert in zwart scherm.
« Reactie #12 Gepost op: 2008/01/12, 09:19:58 »
Ik heb hier ongveer het zelfde probleem.

Als ik kies voor start en install unbuntu dan gaat alles goed het laaste dat er op komt is Running local boot script [ok]
Daarna krijg ik paar keer het signaal van dat er geen output is van mijn videokaart.(Ati Radeon x1600)dus het probleem komt meer voor bij ati denk ik.

volledige systeem: cpu: Amd athlon 64 x2 6000+
                          mem: 3 GIG ddr2
                            vga: ATI Radeon x1600

en dan komt er op dat de grafische server 6 keer is uit gevallen de laaste 90 sec.

ik heb jullie advies van hier boven gelezen maar ik weet niet goed waar ik het moet typen.

bv.dpkg reconfigre phigh xserver xorg
waar moet ik het ergens typen.

ik ken wel wat van windows maar ubuntu is volledig nieuw voor mij.
en ik zou graag van windows van af zijn.

Offline siegi

  • Lid
  • Steunpunt: Nee
Live CD booten resulteert in zwart scherm.
« Reactie #13 Gepost op: 2008/01/12, 11:46:41 »
Toepassingen hulpmiddelen > Terminal venster
En doe het commando aub copy paste.  Want 1 teken is al snel vergeten.

Offline Maarten123

  • Lid
  • Steunpunt: Nee
Live CD booten resulteert in zwart scherm.
« Reactie #14 Gepost op: 2008/01/12, 13:10:29 »
Na het opstarten van Ubuntu:

met CRTL+ALT en F2 kom je in een scherm waar je je opnieuw moet aanmelden.

login: je gebruikersnaam
password: je wachtwoord

vervolgens type je:

sudo dpkg-reconfigure xserver-xorg

nu kun je de Xserver opnieuw configureren

Je kunt de meeste instellingen zo laten zoals wordt voorgesteld.
Kijk m.n. goed naar de instellingen van de grafische kaart (evt. Vesa proberen) en de resolutie van je beeldscherm.
Nadat je hebt opgeslagen, kun je met CTRL+ALT en DEL opnieuw opstarten.

Let wel: het blijft wtt experimenteren wat voor jou/jullie het beste is.

EricM

  • Gast
Live CD booten resulteert in zwart scherm.
« Reactie #15 Gepost op: 2008/01/12, 14:52:22 »
Dataking: Begrijp niet helemaal of je al een geinstalleerd systeem hebt of niet?

Mocht je nog met de installatieprocedure worstelen installeer dan vanaf de alternative CD. Lees echter bijbehorende documentatie.

Als je wel al een geinstalleerd systeem hebt maar geen grafische interface, dan kun je in de veilige modus opstarten.
Nadat deze is opgestart sta je op een commandprompt. Vanaf hier kun je de commando's ingeven. LET OP! Linux is hoofdlettergevoelig!  
Vanaf de commandprompt type je: sudo nano /etc/X11/xorg.conf
Dan kom je in een configuratiebestand voor de nodige IO devices.
In dit bestand enige zaken veranderen.
Gandyman adviseerde onder de section Device toe te voegen: Boardname       "vesa"
Bij mij werkte dit nog niet. Heb toen geprobeerd met:   Driver            "vesa" (of Vesa dat weet ik niet meer)

Dit opgeslagen (cntrl+x) en vervolgens met sudo /etc/init.d/gdm start de zaak geinitialiseerd.
Kreeg toen een grafische interface.

Toen ik echter had ge-reboot had ik wederom problemen met de grafische mode.
Mocht je dit overkomen, dan moet je weer in veilig modus opstarten.
Dan doe je dir  /etc/X11/xorg.conf*
Dan zie je meerdere xorg.conf bestanden staan met een datum tijdstempel: xorg.confYMDHMSMs
Dit zijn je oude bestanden /etc/X11/xorg.conf die je evt. weer kunt hernoemen bewerken
Zo zul je wat moeten experimenteren. Succes

Dataking

  • Gast
Live CD booten resulteert in zwart scherm.
« Reactie #16 Gepost op: 2008/01/12, 17:50:02 »
Ik heb het systeem nog niet kunnen instaleren op men schijf dus daar zit ik een beetje vast.
Sorry dit had ik moeten vermelden.

Dataking

  • Gast
Live CD booten resulteert in zwart scherm.
« Reactie #17 Gepost op: 2008/01/13, 21:19:41 »
Heeft niemand een idee hoe ik het moet oplossen? Want ik zou echt graag ubuntu willen hebben.

Offline Dominique Ramaekers

  • Lid
  • Steunpunt: Nee
Live CD booten resulteert in zwart scherm.
« Reactie #18 Gepost op: 2008/01/13, 21:36:47 »
Download de alternate CD. Hiermee kan je ubuntu installeren.

Als je na de installatie de computer herstart, zal uw scherm waarschijnlijk ook nog altijd niet in orde zijn. Dus volg dan post nr 15 van Maarten123. Bij 'sudo dpkg-reconfigure xserver-xorg' laat je al de voorgestelde keuzes (zoals ook Maarten123 voorstelt).

Als bij het herstarten nog niet werk, doe je 'sudo dpkg-reconfigure xserver-xorg' opnieuw maar kies je voor grafische driver 'vesa'. Die zou moeten werken.

Als dat lukt, kan je op zoek gaan naar een beter oplossing.

Laat maar iets weten wat het resultaat is...

Dataking

  • Gast
Live CD booten resulteert in zwart scherm.
« Reactie #19 Gepost op: 2008/01/14, 17:39:51 »
OK zal het proberen.
Bedankt.

EricM

  • Gast
Live CD booten resulteert in zwart scherm.
« Reactie #20 Gepost op: 2008/01/14, 23:26:53 »
Heb een driver proberen te installeren voor mijn videocard ATI Radeon X700 series; niet echt succesvol door een aantal fouten gemaakt door mijzelf. Verder niet ter zake.
Uiteindelijk weer een schone installatie uitgevoerd.
Section "Device" in Configuratiebestand  /etc/X11/xorg.conf
aangepast:  Driver "vesa"
Vervolgens met sudo /etc/init.d/gdm start de grafische interface kunnen starten. Goed helder beeld.
Echter na een reboot en starten in normale mode krijg ik weer een zwart scherm
Na reboot en starten in recoverymode kan de grafische interface weer worden opgestart zoals eerder gemeld.
Vervolgens de driver geinstalleerd met de Restricted Drivers Manager (System | Administration)
Installatie bleek succesvol te zijn uitgevoerd.
Computer herstart, wederom zwart scherm, wederom moeten starten in recoverymode.
Inspectie leerde dat de restricted driver een status heeft "not in use".

Wend me nu tot hardware en drivers om uit te vinden hoe ik de status kan wijzigen.
Zie post: http://forum.ubuntu-nl.org/topic/20809