Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: fstab bij meerdere gebruikers  (gelezen 1071 keer)

Offline molly w

  • Lid
fstab bij meerdere gebruikers
« Gepost op: 2026/09/13, 16:16:40 »
Ik zit op dit moment voor nood op een systeem met Ubuntu waar ik een van meerdere gebruikers ben. Ik was gewend dat ik de enige gebruiker was, maar de laptop die ik had heeft een opzwellende batterij, dus daar moet ik afscheid van nemen. Alle data stonden al op een NAS, dus die zijn safe.
Nu wil ik middels een fstab-bestand de NAS bereiken. Die is wel bereikbaar via 'Netwerk', maar wanneer ik in een programma een bestand wil openen, lukt dat niet. Ik krijg dan de melding dat het gevraagde bestand niet bestaat. Nee, het bestaat inderdaad niet in mijn eigen profiel maar elders. Nu moet ik steeds teruggaan naar het netwerk en vandaaruit het benodigde programma aanroepen.
Systeembestanden vind ik ook niet in mijn profiel, alleen een speciale selectie. Fstab staat daar niet bij, noch .cifs waar mijn wachtwoord verstopt staat.

Nu kan ik in de Terminal wel bij het fstab-bestand komen, maar dat werkt niet. Er wordt wel een mountpoint gemaakt, maar als ik wil mounten wordt het mountpoint niet gevonden. Ik krijg het vermoeden dat ik IN mijn profiel een fstab moet maken. Dus een folder "etc" maken en daarin het fstab plaatsen.  Zie ik dat goed?
En moet dat dan perse in de Terminal of kan dat ook de grafische omgeving?

Offline vanadium

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #1 Gepost op: 2026/09/13, 16:25:18 »
Er is slechts één fstab bestand op je computer. Het is /etc/fstab, en werkt systeembreed. Het dient om automatisch tijdens de opstart een opslagmedium of een netwerkverbinding tot stand te brengen. Anders kan je dat doen door in bestandsbeheer de verbinding te maken.

Ik kan uit je uitleg niet opmaken wat wel en wat niet werkt. Als ik het goed begrijp, kan je de bestanden op de NAS zien in bestandsbeheer. Als je die dan opent door dubbel te klikken in bestandsbeheer, wat gebeurt er dan? En welk soort bestanden probeer je te openen?

Offline MKe

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #2 Gepost op: 2026/09/13, 16:25:40 »
Geen idee wat je bedoeld met “mijn profiel”.
De vraag is eerst, welk protocol gebruik je om de NAS te delen, is dat smb of nfs?

Als je het bestand wel kan zien, maar niet openen, heb je een rechten probleem.

Offline molly w

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #3 Gepost op: 2026/09/13, 23:29:30 »
Als ik in bestandsbeheer een bestand op de NAS aanklik (dubbelklik) wordt het geopend in het bijbeborende programma. Geen enkel probleem, werkt prima.
Maar omgekeerd, eerst het programma oproepen en dan het bestand openen lukt niet: " Niets gevonden". Daarom wil ik fstab uitbreiden met de partities op de NAS.

In Terminal heb ik fstab geopend (sudo nano /etc/fstab). Ik kon toen een regel toevoegen en fstab opslaan.
Maar mount -a leverde een foutmelding op: media/obelix.local_documents: mount point does not exist. Hoezo??? Als ik met nautilus admin:/// in een grafische omgeving kom zie ik het mountpoint wel degelijk in media staan. Wat doe ik niet goed?

Offline vanadium

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #4 Gepost op: 2026/09/14, 09:54:55 »
Maar omgekeerd, eerst het programma oproepen en dan het bestand openen lukt niet: " Niets gevonden". Daarom wil ik fstab uitbreiden met de partities op de NAS.
We hoorden nog niet over welk programma het gaat, en of het alle programma's betreft. Programma's die als Snap pakket geïnstalleerd zijn, hebben soms geen toegang buiten de home directory, andere dan wel. Het is niet duidelijk of dat de oorzaak kan zijn. Wellicht wel, want het lijkt me dat je met programma's, geïnstalleerd als klassiek .deb pakket, normaal wel toegang moet hebben tot een NAS aangekoppeld met de grafische interface.
In Terminal heb ik fstab geopend (sudo nano /etc/fstab). Ik kon toen een regel toevoegen en fstab opslaan.
Maar mount -a leverde een foutmelding op: media/obelix.local_documents: mount point does not exist. Hoezo??? Als ik met nautilus admin:/// in een grafische omgeving kom zie ik het mountpoint wel degelijk in media staan. Wat doe ik niet goed?
We zien de lijn niet die je hebt toegevoegd in fstab, dus daar is weinig over te zeggen. Een mountpoint als "media/obelix.local_documents" is een relatief pad, dus dat kan niet werken in fstab.

Offline molly w

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #5 Gepost op: 2026/09/14, 10:29:57 »
We hoorden nog niet over welk programma het gaat, en of het alle programma's betreft. Programma's die als Snap pakket geïnstalleerd zijn, hebben soms geen toegang buiten de home directory, andere dan wel. Het is niet duidelijk of dat de oorzaak kan zijn. Wellicht wel, want het lijkt me dat je met programma's, geïnstalleerd als klassiek .deb pakket, normaal wel toegang moet hebben tot een NAS aangekoppeld met de grafische interface.
In eerste instantie gaat het om programma' s als Libre Office. Deze stond al in het overzicht van alle app's. Of dat ' snap'  is of niet, dat weet ik niet. Zoals gezegd, deze Libre Office oproepen door dubbelklik op een office-bestand op de NAS gaat probleemloos. Dat bestand kan ik gewoon bewerken en opslaan.

Citaat
We zien de lijn niet die je hebt toegevoegd in fstab, dus daar is weinig over te zeggen. Een mountpoint als "media/obelix.local_documents" is een relatief pad, dus dat kan niet werken in fstab.
Deze lijn heb ik toegevoegd:
#OBELIX DOCUMENTS
//192.168.2.27/documents        media/obelix.local_documents    cifs    vers=3,redentials=/root/.cifs/credential_AFMW,iocharset=utf8,uid=1000,     0       0
Log ik in met nautilus admin:///
dan zie in 'Media' de map 'obelix.local_documents' staan, maar de map is leeg.

Waarom dan ' mount -a' meldt dat 'obelix.local_documents' niet bestaat, begrijp ik niet. Kun je me dat uitleggen?

Hieronder wat 'mount -a' meldt. (ik stond al in de map ' /etc'.)
Intussen had ik de fstab compleet gemaakt. De credentials staan ook op de aangegeven plaats.
afmwiegerinck@fwiegerinck-thinkpad:/etc$ mount -a
mount: media/obelix.local_documents: mount point does not exist.
       dmesg(1) may have more information after failed mount system call.
mount: (hint) your fstab has been modified, but systemd still uses
       the old version; use 'systemctl daemon-reload' to reload.
mount: /media/obelix.local_documents-prive: mount point does not exist.
       dmesg(1) may have more information after failed mount system call.
mount: /media/obelix.local_film: mount point does not exist.
       dmesg(1) may have more information after failed mount system call.
mount: /media/obelix.local_video: mount point does not exist.
       dmesg(1) may have more information after failed mount system call.
mount: /media/obelix.local_photo: mount point does not exist.
       dmesg(1) may have more information after failed mount system call.
mount: /media/obelix.local_music: mount point does not exist.
       dmesg(1) may have more information after failed mount system call.

Kijk ik (via admin:///) in 'media', dan zie maar 1 map staan, nl obelix.local_documents . De nieuwe regels zijn niet toegevoegd aan /media. Waarom niet?
« Laatst bewerkt op: 2026/09/14, 11:19:59 door molly w »

Offline vanadium

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #6 Gepost op: 2026/09/14, 14:39:00 »
In eerste instantie gaat het om programma' s als Libre Office. Deze stond al in het overzicht van alle app's. Of dat ' snap'  is of niet, dat weet ik niet. Zoals gezegd, deze Libre Office oproepen door dubbelklik op een office-bestand op de NAS gaat probleemloos. Dat bestand kan ik gewoon bewerken en opslaan.
Kijk eens in de Software Store naar LibreOffice: daar kan je zien of het pakket als snap of als gewoon pakket geïnstalleerd is. Als je LO zelf hebt geïnstalleerd, zal het wellicht als snap zijn.

Deze lijn heb ik toegevoegd:
#OBELIX DOCUMENTS
//192.168.2.27/documents        media/obelix.local_documents    cifs    vers=3,redentials=/root/.cifs/credential_AFMW,iocharset=utf8,uid=1000,     0       0
Wellicht zal de map gevonden worden als je hier "/media/obelix.local_documents" van maakt. Dan is het een absoluut pad, wat aangeeft hoe je vanaf de bovenste map (root of /) bij de map komt.

Een computer vereist stipheid: "redentials" zal wellicht "credentials" moeten worden.

Alhoewel dat wellicht geen probleem is, zou ik de comma na de laatste optie ("uid=1000") weglaten.

[/code] dan zie in 'Media' de map 'obelix.local_documents' staan, maar de map is leeg.
Je bedoelt ongetwijfeld "media", niet "Media". Voor Linux zijn dat verschillende namen. Wat je aangeeft, laat vermoeden dat je inderdaad wel degelijk de map "/media/obelix.local_documents" hebt.

Probeer eens of het aankoppelen nu wel lukt.

Offline peer

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #7 Gepost op: 2026/09/14, 17:06:04 »
hieer een voorbeeldregel uit mijn fstab waarin ik mijn NAS aankoppel. Dit werkt prima.
#synology
192.168.2.5:/volume1/data    /data/synology   nfs auto,nofail,noatime,nolock,intr,tcp,actimeo=1800 0 0
Ik gebruik nfs ipv cifs dus dat gedeelte is anders.

Achter mijn ip-adres staat een dubbele punt en dan de directory op de NAS: 192.168.2.5:/volume1/data
De twee slashes: // staan er bij mij niet in
Ik had eerst problemen met  het vinden van het pad van de de directory op de NAS.  In de filemanager van de NAS zie ik wel de directory 'data' maar niet de daarbovenliggende directory 'volume1'. En ik moet het volledige pad gebruiken anders wordt de directory niet gevonden.

En ook in de aankoppeldirectory op mijn pc gebruik ik het volledige pad: /data/synology

Op je NAS zul je waarschijnliijk ook de rechten moeten regelen anders krijg je ook een lege directory.

Offline molly w

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #8 Gepost op: 2026/09/14, 17:14:17 »
ja, die kleine foutjes.
Bij het opnieuw opstarten van de laptop verschenen ineens 5 (van de 6) ikoontjes van de partities van de NAS op het bureaublad. Hoi, dacht ik. Dat werkt. Ik miste alleen de eerste van obelix.local_documents. Maar het ontbrekende / voor media bleek de oorzaak.

Maar dan ...
Wanneer ik op die ikoontjes klik, krijg ik melding dat ik daarvoor superuser moet zijn. Klopt dat en hoe wordt ik superuser telkens als ik inlog als gebruiker - dus wanneer ik de laptop heb gestart?
Het zal daar wel mee samenhangen, maar als ik bijv. Libre Office Writer start en klik op menu File-Open en kies een bestaand bestand, is de melding dat het niet bestaat. En ook staan de partities op de NAS niet vermeld in het Open File menu.

Hier het antwoord van de Terminal op mount -a. ook daarin staat dat ik superuser moet zijn.
afmwiegerinck@fwiegerinck-thinkpad:/etc$ mount -a
mount: /media/obelix.local_documents: must be superuser to use mount.
       dmesg(1) may have more information after failed mount system call.
mount: (hint) your fstab has been modified, but systemd still uses
       the old version; use 'systemctl daemon-reload' to reload.
mount: /media/obelix.local_documents-prive: must be superuser to use mount.
       dmesg(1) may have more information after failed mount system call.
mount: /media/obelix.local_film: must be superuser to use mount.
       dmesg(1) may have more information after failed mount system call.
mount: /media/obelix.local_video: must be superuser to use mount.
       dmesg(1) may have more information after failed mount system call.
mount: /media/obelix.local_photo: must be superuser to use mount.
       dmesg(1) may have more information after failed mount system call.
mount: /media/obelix.local_music: must be superuser to use mount.
       dmesg(1) may have more information after failed mount system call.

Offline vanadium

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #9 Gepost op: 2026/09/15, 15:00:30 »
Waarom voeg je ter controle niet je huidige fstab lijn toe aan je post? Misschien zit er nog steeds een fout in.

Als je ook als gebruiker wil kunnen aankoppelen en ontkoppelen, voeg je ook de optie "user" toe.

Offline molly w

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #10 Gepost op: 2026/09/16, 13:54:18 »
Als het zo eenvoudig zou zijn: 'user' toevoegen aan de regel ...
De vraag is: waar? Heb even gezocht op internet, toen in de regel achteraan deze term toegevoegd ... Dat werkte niet.
Hier een regel:
//192.168.2.27/documents        /media/obelix.local_documents   cifs    vers=3.0,credentials=/root/.cifs/credential_AFMW,iocharset=utf8,uid=1000,gid=1000       0       0

Ik heb ook zitten denken aan het bewerken van de rechten van /media/documents en de andere. Dat lukte niet.
« Laatst bewerkt op: 2026/09/16, 14:01:17 door molly w »

Offline vanadium

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #11 Gepost op: 2026/09/16, 14:53:51 »
Deel vier zijn de opties, dus je voegt dat daar toe:
… vers=3.0,credentials=/root/.cifs/credential_AFMW,iocharset=utf8,uid=1000,gid=1000,user …

Offline molly w

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #12 Gepost op: 2026/09/16, 19:09:06 »
Deel vier zijn de opties, dus je voegt dat daar toe:
… vers=3.0,credentials=/root/.cifs/credential_AFMW,iocharset=utf8,uid=1000,gid=1000,user …

hmm
lukt nog niet.
    zo staat het er nu:
//192.168.2.27/documents        /media/obelix.local_documents   cifs    vers=3.0,credentials=/root/.cifs/credential_AFMW,iocharset=utf8,uid=1000,gid=1000,user  0       0

Dat levert het volgende op:
In de grafische omgeving:r ' read only (zie bijlage)
In de terminal:
afmwiegerinck@fwiegerinck-thinkpad:/etc$ mount -a
mount: /media/obelix.local_documents: must be superuser to use mount.
       dmesg(1) may have more information after failed mount system call.

Waarom ik dit nu graag in orde wil hebben ...?
  • vanuit een programma bij de bestanden op de NAS kunnen om te openen. Dat kan nu niet, de bestanden op de NAS worden door het prpgramma niet gezien
  • ik kan nu een nieuw bestand niet op de NAS opslaan, de NAS wordt niet gezien.
Nu moeten zulke acties steeds via de omweg van mijn eigen mappen op de laptop
« Laatst bewerkt op: 2026/09/16, 19:44:42 door molly w »

Offline vanadium

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #13 Gepost op: 2026/09/17, 08:58:42 »
Je moet "mount -a" uitvoeren met administrator bevoegdheden, dat wil zeggen: met "sudo" ervoor:

sudo mount -a
Je zal gevraagd worden om je gebruikerspaswoord. Als het commando geen output geeft, dan is het gelukt.

Offline aartje

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #14 Gepost op: 2026/09/17, 11:32:48 »
Verder vraag  ik me af of er wel beseft wordt dat alle files en directories
vanaf het mountpunt een uid en gid hebben van 1000 (zie entry in de fstab).....
Heeft de TS dat ook ?
« Laatst bewerkt op: 2026/09/17, 11:34:57 door aartje »

Offline molly w

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #15 Gepost op: 2026/09/17, 14:07:59 »
Verder vraag  ik me af of er wel beseft wordt dat alle files en directories
vanaf het mountpunt een uid en gid hebben van 1000 (zie entry in de fstab).....
Heeft de TS dat ook ?
Yess, dat heeft ie. Ik heb deze regels zelf geschreven voor een Ubuntu installatie op een andere laptop. Zie mijn start

Offline molly w

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #16 Gepost op: 2026/09/17, 14:13:33 »
Je moet "mount -a" uitvoeren met administrator bevoegdheden, dat wil zeggen: met "sudo" ervoor:

sudo mount -a
Je zal gevraagd worden om je gebruikerspaswoord. Als het commando geen output geeft, dan is het gelukt.

Twee opmerkingen:
  • Hoe gaat het dan als ik de laptop start? Moet ik dan elke keer eerst naar de terminal om "toestemming te vragen"?
sudo mount -aleverde het volgende op:
fmwiegerinck@fwiegerinck-thinkpad:/etc$ sudo mount -a
mount: /media/obelix.local_documents: cannot mount //192.168.2.27/documents read-only.
    Dit lukt dus niet. Het is hetzelfde als ik de destop het station aanklik; read-only.
    Is het een syntaxiskwestie in de regel in fstab? Of is het rechtenkwestie in /media?
    [/li]
« Laatst bewerkt op: 2026/09/17, 14:19:28 door molly w »

Offline vanadium

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #17 Gepost op: 2026/09/17, 15:32:22 »
Die foutmelding is op zich weinig behulpzaam: die wijst erop dat zelfs een read-only mount niet lukte, maar geeft geen aanduiding van waarom dat niet lukt.

Anders gezegd, er kunnen allerlei oorzaken zijn. Wat meer informatie kan geven, is de kernel uitvoer.

Probeer nog eens te mounten
sudo mount -a
en kijk onmiddellijk daarna naar de kernel output:
sudo dmesg | tail -n 50

Offline molly w

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #18 Gepost op: 2026/09/17, 19:22:36 »
output van sudo dmesg | tail -n 50afmwiegerinck@fwiegerinck-thinkpad:/etc$ sudo dmesg | tail -n 50
[  981.929582] CIFS: VFS: \\192.168.2.27 failed to create a new SMB session with Unknown: -13
[  981.929601] CIFS: VFS: cifs_mount failed w/return code = -13
[  981.929711] CIFS: enabling forceuid mount option implicitly because uid= option is specified
[  981.929714] CIFS: enabling forcegid mount option implicitly because gid= option is specified
[  981.929717] CIFS: Attempting to mount //192.168.2.27/documents-prive
[  981.990903] CIFS: Status code returned 0xc000006d STATUS_LOGON_FAILURE
[  981.990912] CIFS: VFS: \\192.168.2.27 failed to create a new SMB session with Unknown: -13
[  981.990924] CIFS: VFS: cifs_mount failed w/return code = -13
[  981.992265] CIFS: enabling forceuid mount option implicitly because uid= option is specified
[  981.992269] CIFS: enabling forcegid mount option implicitly because gid= option is specified
[  981.992271] CIFS: Attempting to mount //192.168.2.27/film
[  982.053358] CIFS: Status code returned 0xc000006d STATUS_LOGON_FAILURE
[  982.053372] CIFS: VFS: \\192.168.2.27 failed to create a new SMB session with Unknown: -13
[  982.053389] CIFS: VFS: cifs_mount failed w/return code = -13
[  982.053494] CIFS: enabling forceuid mount option implicitly because uid= option is specified
[  982.053497] CIFS: enabling forcegid mount option implicitly because gid= option is specified
[  982.053499] CIFS: Attempting to mount //192.168.2.27/film
[  982.114267] CIFS: Status code returned 0xc000006d STATUS_LOGON_FAILURE
[  982.114280] CIFS: VFS: \\192.168.2.27 failed to create a new SMB session with Unknown: -13
[  982.114297] CIFS: VFS: cifs_mount failed w/return code = -13
[  982.115921] CIFS: enabling forceuid mount option implicitly because uid= option is specified
[  982.115927] CIFS: enabling forcegid mount option implicitly because gid= option is specified
[  982.115931] CIFS: Attempting to mount //192.168.2.27/video
[  982.175861] CIFS: Status code returned 0xc000006d STATUS_LOGON_FAILURE
[  982.175871] CIFS: VFS: \\192.168.2.27 failed to create a new SMB session with Unknown: -13
[  982.175889] CIFS: VFS: cifs_mount failed w/return code = -13
[  982.176032] CIFS: enabling forceuid mount option implicitly because uid= option is specified
[  982.176036] CIFS: enabling forcegid mount option implicitly because gid= option is specified
[  982.176039] CIFS: Attempting to mount //192.168.2.27/video
[  982.235252] CIFS: Status code returned 0xc000006d STATUS_LOGON_FAILURE
[  982.235268] CIFS: VFS: \\192.168.2.27 failed to create a new SMB session with Unknown: -13
[  982.235290] CIFS: VFS: cifs_mount failed w/return code = -13
[  982.237606] CIFS: enabling forceuid mount option implicitly because uid= option is specified
[  982.237613] CIFS: enabling forcegid mount option implicitly because gid= option is specified
[  982.237617] CIFS: Attempting to mount //192.168.2.27/photo
[  982.295088] CIFS: Status code returned 0xc000006d STATUS_LOGON_FAILURE
[  982.295102] CIFS: VFS: \\192.168.2.27 failed to create a new SMB session with Unknown: -13
[  982.295122] CIFS: VFS: cifs_mount failed w/return code = -13
[  982.295257] CIFS: enabling forceuid mount option implicitly because uid= option is specified
[  982.295261] CIFS: enabling forcegid mount option implicitly because gid= option is specified
[  982.295263] CIFS: Attempting to mount //192.168.2.27/photo
[  982.352866] CIFS: Status code returned 0xc000006d STATUS_LOGON_FAILURE
[  982.352888] CIFS: VFS: \\192.168.2.27 failed to create a new SMB session with Unknown: -13
[  982.352922] CIFS: VFS: cifs_mount failed w/return code = -13
[  982.356839] CIFS: enabling forceuid mount option implicitly because uid= option is specified
[  982.356851] CIFS: enabling forcegid mount option implicitly because gid= option is specified
[  982.419869] CIFS: Status code returned 0xc000006d STATUS_LOGON_FAILURE
[  982.420187] CIFS: enabling forceuid mount option implicitly because uid= option is specified
[  982.420198] CIFS: enabling forcegid mount option implicitly because gid= option is specified
[  982.500558] CIFS: Status code returned 0xc000006d STATUS_LOGON_FAILURE

Offline aartje

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #19 Gepost op: 2026/09/18, 10:14:59 »
Verder vraag  ik me af of er wel beseft wordt dat alle files en directories
vanaf het mountpunt een uid en gid hebben van 1000 (zie entry in de fstab).....
Heeft de TS dat ook ?
Yess, dat heeft ie. Ik heb deze regels zelf geschreven voor een Ubuntu installatie op een andere laptop. Zie mijn start
En heb je op beide  laptops dezelfde uid en guid ? Daar kun je bv achterkomen door een
"grep $USER /etc/passwd" te doen op beide laptops (sorry, het is maar een suggestie)

Offline vanadium

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #20 Gepost op: 2026/09/18, 11:21:43 »
CIFS: Status code returned 0xc000006d STATUS_LOGON_FAILURE
CIFS: VFS: \\192.168.2.27 failed to create a new SMB session with Unknown: -13
CIFS: VFS: cifs_mount failed w/return code = -13
Dit wijst erop dat de server je login niet aanvaard. Check dus het credentials bestand.

Offline molly w

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #21 Gepost op: 2026/09/18, 13:14:25 »
Citaat
En heb je op beide  laptops dezelfde uid en guid ? Daar kun je bv achterkomen door een
"grep $USER /etc/passwd" te doen op beide laptops (sorry, het is maar een suggestie)
Terminal meldt hierop:
afmwiegerinck@fwiegerinck-thinkpad:/etc$ grep $USER /etc/passwd
afmwiegerinck:x:1004:1004:Guus Wiegerinck:/home/afmwiegerinck:/bin/bash
NB ' afmwiegerinck' is ROOD lettertype. Betekent dit een conflict? Want mijn inlognaam is Guus Wiegerinck (Het was niet ik die deze naam als gebruiker heeft opgegeven)
« Laatst bewerkt op: 2026/09/18, 13:35:13 door molly w »

Offline molly w

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #22 Gepost op: 2026/09/18, 13:25:08 »
CIFS: Status code returned 0xc000006d STATUS_LOGON_FAILURE
CIFS: VFS: \\192.168.2.27 failed to create a new SMB session with Unknown: -13
CIFS: VFS: cifs_mount failed w/return code = -13
Dit wijst erop dat de server je login niet aanvaard. Check dus het credentials bestand.

Dat bestand heb ik gezet in /root/.cifs. Daar staat het ook op de andere laptop.
Dat doe ik via dit:
afmwiegerinck@fwiegerinck-thinkpad:~$ nautilus admin:///
** Message: 13:20:23.755: Connecting to org.freedesktop.Tracker3.Miner.Files

Even terzijde:
Wanneer ik in de Terminal naar het credentialsbestand wil gaan, lukt me dat niet
afmwiegerinck@fwiegerinck-thinkpad:~$ sudo cd /root/.cifs
sudo: 'cd': command not found
afmwiegerinck@fwiegerinck-thinkpad:~$ cd /root/.cifs
bash: cd: /root/.cifs: Toegang geweigerd
Zet ik er sudo voor dan werkt commando cd niet, laat ik sudo weg, dan kom ik er niet in. Wat doe ik niet goed?
« Laatst bewerkt op: 2026/09/18, 13:36:13 door molly w »

Offline vanadium

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #23 Gepost op: 2026/09/18, 14:53:42 »
Het kan een fout zijn in het credentials bestand; typfout van naam of paswoord, of verkeerd formaat. Probeer eens rechtstreeks aan te koppelen met volgende commando:

sudo mount -t cifs //192.168.2.27/documents  /media/obelix.local_documents  -o username=myuser,password=mypassword,vers=3.0
waarbij je myuser en mypassword vervangt door je gebruikersnaam en paswoord.

Lukt dat, dan weet je dat het aan je credentials bestand ligt. Lukt dat ook niet, dan is er iets met je logon op die server (lijkt mij minder waarschijnlijk, want je kan erop met bestandsbeheer).

Offline molly w

  • Lid
Re: fstab bij meerdere gebruikers
« Reactie #24 Gepost op: 2026/09/18, 17:01:47 »
Het kan een fout zijn in het credentials bestand; typfout van naam of paswoord, of verkeerd formaat. Probeer eens rechtstreeks aan te koppelen met volgende commando:

sudo mount -t cifs //192.168.2.27/documents  /media/obelix.local_documents  -o username=myuser,password=mypassword,vers=3.0
waarbij je myuser en mypassword vervangt door je gebruikersnaam en paswoord.


Ja, gedaan. gebruikersnaam en wachtwoord ingevuld waarmee in inlog als ik de laptop start.
Terminal antwoordde:
mount: onjuist gebruik
Typ 'mount --help' voor meer informatie.

Daarna gebruikersnaam en wachtwoord (= voor de NAS) uit de credentials ingevuld
Terminal antwoordde niets. Geen foutmelding, geen bevestiging.
afmwiegerinck@fwiegerinck-thinkpad:~$

een derde variant:
Ipv van de gebruikersnaam uit de credentials heb ik de naam gebruikt zoals in  afmwiegerinck@fwiegerinck-thinkpad: staat.
Dit was het resultaat:mount: /media/obelix.local_documents: kan //192.168.2.27/documents niet aankoppelen voor alleen-lezen.
       dmesg(1) may have more information after failed mount system call.

Mijn voorzichtige conclusie is dat ik als gebruikersnaam in de credentials die laatste versie moet nemen. Hoewel er nog steeds niet aangekoppeld wordt en dan ook nog 'alleen lezen'. En hoewel met de huidige gebruikersnaam in de credentials de output hetzelfde is: kan niet aankoppelen voor alleen-lezen
« Laatst bewerkt op: 2026/09/18, 17:19:24 door molly w »