Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Opruim commando's  (gelezen 392 keer)

Offline HWE64

  • Lid
  • Steunpunt: Nee
Opruim commando's
« Gepost op: 2021/08/12, 11:52:15 »
Misschien hoort dit draadje hier niet thuis maar dan moet men hem maar verplaatsen.
Mijn vraag; wanneer gebruik je het commando: sudo apt-get clean en wanneer: sudo apt-get autoremove en is dit wel nodig want als een programma met Synaptic verwijder dan verwijder je toch automatisch ook de hulpprogramma's. Wie kan mij duidelijkheid geven.
Niet panikeren, er is een Ubuntuforum.

1] Linux Mint 20.2Xfce (Desktop hoofd pc). 2] Linux Mint 20.2 Xfce/Xubuntu 20.04.2 LTS (Clevo Laptop ). 3] Xubuntu 20.04.2 LTS/Linux Mint 20.2 Xfce (HP Desktop test pc).  4] W10 (Dell Desktop). 5] Linux Mint 20.2 Xfce/Xubuntu 20.04.2 LTS (Toshiba Testlaptop)

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: Opruim commando's
« Reactie #1 Gepost op: 2021/08/12, 12:30:48 »
Met sudo apt clean verwijder je files die gedownload zijn om iets te kunnen installeren (of een upgrade uit te voeren).
Met sudo apt autoremove verwijder je verweesde files, die heb je vaak, synaptic verwijderd niet alles voor 100%.

Dit is voor zover ik het heb begrepen, mij verbeteren is nuttig, dan leer ik weer iets bij :lol:
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een Dwarsligger uit 0166
Er is ook nog een andere hobby.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Opruim commando's
« Reactie #2 Gepost op: 2021/08/12, 12:32:48 »
(Ron was mij weer voor  =D)

"sudo apt clean" verwijdert gedownloade .deb installatiebestanden (onder /var/cache/apt)

"sudo apt autoremove" verwijdert automatisch geinstalleerde afhankelijkheden, die, na het verwijderen van software, door geen enkel ander programma meer gebruikt worden.

Ik zie geen instelling in synaptic om bij het verwijderen van een pakket ook automatisch de afhankelijken te verwijderen. Doet hij dus volgens mij niet. In plaats van het autoremove comando, kan je wel de pakketten die "autoremovable" zijn, in één keer oplijsten (categorie in linker kolom) en zo verwijderen.
« Laatst bewerkt op: 2021/08/12, 12:41:18 door vanadium »

Offline HWE64

  • Lid
  • Steunpunt: Nee
Re: Opruim commando's
« Reactie #3 Gepost op: 2021/08/12, 12:40:21 »
@Ron en vanadium, bedankt voor jullie uitleg. Dan kan ik toch nog wat opruimen.
gr. Henk
Niet panikeren, er is een Ubuntuforum.

1] Linux Mint 20.2Xfce (Desktop hoofd pc). 2] Linux Mint 20.2 Xfce/Xubuntu 20.04.2 LTS (Clevo Laptop ). 3] Xubuntu 20.04.2 LTS/Linux Mint 20.2 Xfce (HP Desktop test pc).  4] W10 (Dell Desktop). 5] Linux Mint 20.2 Xfce/Xubuntu 20.04.2 LTS (Toshiba Testlaptop)

Offline HWE64

  • Lid
  • Steunpunt: Nee
Re: Opruim commando's
« Reactie #4 Gepost op: 2021/08/12, 16:50:46 »
Trouwens maakt het nog wat uit als je zoals in de vraag sudo apt-get clean en sudo apt-get autoremove plaatst.

Edit: ben al een uitleg tegengekomen https://linuxhint.com/diff_apt_vs_aptget/
« Laatst bewerkt op: 2021/08/12, 17:06:45 door HWE64 »
Niet panikeren, er is een Ubuntuforum.

1] Linux Mint 20.2Xfce (Desktop hoofd pc). 2] Linux Mint 20.2 Xfce/Xubuntu 20.04.2 LTS (Clevo Laptop ). 3] Xubuntu 20.04.2 LTS/Linux Mint 20.2 Xfce (HP Desktop test pc).  4] W10 (Dell Desktop). 5] Linux Mint 20.2 Xfce/Xubuntu 20.04.2 LTS (Toshiba Testlaptop)

Offline ed-kroket

  • Lid
Re: Opruim commando's
« Reactie #5 Gepost op: 2021/08/16, 09:22:47 »
Misschien hoort dit draadje hier niet thuis maar dan moet men hem maar verplaatsen.
Mijn vraag; wanneer gebruik je het commando: sudo apt-get clean en wanneer: sudo apt-get autoremove en is dit wel nodig want als een programma met Synaptic verwijder dan verwijder je toch automatisch ook de hulpprogramma's. Wie kan mij duidelijkheid geven.

gebruik de volgende 3 schoonmaak commando's:

apt/apt-get clean → cleans the packages and install script in /var/cache/apt/archives/
apt/apt-get autoclean → cleans obsolete deb-packages, less than clean
apt/apt-get autoremove → removes orphaned packages which are not longer needed from

Offline Bloom

  • Lid
  • Steunpunt: Ja
Re: Opruim commando's
« Reactie #6 Gepost op: 2021/08/16, 09:45:42 »
De installatieprocedure verwijdert tegenwoordig inderdaad alle "oude" pakketten als je nieuwe installeert, maar alleen voor programma's die NIET in gebruik zijn. Als er programma's draaien terwijl ze bijgewerkt worden en die niet zomaar herstart kunnen worden (bijvoorbeeld het geval voor alle desktopapplicaties), dan blijven de oude pakketten staan omdat het bijhorende programma nog in het geheugen zit met alle bijhorende bibliotheken. Als je daarna de applicatie afsluit en later weer herstart, zal de nieuwe versie gebruikt worden. Een apt autoremove zal nu de overgebleven oude pakketten kunnen opruimen. Daarom is het eigenlijk geen slecht idee om een 'apt autoremove' in te bouwen in de startuproutines van een desktopsysteem.

Offline HWE64

  • Lid
  • Steunpunt: Nee
Re: Opruim commando's
« Reactie #7 Gepost op: 2021/08/16, 11:19:29 »
Blijf voorlopig "Apt" gebruiken zoals hier in https://linuxhint.com/diff_apt_vs_aptget/ geadviseerd wordt.
Niet panikeren, er is een Ubuntuforum.

1] Linux Mint 20.2Xfce (Desktop hoofd pc). 2] Linux Mint 20.2 Xfce/Xubuntu 20.04.2 LTS (Clevo Laptop ). 3] Xubuntu 20.04.2 LTS/Linux Mint 20.2 Xfce (HP Desktop test pc).  4] W10 (Dell Desktop). 5] Linux Mint 20.2 Xfce/Xubuntu 20.04.2 LTS (Toshiba Testlaptop)

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Opruim commando's
« Reactie #8 Gepost op: 2021/08/16, 11:24:02 »
De installatieprocedure verwijdert tegenwoordig inderdaad alle "oude" pakketten als je nieuwe installeert, maar alleen voor programma's die NIET in gebruik zijn. Als er programma's draaien terwijl ze bijgewerkt worden en die niet zomaar herstart kunnen worden (bijvoorbeeld het geval voor alle desktopapplicaties), dan blijven de oude pakketten staan omdat het bijhorende programma nog in het geheugen zit met alle bijhorende bibliotheken. Als je daarna de applicatie afsluit en later weer herstart, zal de nieuwe versie gebruikt worden. Een apt autoremove zal nu de overgebleven oude pakketten kunnen opruimen. Daarom is het eigenlijk geen slecht idee om een 'apt autoremove' in te bouwen in de startuproutines van een desktopsysteem.
Dat rijmt niet volgens mij.

- Je hebt:  de installatiepakketten (.deb bestanden in /var/cache/apt). Die worden verwijderd door "clean", of "autoclean" voor oude pakketversies. Dit staat helemaal los van de lopende programma's en hun bibliotheken.
- Je hebt:  de geïnstalleerde programmabibliotheken. Die worden verwijderd door "autoremove", enkel indien niet meer in gebruik door enig programma. Als die worden bijgewerkt, dan worden de oude binaire bestanden overschreven.

Het lijkt mij dus niet mogelijk dat de "oude versie" niet wordt gewist als de programmabibliotheek bijgewerkt wordt. Programmabibliotheken worden immers overschreven door nieuwere versies.

Wel kan de oude versie nog in RAM zitten als er programma's aan het lopen zijn, die die bibiotheek gebruiken. En als op een bepaald moment de bibliotheek moet heringelezen worden, dan zal het de nieuwe versie worden, en dat kan dan al dan niet (meestal niet) problemen geven voor het al lopende programma.

Als de installatieprocedure tegenwoordig ook overbodige bibliotheken verwijdert (i.e. autoremove) , dan zal die dat zonder meer doen. Autoremove gebeurt immers (per definitie) nooit als er nog programma's lopen of op de harde schijf staan, die die bibliotheken gebruiken.

Offline Phil II

  • Lid
  • Steunpunt: Nee
Re: Opruim commando's
« Reactie #9 Gepost op: 2021/08/16, 12:17:17 »
 Herneemt in zekere zin al het vorig geposte , ik gebruik nu voor de opruiming van een applicatie en bijhorende pakketten ,  het terminal commando :
sudo apt purge ****** && sudo apt autoremove

neem bvb : VLC

*****@*****-x75vd:~$ sudo apt purge vlc && sudo apt autoremove
[sudo] wachtwoord voor ***** :
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd... Klaar
De statusinformatie wordt gelezen... Klaar
De volgende pakketten zijn automatisch geïnstalleerd en zijn niet langer nodig:
  libaribb24-0 libcddb2 libdvbpsi10 libebml5 libixml10 libmad0 libmatroska7
  libopenmpt-modplug1 libplacebo72 libprotobuf-lite23 libproxy-tools
  libresid-builder0c2a libsdl-image1.2 libsdl1.2debian libsidplay2
  libspatialaudio0 libupnp13 libva-wayland2 libvlc-bin libvlc5 libvlccore9
  libxcb-composite0 libxcb-xv0 vlc-bin vlc-data vlc-l10n
  vlc-plugin-access-extra vlc-plugin-base vlc-plugin-notify vlc-plugin-qt
  vlc-plugin-samba vlc-plugin-skins2 vlc-plugin-video-output
  vlc-plugin-video-splitter vlc-plugin-visualization
Gebruik 'sudo apt autoremove' om ze te verwijderen.
De volgende pakketten zullen VERWIJDERD worden:
  vlc*
0 opgewaardeerd, 0 nieuw geïnstalleerd, 1 te verwijderen en 0 niet opgewaardeerd.
Na deze bewerking zal er 236 kB schijfruimte vrijkomen.
Wilt u doorgaan? [J/n] j

(Database wordt ingelezen ... 294719 bestanden en mappen momenteel geïnstalleerd.)
vlc (3.0.16-1) wordt verwijderd ...
Bezig met afhandelen van triggers voor mailcap (3.69) ...
Bezig met afhandelen van triggers voor desktop-file-utils (0.26-1) ...
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd... Klaar
De statusinformatie wordt gelezen... Klaar
De volgende pakketten zullen VERWIJDERD worden:
  libaribb24-0 libcddb2 libdvbpsi10 libebml5 libixml10 libmad0 libmatroska7
  libopenmpt-modplug1 libplacebo72 libprotobuf-lite23 libproxy-tools
  libresid-builder0c2a libsdl-image1.2 libsdl1.2debian libsidplay2
  libspatialaudio0 libupnp13 libva-wayland2 libvlc-bin libvlc5 libvlccore9
  libxcb-composite0 libxcb-xv0 vlc-bin vlc-data vlc-l10n
  vlc-plugin-access-extra vlc-plugin-base vlc-plugin-notify vlc-plugin-qt
  vlc-plugin-samba vlc-plugin-skins2 vlc-plugin-video-output
  vlc-plugin-video-splitter vlc-plugin-visualization
0 opgewaardeerd, 0 nieuw geïnstalleerd, 35 te verwijderen en 0 niet opgewaardeerd.
Na deze bewerking zal er 75,0 MB schijfruimte vrijkomen.
Wilt u doorgaan? [J/n] j

(Database wordt ingelezen ... 294700 bestanden en mappen momenteel geïnstalleerd
.)
vlc-plugin-base:amd64 (3.0.16-1) wordt verwijderd ...
libaribb24-0:amd64 (1.0.3-2) wordt verwijderd ...
libcddb2 (1.3.2-6+b1) wordt verwijderd ...
libdvbpsi10:amd64 (1.3.3-1) wordt verwijderd ...
libmatroska7:amd64 (1.6.2-1) wordt verwijderd ...
libebml5:amd64 (1.4.2-1) wordt verwijderd ...
libupnp13:amd64 (1:1.8.4-2) wordt verwijderd ...
libixml10:amd64 (1:1.8.4-2) wordt verwijderd ...
libmad0:amd64 (0.15.1b-10) wordt verwijderd ...
libopenmpt-modplug1:amd64 (0.4.11-1) wordt verwijderd ...
vlc-plugin-video-output:amd64 (3.0.16-1) wordt verwijderd ...
libplacebo72:amd64 (2.72.2-1) wordt verwijderd ...
libprotobuf-lite23:amd64 (3.12.4-1) wordt verwijderd ...
libproxy-tools (0.4.17-1) wordt verwijderd ...
libresid-builder0c2a (2.1.1-15+b1) wordt verwijderd ...
libsdl-image1.2:amd64 (1.2.12-12) wordt verwijderd ...
libsdl1.2debian:amd64 (1.2.15+dfsg2-6) wordt verwijderd ...
libsidplay2 (2.1.1-15+b1) wordt verwijderd ...
libspatialaudio0:amd64 (0.3.0+git20180730+dfsg1-2+b1) wordt verwijderd ...
libva-wayland2:amd64 (2.10.0-1) wordt verwijderd ...
vlc-bin (3.0.16-1) wordt verwijderd ...
libvlc-bin:amd64 (3.0.16-1) wordt verwijderd ...
libvlc5:amd64 (3.0.16-1) wordt verwijderd ...
vlc-plugin-visualization:amd64 (3.0.16-1) wordt verwijderd ...
vlc-plugin-access-extra:amd64 (3.0.16-1) wordt verwijderd ...
vlc-plugin-video-splitter:amd64 (3.0.16-1) wordt verwijderd ...
vlc-plugin-skins2:amd64 (3.0.16-1) wordt verwijderd ...
libxcb-composite0:amd64 (1.14-3) wordt verwijderd ...
libxcb-xv0:amd64 (1.14-3) wordt verwijderd ...
vlc-data (3.0.16-1) wordt verwijderd ...
vlc-l10n (3.0.16-1) wordt verwijderd ...
vlc-plugin-notify:amd64 (3.0.16-1) wordt verwijderd ...
vlc-plugin-qt:amd64 (3.0.16-1) wordt verwijderd ...
vlc-plugin-samba:amd64 (3.0.16-1) wordt verwijderd ...
libvlccore9:amd64 (3.0.16-1) wordt verwijderd ...
Bezig met afhandelen van triggers voor libc-bin (2.31-13) ...
Bezig met afhandelen van triggers voor man-db (2.9.4-2) ...
Bezig met afhandelen van triggers voor hicolor-icon-theme (0.17-2) ...
*****@*****-x75vd:~$

grondig ( ? ) opgeruimd staat netjes .
« Laatst bewerkt op: 2021/08/16, 12:22:38 door Phil II »
Debian 11 Bullseye 64-bit stable / Cinnamon
HP LaserJet Pro MFP M130fw