Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Extensies verouderd in FF 55.0.1  (gelezen 516 keer)

Offline HWE64

  • Lid
  • Steunpunt: Nee
Extensies verouderd in FF 55.0.1
« Gepost op: 2017/08/15, 21:42:34 »
Met de komst van de nieuwe FF 55.0.1 veel zijn de extensies verouderd en je kunt ze niet updaten. Wie weet hier een oplossing voor?

P.S. Heeft het misschien hiermee iets mee te maken? https://forum.ubuntu-nl.org/index.php?topic=102135.msg1000861#msg1000861 Later pas gevonden.
« Laatst bewerkt op: 2017/08/15, 22:04:52 door HWE64 »
Niet panikeren, er is een Ubuntuforum.

Desktop pentium 4, 4GB, dualboot Xubuntu 16.04 LTS /W10 .  Laptop Toshiba Satallite C855 I5, 8GB, Xubuntu 16.04 LTS . Desktop HP Compaq DC5750 AMD64, AMD Athlon X64 X2  2,1GHz RAM 3GB HDD 80GB, Test PC, Xubuntu 16.04 LTS/Linux Mint 18.2 Xfce (beginneling)

Offline kuifje09

  • Lid
Re: Extensies verouderd in FF 55.0.1
« Reactie #1 Gepost op: 2017/08/15, 22:07:57 »
Tja, een eeuwige wedstrijd lijkt het wel...

Is het in dit geval ook niet domweg even wachten of er een nieuwe versie van de extentie uitkomt?
Gaat meestal wel vanzelf dacht ik zo.
Maar, er kan er ook zomaar nooit meer ondersteund worden...

n.b. ik zit hier nog op FF 52 zie ik, dus even zo laten maar ...

Offline spievensterke

  • Lid
  • Steunpunt: Nee
Re: Extensies verouderd in FF 55.0.1
« Reactie #2 Gepost op: 2017/08/15, 22:12:55 »
@ HWE64,

Heb dit ook opgemerkt, bij de extentie van eID Belgium, dat deze als verouderd stond aangestipt, na de recente update van FF.

Blijkt nu, dat dit het nieuwe beveiligingsbeleid is van Mozilla voor Firefox.
Alles wat niet up-to-date is wordt aangemerkt als verouderd.
En ik weet ook niet hoe dit opgelost, gewijzigd, veiliger kan. Updaten...??? Sandbox ...??? Firejaill ...???
Andere browser gebruiken ...???  het wordt ons wat lastig gemaakt en het brengt ook wat onzekerheid mee...

Het zal bij de volgende punt-versie van Firefox nog strenger zijn. ...
« Laatst bewerkt op: 2017/08/15, 22:29:59 door spievensterke »
Testlaptop Toshiba Satellite L500-1C7> Hdd1:  Ubuntu 16.04.3 LTS -64bit- in dualboot met PCLinuxOS64-Kde5- / Hdd2: LinuxMint Maté 18.2 -64bit- in dualboot met LinuxMint64- Cinnamon- 18.2  >  Intel Mobile Video /
AcerOne10  ( Hybride, 2 in 1 ) met Ubuntu 16.04.3 LTS -64bit- 32bit Uefi.

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Extensies verouderd in FF 55.0.1
« Reactie #3 Gepost op: 2017/08/15, 22:21:54 »
Een tijd geleden was dit ook, alles werd aangemerkt als onveilig en uitgezet.
Dit kon je toen overbruggen, ben even kwijt hoe.

Maar firefox zou tav plugins/add-ons overgaan naar een nieuw systeem, of dit met 55 gaat gebeuren, zou kunnen, dan zou alle oude add-ons gaan weigeren, en de software makers moeten hele nieuwe add-ons maken. Google hier maar op.

Offline HWE64

  • Lid
  • Steunpunt: Nee
Re: Extensies verouderd in FF 55.0.1
« Reactie #4 Gepost op: 2017/08/15, 22:28:20 »
Een tijd geleden was dit ook, alles werd aangemerkt als onveilig en uitgezet.
Dit kon je toen overbruggen, ben even kwijt hoe.

Maar firefox zou tav plugins/add-ons overgaan naar een nieuw systeem, of dit met 55 gaat gebeuren, zou kunnen, dan zou alle oude add-ons gaan weigeren, en de software makers moeten hele nieuwe add-ons maken. Google hier maar op.
@jan11000 je was me net even voor. Als je klickt op 'verouderd' krijg je uitleg van Mozilla. Tot november 2017 hebben de ontwikkelaars van Mozilla nog de tijd  om over te gaan naar Webextentions.
@ HWE64,

Heb dit ook opgemerkt, bij de extentie van eID Belgium, dat deze als verouderd stond aangestipt, na de recente update van FF.

Blijkt nu, dat dit het nieuwe beveiligingsbeleid is van Mozilla voor Firefox.
Alles wat niet up-to-date is wordt aangemerkt als verouderd.
Het zal bij de volgende punt-versie van Firefox nog strenger zijn. ...
@spievensterke, heeft dit dan ook nog gevolgen voor Firejail omdat in dit artikel https://www.security.nl/posting/504457/Firefox+54+wordt+eerste+Firefox-versie+met+sandbox-beveiliging ook spreekt over een sandbox in de nieuwe FF? Ik gebruik namelijk Fairejail zowel in FF als in TB.
« Laatst bewerkt op: 2017/08/15, 22:35:05 door HWE64 »
Niet panikeren, er is een Ubuntuforum.

Desktop pentium 4, 4GB, dualboot Xubuntu 16.04 LTS /W10 .  Laptop Toshiba Satallite C855 I5, 8GB, Xubuntu 16.04 LTS . Desktop HP Compaq DC5750 AMD64, AMD Athlon X64 X2  2,1GHz RAM 3GB HDD 80GB, Test PC, Xubuntu 16.04 LTS/Linux Mint 18.2 Xfce (beginneling)

Offline spievensterke

  • Lid
  • Steunpunt: Nee
Re: Extensies verouderd in FF 55.0.1
« Reactie #5 Gepost op: 2017/08/15, 22:33:08 »
@ HWE64,

Zoals je in jou onderschrift vermeld, niet panikeren ... afwachten wat er als oplossing uit de bus komt...

meer ( voor ontwikkelaars) info zou kunnen te lezen zijn in:  https://blog.mozilla.org/addons/2017/08/10/upcoming-changes-compatibility/
« Laatst bewerkt op: 2017/08/15, 22:40:52 door spievensterke »
Testlaptop Toshiba Satellite L500-1C7> Hdd1:  Ubuntu 16.04.3 LTS -64bit- in dualboot met PCLinuxOS64-Kde5- / Hdd2: LinuxMint Maté 18.2 -64bit- in dualboot met LinuxMint64- Cinnamon- 18.2  >  Intel Mobile Video /
AcerOne10  ( Hybride, 2 in 1 ) met Ubuntu 16.04.3 LTS -64bit- 32bit Uefi.

Offline HWE64

  • Lid
  • Steunpunt: Nee
Re: Extensies verouderd in FF 55.0.1
« Reactie #6 Gepost op: 2017/08/15, 22:37:36 »
@ HWE64,

Zoals je in jou onderschrift vermeld, niet panikeren ... afwachten wat er als oplossing uit de bus komt...
Thx, Henk
Niet panikeren, er is een Ubuntuforum.

Desktop pentium 4, 4GB, dualboot Xubuntu 16.04 LTS /W10 .  Laptop Toshiba Satallite C855 I5, 8GB, Xubuntu 16.04 LTS . Desktop HP Compaq DC5750 AMD64, AMD Athlon X64 X2  2,1GHz RAM 3GB HDD 80GB, Test PC, Xubuntu 16.04 LTS/Linux Mint 18.2 Xfce (beginneling)

Offline kuifje09

  • Lid
Re: Extensies verouderd in FF 55.0.1
« Reactie #7 Gepost op: 2017/08/16, 09:59:40 »
Wellicht niet helemaal on-topic, maar als FF denk nu veiliger te worden?
Ik probeerde laatst een klein testje uit met een eigen webserver, die gaf een normale string als antwoord als je kontakt maakte, in het geheel geen html-response,  en FF op android ( zal inderdaad een nieuwe versie zijn ) gaf aan de site niet te willen bezoeken omdat de reply niet in orde leek, en voor mijn veiligheid wordt de content niet toonbaar gemaakt. Mijn oudere FF laat keurig de string als response zien...
Nog even en je eigen website moet voldoen aan de laatste html-standaard... Dat gaat nog wat worden zo.

Maar als het over de extensies en plugins gaat denk ik toch dat FF niet echt zit te wachten op al die slimme tooltjes die je kan instaleren.... zoals de ad-blockers, download helpers etc....
Die doen het af en toe niet, en is het wachten op een updated versie daarvan.
Overigens heb ik nooit een extentie of add-on gemaakt, en is het een kwestie van aangeven dat je extentie of add-on versie-compliant is, voldoende om hem weer te laten werken ?

Zal me niet verbazen als er op de achtergrond discussies gaande zijn door de verschillende grote partijen.

Maar ja, wat il al zei, niet helemaal on-topic.

edit: gisteren de test met de response ook buitenshuis op een MS-explorer geprobeerd. Die geeft aan dat de response niet HTML is of zo, en weigerd de content te tonen. Maar hij geeft het wel aan !
« Laatst bewerkt op: 2017/08/16, 10:04:42 door kuifje09 »

Offline nahjo

  • Lid
  • Steunpunt: Nee
Re: Extensies verouderd in FF 55.0.1
« Reactie #8 Gepost op: 2017/08/16, 11:38:54 »
Wat ik mij een beetje afvraag is wie die 'universele webrowser extenties' gaat bewaken. :'(
https://www.security.nl/posting/527915/Acht+Chrome-extensies+gehackt+en+voorzien+van+adware

Hoever ze zijn met je favo extensie: http://arewewebextensionsyet.com/#addons

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Extensies verouderd in FF 55.0.1
« Reactie #9 Gepost op: 2017/08/21, 13:15:45 »
Op de website van Mozilla staat trouwens meer info, over de door nahjo genoemde WebExtensions.
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline Jenske

  • Lid
  • Steunpunt: Nee
Re: Extensies verouderd in FF 55.0.1
« Reactie #10 Gepost op: 2017/08/22, 20:54:50 »
Wel pokke-vervelend dat Firefox slechts "verouderd" weergeeft, zonder ook maar de minste verdere indicatie dat het hier niets dramatisch is. Ik kan me voorstellen dat er heel wat eenvoudiger gebruiker behoorlijk in paniek slaan als ze lezen: "verouderd".

Wat mij betreft een bij-zon-der klant onvriendelijke houding van Firefox! >:(
.. thuis volledig Ubuntu sinds 2006
.. xubuntu 14.04
.. HP desktop 1,5 Tbyte harde schijf 7200 rpm, 4 Mhz processor, 6 Gbyte RAM

Offline Lowlands

  • Lid
  • Steunpunt: Nee
Re: Extensies verouderd in FF 55.0.1
« Reactie #11 Gepost op: 2017/08/30, 09:27:43 »
Inderdaad,best dat die addon veroudert is,maar schakel hem dan niet uit!En geef de mogelijkheid om te updaten.Nu zit ik weer met een hele hoop reclame tussen door.. :mad:
Doe rustig aan,ben ik ook de hele dag druk mee.

Offline nahjo

  • Lid
  • Steunpunt: Nee
Re: Extensies verouderd in FF 55.0.1
« Reactie #12 Gepost op: 2017/08/30, 17:12:04 »
Inderdaad,best dat die addon veroudert is,maar schakel hem dan niet uit!En geef de mogelijkheid om te updaten.Nu zit ik weer met een hele hoop reclame tussen door.. :mad:
Da's vreemd  ??? Bij mij staat bij alle addons wel 'verouderd' maar geen enkele is uitgeschakeld.
FF55.0.2 uBlock NoScript

Offline partyrabbit

  • Lid
  • Steunpunt: Ja
Re: Extensies verouderd in FF 55.0.1
« Reactie #13 Gepost op: 2017/08/30, 17:15:15 »
Staat bij mij ook. Maar toevallig heeft NoScript gisteren gewoon geupdate en werkt ook gewoon.
55.0.2 (64-bits)
I ♥ Linux