Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: VPN/PPTP/Terminal Server Client: ik kom er niet uit  (gelezen 20905 keer)

Offline Els

  • Lid
  • Steunpunt: Nee
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Gepost op: 2007/02/12, 23:03:57 »
Ik probeer een VPN-verbinding in te stellen met het windows netwerk van mijn werk, met pptpconfig. Ik denk dat dat gelukt is, want pptpconfig geeft voor de tunnel bij status: running. Maar ik weet niet goed wat ik in de Terminal Server Client moet invullen, bijv. bij protocol, en moet ik alle velden daar invullen? Tot nu toe doe ik het niet goed want ik krijg steeds 'Unable to connect to VNC server'.

Help?

Azalin

  • Gast
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #1 Gepost op: 2007/02/13, 08:34:31 »
Citaat van: Els
Ik probeer een VPN-verbinding in te stellen met het windows netwerk van mijn werk, met pptpconfig. Ik denk dat dat gelukt is, want pptpconfig geeft voor de tunnel bij status: running. Maar ik weet niet goed wat ik in de Terminal Server Client moet invullen, bijv. bij protocol, en moet ik alle velden daar invullen? Tot nu toe doe ik het niet goed want ik krijg steeds 'Unable to connect to VNC server'.

Help?
Voor Windows vul jet het IP adres in van de PC waar je mee wilt verbinden (uiteraard :) ) verder moet je RDP of RDPv5 selecteren en verder hóef je niets in te vullen. Windows maakt gebruik van een Terminal Server en dat is geen VNC vandaar dat je dus die error krijgt.

Offline Els

  • Lid
  • Steunpunt: Nee
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #2 Gepost op: 2007/02/13, 11:01:57 »
Hmm... nu krijg ik steeds:

ERROR: connect: Connection timed out

Het ligt niet aan de server, met mijn windows pc kan ik gewoon verbinding maken. Nog een idee?

Bij het stoppen van de verbinding krijg ik ook deze melding:

Tunnel not running, or /var/run/ppp-.pid is missing.

Moet ik daar iets mee?

Offline Els

  • Lid
  • Steunpunt: Nee
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #3 Gepost op: 2007/02/14, 19:04:41 »
Ja ik ga daar niet naar pagina 2 verdwijnen hé ;)

Na een hoop gezoek en gegoogle ben ik er nog niet uit, terwijl ik uit wat ik vind toch de indruk krijg dat het heel simpel is. Volgens mij heb ik pptpconfig helemaal niet nodig. Ik heb het ook al geprobeerd met rdesktop in de terminal (nog steeds: connection timed out), maar weet nog steeds niet wat ik moet invullen.
Ik heb de naam van de windows server, inlognaam en wachtwoord, het ip-adres van mijn pc in het windowsnetwerk. Wat moet waar???

breukkie

  • Gast
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #4 Gepost op: 2007/02/14, 19:43:49 »
Is het niet makkelijker om op je ubuntu vnc te instaleren en een paar  poorten  in de router open te zetten ?
poortnummers zijn  5800/59000
via de terminal kun je het commando ifconfig geven en deze opschrijven.
Dit adres in de browser inkloppen en het routerscherm opent zich.(misschien nog even een gebruikersnaam en een wachtwoord van de router ingeven.)
Hier moet afhankelijk van je modem/router een omgeving zitten met NAT virtual servers.
In deze omgeving kan je de poorten openzetten internal/external poort  en je lan ipadres opgeven,zodat de router weet waar hij de verbinding naartoe moet leggen.
Het instellen van vncvieuwer is vrij eenvoudig.

link voor realvnc : http://www.realvnc.com/cgi-bin/download.cgi

Offline Els

  • Lid
  • Steunpunt: Nee
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #5 Gepost op: 2007/02/14, 20:27:35 »
Ik had ook al wat gevonden over vncviewer maar Azalin zegt net

Citaat
Windows maakt gebruik van een Terminal Server en dat is geen VNC vandaar dat je dus die error krijgt.
dus kan ik daar dan wat mee?

breukkie

  • Gast
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #6 Gepost op: 2007/02/14, 21:01:55 »
Ik zit nu op mn werk en maak hier gebruik van vnc (redhat linux) en kan gewoon naar mn windows machine een verbinding opzetten.
kan ook via rdp en connect ik via poort 3389 op mn windows machine.
Via linux naar linux gebruik ik ssh voor een terminal sessie.
Als je op het werk een server heb staan met de vncserver moet je gewoon kunnen connecten.

Offline Els

  • Lid
  • Steunpunt: Nee
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #7 Gepost op: 2007/02/14, 21:14:06 »
Citaat van: breukkie
Als je op het werk een server heb staan met de vncserver moet je gewoon kunnen connecten.
Dat zal ik dan eerst even moeten uitzoeken, ik heb nl. geen idee :)

Azalin

  • Gast
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #8 Gepost op: 2007/02/14, 22:56:15 »
Standaard zit er géén VNC server in WIndows. Je kan wel met de standaard meegeleverde Viewer VNC én Terminal Servers bekijken/connecten. Als je VNC wil hebben in Windows zal je een VNC server moeten downloaden en installeren (TightVNC is dan een goede optie) maar is niet nodig als je ook genoegen wilt nemen met Terminal Server. Je moet die alleen wel in je Windows aanzetten. Je moet dan Deze COmputer/Mijn Computer > Eigenschappen > Iets met verbinding op afstand > daar zie je hulp op afstand maar dat wil je niet, en je ziet daar iets over bureaublad delen... dát is de Terminal Server kant van Windows. Aanvinken en op OK drukken.
Om een TSC verbinding op te zetten heb je pptpconfig niet nodig, weer wel als je een VPN naar je Terminal Server wil opzetten. Op zich wel zo verstandig aangezien de poort van terminal server niet echt heel erg sterk is en makkelijk over te nemen schijnt.
Vanuit Ubuntu naar je Windows via Terminal Server is vrij simpel: Toepassingen > Internet > Terminal Server Client
Protocol RDP, ip adres van de computer opgeven die je wil bellen en klaar...

breukkie

  • Gast
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #9 Gepost op: 2007/02/14, 23:11:42 »
Ik had erbij moeten vermelden dat er geen standaard vnc server in windows zit gebakken, uit de starter van dit  topic had ik dit opgemaakt .
En inderdaad via het icoontje "deze computer"  met rechts aanklikken en dan naar  verbinding van buitenaf kun je de terminal aanzetten.(buroblad delen)
hierbij moet vermeld worden dat er voor vnc wel een gebruikersaccount onder windows dient aangemaakt te worden, anders werkt het alsnog niet.
Dit geld ook voor rdp deze werkt  via poort 3389.
Voor vnc heb ik poort 5900 en 5800 aanstaan.

Offline Els

  • Lid
  • Steunpunt: Nee
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #10 Gepost op: 2007/02/15, 00:14:56 »
Jongens, over het windows-gebeuren op m'n werk heb ik echt niets te vertellen, ik zal het moeten doen met wat er is. Momenteel heb ik op mijn XP pc een VPN verbinding en kan ik via Bureau-accessoires > Communicatie > Bureaublad op afstand op mijn kantoorcomputer werken. Diezelfde instelling wil ik op mijn Ubuntu laptop.

Citaat
Vanuit Ubuntu naar je Windows via Terminal Server is vrij simpel: Toepassingen > Internet > Terminal Server Client
Protocol RDP, ip adres van de computer opgeven die je wil bellen en klaar...
Dat begrijp ik ook als ik eens rondkijk en google, dus ik begrijp niet goed waarom het dan niet lukt, het moet toch haast iets heel simpels zijn dat ik over het hoofd zie. Maar ik kom nog steeds niet verder dan Connection timed out :(

Dus, even checken of ik dit tot nu toe goed doe: ik start de tunnel met pptpconfig, als hier Status: running wordt aangegeven ga ik naar Terminal Server Client en vul ik het ip-adres van mijn kantoorcomputer in, kies RDP en klik op Connect. Ik heb het ook al geprobeerd met ook username en password invullen, maar tot nu toe geen verbinding dus.

Azalin

  • Gast
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #11 Gepost op: 2007/02/15, 19:54:35 »
Citaat van: Els
Jongens, over het windows-gebeuren op m'n werk heb ik echt niets te vertellen, ik zal het moeten doen met wat er is. Momenteel heb ik op mijn XP pc een VPN verbinding en kan ik via Bureau-accessoires > Communicatie > Bureaublad op afstand op mijn kantoorcomputer werken. Diezelfde instelling wil ik op mijn Ubuntu laptop.

Citaat
Vanuit Ubuntu naar je Windows via Terminal Server is vrij simpel: Toepassingen > Internet > Terminal Server Client
Protocol RDP, ip adres van de computer opgeven die je wil bellen en klaar...
Dat begrijp ik ook als ik eens rondkijk en google, dus ik begrijp niet goed waarom het dan niet lukt, het moet toch haast iets heel simpels zijn dat ik over het hoofd zie. Maar ik kom nog steeds niet verder dan Connection timed out :(

Dus, even checken of ik dit tot nu toe goed doe: ik start de tunnel met pptpconfig, als hier Status: running wordt aangegeven ga ik naar Terminal Server Client en vul ik het ip-adres van mijn kantoorcomputer in, kies RDP en klik op Connect. Ik heb het ook al geprobeerd met ook username en password invullen, maar tot nu toe geen verbinding dus.
Je moet natuurlijk wel éérst een VPN verbinding hebben ... ik had niet helemaal begrepen of je nu wél of géén VPN verbinding nodig hebt voor je werk. Die pptpconfig heb je echt nodig voor een VPN verbinding ... Je zou ook eventueel Network Manager kunnen installeren. Dat werk stukken beter dan pptpconfig, je moet dan alleen wel je /etc/network/interfaces leeg maken (op de iface lo en eventueel iface sit na dan!). Network Manager doet dit allemaal voor je configureren.
Verder raad ik je aan om de gui van firestarter te installeren en het IP adres van je werk toe te voegen (het internet ip adres, niet het interne) als het ip adres dat alle toegang heeft tot je PC.



ALs je dit niet doet dan wordt het GRE protocol (nodig om een VPN op te zetten schijnbaar) tegengehouden. Ook moet je zorgen dat je router poort 1723 niet dicht heeft zitten (als je tenminste de standaard VPN poort gebruikt) naar buiten toe. Klinkt raar maar er zijn zat routers die dit dus tegenhouden terwijl alles open lijkt te staan. Ik heb er eens een router voor moeten vervangen omdat het niet uit te zetten was.

Wanneer je een werkende VPN hebt, dan kun je met het interne lokale IP adres van je werk pc verbinding maken. Dus als 213.12.243.2 het IP adres zou zijn dat je werk voor de buitenwereld heeft en adressen als 192.168.0.1 of 10.0.0.25 adressen van het lokale netwerk op je werk zijn, dan moet je dus die interne adressen gebruiken, je bent dan namelijk deel van het netwerk op je werk alsof je aan een switch ter plaatse zit.

Hopelijk helpt dit je wat meer... zo niet, dan zal ik proberen je verder te helpen :)

Offline Els

  • Lid
  • Steunpunt: Nee
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #12 Gepost op: 2007/02/15, 22:47:35 »
Azalin, bedankt voor je uitgebreide antwoord. Al is het kwartje nog niet helemáál gevallen ben ik bang...
Als ik pptpconfig doe en die geeft status: running, dan betekent dat toch dat ik een VPN-verbinding heb?? Of heb ik dat helemaal verkeerd begrepen?

Network Manager heb ik geïnstalleerd, maar die doet helemaal niets, ws. omdat ik /etc/network/interfaces niet leeg hebt gemaakt inderdaad. Maar dat durf ik eigenlijk niet omdat ik bang ben dat ik dan m'n internet weer kwijt ben en daar ben ik me toch een tijd mee aan het prutsen geweest :(

Dus heb ik dan Network Manager toch nog nodig?

Citaat
Verder raad ik je aan om de gui van firestarter te installeren en het IP adres van je werk toe te voegen (het internet ip adres, niet het interne) als het ip adres dat alle toegang heeft tot je PC.
Weet niet of ik je misschien verkeerd begrijp, maar dat ip adres hoeft toch geen toegang te hebben tot mijn computer thuis?

Verder staat er in de instelllingen van de router onder VPN:
IPSec Passthrough: Enable
PPTP Passthrough: Enable
L2TP Passthrough: Enable
Ik weet niet waar ik iets over poorten kan zien...

Edit: trouwens, als het met de XP pc allemaal wèl lukt, betekent dat toch dat er met de routerinstellingen niets mis is?

Azalin

  • Gast
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #13 Gepost op: 2007/02/15, 23:32:00 »
Citaat van: Els
Azalin, bedankt voor je uitgebreide antwoord. Al is het kwartje nog niet helemáál gevallen ben ik bang...
Als ik pptpconfig doe en die geeft status: running, dan betekent dat toch dat ik een VPN-verbinding heb?? Of heb ik dat helemaal verkeerd begrepen?

Network Manager heb ik geïnstalleerd, maar die doet helemaal niets, ws. omdat ik /etc/network/interfaces niet leeg hebt gemaakt inderdaad. Maar dat durf ik eigenlijk niet omdat ik bang ben dat ik dan m'n internet weer kwijt ben en daar ben ik me toch een tijd mee aan het prutsen geweest :(

Dus heb ik dan Network Manager toch nog nodig?

Citaat
Verder raad ik je aan om de gui van firestarter te installeren en het IP adres van je werk toe te voegen (het internet ip adres, niet het interne) als het ip adres dat alle toegang heeft tot je PC.
Weet niet of ik je misschien verkeerd begrijp, maar dat ip adres hoeft toch geen toegang te hebben tot mijn computer thuis?

Verder staat er in de instelllingen van de router onder VPN:
IPSec Passthrough: Enable
PPTP Passthrough: Enable
L2TP Passthrough: Enable
Ik weet niet waar ik iets over poorten kan zien...

Edit: trouwens, als het met de XP pc allemaal wèl lukt, betekent dat toch dat er met de routerinstellingen niets mis is?
Klopt, router is dan niks mis mee. De bevindingen met een router die ik had waren overigens onder Windows, dus als je dat onder Windows wel lukt dan is je router prima in orde :)

Ik heb een tijdje lopen rommelen voor ik het eindelijk aan de praat had een tijdje terug, alleen gebruik ik het nu niet meer. Bij mij bleek het dat firestarter/iptables (je firewall) mijn verbinding tegen hield. Ookal had ik een VPN verbinding, ik kon geen verbinding via Terminal Service krijgen. Toen ik de firewall uitzette (door middel van de gui van firestarter) kon ik ineens wel op de server terecht.

Offline Els

  • Lid
  • Steunpunt: Nee
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #14 Gepost op: 2007/02/15, 23:38:28 »
Citaat van: Azalin
Ik heb een tijdje lopen rommelen voor ik het eindelijk aan de praat had een tijdje terug, alleen gebruik ik het nu niet meer. Bij mij bleek het dat firestarter/iptables (je firewall) mijn verbinding tegen hield. Ookal had ik een VPN verbinding, ik kon geen verbinding via Terminal Service krijgen. Toen ik de firewall uitzette (door middel van de gui van firestarter) kon ik ineens wel op de server terecht.
Okee, ik snap het, bedankt. Ik ga het proberen!

Offline Els

  • Lid
  • Steunpunt: Nee
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #15 Gepost op: 2007/02/16, 14:09:14 »
Er is nu in ieder geval iets veranderd:

ERROR: connect: Connection refused

En die krijg ik zowel als ik die regel in Firestarter heb toegevoegd als wanneer ik hem er weer uithaal...
Het verschil met daarvoor is dus alleen dat ik nu Firestarter heb geïnstalleerd.

Wat nu?

Aanvulling: als ik in de Firestarter GUI kijk bij Gebeurtenissen dan staat er niets onder geblokkeerde verbindingen.

Nog een aanvulling: iets te snel gekeken, er staat wel iets bij geblokkeerde verbindingen:
(datum/tijd) Poort: 137 Bron: 192.168.0.100 Protocol: UDP Dienst: Samba (SMB)

Offline Els

  • Lid
  • Steunpunt: Nee
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #16 Gepost op: 2007/02/16, 14:52:55 »
Hm.. Firestarter blokkeert gewoon alles. Ik zoek even verder in de instellingen.

Aanvulling: okee, dat werkt weer. Maar:

Citaat
Verder raad ik je aan om de gui van firestarter te installeren en het IP adres van je werk toe te voegen (het internet ip adres, niet het interne) als het ip adres dat alle toegang heeft tot je PC.
Ik heb daar geen IP adres van, alleen de naam, dus die heb ik ingevuld. Is dat ook goed of moet ik per se het IP adres hebben?

Nu is het dus weer ERROR: connect: Connection timed out.

Offline Els

  • Lid
  • Steunpunt: Nee
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #17 Gepost op: 2007/02/17, 20:07:01 »
Ik verhuis weer vrolijk (nou ja...) naar pagina 1 ;)

Intussen naast tsclient ook krdc en gnome-rdp geprobeerd, wat - natuurlijk - niets blijkt uit te maken voor het resultaat. Alleen tsclient en gnome-rdp geven als fout: connection timed out, en krdc: connection attempt to host failed.

Omdat de VPN-verbinding werkt, en ik kan de server pingen, begin ik te denken dat het misschien iets anders is: kan het iets met snelheid of zo te maken hebben? De VPN-verbinding tot stand brengen duurt ook wel zo'n 10 minuten. Misschien kan mijn laptop dit niet aan? Wel eens van gehoord of er bepaalde systeemvereisten zijn?

Azalin

  • Gast
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #18 Gepost op: 2007/02/18, 00:26:18 »
Mm, niet dat ik weet, De problemen die jij hier beschijft zijn allemaal problemen die ik ook had en oploste door (tijdelijk) de firewall te stoppen ... Dit kun je doen in Firestarter. Verder zou ik het ook niet weten.

Offline Els

  • Lid
  • Steunpunt: Nee
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #19 Gepost op: 2007/02/18, 00:38:11 »
Citaat van: Azalin
Bij mij bleek het dat firestarter/iptables (je firewall) mijn verbinding tegen hield.
Zou je deze uitspraak van jou nog even willen toelichten? Want ik toen ik hiermee begon had ik Firestarter nog helemaal niet geïnstalleerd en toen deed ie het ook al niet, dus daar kan het niet aan liggen lijkt me. Maar wat bedoel je met iptables?

Azalin

  • Gast
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #20 Gepost op: 2007/02/18, 10:34:42 »
Toen je Firestarter niet had geinstalleerd kreeg je een andere melding volgens mij. Firestarter, de GUI dan, configureert iptables net even iets anders dan standaard en dan worden sommige dingen anders tegengehouden en dus een ander soort foutmelding. Wanneer je in Firestarter Firewall stoppen doet, dan wordt iptables ook op een dergelijke manier geconfigureerd dat alles er in en er uit mag.

Wat IPTables is? Eigenlijk heel simpel, dat is de eigenlijke firewall. Op basis van regels bepaald dat wat er wel en niet naar buiten en naar binnen mag over je netwerkaansluiting. Firestarter staat standaard al geïnstalleerd alleen merk je dat pas wanneer je de GUI installeert. Firestarter bestaat namelijk uit twee delen: de daemon die configureert en controleert je IPTables, en de GUI die de daemon weer aanstuurt.

Van wat ik begrijp is dat je wel verbinding hebt maar dat het routen van het verkeer niet goed gaat. Je zou eens in pptpconfig  op het profiel moeten klikken dat je gebruikt, dan naar Routing gaan en eens kijken hoe dat geconfigureerd staat. Blijft er bij dat vóór je een VPN tot stand brengt, je toch eens zou moeten proberen om met firestarter de firewall eens te stoppen, dán een vpn verbinding openen en dán met terminal server client proberen verbinding te krijgen. Als dat lukt, dan kunnen we eens verder kijken hoe de firewall goed te configureren... Als dat nog niet lukt, dan moet er dus met die routing iets niet goed staan. Je zou ook de informatie die in het schermpje van pptpconfig voorbij komt wanneer je een verbinding maakt eens hier kunnen plakken. Misschien dat ik er dan wat meer over kan zeggen.

Offline Els

  • Lid
  • Steunpunt: Nee
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #21 Gepost op: 2007/02/18, 14:46:51 »
Hartstikke bedankt voor je geduld en je uitgebreide uitleg! Ik moet nu eerst dringend wat werk afhandelen (gelukkig doet ie 't op de XP pc wel), maar ga e.e.a. daarna meteen proberen en hier weer rapporteren!

Offline Els

  • Lid
  • Steunpunt: Nee
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #22 Gepost op: 2007/02/18, 22:47:49 »
Ook met Firestarter gestopt niks :(

Bij Routing staat Client to LAN geselecteerd. Als ik bij Edit Network Routes 192.168.0.17/32 invul, krijg ik dit:

Using interface ppp0pptpconfig: monitoring interface ppp0

Connect: ppp0 <--> /dev/pts/1
CHAP authentication succeeded
MPPE 40-bit stateless compression enabled
Cannot determine ethernet address for proxy ARP
local  IP address 192.168.0.203
remote IP address 192.168.0.1
pptpconfig: pppd process exit status 0 (started)
ip route replace 83.161.22.73 via 192.168.1.1 dev wlan0  src 192.168.1.101
ip route add '192.168.0.17/32' dev 'ppp0'
Cannot find device "ppp0"

pptpconfig: command failed, exit code 255
pptpconfig: connected
Als ik dat weer weghaal dit:

Using interface ppp0pptpconfig: monitoring interface ppp0

Connect: ppp0 <--> /dev/pts/1
CHAP authentication succeeded
MPPE 40-bit stateless compression enabled
Cannot determine ethernet address for proxy ARP
local  IP address 192.168.0.203
remote IP address 192.168.0.1
pptpconfig: pppd process exit status 0 (started)
ip route replace 83.161.22.73 via 192.168.1.1 dev wlan0  src 192.168.1.101
pptpconfig: routes added to remote networks
pptpconfig: connected
In Terminal Server Client heb ik bij Computer: 192.168.0.17 staan en bij Protocol: RDP (als ik daar RDPv5 van maak zelfde resultaat).
Als ik naar het Windows 'Verbinding met extern bureaublad' venster kijk, staat daar ook nog gebruikersnaam en domein ingevuld. Ook als ik datzelfde in Terminal Server Client invul, maakt het nog steeds geen verschil. Als ik op Connect heb geklikt verdwijnt het venster, en duurt het ca. 6 minuten voor de melding Connection timed out verschijnt.

Azalin

  • Gast
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #23 Gepost op: 2007/02/20, 08:52:30 »
Het eerste wat ik mij afvraag is: wat is het adres van je lokale netwerk? Thuis dus... Als jij namelijk in dezelfde hoek zit als het lokale adres op je werk dan kun je een hoop problemen verwachten (ik had hier zo veel problemen mee dat ik thuis mijn hele netwerk heb om moeten gooien). Stel dat je bijvoorbeeld op je werk een server hebt die lokaal 192.168.0.1 is en thuis heb jij een router die 192.168.0.1 is ... dan hoef ik je denk ik niet uit te leggen dat dit niet helemaal lekker zal gaan .. zeker niet wanneer je pptpconfig zo configureert dat je hele netwerk in de VPN wordt opgenomen (dit is volgens mij wat je nu hebt namelijk)
Dus kijk daar ook eens naar.

Verder, als je ping 192.168.0.17 doet in een terminal venster, krijg je dan antwoord? of krijg je dan iets anders? en wat krijg je dan precies?

Overigens moet je niet bij Edit Network routes het IP adres van de destination invullen (niet wanneer je er een 32 achter plaatst) maar volgens mij moet je daar een network range opgeven: 192.168.0.0/24 is volgens mij dat zou moeten werken. Zou je ook eens kunnen proberen.

De volgende melding vind ik ook een beetje vaag: Cannot determine ethernet address for proxy ARP
Waar dat vandaan komt geen idee maar volgens mij is dat ook niet helemaal zoals het zou moeten.

Overigens zie ik nu ineens dat je thuisnetwek in een iets andere scop zit dan je werk netwerk dus dat moet wel loslopen, daar kan het probleem dus niet zitten. (192.168.1.1 dev wlan0  src 192.168.1.101)

Een kant en klare oplossing heb ik niet, en heel erg veel know-how over pptpconfig is er op dit forum volgens mij oo niet. Wat je trouwens zou kúnnen doen is eens een extra draadje op het engelstalig forum aanmaken. Twee plaatsen bieden meer hulp dan één vaak.

Offline Els

  • Lid
  • Steunpunt: Nee
VPN/PPTP/Terminal Server Client: ik kom er niet uit
« Reactie #24 Gepost op: 2007/02/20, 19:54:11 »
Citaat
Verder, als je ping 192.168.0.17 doet in een terminal venster, krijg je dan antwoord? of krijg je dan iets anders? en wat krijg je dan precies?
elizabeth@laptop_els:~$ ping -c 5 192.168.0.17
PING 192.168.0.17 (192.168.0.17) 56(84) bytes of data.

--- 192.168.0.17 ping statistics ---
5 packets transmitted, 0 received, 100% packet loss, time 4000ms
Citaat
Overigens moet je niet bij Edit Network routes het IP adres van de destination invullen (niet wanneer je er een 32 achter plaatst) maar volgens mij moet je daar een network range opgeven: 192.168.0.0/24 is volgens mij dat zou moeten werken. Zou je ook eens kunnen proberen.
Dat had ik hier vandaan. Maar met jouw voorbeeld kreeg ik ongeveer dezelfde melding.
Citaat
De volgende melding vind ik ook een beetje vaag: Cannot determine ethernet address for proxy ARP
Waar dat vandaan komt geen idee maar volgens mij is dat ook niet helemaal zoals het zou moeten.
Dat geeft kennelijk niet, zie hier (onderaan).
Citaat
Wat je trouwens zou kúnnen doen is eens een extra draadje op het engelstalig forum aanmaken. Twee plaatsen bieden meer hulp dan één vaak.
Goed idee, zal ik doen. In ieder geval heel erg bedankt voor al je moeite. Mocht het nog ooit gaan lukken dan zal ik het hier laten weten.