Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Hoi,ik heb een probleem met mijn fglrx van Ati met kubuntu Feisty  (gelezen 576 keer)

Offline merijn

  • Lid
  • Steunpunt: Nee
Hoi,Linux vrienden.
Ik,ben nu weer na een hele tijd weer windowsXp te hebben gebruikt weer terug gegaan naar Linux.
Nu dus weer naar Kubuntu.
Daarom ben ik na lang weg te zijn geweest ook weer eens terug op dit forum.
Nu heb ik dus het volgende probleem.
Ik heb dus feisty geinstalleerd,maar heb een probleem met mijn fglrx op mijn ati radeon x800 pro.
Alles heb ik volgens de regels geinstalleerd,maar krijg altijd als ik fglrxinfo doe in mijn terminal deze fout.
-------------------------------
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (1.5 Mesa 6.5.2)

-----------------------------------------

Ik weet niet wat er fout is,ik zal ook even een zicht geven  op mijn xorg.conf bestand.


---------------------------------------


# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
  Identifier "Default Layout"
  screen 0 "aticonfig-Screen[0]" 0 0
  InputDevice "Generic Keyboard"
  InputDevice "Configured Mouse"
  InputDevice "stylus" "SendCoreEvents"
  InputDevice "cursor" "SendCoreEvents"
  InputDevice "eraser" "SendCoreEvents"
EndSection

Section "Files"
 
  # path to defoma fonts
  FontPath "/usr/share/fonts/X11/misc"
  FontPath "/usr/share/fonts/X11/cyrillic"
  FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
  FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
  FontPath "/usr/share/fonts/X11/Type1"
  FontPath "/usr/share/fonts/X11/100dpi"
  FontPath "/usr/share/fonts/X11/75dpi"
  FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
  Load "i2c"
  Load "bitmap"
  Load "ddc"
  Load "extmod"
  Load "freetype"
  Load "int10"
  Load "vbe"
  load "glx"
  load "dbe"
  load "v4l"
EndSection

Section "InputDevice"
  Identifier "Generic Keyboard"
  Driver "kbd"
  option "CoreKeyboard"
  option "XkbRules" "xorg"
  option "XkbModel" "pc105"
  option "XkbLayout" "us"
  option "XkbVariant" "alt-intl"
EndSection

Section "InputDevice"
  Identifier "Configured Mouse"
  Driver "mouse"
  option "CorePointer"
  option "Device" "/dev/input/mice"
  option "Protocol" "ImPS/2"
  option "ZAxisMapping" "4 5"
  option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
  Identifier "stylus"
  Driver "wacom"
  option "Device" "/dev/input/wacom"
  option "Type" "stylus"
  option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
  Identifier "eraser"
  Driver "wacom"
  option "Device" "/dev/input/wacom"
  option "Type" "eraser"
  option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
  Identifier "cursor"
  Driver "wacom"
  option "Device" "/dev/input/wacom"
  option "Type" "cursor"
  option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Monitor"
  Identifier "Generic Monitor"
  option "DPMS"
EndSection

Section "Monitor"
  identifier "aticonfig-Monitor[0]"
  vendorname "Panasonic"
  modelname "Panasonic SL90 (TX-D9S54)"
  HorizSync 30.0-95.0
  VertRefresh 50.0-180.0
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  modeline  "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
  modeline  "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
  modeline  "640x480@85" 36.0 640 696 752 832 480 481 484 509 -vsync -hsync
  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline  "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
  modeline  "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
  modeline  "800x600@85" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline  "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
  modeline  "1024x768@85" 94.5 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
  modeline  "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
  modeline  "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
  modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
  modeline  "1024x768@43" 44.9 1024 1032 1208 1264 768 768 776 817 +hsync interlace +vsync
  modeline  "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
  modeline  "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
  modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
  modeline  "1280x960@85" 148.5 1280 1344 1504 1728 960 961 964 1011 +hsync +vsync
  modeline  "1280x1024@85" 157.5 1280 1344 1504 1728 1024 1025 1028 1072 +hsync +vsync
  modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
  modeline  "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
  modeline  "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
  modeline  "1400x1050@75" 155.85 1400 1496 1648 1896 1050 1051 1054 1096 -hsync +vsync
  modeline  "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
  modeline  "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
  modeline  "1600x1200@75" 202.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
  modeline  "1600x1200@70" 189.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
  modeline  "1792x1344@60" 204.8 1792 1920 2120 2448 1344 1345 1348 1394 -hsync +vsync
  modeline  "1856x1392@60" 218.3 1856 1952 2176 2528 1392 1393 1396 1439 -hsync +vsync
  modeline  "1920x1440@60" 234.0 1920 2048 2256 2600 1440 1441 1444 1500 -hsync +vsync
  modeline  "2048x1536@60" 266.95 2048 2200 2424 2800 1536 1537 1540 1589 -hsync +vsync
  gamma 1.0
EndSection

Section "Device"
  Identifier "ATI Technologies Inc R420 JI [Radeon X800PRO]"
  Driver "ati"
  BusID "PCI:3:0:0"
EndSection

Section "Device"
  identifier "aticonfig-Device[0]"
  boardname "ati"
  busid "PCI:3:0:0"
  driver "fglrx"
  screen 0
EndSection

Section "Screen"
  Identifier "Default Screen"
  Device "ATI Technologies Inc R420 JI [Radeon X800PRO]"
  Monitor "Generic Monitor"
  DefaultDepth 24
  SubSection "Display"
    Depth 1
    Modes "1600x1200" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
  EndSubSection
  SubSection "Display"
    Depth 4
    Modes "1600x1200" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
  EndSubSection
  SubSection "Display"
    Depth 8
    Modes "1600x1200" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
  EndSubSection
  SubSection "Display"
    Depth 15
    Modes "1600x1200" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
  EndSubSection
  SubSection "Display"
    Depth 16
    Modes "1600x1200" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
  EndSubSection
  SubSection "Display"
    Depth 24
    Modes "1600x1200" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
  EndSubSection
EndSection

Section "Screen"
  Identifier "aticonfig-Screen[0]"
  Device "aticonfig-Device[0]"
  Monitor "aticonfig-Monitor[0]"
  DefaultDepth 24
  SubSection "Display"
    depth 24
    virtual 2048 1536
    modes "1280x1024@85" "1280x1024@60" "1280x960@85" "1280x960@75" "1280x960@60" "1400x1050@60" "1280x1024@75" "1400x1050@75" "1152x864@75" "1600x1200@65" "1024x768@43" "1600x1200@60" "1024x768@60" "1600x1200@75" "1024x768@70" "1600x1200@70" "1024x768@75" "1792x1344@60" "1024x768@85" "1856x1392@60" "832x624@75" "1920x1440@60" "800x600@60" "2048x1536@60" "800x600@85" "800x600@75" "800x600@72" "800x600@56" "640x480@85" "640x480@75" "640x480@72" "640x480@60"
  EndSubSection
EndSection

Section "DRI"
  Mode 0666
EndSection

Section "device" #
  identifier "device1"
  boardname "ati"
  busid "PCI:3:0:0"
  driver "fglrx"
  screen 1
EndSection
Section "screen" #
  identifier "screen1"
  device "device1"
  defaultdepth 24
  monitor "monitor1"
EndSection
Section "monitor" #
  identifier "monitor1"
  gamma 1.0
EndSection
Section "ServerFlags"
EndSection
-------------------

Het is wel een erg groot bestand,maar ik hoop dat iemand kan zien wat het probleem zou kunnen zijn,en zo vriendelijk zou willen zijn mij te willen helpen dit op te lossen.

Alvast bedankt.


Groetjes,

Merijn

Offline merijn

  • Lid
  • Steunpunt: Nee
Hoi,ik heb een probleem met mijn fglrx van Ati met kubuntu Feisty
« Reactie #1 Gepost op: 2007/05/03, 23:50:13 »
Citaat van: merijn
Hoi,Linux vrienden.
Ik,ben nu weer na een hele tijd weer windowsXp te hebben gebruikt weer terug gegaan naar Linux.
Nu dus weer naar Kubuntu.
Daarom ben ik na lang weg te zijn geweest ook weer eens terug op dit forum.
Nu heb ik dus het volgende probleem.
Ik heb dus feisty geinstalleerd,maar heb een probleem met mijn fglrx op mijn ati radeon x800 pro.
Alles heb ik volgens de regels geinstalleerd,maar krijg altijd als ik fglrxinfo doe in mijn terminal deze fout.
-------------------------------
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (1.5 Mesa 6.5.2)

-----------------------------------------

Ik weet niet wat er fout is,ik zal ook even een zicht geven  op mijn xorg.conf bestand.


---------------------------------------


# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
  Identifier "Default Layout"
  screen 0 "aticonfig-Screen[0]" 0 0
  InputDevice "Generic Keyboard"
  InputDevice "Configured Mouse"
  InputDevice "stylus" "SendCoreEvents"
  InputDevice "cursor" "SendCoreEvents"
  InputDevice "eraser" "SendCoreEvents"
EndSection

Section "Files"
 
  # path to defoma fonts
  FontPath "/usr/share/fonts/X11/misc"
  FontPath "/usr/share/fonts/X11/cyrillic"
  FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
  FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
  FontPath "/usr/share/fonts/X11/Type1"
  FontPath "/usr/share/fonts/X11/100dpi"
  FontPath "/usr/share/fonts/X11/75dpi"
  FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
  Load "i2c"
  Load "bitmap"
  Load "ddc"
  Load "extmod"
  Load "freetype"
  Load "int10"
  Load "vbe"
  load "glx"
  load "dbe"
  load "v4l"
EndSection

Section "InputDevice"
  Identifier "Generic Keyboard"
  Driver "kbd"
  option "CoreKeyboard"
  option "XkbRules" "xorg"
  option "XkbModel" "pc105"
  option "XkbLayout" "us"
  option "XkbVariant" "alt-intl"
EndSection

Section "InputDevice"
  Identifier "Configured Mouse"
  Driver "mouse"
  option "CorePointer"
  option "Device" "/dev/input/mice"
  option "Protocol" "ImPS/2"
  option "ZAxisMapping" "4 5"
  option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
  Identifier "stylus"
  Driver "wacom"
  option "Device" "/dev/input/wacom"
  option "Type" "stylus"
  option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
  Identifier "eraser"
  Driver "wacom"
  option "Device" "/dev/input/wacom"
  option "Type" "eraser"
  option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
  Identifier "cursor"
  Driver "wacom"
  option "Device" "/dev/input/wacom"
  option "Type" "cursor"
  option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Monitor"
  Identifier "Generic Monitor"
  option "DPMS"
EndSection

Section "Monitor"
  identifier "aticonfig-Monitor[0]"
  vendorname "Panasonic"
  modelname "Panasonic SL90 (TX-D9S54)"
  HorizSync 30.0-95.0
  VertRefresh 50.0-180.0
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  modeline  "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
  modeline  "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
  modeline  "640x480@85" 36.0 640 696 752 832 480 481 484 509 -vsync -hsync
  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline  "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
  modeline  "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
  modeline  "800x600@85" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline  "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
  modeline  "1024x768@85" 94.5 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
  modeline  "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
  modeline  "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
  modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
  modeline  "1024x768@43" 44.9 1024 1032 1208 1264 768 768 776 817 +hsync interlace +vsync
  modeline  "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
  modeline  "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
  modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
  modeline  "1280x960@85" 148.5 1280 1344 1504 1728 960 961 964 1011 +hsync +vsync
  modeline  "1280x1024@85" 157.5 1280 1344 1504 1728 1024 1025 1028 1072 +hsync +vsync
  modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
  modeline  "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
  modeline  "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
  modeline  "1400x1050@75" 155.85 1400 1496 1648 1896 1050 1051 1054 1096 -hsync +vsync
  modeline  "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
  modeline  "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
  modeline  "1600x1200@75" 202.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
  modeline  "1600x1200@70" 189.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
  modeline  "1792x1344@60" 204.8 1792 1920 2120 2448 1344 1345 1348 1394 -hsync +vsync
  modeline  "1856x1392@60" 218.3 1856 1952 2176 2528 1392 1393 1396 1439 -hsync +vsync
  modeline  "1920x1440@60" 234.0 1920 2048 2256 2600 1440 1441 1444 1500 -hsync +vsync
  modeline  "2048x1536@60" 266.95 2048 2200 2424 2800 1536 1537 1540 1589 -hsync +vsync
  gamma 1.0
EndSection

Section "Device"
  Identifier "ATI Technologies Inc R420 JI [Radeon X800PRO]"
  Driver "ati"
  BusID "PCI:3:0:0"
EndSection

Section "Device"
  identifier "aticonfig-Device[0]"
  boardname "ati"
  busid "PCI:3:0:0"
  driver "fglrx"
  screen 0
EndSection

Section "Screen"
  Identifier "Default Screen"
  Device "ATI Technologies Inc R420 JI [Radeon X800PRO]"
  Monitor "Generic Monitor"
  DefaultDepth 24
  SubSection "Display"
    Depth 1
    Modes "1600x1200" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
  EndSubSection
  SubSection "Display"
    Depth 4
    Modes "1600x1200" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
  EndSubSection
  SubSection "Display"
    Depth 8
    Modes "1600x1200" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
  EndSubSection
  SubSection "Display"
    Depth 15
    Modes "1600x1200" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
  EndSubSection
  SubSection "Display"
    Depth 16
    Modes "1600x1200" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
  EndSubSection
  SubSection "Display"
    Depth 24
    Modes "1600x1200" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
  EndSubSection
EndSection

Section "Screen"
  Identifier "aticonfig-Screen[0]"
  Device "aticonfig-Device[0]"
  Monitor "aticonfig-Monitor[0]"
  DefaultDepth 24
  SubSection "Display"
    depth 24
    virtual 2048 1536
    modes "1280x1024@85" "1280x1024@60" "1280x960@85" "1280x960@75" "1280x960@60" "1400x1050@60" "1280x1024@75" "1400x1050@75" "1152x864@75" "1600x1200@65" "1024x768@43" "1600x1200@60" "1024x768@60" "1600x1200@75" "1024x768@70" "1600x1200@70" "1024x768@75" "1792x1344@60" "1024x768@85" "1856x1392@60" "832x624@75" "1920x1440@60" "800x600@60" "2048x1536@60" "800x600@85" "800x600@75" "800x600@72" "800x600@56" "640x480@85" "640x480@75" "640x480@72" "640x480@60"
  EndSubSection
EndSection

Section "DRI"
  Mode 0666
EndSection

Section "device" #
  identifier "device1"
  boardname "ati"
  busid "PCI:3:0:0"
  driver "fglrx"
  screen 1
EndSection
Section "screen" #
  identifier "screen1"
  device "device1"
  defaultdepth 24
  monitor "monitor1"
EndSection
Section "monitor" #
  identifier "monitor1"
  gamma 1.0
EndSection
Section "ServerFlags"
EndSection
-------------------

Het is wel een erg groot bestand,maar ik hoop dat iemand kan zien wat het probleem zou kunnen zijn,en zo vriendelijk zou willen zijn mij te willen helpen dit op te lossen.

Alvast bedankt.


Groetjes,

Merijn
Hoi,ik citeer op mijn eigen vraag.
Ik heb namelijk zelf het probleem opgelost.
Het kostte mij wel veel tijd,want mij hele pc moest weer plat.
Volgens mij is er voor Kubuntu voor mijn probleem nog geen oplossing.
Want ik heb wel eerst zelf wat dingen opgezocht,maar toen ik dat had uitgetest bleef mijn pc hangen na een restart,en kon helemaal niets meer.
Mijn xorg.conf bestand was zo erg aangetast,dat ik er helemaal niet meer bij kon.
Toen baalde ik echt,want ik had er bijna een hele dag ingestoken om mijn pc goed te krijgen met al mijn eigen instellingen en geinstalleerde programma┬┤s en zo.
Nu heb ik dus Ubuntu geinstalleerd en nu werkt alles wel ineens goed met fglrx,dat kon ik gewoon aanvinken binnen Ubuntu zelf,klasse.
Ik neem dus gewoon aan dat er binnen de Feisty Kubuntu versie dus gewoon ergens een bug binnen kde of zo zit,die gewoon niet goed kan samenwerken met de ati fglrx driver.
Maar goed ik ben nu weer tevreden,want Gnome scoort eigenlijk ook best goed.


Groetjes,

Merijn