Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Update raspberry pi  (gelezen 210 keer)

Offline Rene79

  • Lid
Update raspberry pi
« Gepost op: 2016/12/30, 09:14:08 »
Hallo allemaal,

Ik ben aan het proberen om mijn raspberry update te houden echter bij een regel gaat het mis dan geeft hij aan bestand of map niet, de regel dat het fout gaat is de sudo wget https://
Citaat
[Om de Raspberry Pi up-to-date te houden, installeren we ook Hexxeh's RPI update tool:

  sudo apt-get install ca-certificates

  sudo apt-get install git-core

  sudo wget https://raw.github.com/Hexxeh/rpi-update/master/rpi-update -O /usr/bin/rpi-update && sudo chmod +x /usr/bin/rpi-update

  sudo rpi-update

  sudo shutdown -r now/quote]

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Nee
Re: Update raspberry pi
« Reactie #1 Gepost op: 2016/12/30, 15:52:15 »
Hallo, het eerste deel van die opdracht

sudo wget https://raw.github.com/Hexxeh/rpi-update/master/rpi-update
kan ik met succes uitvoeren, alhoewel ik wel een 301-fout krijg (Moved permanently). Dit lijkt goed te gaan, de software wordt hier gewoon gedownload. Probleem bij jou zit dan mogelijk in de vervolgopdracht:

-O /usr/bin/rpi-update && sudo chmod +x /usr/bin/rpi-update
Mogelijk bestaat de map /usr/bin/rpi-update niet op jouw systeem, check dat eens.
https://allesgimpofbijna.wordpress.com - GIMP en omstreken
https://paulsphotopalace.wordpress.com (Engelstalig) - Raw, RawTherapee, G'MIC, GIMP...

Offline partsman

  • Lid
  • Steunpunt: Nee
Re: Update raspberry pi
« Reactie #2 Gepost op: 2016/12/30, 20:26:30 »
Heb je al wel https geinstalleert?


sudo apt-get install apt-transport-https

Offline Rene79

  • Lid
Re: Update raspberry pi
« Reactie #3 Gepost op: 2016/12/31, 22:37:55 »
Ik heb de code nog eens uitgevoerd toen kreeg een foutmelding 400 batrequest.

Daarna heb ik transport-https geïnstalleerd, daarna nog eens geprobeerd en nu krijg ik wee map of bestandsnaam bestaan niet.

Offline Rene79

  • Lid
Re: Update raspberry pi
« Reactie #4 Gepost op: 2017/01/01, 15:09:05 »
Beste Paul ik heb gekeken of het bestand bestand maar krijg bij jou code de meldin ongeldige optie