Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Php 5  (gelezen 3827 keer)

Sven1989

  • Gast
Php 5
« Gepost op: 2007/04/27, 21:15:19 »
Weet er iemand de fout zitten ? Wanneer ik op btnVerzenden klik gebeurt er gewoon niks...


S-Net


Inleidende tekst over mijn provider












if(isset($_POST['btnVerzenden'])){
mkdir("/var/www/hahahaha",0777);
print "done";
}

?>

reinhout

  • Gast
Php 5
« Reactie #1 Gepost op: 2007/04/27, 21:59:36 »
dit is toch niet je hele code, of wel?

beess

  • Gast
Php 5
« Reactie #2 Gepost op: 2007/04/27, 22:15:17 »

reinhout

  • Gast
Php 5
« Reactie #3 Gepost op: 2007/04/28, 08:57:30 »
ik weet het niet, maar ga eens naar www.phphulp.nl, registreer en stuur een pm (topics zoals zoek de fout zijn daar niet echt welkom)

Sven1989

  • Gast
Php 5
« Reactie #4 Gepost op: 2007/04/28, 09:11:11 »
Het is code die op 1 pagina moet werken, als ik op de knop klik moet er op het scherm verschijnen: "done" en moet de map aangemaakt worden, maar dat gebeurt niet...

reinhout

  • Gast
Php 5
« Reactie #5 Gepost op: 2007/04/28, 19:18:43 »
ik kan je alleen maar aanraden om te registreren op phphulp.nl

wacht eens even... hoe is die pagina opgeslagen, als .php of als .htm(l)

beess

  • Gast
Php 5
« Reactie #6 Gepost op: 2007/04/28, 20:05:36 »
"; ?>



testje




S-Net


Inleidende tekst over mijn provider.



 
 

 
 

 

if(isset($_POST['btnVerzenden'])){
mkdir("/var/www/hahahaha",0777);
print "done";
}

?>

Opslaan als blabla.php, zien dat die voldoende rechten heeft op je server - anders krijg je foutmelding, en laten lopen. Werkt hier prima.

Offline anko

  • Lid
  • Steunpunt: Nee
Php 5
« Reactie #7 Gepost op: 2007/04/28, 20:51:25 »
Citaat van: Sven1989
Weet er iemand de fout zitten ? Wanneer ik op btnVerzenden klik gebeurt er gewoon niks...


S-Net


Inleidende tekst over mijn provider












if(isset($_POST['btnVerzenden'])){
mkdir("/var/www/hahahaha",0777);
print "done";
}

?>
Zo zou het moeten:
Citaat
if(isset($_POST['btnVerzenden'])){
mkdir("/var/www/hahahaha",0777);
print "done";
}
?>





S-Net


Inleidende tekst over mijn provider



' >








Pagina opslaan als .php
De pagina opent, voor de eerste keer. Ziet dat btnVerzenden nog niet is gezet en slaat dat stukje dus over.
Het formulier komt in beeld en kan ingevuld en verzonden worden.
Omdat je de pagina naar zichzelf verwijst komt hij direct weer terug.
Op dat moment is btnVerzenden wel gezet en kan de script zijn werk doen.

Voor mkdir moet je overigens meen ik uitgaan van de documentroot zoals te zien in phpinfo().
Citaat
phpinfo()
?>
Dat is het idee er achter in ieder geval. Op dit moment even geen mogelijkheid het zelf te testen, maar je begrijpt de bedoeling hopelijk.
Verder verwijs ik je graag naar een van de vele php-help sites voor specifieke vragen over php-scripting.
Helaas is de site die ik vroeger gebruikte enige tijd geleden uit de lucht gegaan. Maar bijvoorbeeld http://phpfreakz.nl is een goede om te beginnen. Op google kom je er waarschijnlijk nog honderden tegen.

Op deze site wordt voornamelijk over linux in het algemeen en Ubuntu in het byzonder geschreven. Ook heel erg interessant ;)

EDIT; ik zie dat er al een uitgebreider antwoord is gegeven door beess. Nu ja, dan maar twee keer.
Als je denkt te weten dat de weg recht is, mis je de bocht.
lidnummer 3487(?)

Sven1989

  • Gast
Php 5
« Reactie #8 Gepost op: 2007/04/29, 15:53:40 »
Citaat van: beess
"; ?>



testje




S-Net


Inleidende tekst over mijn provider.



 
 

 
 

 

if(isset($_POST['btnVerzenden'])){
mkdir("/var/www/hahahaha",0777);
print "done";
}

?>

Opslaan als blabla.php, zien dat die voldoende rechten heeft op je server - anders krijg je foutmelding, en laten lopen. Werkt hier prima.
Het werkt, ik krijg idd wel die foutmelding van die rechten. Hoe kan ik dat php bestand nu voldoende rechten geven ?

beess

  • Gast
Php 5
« Reactie #9 Gepost op: 2007/04/29, 16:47:14 »
sudo chmod +x blablabla.php

Sven1989

  • Gast
Php 5
« Reactie #10 Gepost op: 2007/04/29, 20:13:33 »
Ik blijf dezelfde foutmelding krijgen:

Warning: mkdir() [function.mkdir]: Permission denied in /var/www/S-Net/index.php on line 15
done

Offline muksie

  • Lid
  • Steunpunt: Nee
Php 5
« Reactie #11 Gepost op: 2007/04/29, 20:18:52 »
Je bent waarschijnlijk ook nog schrijfrechten in de www directory nodig. Dus doe even sudo chmod +w /var/www

Sven1989

  • Gast
Php 5
« Reactie #12 Gepost op: 2007/04/29, 23:49:27 »
Werkt nog steeds niet. Aan wat kan het nog liggen ?

beess

  • Gast
Php 5
« Reactie #13 Gepost op: 2007/04/30, 10:48:44 »
1) Geef eens de preciese foutmelding, en in het geval van een regelnummer de regels uit je php-bestand ?
2) Toon eens de output van "ls -al /var/" en "ls -al /var/www/"

Wat je nog kan proberen is "sudo chmod -R +rwx /var/www/"

Sven1989

  • Gast
Php 5
« Reactie #14 Gepost op: 2007/04/30, 11:25:59 »
Het enige wat ik nu al bereikt heb is dat ik nu zelfs niet meer kan surfen naar mijn webserver vanaf de client :s

Kan ik die commands ongedaan maken ofzo ??

beess

  • Gast
Php 5
« Reactie #15 Gepost op: 2007/04/30, 14:35:34 »
Je geeft te weinig informatie om echt gericht hulp te kunnen bieden. Het commando chmod past enkel de rechten aan op een bestand, en verandert voor de rest niets aan bestanden. "chmod -R +rwx /var/www/" zet alle rechten op de map /var/www en al diens submappen op read, write en execute.
Geef bij foutmeldingen de volledige tekst mee. Waarom kan je niet meer surfen ? Wat heb je dan allemaal precies gedaan ? Welke foutmelding krijg je precies ? Surf je binnen je eigen netwerk met een ubuntu server ?

Kortom : geef eens wat meer informatie dan "Het werkt niet, wat nu ?", okay ?

Sven1989

  • Gast
Php 5
« Reactie #16 Gepost op: 2007/04/30, 14:48:19 »
Zoals ik hierboven al schreef: Warning: mkdir() [function.mkdir]: Permission denied in /var/www/S-Net/index.php on line 15
Na het uitvoeren van de command: chmod -R +rwx /var/www/ kan ik niet meer surfen naar mijn webserver. Beide pc's staan in hetzelfde netwerk.

Foutmelding als ik nu surf naar mijn webserver:

ERROR
The requested URL could not be retrieved

--------------------------------------------------------------------------------

While trying to retrieve the URL: http://192.168.0.163:8080/

The following error was encountered:

Connection to 192.168.0.163 Failed
The system returned:

    (111) Connection refusedThe remote host or network may be down. Please try the request again.

Your cache administrator is webmaster.



--------------------------------------------------------------------------------

Generated Mon, 30 Apr 2007 13:34:48 GMT by ubuntu.telenet.be (squid/2.6.STABLE1)

Sven1989

  • Gast
Php 5
« Reactie #17 Gepost op: 2007/04/30, 15:37:25 »


Voldoende info om mij voort te helpen ??

beess

  • Gast
Php 5
« Reactie #18 Gepost op: 2007/04/30, 16:10:31 »
Owkay, foutje van mij in een hoger vermeld commando : gebruik "sudo chmod -R 777 /var/www/" en je volledige web-folder is - heel onveilig, maar je zit op vmware - volledig bewerkbaar door iedereen. Da's een oplossing voor je script, niet voor het feit dat je niet kan surfen naar je webserver.

Heb je ook nog een foutmelding waarbij je niet kan surfen naar je server ?

Sven1989

  • Gast
Php 5
« Reactie #19 Gepost op: 2007/05/01, 16:02:35 »
Ik krijg volgende foutmelding als ik naar mijn server surf:

ERROR
The requested URL could not be retrieved

--------------------------------------------------------------------------------

While trying to retrieve the URL: http://192.168.0.163:8080/

The following error was encountered:

Connection to 192.168.0.163 Failed
The system returned:

    (111) Connection refusedThe remote host or network may be down. Please try the request again.

Your cache administrator is webmaster.

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
Php 5
« Reactie #20 Gepost op: 2007/05/01, 17:50:31 »
Het kan zijn dat dat een interne ipares betreft waar je van buitenaf naartoe wil, in dat geval heb je de externe ipadres nodig.
Het kan zijn dat poort 8080 niet open is, dan even kijken in je ports bestand.

beess

  • Gast
Php 5
« Reactie #21 Gepost op: 2007/05/02, 07:44:49 »
check ook even of apache nog loopt. Kan je pingen naar je server ?