Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Mounten lunkt niet meer  (gelezen 437 keer)

Offline erikvb

  • Lid
Mounten lunkt niet meer
« Gepost op: 2016/12/11, 13:31:27 »
Ik heb een nieuwe Ubuntu versie geïnstaleerd (Lubuntu 16.10).
Nu lukt het mounten via Fstab niet meer.
Zit een USB windows schijf op mijn router.
Gebruik de opdracht regel in Fstab:
//192.168.1.1/volume9/data /media/data cifs uid=1000,credentials=/home/beelen/.smbcredentials.txt,iocharset=utf8,sec=ntlm 0 0

Dir is aangemaakt in media.
Cifs is geïnstalleerd.
Op de vorige versie werkte alles prima op deze wijze.
In PCManFM verschijnt wel de map data.
als ik daar echter op klik krijg ik nu de melding "Alleen systeembeheerders hebben het recht om dit te doen".

Lijkt erop dat ik niet de juiste rechten heb, wat nooit was.
Iemand enige idee op het weer werkzaam te krijgen ?

Offline erikvb

  • Lid
Re: Mounten lukt niet meer
« Reactie #1 Gepost op: 2016/12/30, 23:12:18 »
Had meer van de Ubuntu gemeenschap verwacht.
Lubuntu opnieuw geïnstalleerd, probleem blijft.
Een een OS upgrade is dus een slecht idee en kennelijk niet op te lossen aangezien er niemand is met een oplossing.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Mounten lunkt niet meer
« Reactie #2 Gepost op: 2016/12/31, 10:38:13 »
Voeg bij de opties eens "noauto" toe, en ga dan pas later over tot het aankoppelen van de netwerkschijf, bijvoorbeeld door het toevoegen van een mount commando in /etc/rc.local.

mount /media/data

Mijn vermoeden is dat mogelijk cifs nog niet beschikbaar is op het ogenblik dat fstab uitgevoerd wordt. Met mijn suggestie kondig je enkel de netwerkschijf aan, maar voer je de mount nog niet effectief uit. Dat doe je dan pas later, op het ogenblik dat rc.local uitgevoerd wordt (zowat op het einde van het bootproces).

Tja, we zijn hier allen amateurs en vrijwilligers zoals jij. Niet iedereen heeft ook noodzakelijk je bericht gezien. Jou bericht is "ondergesneeuwd" geraakt. Je mag, als er geen respons is na 24 uur, gerust eens (beleefd) "bumpen": dat is perfect OK.

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Mounten lunkt niet meer
« Reactie #3 Gepost op: 2016/12/31, 11:10:12 »
Map die je gemaakt hebt, waar je je router aan koppelt, wat voor rechten heeft deze map?
Verander deze eens naar je gebruiker.

Offline kareltjekrul

  • Lid
  • Steunpunt: Nee
Re: Mounten lunkt niet meer
« Reactie #4 Gepost op: 2016/12/31, 11:51:37 »
Ik heb daar ook het nodige mee gekl--t, na deze toevoeging in fstab werkt het bij mij, dir_mode=0777,file_mode=0777
Misschien bij jou ook?

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Mounten lunkt niet meer
« Reactie #5 Gepost op: 2016/12/31, 12:24:09 »
Ik heb hier ook een router met USB poorten. Ik heb het kunnen uittesten. Ook ik maak gebruik van een credentials bestand, met daarin een username en password. Als ik dat doe met dezelfde fstab opties als uit de startpost, dan werkt het gewoon. Dit zowel in Ubuntu 14.04 en Xubuntu 16.10. De rechten van de map waarin de USB-stick van de router wordt aangekoppeld, heb ik niet hoeven wijzigen. Wel heb ik cifs-utils moeten installeren.

sudo apt-get install cifs-utils [Enter]
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline erikvb

  • Lid
Re: Mounten lunkt niet meer
« Reactie #6 Gepost op: 2017/01/03, 21:35:37 »
A) Pardon, was wat snel met reactie, zal het bumpen onthouden, al verschillende zaken opgelost d.m.v. forum doorzoeken maar deze wil niet lukken.

B)
Geen van de opties hebben geholpen  >:(.
CIFS was al geïnstalleerd.
Dir en file mode helpen ook niet.
Map eigenaar geprobeerd als root of gebruiker (UID=1000), maakt ook geen verschil.
Noauto met mount regel in /etc/rc.local doet het ook niet, heb bestand rc.local aangemaakt maar daar lijkt het systeem niks mee te doen.
Het lijkt wel te maken te hebben met opstarten, mounten, nog geen netwerk tijdens boot.
Als ik na het opstarten in terminal het sudo mount -a command geef is de map wel bereikbaar.
Wil hem echter aangekoppeld hebben zodra systeem draait, dit voor backup doeleinde.
Blijft nog steeds het vreemde detail dat onder de oude OS versie ik in locaties een netwerk map kreeg die ik meteen kon openen, nu krijg ik de
"Alleen systeembeheerders hebben het recht om dit te doen" melding.


Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Mounten lunkt niet meer
« Reactie #7 Gepost op: 2017/01/04, 05:37:49 »
Maak dan een script die even wacht en dan de mount doet,
mount -a
En voor de mount sleep 2
dus een teksdt file die op het einde sh heet.
hardeschijf.sh

sleep 2
mount -a

Sleep kun je misschien nog verhogen.
Zoek ook even hoe je een script maakt en of sleep de goede is.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Mounten lunkt niet meer
« Reactie #8 Gepost op: 2017/01/04, 10:19:47 »
Mijn vermoeden blijkt dus juist. Je dient dus wat later tijdens de opstart te mounten. Klassiek had je rc.local, wat in Ubuntu 16.04 standaard geactiveerd is. /etc/rc.local lijkt echter aan het verdwijnen te zijn: hier is een interessant artikeltje daarover.

Probeer eens de optie _netdev in je /etc/fstab? Deze optie zou er moeten voor zorgen dat er gewacht wordt met mounten tot het netwerk beschikbaar is.

Offline erikvb

  • Lid
Re: Mounten lunkt niet meer
« Reactie #9 Gepost op: 2017/01/05, 21:40:40 »
Mmmm, alles getracht wil niet lukken vanaf boot.
_netdev, geen effect.
rc.local gemaakt, geen resultaat. staat in /etc, rechten root en iedereen mag hem uitvoeren.
een script gemaakt in Netschijf.sh, script werkt als ik het uitvoer, maar doet bij opstart niks !

Dus zoek druk verder.
Het detail van de locaties waarbij er wel een netwerk map door het systeem wordt gemaakt maar niet gemount en waarbij ik ook niet de rechten heb om te mounten als ik er op klik blijft denk ik wel de oorzaak van mijn probleem. Dit was in de oude OS versie wel direct goed.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Mounten lunkt niet meer
« Reactie #10 Gepost op: 2017/01/05, 22:31:06 »
Blijkbaar zijn er geen gemakkelijke oplossingen meer om zelf iets bij de opstart te regelen. systemd ondersteunt niet meer standaard het gebruik van rc.local (de autoexec.bat van linux, zeg maar), tenzij je distributie dit implementeert (zoals standaard Ubuntu 16.04, maar blijkbaar niet Lubuntu. Mogelijk moet je je zelf eens in systemd verdiepen (zie een primer hier of een voorbeeld hier.

Misschien een gemakkelijker oplossing als dat aanvaarbaar is: koppel automatisch aan na het inloggen, via je opstartprogramma's.
- Voeg in de opties in fstab "noauto,users" toe
- Koppel aan via je startup applicaties met het commando "mount /media/data"

Ze maken het leven met rc.local opzettelijk moeilijk omdat dat een zwak punt is dat gemakkelijk gehackt kan worden.

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Mounten lunkt niet meer
« Reactie #11 Gepost op: 2017/01/05, 22:43:12 »
Ik heb hier 2 netwerk volumes - weliswaar NFS - die automatisch aangekoppeld worden zodra de netwerk verbinding tot stand komt. In /etc/fstab met volgende lijnen:banana:/data/ /srv/data nfs rw,intr,hard,comment=systemd.automount,noatime 0 0
banana:/iso/ /srv/iso nfs rw,intr,hard,comment=systemd.automount,noatime 0 0
Mogelijks werken deze opties ook voor CIFS?

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Mounten lunkt niet meer
« Reactie #12 Gepost op: 2017/01/06, 08:49:06 »
Mogelijks werken deze opties ook voor CIFS?
Zeker niet. Specifieke opties voor cifs vind je in man mount.cifs. In principe is de (algemene) _netdev optie net bedoeld voor het probleem hier, maar dat blijkt niet te werken.

Offline erikvb

  • Lid
Re: Mounten lunkt niet meer
« Reactie #13 Gepost op: 2017/01/24, 22:51:43 »
Even druk met werk en verdiepen in systemd, uitvoerbaar scrppt, .sh bestand maken.
Voor een deel gelukt.
Bij opstarten is de schijf bereikbaar.
Bij een reboot niet meer.
Dus niet 100% betrouwbaar.
We ploeteren verder, wel met enig plezier, programmeren lang niet gedaan.

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Mounten lunkt niet meer
« Reactie #14 Gepost op: 2017/01/25, 07:31:09 »
Zet in je script ook
sleep 2
of langer, dan wacht de script een bepaalde tijd, voordar deze wordt uitgevoerd, en je linux kan dan eerst goed opstarten.