Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Niet ontwaken na suspend (pauze)  (gelezen 251 keer)

Offline 10o

  • Lid
  • Steunpunt: Nee
Niet ontwaken na suspend (pauze)
« Gepost op: 2016/12/07, 10:17:59 »
Onlangs verse installatie gedaan van 16.04.1 op mijn workstation met volledige encryptie (luks). Sindsdien ontwaakt het systeem niet (zichtbaar) uit suspend (pauzestand). Zodra ik de (knipperende) powerbutton indrukt, zie ik aan de knipperde leds op de case dat het systeem bezig is, maar de monitor gaat meteen in slaapstand. Toetsenbord licht wel op, maar ik kom met geen mogelijkheid het systeem binnen. Hard uitzetten is de enige oplossing.

De nvidia drivers heb ik uitgezet. Draai dus weer op standaard X.Org X server. Als ik de aangeboden NVIDIA binary driver version 367.57 van nvidia gebruik, krijg ik in de beginfase van de boot geen mogelijkheid (te zien) om het systeem te decrypten. Wellicht is er een relatie met mijn grafische hardware in dezen...?

Op basis van enkele engelstalige draadjes leek het niet ontwaken uit suspend te maken te kunnen hebben met een impliciet encrypted swap. Dus heb ik in /etc/crypttab en /etc/fstab desbetreffende swap regels uitgecommentarieerd. Met 16GiB geheugen is een swap toch niet perse nodig. Dat leek even te helpen, maar blijkt niet zo te zijn. Dus ook zonder swap, is de pauzestand onwerkbaar.

Nu kan ik het systeem en mijn data wel veilig stellen door te locken met ctrl-alt-L, maar om energie te besparen, maak ik natuurlijk liever gebruik van de suspend/pauze stand.

Heeft iemand enig idee wat er aan de hand kan zijn en welke oplossingsrichtingen er mogelijk nog zijn?
« Laatst bewerkt op: 2016/12/07, 14:38:54 door 10o »
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Niet ontwaken na suspend (pauze)
« Reactie #1 Gepost op: 2016/12/11, 13:49:14 »
Extra info: het lijkt erop dat de duur van de pauze van invloed is op het al dan niet kunnen ontwaken. Als ik binnen enkele minuten laat ontwaken, lukt het namelijk wel...
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Niet ontwaken na suspend (pauze)
« Reactie #2 Gepost op: 2016/12/11, 15:15:37 »
Link verschijnsel in combinatie met volledige versleuteling....  :o

Overweeg eens om over te schakelen op een beperktere versleuteling, bijvoorbeeld uitsluitend je /home?

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Niet ontwaken na suspend (pauze)
« Reactie #3 Gepost op: 2016/12/11, 15:49:57 »
Da's inderdaad tricky, mocht ik niet meer binnen kunnen komen. Omschakelen is volgens mij niet mogelijk, behalve door een volledige herinstallatie te doen. En dat is nu precies wat ik probeer te voorkomen gezien de hoeveelheid tijd die daarmee gemoeid is (ondanks install scripts)... Maar uhm, dit zou toch gewoon moeten kunnen werken? Precies waar linux in uit zou moeten blinken, lijkt me. Frappant dat suspend wel netjes zijn werk kan doen als de suspend tijd beperkt is. Dat was voor het uitzetten van swap overigens niet het geval.
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Niet ontwaken na suspend (pauze)
« Reactie #4 Gepost op: 2016/12/12, 19:35:52 »
Toch maar een nieuwe install gedaan... Dus nu is alleen /home encrypted. In eerste instantie bleef exact het probleem zich voordoen. Maar nu ik de aangeboden nvidia drivers heb geactiveerd (in plaats van de default X.Org server) gaat het wel goed. Kortom, er lijkt hier een relatie te zijn tussen suspend en de grafische drivers.

Met de nvidia grafische drivers geactiveerd kon ik eerder (bij full encryption) het systeem niet eens booten omdat het decrypt scherm niet zichtbaar werd. Uiteindelijk heb ik met veel gedoe in een "veilige" grafische boot de boel kunnen omzetten naar de X.Org server, maar dan werkte het terugkomen uit suspend dus niet meer.

Anyway, voor nu ben ik persoonlijk uit de brand.
« Laatst bewerkt op: 2016/12/13, 09:45:16 door 10o »
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline spievensterke

  • Lid
  • Steunpunt: Nee
Testlaptop Toshiba Satellite L500-1C7 - Ubuntu Maté 16.04.2 LTS -64bit- in dualboot met LinuxMint Maté 18.1 -64bit-   Hdd 250GB  Intel Mobile Video /
AcerOne10  ( Hybride, 2 in 1 ) met Ubuntu 16.04.3 LTS -64bit- 32bit Uefi.

Offline 10o

  • Lid
  • Steunpunt: Nee
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)