Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!  (gelezen 9485 keer)

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Gepost op: 2007/04/26, 12:56:37 »
Bekend probleem als je een Nvidia videokaart hebt, met de fabrieksdriver geïnstalleerd: in Feisty wil de beeldfrequentie voor een TFT-scherm, niet hoger trillen dan 50 of 55 Hz. Althans, dat lijkt zo, want in feite trilt hij hoger! Controleer de frequentie maar eens in het BIOS van je scherm (via de fysieke knoppen op je scherm).

Er is een oplossing voor! Ik had deze fout gemeld bij Canonical, via Launchpad. De fout blijkt te zitten in de driver van Nvidia, en niet in Ubuntu zelf. Het heeft te maken met Twinview (als je twee schermen hebt gekoppeld aan je videokaart). De Nvidia driver onderscheidt blijkbaar de schermen aan de hand van hun trillingsgetal. Probleem is alleen, dat Twinview zich als een storende factor gaat gedragen als je maar één scherm hebt.....

De oplossing is het uitschakelen van Twinview (tip van Ubuntu-ontwikkelaar).

Als volgt:
Toepassingen - Hulpmiddelen - Terminalvenster
sudo gedit /etc/X11/xorg.conf

Voeg de volgende tekst toe aan de Section "Screen" van xorg.conf:
Option         "DynamicTwinView"    "FALSE"
Voorbeeld:
Section "Screen"
    Identifier     "Default Screen"
    Device         "nVidia Corporation NV17 [GeForce4 MX 440]"
    Monitor        "HP vs17e"
    DefaultDepth    24
    Option         "UseEdidFreqs" "FALSE"
    Option         "DynamicTwinView" "FALSE"
    Option         "AddARGBVisuals" "True"
    Option         "NoLogo" "True"
    Option         "AddARGBGLXVisuals" "True"
Opslaan, sluiten en herstarten. Controleer daarna even of het heeft gewerkt:
Systeem - Voorkeuren - Schermresolutie

Groet, Pjotr.

koos

  • Gast
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #1 Gepost op: 2007/04/26, 13:07:33 »
ik heb geen tft, toch werkte dit voor mij ook, resolutie stond op 50 Hz, na deze aanpassing op 60 Hz.
bedankt voor de tip

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #2 Gepost op: 2007/04/26, 23:03:14 »
Graag gedaan! Hopelijk helpt deze tip nog meer mensen.

DPC

  • Gast
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #3 Gepost op: 2007/04/27, 07:18:02 »
Mooie tip Pjotr.

Mijn resolutie stond ook op 50 Hz, maar het beeld was wel goed.
Nu staat hij netjes op 75 Hz.
Ook gewoon een CRT monitor trouwens




Offline mcgyver

  • Lid
  • Steunpunt: Nee
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #4 Gepost op: 2007/04/27, 15:20:49 »
Je bedoelt waarschijnlijk  refreshrate? Zo ja, even de titel aanpassen want deze is wel heel belangrijk.

We hebben trouwens exact dezelfde videokaart Pjotr, fijn om dat te weten. (your problems are my problems)

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #5 Gepost op: 2007/04/27, 16:17:57 »
@Pjotr:
Deze regel:
   Option         "AddARGBGLXVisuals" "True"Heb je er dubbel in staan.
Het zal wel geen kwaad kunnen, maar het hoort natuurlijk niet :)

Edit: Ik zie net dat het 2 verschillende regels zijn:
AddARGBGLXVisuals
en
AddARGBVisuals

Ik heb maar 1 van die 2 er in staan, namelijk AddARGBGLXVisuals

Wat is het verschil tussen die 2, en waarom heb jij ze er beide in staan?

Nizzle

  • Gast
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #6 Gepost op: 2007/04/27, 16:37:24 »
werkte voor mij met kapotte CRT monitortje :)

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #7 Gepost op: 2007/04/27, 18:07:16 »
@Bedankt pjotr123 voor de tip.
Nu blijft mijn CRT monitor op 85 Hz staan.


Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline noyomipa

  • Lid
  • Steunpunt: Nee
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #8 Gepost op: 2007/04/27, 18:50:52 »
Citaat van: pjotr123
Bekend probleem als je een Nvidia videokaart hebt, met de fabrieksdriver geïnstalleerd: in Feisty wil de schermresolutie voor een TFT-scherm, niet hoger dan 50 of 55 Hz.

Er is een oplossing voor! Ik had deze fout gemeld bij Canonical, via Launchpad. De fout blijkt te zitten in de driver van Nvidia, en niet in Ubuntu zelf. Het heeft te maken met Twinview (als je twee schermen hebt gekoppeld aan je videokaart). De Nvidia driver onderscheidt blijkbaar de schermen aan de hand van hun schermresolutie. Probleem is alleen, dat Twinview zich als een storende factor gaat gedragen als je maar één scherm hebt.....

De oplossing is het uitschakelen van Twinview (tip van Ubuntu-ontwikkelaar).

Als volgt:
Toepassingen - Hulpmiddelen - Terminalvenster
sudo gedit /etc/X11/xorg.conf

Voeg de volgende tekst toe aan de Section "Screen" van xorg.conf:
Option         "DynamicTwinView"    "FALSE"
Voorbeeld:
Section "Screen"
    Identifier     "Default Screen"
    Device         "nVidia Corporation NV17 [GeForce4 MX 440]"
    Monitor        "HP vs17e"
    DefaultDepth    24
    Option         "UseEdidFreqs" "FALSE"
    Option         "DynamicTwinView" "FALSE"
    Option         "AddARGBVisuals" "True"
    Option         "NoLogo" "True"
    Option         "AddARGBGLXVisuals" "True"
Opslaan, sluiten en herstarten. Controleer daarna even of het heeft gewerkt:
Systeem - Voorkeuren - Schermresolutie

Groet, Pjotr.
nu zonder moeilijk doen 1680x1050 / 60 THX!!
OS:  ubuntu + Budgie DE 18.04/64
Ubuntu-user  12044

Pensacola

  • Gast
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #9 Gepost op: 2007/04/27, 19:10:44 »
Ik ben blijkbaar de enige waar het niet werkt :'(

Nizzle

  • Gast
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #10 Gepost op: 2007/04/27, 19:30:48 »
Citaat van: Pensacola
Ik ben blijkbaar de enige waar het niet werkt :'(
al restart gedaan?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #11 Gepost op: 2007/04/27, 20:08:05 »
Ik stel voor, dat we deze fout in de Linuxdriver melden aan Nvidia:
http://nvidia.custhelp.com/cgi-bin/nvidia.cfg/php/enduser/ask.php?p_sid=-k7Dq4Wh&p_sp=cF9zcmNoPSZwX3NvcnRfYnk9JnBfZ3JpZHNvcnQ9JnBfcm93X2NudD0yNTYmcF9wcm9kcz0mcF9jYXRzPSZwX3B2PSZwX2N2PSZwX3BhZ2U9MQ**&p_email=&p_sla=

Wie doet er mee?

Ik heb de volgende tekst ingestuurd:

There is a bug in the Linuxdriver for my GeForce4 MX 440 graphics card. I use Ubuntu Linux 7.04.

This confirmed bug is in the Twinview option. I have only one screen, and default I cannot get a higher refresh rate than 50 Hz.

I can only achieve higher refresh rates when I disable Twinview in my xorg.conf, by adding the following line to the Section "Screen" of my xorg.conf:
Option         "DynamicTwinView" "FALSE"

Please repair your Linuxdriver.

Thanks in advance, Pjotr.

@Johanvd:
Ik heb alleen de fabrieksdriver geïnstalleerd en daarna Beryl geïnstalleerd op de volgende wijze:
https://wiki.ubuntu.com/NederlandstaligeDocumentatie/Beryl
Verder niks.

Pensacola

  • Gast
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #12 Gepost op: 2007/04/27, 20:28:45 »
Nizzle: als ik niet restart kan ik ook niet weten dat ie niet werkt :D (Ctrl+Alt+Backspace voor alle duidelijkheid ;))

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #13 Gepost op: 2007/04/27, 20:35:16 »
@pjotr
top, ben benieuwd naar de reactie van nvidia.je hebt ook een bugmelding gedaan in launchpad? veel mensen hebben profijt van deze howto. :)

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #14 Gepost op: 2007/04/27, 20:36:01 »
Ik zou dit: I have only one screen, and default I cannot get a higher resolution than 50 Hz.
Veranderen in:
I have only one screen, and default I cannot get a higher refreshrate than 50 Hz.

Overigens gebeurt het ook op andere kaarten, en waarschijnlijk willen ze ook wel weten welke versie driver je gebruikt.
(nvidia-glx of nvidia-glx-new)
Ik heb het probleem namelijk ook (Geforce 6600GT, glx-new drivers, dvi aansluiting)

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #15 Gepost op: 2007/04/27, 20:46:01 »
inderdaad "refresh rate". Toegevoegd aan foutmelding en gewijzigd in berichten.


Offline dorusone

  • Lid
  • Steunpunt: Nee
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #17 Gepost op: 2007/05/10, 07:25:00 »
@pjotr :  ik heb je tip gevolgd maar het lukt niet
bijgaand de betreffende xorg.conf  screen sectie

Thx
Theo



Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24

    Option         "DynamicTwinView" "FALSE"
    SubSection     "Display"
         
        Depth       24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Offline dorusone

  • Lid
  • Steunpunt: Nee
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #18 Gepost op: 2007/05/11, 06:58:17 »
ik ben er al uit via onderstaand :

http://www.ubuntugeek.com  

Howto Install Beryl with latest nvidia drivers in Ubuntu Feisty Fawn

voortreffelijke Ubuntu site overigens...........

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #19 Gepost op: 2007/05/11, 09:01:36 »
Citaat van: dorusone
ik ben er al uit via onderstaand :

http://www.ubuntugeek.com  

Howto Install Beryl with latest nvidia drivers in Ubuntu Feisty Fawn

voortreffelijke Ubuntu site overigens...........
waar staat hoe de refreshrate kan aanpassen? ik zoek me ongeluk. dat was toch je vraag richting pjotr?
voor het installeren van beryl op feisty( een totaal andere vraag ) ken ik een leuke site die exact hetzelfde als vertelt als bovenstaande: https://wiki.ubuntu.com/NederlandstaligeDocumentatie/Beryl#preview

VrolijkUbuntu

  • Gast
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #20 Gepost op: 2007/05/11, 17:45:47 »
Het is al een ouder topic maar ik heb me wezenloos zitten zoeken!!
Draai Ubuntu nu bijna 2 weken en kreeg die resolutie maar niet goed, wat ik ook probeerde in de nvidia consule (via sysinfo) ik bleef maar lagere resoluties houden.
Mijn dank is bijzonder groot!!!

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #21 Gepost op: 2007/05/11, 18:43:03 »
Mooi! Blij dat er weer iemand is geholpen. Volgens de technische ondersteuningsdienst van Nvidia zelf, is het trouwens niet echt een probleem: Gnome "liegt" over de frequentie, vermeldt hem lager dan hij in feite is.

Je kunt de echte waarde controleren via de knoppen op het beeldscherm zelf (het BIOS van het beeldscherm). Maar goed, het is een stom probleem en het moet de wereld uit. Mensen raken ervan in de war.

Groet, Pjotr.

Offline tabasco

  • Lid
  • Steunpunt: Nee
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #22 Gepost op: 2007/05/11, 18:47:39 »
Bedankt voor deze geweldige tip! (Ben ook een MX440 bezitter)

Echter na opstarten, correcte 85Hz, maar op mijn panel is het mount icoon verdwenen en kan 'em ook niet meer plaatsen. Dit kan toch geen verband hebben met elkaar!?!
Misschien dat deze disk mounter alleen op 50hz werkt :)

[edit]

Sorry, na een volledige reboot werkt t wel 5 iconen weer verwijderd. Dus ctrl-alt-backspace is niet aan te raden.
Groet,

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #23 Gepost op: 2007/05/12, 15:58:09 »
moet gezien post #item 22 de titel van dit topic nog aangepast worden?
het zet de refreshrate problematiek wel in een ander daglicht.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Oplossing gevonden voor beeldfrequentie Nvidia in Feisty!
« Reactie #24 Gepost op: 2007/05/12, 18:04:53 »
Citaat van: leoquant
moet gezien post #item 22 de titel van dit topic nog aangepast worden?
het zet de refreshrate problematiek wel in een ander daglicht.
Nou, de titel is toch nog goed, denk ik. Want mensen doorzoeken het forum gericht op precies dit "probleem". Anders wordt de titel onduidelijk.

Wel heb ik de beginregels van mijn eerste post aangepast:
"Bekend probleem als je een Nvidia videokaart hebt, met de fabrieksdriver geïnstalleerd: in Feisty wil de beeldfrequentie voor een TFT-scherm, niet hoger trillen dan 50 of 55 Hz. Althans, dat lijkt zo, want in feite trilt hij hoger! Controleer de frequentie maar eens in het BIOS van je scherm (via de fysieke knoppen op je scherm)."

Zo is het 't makkelijkste voor iemand die een oplossing zoekt.