Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Numlock  (gelezen 279 keer)

Offline dan

  • Lid
Numlock
« Gepost op: 2016/09/06, 16:39:17 »
Schakel het cijfertoetsenblokje van uw toetsenbord in (Num Lock)
Hallo  Potjr,

ik heb uit bovenstaande artikel alles exact uitgevoerd en nog steeds wil numlock niet aan.

enig idee wat er nog kan gedaan worden

tnx

dan

Offline staf

  • Lid
Re: Numlock
« Reactie #1 Gepost op: 2016/09/06, 17:22:19 »
Het is numlockx en niet Num Lock or whatever

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: Numlock
« Reactie #2 Gepost op: 2016/09/06, 20:12:11 »
Kan het zijn, dat het wel werkt, maar dat het lampje niet aangaat?
Dat heb ik n.l. op één van mijn laptops..............
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

Offline dan

  • Lid
Re: Numlock
« Reactie #3 Gepost op: 2016/09/06, 21:10:11 »
@ staf  ja idd is juist wat je schrijft maar ik heb juist de titel gekopieerd van de uitleg om hier te plaatsen.
maar in het hoe staat het dan juist en heb het gedaan zoals beschreven met de juiste schrijfwijze.

@ron

bij mij gaat het over een toetsenbord van een pc dus geen laptop
zou dat dan niet werken als het geen laptop is?
het lampje is niet kapot want als ik op numlock tots druk brand het ledje

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: Numlock
« Reactie #4 Gepost op: 2016/09/06, 21:23:13 »
het lampje is niet kapot want als ik op numlock toets druk brand het ledje
Met numlockx on gaat de numlock aan en met numlockx off gaat deze weer uit.
Bij mij werkt alles, alleen het lampje niet, dat is wat ik schreef.
Heb jij hetzelfde, of werkt de numlock zelf ook niet, evenals het lampje.
Voor de goede orde, op 2 laptops werkt het goed, op een 3e niet, zoals ik hierboven uitleg.
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

Offline MKe

  • Lid
  • Steunpunt: Nee
Re: Numlock
« Reactie #5 Gepost op: 2016/09/07, 12:05:04 »
Welke variant gebruik je?

Er is namelijk in Ubuntu een eenvoudiger manier dan bovenstaande om numlock automatisch te zetten, namelijk via de keyboard layout in de system settings. Zie (in engels) https://help.ubuntu.com/community/NumLock


Nadeel is dat de numlock pas werkt nadat je ingelogged bent en dat het niet werkt als je rechtstreeks naar de console inlogged. Maar dat is voor de meeste gebruikers niet echt een probleem denk ik.

edit: ik weet niet waarom het plaatje niet te voorschijn komt. Zou toch moeten werken. Maar goed, je kunt het plaatje in de andere link zien.
« Laatst bewerkt op: 2016/09/07, 12:07:19 door MKe »
Mijn blokkendoos blog: http://mke21.wordpress.com/

Offline dan

  • Lid
Re: Numlock
« Reactie #6 Gepost op: 2016/09/07, 14:26:30 »
@ ron  het lampje floept even aan bij het opstarten en dan is het weer uit.
als ik dan mijn paswoord wil invoeren welke cijfers bevat dan werkt het dus niet.
moet dan op de toests numlock drukken om het werkend te krijgen.

@MKe  als ik het goed begrijp dan zou ik na install numlockx ( welke ik al gedaan had in een vorige poging) het script moeten uitvoeren.


Enabling Numlock on startup can be done of several different ways. First install numlockx:
sudo apt-get install numlockx

bovenstaande is al gedaan geweest

Place command with init scripts

sudo sed -i 's|^exit 0.*$|# Numlock enable\n[ -x /usr/bin/numlockx ] \&\& numlockx on\n\nexit 0|' /etc/rc.local   dit zou ik dus moeten uitvoeren.
ben nog maar onlangs met ubuntu van start gegaan daarom deze vragen.

het is idd niet zo erg dat numlock niet direct bij het opstarten   werkt maar 't zou wel handiger zijn, soms vergeet ik wel eens op de numlock toets te drukken  :)

Dan

Offline MKe

  • Lid
  • Steunpunt: Nee
Re: Numlock
« Reactie #7 Gepost op: 2016/09/07, 18:53:45 »
Voor zover ik weet kun je dus in unity zonder numlockx gewoon in de settings de numlock uit zetten.
Via toetsenborden. Bekijk het plaatje maar eens in die link.

Offline Suns

  • Lid
  • Steunpunt: Nee
Re: Numlock
« Reactie #8 Gepost op: 2016/09/09, 07:45:32 »
Hallo,

Ik doe het altijd zo en werk hier....

sudo apt-get install numlockx


gksudo gedit /etc/lightdm/lightdm.conf

( en dan onder de regel die er al in het bestand staat staat  de volgende regel toevoegen en opslaan )

greeter-setup-script=/usr/bin/numlockx on