Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: unmounten NAS-directories tijdens afsluiten duurt lang  (gelezen 94 keer)

Offline neerke62

  • Lid
unmounten NAS-directories tijdens afsluiten duurt lang
« Gepost op: 2016/08/31, 16:14:29 »
Ik heb in het fstab een regel opgenomen waarmee de NAS-directories tijdens het opstarten automatisch worden gekoppeld. De regel is als volgt:
//XXX.XXX.XXX.XX/video /media/video cifs username=XXXX,password=XXXXXXX,rw,noperm,iocharset=utf8,dir_mode=0777,file_mode=0777 0 0.

In 14.04 werkte dit goed en was er met afsluiten geen probleem. Na het upgraden naar 16.04 werkt het koppelen nog steeds goed maar het afsluiten duurt lang. Als ik met CTRL ALT F1 de voortgang van het afsluiten bekijk zie ik eerst de melding unmounting /media/video..., gevolgd door de melding "CIFS VFS: server XXX.XXX.XXX.XX has not responded in 120 sec; reconnecting" waarna het afsluiten wordt voortgezet en de laptop uiteindelijk wordt afgesloten.

Als ik voor het afsluiten via de terminal met umount --all alle verbinding ontkoppel sluit de laptop gelijk af.

Hoe kan ik ervoor zorgen dat het unmounten tijdens het afsluiten sneller verloopt?
« Laatst bewerkt op: 2016/08/31, 16:23:02 door neerke62 »

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: unmounten NAS-directories tijdens afsluiten duurt lang
« Reactie #1 Gepost op: 2016/08/31, 21:37:12 »
Je kunt zoeken naar een oplossing, wat misschien ook het beste is.

Maar je kunt voorlopig misschien,
een script maken aflsuiten.sh
deze starten als je wilt afsluiten, met ongeveer zoiets erin,
umount --all
shutdown

De precieze commando moet je even proberen of opzoeken met google.