Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu 16.04.1 Realtek RTL8168 werkt soms niet  (gelezen 507 keer)

Offline streulma

  • Lid
Ubuntu 16.04.1 Realtek RTL8168 werkt soms niet
« Gepost op: 2016/08/31, 15:15:28 »
Het is duidelijk dat mijn Realtek RTL8168-8111 PCI-E Gigabit netwerkkaart van mijn Asus N751JX niet met Linux kan omgaan.

Betreft hier het besturingssysteem Ubuntu 16.04.1.

Werkt niet:
Wanneer ik de notebook de eerste maal aan steek krijg ik connectie.
Bij een herstart blijft hij maar zoeken naar een IP-adres met DHCP.
Bij een tweede herstart blijft het hetzelfde, hij blijft zoeken naar een IP-adres.

Workaround:
Wanneer ik de notebook de eerste maal aan steek krijg ik connectie.
Daarna zet ik de notebook volledig uit.
Bij de opstart van 0 daarna werkt het wel en krijg ik wel een IP-adres.

Wat is hier de oplossing voor?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Ubuntu 16.04.1 Realtek RTL8168 werkt soms niet
« Reactie #1 Gepost op: 2016/08/31, 15:18:49 »
Dat heeft waarschijnlijk niet te maken met de netwerkkaart, maar mogelijk wel hiermee:
https://sites.google.com/site/computertip/geenbedraadinternet

Offline streulma

  • Lid
Re: Ubuntu 16.04.1 Realtek RTL8168 werkt soms niet
« Reactie #2 Gepost op: 2016/08/31, 15:24:38 »
Juist Pjotr.... IPv6.
Dit had ik in het verleden al eens uitgezet en dan werkte het beter.

Offline streulma

  • Lid
Re: Ubuntu 16.04.1 Realtek RTL8168 werkt soms niet
« Reactie #3 Gepost op: 2016/08/31, 16:14:22 »
Nu ik het zie... Dit is de Realtek rtl8169 driver die gebruikt wordt.

Ik kwam deze bug ook al in het verleden tegen op andere computers. Maar deze sleept al een tijdje aan, is dat nu nog niet opgelost seg?

Ook met het uitzetten van IPv6 blijft hij zoeken, zelfs na een reboot en spuwt er uiteindelijk nog een stack trace bij.

Na het volledig uitzetten en terug aanzetten is het probleem opgelost.

Offline streulma

  • Lid
Re: Ubuntu 16.04.1 Realtek RTL8168 werkt soms niet
« Reactie #4 Gepost op: 2016/08/31, 16:19:49 »
Een zoekopdracht op dit forum levert me ook al heel wat resultaten op van deze netwerkkaart die problemen geeft.

Zoek maar eens op "rtl8168".

Offline streulma

  • Lid
Re: Ubuntu 16.04.1 Realtek RTL8168 werkt soms niet
« Reactie #5 Gepost op: 2016/08/31, 16:52:44 »
Pjotr...

Ik had IPv6 gedisabled in /etc/sysctl.conf maar dit bleek niet te werken.

Mijn probleem is opgelost: ik heb ipv6.disable=1 toegevoegd aan grub.

Matthias

Offline hvb

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 16.04.1 Realtek RTL8168 werkt soms niet
« Reactie #6 Gepost op: 2016/09/02, 22:16:15 »


Mijn probleem is opgelost: ik heb ipv6.disable=1 toegevoegd aan grub.

Matthias

Ik zit met hetzelfde probleem met 16.04.1  en windows 10 vandaar mijn vraag.

Hoe heb je dat gedaan het  toevoegen van ipv6.disable=1 aan grub

vast bedankt

hans

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 16.04.1 Realtek RTL8168 werkt soms niet
« Reactie #7 Gepost op: 2016/09/03, 00:51:07 »
Hier is een voorbeeld met iets anders.
https://sites.google.com/site/computertip/geenbeeld

ga naar,
"Beeld via de opstartopties van Grub"
daar staat beschreven wat je kunt proberen, en waar je het moet invullen.
Dus
ipv6.disable=1
toevoegen.