Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: NAS koppelen aan /mnt  (gelezen 1377 keer)

Offline h2o

  • Lid
  • Steunpunt: Nee
NAS koppelen aan /mnt
« Gepost op: 2016/08/06, 19:58:30 »
Op mijn werkplek hebben we onlangs een NAS gekregen. Die is zodanig geconfigureerd dat je de NAS prima kunt zien met het programma gigolo. Je kunt die nas prima benaderen met thunar en er bestanden opzetten, verwijderen enz. Je hoeft zelfs geen gebruikersnaam of wachtwoord te gebruiken. Het is een Western Digital NAS met (dacht ik)  owncloud erop.

Er is voor mij echter een probleem. Die NAS kan ik niet koppelen aan een koppelpunt op mijn werkstation en laptops. Dat heb ik eigenlijk wel nodig om er het een en ander mee te synchroniseren via rsync.
Verder is het onhandig omdat ik dan allerlei bestanden eerst moet gaan downloaden om ze te kunnen zien, bijv. foto's. En dat is best hinderlijk.

Als ik met Giglo met de NAS verbonden ben, is het mogelijk om dan de koppeling te achterhalen?
Ik heb alle gvfs zaken al geïnstalleerd.
« Laatst bewerkt op: 2016/08/06, 21:03:55 door h2o »
Laptops + werkstations: Debian Stable + backports, server Debian Stable.
Test-laptop: Debian Tesing/Unstable

Offline Roel1963

  • Lid
  • Steunpunt: Nee
Re: NAS koppelen aan /mnt
« Reactie #1 Gepost op: 2016/08/07, 11:46:30 »
Je kunt die nas prima benaderen met thunar en er bestanden opzetten, verwijderen enz. Je hoeft zelfs geen gebruikersnaam of wachtwoord te gebruiken. Het is een Western Digital NAS met (dacht ik)  owncloud erop.

Maar als je bestandsbeheer kunt toepassen dan is de NAS toch al gekoppeld? Kun je het pad in Thunar niet zien?

Geeft df -h geen info? Is er geen mount-opdracht die de mounts laat zien? Ik zou ook eens kijken in /media wat daar in zit, na gebruik van Gigolo (die ik overigens niet ken).

Offline McVries

  • Lid
  • Steunpunt: Nee
Re: NAS koppelen aan /mnt
« Reactie #2 Gepost op: 2016/08/07, 15:59:10 »
Als je nas met smb of cifs werkt dan denk ik dat hier voor jou de oplossing te vinden is:

https://forum.ubuntu-nl.org/index.php?topic=59558.msg661048
_________________________________
Ubuntu Gnome

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: NAS koppelen aan /mnt
« Reactie #3 Gepost op: 2016/08/08, 11:39:18 »
Alvast bedankt voor deze reacties.
Gigolo is een soort schil om gvfs-fuse. Ik kan met df -h geen koppelpunt ontdekken, dat is juist het vervelende.
Met cifs de zaak mounten geeft een melding dat het door mij gewenste koppelpunt /mnt niet in /etc/fstab staat. Als ik dat daar plaats dan krijg ik met mount -a de zaak ook niet gekoppeld.

Zoals ik al schreef is het een cloud situatie waarmee ik wel alles kan zien, kopiëren enz. maar ik kan met bijv. vlc geen film afspelen of met een ander programma foto's bekijken. Dan moet ik eerst alles downloaden. En uiteindelijk wil ik met rsync het een en ander synchroniseren.
Laptops + werkstations: Debian Stable + backports, server Debian Stable.
Test-laptop: Debian Tesing/Unstable

Offline MKe

  • Lid
  • Steunpunt: Nee
Re: NAS koppelen aan /mnt
« Reactie #4 Gepost op: 2016/08/09, 06:22:18 »
Voor rsync hoef je geen mountpoint te hebben hoor, je kunt rsync ook over ftp, ssh of de rsync daemon laten syncen.
Owncloud is een webdav protocol, dus je kan prima via webdav mounten met davfs. HIer een beschrijving van de Arch wiki, helaas in het engels: https://wiki.archlinux.org/index.php/OwnCloud#Mounting_files_with_davfs2

Als je smbclient hebt geinstalleerd, dan kun je de samba shares op de nas zien met:
smbclient -L <ip-van-de-nas> -U%

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: NAS koppelen aan /mnt
« Reactie #5 Gepost op: 2016/08/09, 21:45:35 »
Bedankt voor je reactie. Het is (blijkt nu) mycloud wat door Western Digital wordt gebruikt. Ik zal als ik terug ben van vakantie eens proberen of ik iets met rsync deamon kan proberen.
smbfs is geen optie omdat Debian Jessie dat niet meer gebruikt, dat is nu cifs.
Laptops + werkstations: Debian Stable + backports, server Debian Stable.
Test-laptop: Debian Tesing/Unstable

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: NAS koppelen aan /mnt
« Reactie #6 Gepost op: 2016/08/20, 18:38:15 »
Het is mij vanmiddag gelukt om de NAS van mijn werk aan mijn laptop te mounten. Dat gaat het het commando:
mount -t cifs -o user=root //x.x.x.x//bron /mnt/doelIk heb er een scriptje voor gemaakt en het werkt allemaal prima. Er zit nog één schoonheidsfoutje is. Als ik het scriptje of commando uitvoer wordt er gevraagd om het root wachtwoord voor de NAS. Dat is echter leeg omdat er op de NAS geen gebruikers zijn. Alles loopt daar via een interne cloud. Geef ik een enter dan is de NAS aangekoppeld aan mijn laptop.

Hoe krijg ik het commando zover dat er niet om een wachtwoord wordt gevraagd. Is dat een parameter passwd="" , dus dat het commando luidt
mount -t cifs -o user=root passwd="" //x.x.x.x/bron /mnt/doel
Laptops + werkstations: Debian Stable + backports, server Debian Stable.
Test-laptop: Debian Tesing/Unstable

Offline MKe

  • Lid
  • Steunpunt: Nee
Re: NAS koppelen aan /mnt
« Reactie #7 Gepost op: 2016/08/20, 19:56:39 »
Daar hoef je geen scriptje voor te maken, daar is de fstab voor.

Zet de volgende regel in de /etc/fstab.

//x.x.x.x/bron       /mnt/doel    cifs   auto,x-systemd.automount,noperm,credentials=/home/myuser/.credentials,iocharset=utf8,rw      0 0Let op, ik ben er hier vanuit gegaan dat je Ubuntu 16.04 hebt en dus systemd. Dit zorgt ervoor dat de drive alleen gemount wordt als je daardwerkelijk naar de moutpoint gaat. 14.04 heeft geen systemd en daar werkt dit dus niet en moet je het zonder automount doen.


Verder moet je dus een credentials file maken in je home (/home/myuser) daarin moeten het wachtwoord en de usernaam staan waarmee je op de cifs mount kunt mounten, dus niet de sudo credentials!

De drive wordt dus automatisch gemount als je opstart en dan alleen als je vervolgens de drive gaat gebruiken.

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: NAS koppelen aan /mnt
« Reactie #8 Gepost op: 2016/08/20, 20:37:28 »
Daar hoef je geen scriptje voor te maken, daar is de fstab voor.

Voor mijn vaste werkstation is dat een optie, maar voor mijn laptop niet. Dan moet ik handmatig mounten.

Citaat
Zet de volgende regel in de /etc/fstab.

//x.x.x.x/bron       /mnt/doel    cifs   auto,x-systemd.automount,noperm,credentials=/home/myuser/.credentials,iocharset=utf8,rw      0 0Let op, ik ben er hier vanuit gegaan dat je Ubuntu 16.04 hebt en dus systemd. Dit zorgt ervoor dat de drive alleen gemount wordt als je daardwerkelijk naar de moutpoint gaat. 14.04 heeft geen systemd en daar werkt dit dus niet en moet je het zonder automount doen.
Klopt, ik heb Debian Jessie en gebruik ook systemd

Citaat
Verder moet je dus een credentials file maken in je home (/home/myuser) daarin moeten het wachtwoord en de usernaam staan waarmee je op de cifs mount kunt mounten, dus niet de sudo credentials!

De drive wordt dus automatisch gemount als je opstart en dan alleen als je vervolgens de drive gaat gebruiken.
Het punt is dat er geen gebruikers zijn aangemaakt op die NAS. Het is een cloud systeem. Als je op mijn werk via een Windows computer op die NAS gaat, dan hoef je niets in te voeren. Ook bij Gigolo (een gvfs schil) gaat het zonder gebruikersnaam en wachtwoord. Alleen heb je dan geen koppelpunt.

Ik neem aan dat je met mijn eigen inlognaam ook een leeg wachtwoord kan invoeren in dat credentials bestandje.

Op mijn vaste werkstation heb ik in mijn fstab twee probeersels:
Citaat
#//10.20.126.230/bron /mnt/nas cifs   guest_netdev,root   0   0
#//10.20.126.230/bron /mnt/nas cifs defaults,uid=1000,gid=1000   0   0

Die bovenste regel heb ik al geprobeerd. Koppelt wel, maar alles is read-only. Die onderste regel heb ik vanavond uitgedokterd maar nog niet geprobeerd.
« Laatst bewerkt op: 2016/08/20, 20:44:08 door h2o »
Laptops + werkstations: Debian Stable + backports, server Debian Stable.
Test-laptop: Debian Tesing/Unstable

Offline MKe

  • Lid
  • Steunpunt: Nee
Re: NAS koppelen aan /mnt
« Reactie #9 Gepost op: 2016/08/20, 22:01:47 »
Voor gebruik op de laptop is juist dat automount. Dan wordt er alleen gemount als dat kan en moet.

Waarom zou je dan handmatig mounten?
Je kunt de credentials waarschijnlijk achterwege laten in jouw geval.

Kijk even naar mijn regel. Ik gebruik noperm een de optie rw.