Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Even voorstellen en gelijk een vraag...  (gelezen 2798 keer)

Bassos

  • Gast
Even voorstellen en gelijk een vraag...
« Gepost op: 2007/04/25, 13:56:36 »
Hoi,

ik ben sinds een paar dagen Ubuntu gebruiker (Dualboot met XP). Want ik wil graag wat meer kennis gaan maken met het open source principe. Want ik ben van mening dat dit de toekomst heeft. Gebruikers zorgen voor de content. En Ubuntu leek mij een goede start. Het installeren is verder met wat vallen en opstaan goed gegaan en ik ben inmiddels online.

Ik zit met het volgende probleem:

Ik wil de desktop effects inschakelen maar het lukt niet. Ik krijg de volgende melding:

De Composite-uitbreiding is niet beschikbaar.

Ik heb overigens een ATI Mobility Radeon X1300 grafische kaart en ik heb de driver hiervoor geinstalleerd via restricted drivers.

Kan iemand mij met dit probleem helpen?

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Even voorstellen en gelijk een vraag...
« Reactie #1 Gepost op: 2007/04/25, 14:40:33 »
Vooreerst: Welkom op het forum. ;)

Heb je eens op de wiki gekeken?
https://wiki.ubuntu.com/NederlandstaligeDocumentatie/Beryl
Krijg je ergens foutmeldingen?
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Bassos

  • Gast
Even voorstellen en gelijk een vraag...
« Reactie #2 Gepost op: 2007/04/25, 15:06:34 »
Zijn die desktop-effecten dan Beryl?

edit: En die link gaat niet over het installeren wanneer je een ATI kaart hebt.

Bassos

  • Gast
Even voorstellen en gelijk een vraag...
« Reactie #3 Gepost op: 2007/04/26, 09:22:47 »
Maar die link die gaat over het installeren van ATI drivers onder de vorige versie van Ubuntu 6.10.

Dit citeer ik even:
"Deze gids legt uit hoe je het werkend krijgt op Ubuntu 6.10 (Edgy Eft). Probeer dit niet uit op Dapper Drake (6.06), want dat zal niet werken!"

Werkt het dan wel op de nieuwe versie 7.04?

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Even voorstellen en gelijk een vraag...
« Reactie #4 Gepost op: 2007/04/26, 09:28:58 »
je hebt gelijk. ati wordt nog niet behandeld in de 7.04 howto. omdat er bij ati
niet 1 oplossing is voor de vele ati-problemen wat beryl betreft.
het kan wel met ati natuurlijk.

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Even voorstellen en gelijk een vraag...
« Reactie #5 Gepost op: 2007/04/26, 09:50:47 »
voor een X1300 zou ik het voorlopig maar bij de proprietary (restricted) fglrx driver houden en dan Xgl installeren, en dan pas kan je Desktop-effects (of desgewenst Beryl) installeren
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Bassos

  • Gast
Even voorstellen en gelijk een vraag...
« Reactie #6 Gepost op: 2007/04/26, 10:01:34 »
Dat houdt in dat de restricted driver die ik nu heb geinstalleerd gewoon moet laten staan. Hoe kan ik controleren of de driver die ik nu heb de juiste is (fglrx driver)? Vervolgens moet ik Xgl installeren. De volgende vraag wat is Xgl en waar kan ik het vinden?

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Even voorstellen en gelijk een vraag...
« Reactie #7 Gepost op: 2007/04/26, 10:33:06 »
om fglrx te controleren: typ eens fglrxinfo in een terminalvenster

wat Xgl betreft: xserver-xgl volgens mij, maar je kan best wat Googlen en/of op de wiki zoeken voor je hieraan begint... je moet ook weten dat dit 3D desktopgedoe nog experimenteel is en niet altijd goed werkt.
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Bassos

  • Gast
Even voorstellen en gelijk een vraag...
« Reactie #8 Gepost op: 2007/04/26, 10:39:30 »
Dit geeft fglrxinfo weer in het terminalvenster:

display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon X1300
OpenGL version string: 2.0.6334 (8.34.8)

Door het klaar maken van mijn systeem voor de desktop effects (beryl) wordt het dan instabieller. Raad je aan om hier nog even mee te wachten?

Bassos

  • Gast
Even voorstellen en gelijk een vraag...
« Reactie #9 Gepost op: 2007/05/01, 16:06:09 »
Om even terug te komen bij dit topic. Ik merkte net dat de kleuren van een video/filmpje niet kloppen als ik het afspeel. Namelijk te veel blauw en paars.

Ik heb verder niks veranderd of met drivers gerotzooid. Het zal wel aan het begin net na de installatie (vorige week geloof ik) ook al zijn geweest. Alleen speelde ik net pas voor het eerst een filmpje af. Je weet wel die bij de examples staat.

Hoe kan ik nu zien wat het probleem is en hoe kan ik het probleem oplossen?

Offline #!

  • Lid
    • tuxtopia
  • Steunpunt: Nee
Even voorstellen en gelijk een vraag...
« Reactie #10 Gepost op: 2007/05/01, 16:26:15 »
Ik kon ook geen 3D effects gebruiken (geen compiz of Beryl) en me video's zagen er ook niet uit toen ik de ati driver gebruikte die restricted was,

ik heb deze uit gevinkt, en toen de open source driver gebruikt, hierna kon ik ineens alles gewoon, ik moet wel beryl uitzetten als ik een filmpje wil kijken omdat het nog wel is niet werkt(zwart beeld)

hoop dat je hier wat aan hebt!

Bassos

  • Gast
Even voorstellen en gelijk een vraag...
« Reactie #11 Gepost op: 2007/05/01, 16:33:13 »
Maar ik heb ergens gelezen dat die opensource driver van ATI niet mijn grafische kaart ondersteund.

ATI Mobility Radeon X1300

edit:typfoutje

Bassos

  • Gast
Even voorstellen en gelijk een vraag...
« Reactie #12 Gepost op: 2007/05/01, 19:58:23 »
Ik heb via de officiële wiki de opensource driver geinstalleerd, alleen is er helemaal niks veranderd. Dus ik ga er van uit dat ik die driver al gebruikte. De onderstaande wiki heb ik gebruikt.

http://wiki.cchtml.com/index.php/Ubuntu_Feisty_Installation_Guide#Configure_the_Driver

Als ik mijn desktop effects wil inschakelen dan geeft ie nog steeds de volgende foutmelding:

De Composite-uitbreiding is niet beschikbaar

Wat moet ik nu verder doen om het wel werkend te krijgen?

Bassos

  • Gast
Even voorstellen en gelijk een vraag...
« Reactie #13 Gepost op: 2007/05/01, 20:17:15 »
Dat van die blauwe video beelden heb ik inmiddels aangepast. Ik heb het antwoord gevonden op de website van Beryl:

http://wiki.beryl-project.org/wiki/Troubleshooting_AIGLX

Bassos

  • Gast
Even voorstellen en gelijk een vraag...
« Reactie #14 Gepost op: 2007/05/01, 21:37:02 »
Dit vond ik ergens anders op een forum:

This is not a bug. The proprietary ATI driver does not support the AIGLX extension right now, so the composite extension is not usable with recent ATI cards.

You have to wait for new ATI drivers.

edit: dit is overigens een bericht van 3 weken oud...

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Even voorstellen en gelijk een vraag...
« Reactie #15 Gepost op: 2007/05/01, 21:38:33 »
Citaat van: Bassos
Dit vond ik ergens anders op een forum:

This is not a bug. The proprietary ATI driver does not support the AIGLX extension right now, so the composite extension is not usable with recent ATI cards.

You have to wait for new ATI drivers.
Verd.... ATI weer.... Wat een rotbedrijf.

Bassos

  • Gast
Even voorstellen en gelijk een vraag...
« Reactie #16 Gepost op: 2007/05/01, 22:03:33 »
Daar op het forum wordt ook uitgelegd dat het wel werkt in combinatie met XGL in plaats van AIGLX. Dus dat brengt me weer bij af. Toch eens wat meer informatie gaan zoeken over XGL...

Bassos

  • Gast
Even voorstellen en gelijk een vraag...
« Reactie #17 Gepost op: 2007/05/01, 22:20:28 »
Dit staat er in mijn xorg.conf:

Section "Device"
   Identifier  "Generic Video Card"
   Driver      "fglrx"
   Option       "VideoOverlay" "on"
   Option       "OpenGLOverlay" "off"
   BusID       "PCI:1:0:0"
EndSection

Bassos

  • Gast
Even voorstellen en gelijk een vraag...
« Reactie #18 Gepost op: 2007/05/01, 22:25:23 »
Blijkbaar moet ik dus XGL installeren voor de 3d/desktop effecten. XGL in combinatie met fglrx dus. Maar hoe installeer ik XGL?

Offline Youngone

  • Lid
  • Steunpunt: Nee
Even voorstellen en gelijk een vraag...
« Reactie #19 Gepost op: 2007/05/02, 00:09:10 »
Hoi,

Hier een goede howto, werkte voor mijn ATI 9800

http://ubuntuguide.org/wiki/Ubuntu:Feisty#How_to_install_Beryl_.28ATI.29

ATI kaarten werken nog niet lekker zonder Xgl, althans niet met Beryl en Compiz onder Ubuntu Feisty!

Offline #!

  • Lid
    • tuxtopia
  • Steunpunt: Nee
Even voorstellen en gelijk een vraag...
« Reactie #20 Gepost op: 2007/05/02, 06:36:20 »
wat is dat toch voor gezeur met ati :(
ik hoop dat ze mij als linux gebruiker binnenkort is wel herkennen :P want dit is niet grappig meer!