Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: LTS versie icm niet goed ondersteunde hardware  (gelezen 406 keer)

Offline jeroenhog

  • Lid
LTS versie icm niet goed ondersteunde hardware
« Gepost op: 2016/06/10, 08:41:55 »
Beste,

Ik gebruik nu al een tijdje Ubuntu 16.0.4 LTS op mijn laptop en ben(bijna helemaal)  tevreden. Het enige probleem  dat ik heb is dat mijn wifi chip (Realtek 8821AE) niet goed ondersteund wordt. 5Ghz verbinding werk niet, af en en toe valt de verbinding zomaar weg en na het sluiten van het deksel van de laptop komt de verbinding vaak niet meer goed op en moet ik de computer rebooten.
Hier ben ik al avonden mee bezig geweest, allerlei tips gevolgd op diverse fora met uiteindelijk resultaat dat de wifi het helemaal niet meer deed (->herinstallatie). Komt er op neer dat de gebruikte driver nog niet helemaal bug vrij is.
Ik vroeg me af: kan het zo zijn dat dit naar verloop van tijd over gaat? Ik bedoel zou het zo kunnen zijn dat er in de toekomst een patch komt van of de kernel of van de driver dat het wel gaat werken? Of blijft de kernel op dezelfde versie draaien ? Het is mij niet helemaal duidelijk?
« Laatst bewerkt op: 2016/06/10, 11:20:29 door jeroenhog »

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: LTS versie icm niet goed ondersteunde hardware
« Reactie #1 Gepost op: 2016/06/10, 10:36:59 »
Na iedere (kernel) update, kan het zijn dat het verbetert, een kwestie van hopen en proberen.
Soms is het mogelijk, om zelf een driver er in te zetten, soms kan ook de Windows driver via een omweg gebruikt worden en heel soms heeft de fabrikant een Linux driver.
Anders een USB dongel aanschaffen, die wel 100% ondersteund wordt..............
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

Offline jeroenhog

  • Lid
Re: LTS versie icm niet goed ondersteunde hardware
« Reactie #2 Gepost op: 2016/06/10, 11:18:29 »
Na iedere (kernel) update, kan het zijn dat het verbetert, een kwestie van hopen en proberen.
Soms is het mogelijk, om zelf een driver er in te zetten, soms kan ook de Windows driver via een omweg gebruikt worden en heel soms heeft de fabrikant een Linux driver.
Anders een USB dongel aanschaffen, die wel 100% ondersteund wordt..............

Dus kernel updates krijg je wel voor een LTS versie? Dus ook de versie van de kernel gaat dan omhoog bij een update van een LTS versie? En vwb die drivers zou je dus ook kunnen krijgen bij een update, want die maken toch geen integraal onderdeel uit van de kernel?

Een losse USB dongle had ik al aangeschaft, het probleem hiermee is: er zijn twee versies, één superklein uitgevoerde die je graag wilt in een laptop maar die heeft slecht bereik, of een met beter bereik maar die steekt ver uit in je laptop, dus de kans dat die afbreekt is erg groot. Met dat idee heb ik gekeken naar een wifi usb dongle van think penguin, maar die zijn én duur én momenteel niet leverbaar vanuit de UK met als gevolg hoge verzendkosten... Dus heb ik een goedkope dongle van Edimax gekocht, maar deze heeft dezelfde kuren jammer genoeg...

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: LTS versie icm niet goed ondersteunde hardware
« Reactie #3 Gepost op: 2016/06/10, 11:38:59 »
Kernel updates komen (voor zover ik weet) gewoon bij de updates.
Anders type je in een terminal sudo apt dist-upgrade dan komen ze zeker !
Heb je al op de website van de fabrikant van de PC en/of de chipset gekeken?
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

Offline jeroenhog

  • Lid
Re: LTS versie icm niet goed ondersteunde hardware
« Reactie #4 Gepost op: 2016/06/10, 12:36:41 »
Kernel updates komen (voor zover ik weet) gewoon bij de updates.
Anders type je in een terminal sudo apt dist-upgrade dan komen ze zeker !
Heb je al op de website van de fabrikant van de PC en/of de chipset gekeken?

Zowel de fabrikant van de laptop alsmede de fabrikant van de chipset hebben geen linux drivers.
Ik zal dat commando zo af en toe eens draaien, kijken of het helpt.
Verder ben ik ook al  eens in Driver Backports gedoken. Dat zijn driver updates voor de niet nieuwste kernel, maar de versienummering daar kom ik niet uit. Ook zou het bestaan van Driver Backports suggereren dat de niet nieuwste versies van de Kernel, dus niet de laatste driver updates krijgen...
« Laatst bewerkt op: 2016/06/10, 16:44:46 door jeroenhog »

Offline Kees3

  • Lid
  • Steunpunt: Ja
Re: LTS versie icm niet goed ondersteunde hardware
« Reactie #5 Gepost op: 2016/06/10, 15:11:41 »
Heb je de handleiding op de onvolprezen site van Pjotr al geprobeerd?

Moderator edit: Link gerepareerd, dubbel bericht verwijderd.
« Laatst bewerkt op: 2016/06/10, 15:20:08 door Ron »

Offline jeroenhog

  • Lid
Re: LTS versie icm niet goed ondersteunde hardware
« Reactie #6 Gepost op: 2016/06/10, 16:43:46 »
Heb je de handleiding op de onvolprezen site van Pjotr al geprobeerd?
Die (handige) site heb ik inderdaad al gezien en veel aan gehad! De driver die genoemd wordt daarvan weet ik niet zeker meer of ik dat geprobeerd heb volgens de handleiding, ik ben er namelijk al zoveel geprobeerd... In ieder geval komt de chipset die genoemd wordt niet helemaal overeen met de chipset die ik heb. Namelijk, er wordt beschreven hoe te handelen met een 8821AU en ikzelf heb een 8821AE, of zou het kunnen werken ?
« Laatst bewerkt op: 2016/06/10, 16:51:20 door Ron »

Offline jeroenhog

  • Lid
Re: LTS versie icm niet goed ondersteunde hardware
« Reactie #7 Gepost op: 2016/06/10, 23:03:01 »
Zo, wat een toeval. Net weer een stukje verder gekomen. Er is dus een aparte git repository voor alle (edit: niet alle, maar een aantal)  realtek chipsets:

https://github.com/lwfinger/rtlwifi_new/

met een bijbehorend forum. Blijkt er dus vandaag iemand bezig te zijn geweest met problemen met deze chipset icm 5Ghz. En die heeft een fix gemaakt, het draadje in dat forum lees je hier:

https://github.com/lwfinger/rtlwifi_new/issues/56

Is er dus een half uur geleden een fix gemaakt in de "master branch". Deze heb ik gegitcloned en gebouwd en geinstalleerd, en 5 Ghz werkt nu! Ik weet nog niet hoe het zit met de connectionlosses maar dat laat ik nog weten. Voor de liefhebbers: voor mij was de (voorlopige)  fix dus:

sudo apt install git
mkdir temp
cd temp
git clone https://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new/
make
sudo make install

* reboot *

« Laatst bewerkt op: 2016/06/11, 00:02:35 door jeroenhog »

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: LTS versie icm niet goed ondersteunde hardware
« Reactie #8 Gepost op: 2016/06/10, 23:47:41 »
Fijn om te horen, blijkbaar was je niet de enige :lol:
Laat wel weten hoe het gaat met deze driver.
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

Offline jeroenhog

  • Lid
Re: LTS versie icm niet goed ondersteunde hardware
« Reactie #9 Gepost op: 2016/06/12, 23:25:48 »
Ben inmiddels een tijdje verder waarbij ik de hele tijd verbonden ben geweest met 5 Ghz. Mijn ervaringen tot nu toe:

Connectionlosses -> opgelost
Geen netwerk verbinding meer mogelijk na sluiten van de laptop -> opgelost

Het enige probleem is dat nadat het deksel van de laptop dicht is geweest het wifi menu (network manager?) in een vreemde status terecht komt, ik kan dan niet een ander netwerk meer kiezen (zie bijlage).

Ik zal de komende dagen via 2.4Ghz werken, om te bekijken wat er dan gebeurd, dit post ik dan nog even.

Offline jeroenhog

  • Lid
Re: LTS versie icm niet goed ondersteunde hardware
« Reactie #10 Gepost op: 2016/06/15, 21:56:43 »
15-7 Voor de liefhebber, alle problemen zijn opgelost. Allereerst: ook op 2.4 Ghz dezelfde problemen met het sluiten van het deksel van de laptop: netwerk komt niet goed op en de netwerk manager komt in een vreemde status. Het zit hem in het niet netjes afsluiten van de netwerk manager bij het sluiten het deksel, dit als volgt opgelost:

nieuw bestand gemaakt met root: /etc/acpi/events/lm_lid
met de volgende inhoud:

event=button/lid.*
action=/etc/acpi/lid.sh

En een tweede script met root en +x rechten:  /etc/acpi/lid.sh
met de volgende inhoud:

#!/bin/sh
grep -q closed /proc/acpi/button/lid/LID/state
if [ $? = 0 ]
then
       service network-manager stop
else
       service network-manager start
fi

*reboot*

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: LTS versie icm niet goed ondersteunde hardware
« Reactie #11 Gepost op: 2016/06/16, 11:44:21 »
Dat uitzoeken heeft je een hoop tijd gekost, mogelijk hebben anderen veel aan deze info.
Bedankt !
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: LTS versie icm niet goed ondersteunde hardware
« Reactie #12 Gepost op: 2016/06/16, 15:35:28 »
Zouden deze problemen zich ook voordoen met wicd?
Laptops + werkstations: Debian Stable + backports, server Debian Stable.
Test-laptop: Debian Tesing/Unstable