Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Headphone uitgang geen geluid  (gelezen 2262 keer)

Minardus

  • Gast
Headphone uitgang geen geluid
« Gepost op: 2007/04/24, 00:17:56 »
Hallo, ik heb hier een probleem met mijn onboard geluidskaart.

Het is het type Realtek ALC880 oftewel hda-intel
Hij zit in een laptop (Asus a6vm) en heeft een line-in, mic, en headphone uitgang.

Er komt wel geluid uit de onboard speakers, maar niet uit de koptelefoon uitgang.
Nou heb ik al gezocht, maar niks lijkt het op te lossen.
Want als ik bijvoorbeeld deze volg http://doc.gwos.org/index.php/Comprehensive_Sound_Problems_Solutions_Guide
Dan krijg ik altijd wel een compile fout ofzo.

Help!

Groeten Minardus

Offline wutnubu

  • Lid
  • Steunpunt: Nee
Headphone uitgang geen geluid
« Reactie #1 Gepost op: 2007/04/24, 06:47:27 »
Dubbelklik eens op het luidsprekertje of Systeem->Voorkeuren->Geluid en wijzig de schuifjes.

Succes

Minardus

  • Gast
Headphone uitgang geen geluid
« Reactie #2 Gepost op: 2007/04/24, 07:36:15 »
Al gedaan,maar dan hoor ik nog steeds geen geluid.
Ik heb ook al verschillende dingen geprobeerd, zoals compileren van de laatste alsa driver.
Nu doet ie het helemaal niet meer, omdat ik steeds compile fouten krijg.

Azalin

  • Gast
Headphone uitgang geen geluid
« Reactie #3 Gepost op: 2007/04/24, 08:23:58 »
Je alsa driver is ook in orde, er moet denk ik alleen een kleine aanpassing op je alsa-base uitgevoerd worden. Bij mijn VIA chipset moest ik de hda-intel een andere index geven. Ik kreeg in Dmesg steeds deze melding:

hda-intel: Invalid position buffer, using LPIB read method instead.

Ik heb toen aan /etc/modprobe.d/alsa-base de volgende regel toe te gevoegd:
options snd-hda-intel position_fix=1 model=3stack

Na opnieuw opstarten was bij mij het geluid in orde. Ik had ineens surround, een koptelefoon uitgang die het ook echt deed en ga zo maar door.

Je zou deze fix kunnen proberen of even de output van dmesg hier kunnen posten.

Aangezien dit een vervolg is van het andere thread, en ik dat even niet had gezien :), moet je me eens even vertellen wat je precies gedaan hebt waardoor het audio het nu niet meer doet. Je hebt gecompileerd ... en toen? Alleen dan kunnen we wellicht je audio fixen.

Minardus

  • Gast
Headphone uitgang geen geluid
« Reactie #4 Gepost op: 2007/04/24, 13:30:09 »
Nu heb ik dat luidsprekertje met een rood dingetje. Hij kan de geluidskaart niet vinden.

Ik probeerde de laatste (beta) drivers van alsa-project.org te installeren.
./configure liep goed.
Alleen bij sudo make en sudo make install gaven fouten.
Zoals make: *** Compile Fout 2

Ik heb linux-headers + linux-source + build-essential wel geinstalleerd.

Ik heb deze guide http://doc.gwos.org/index.php/Comprehensive_Sound_Problems_Solutions_Guide#Getting_the_ALSA_drivers_from_a_.2Afresh.2A_kernel gevolgd om het alsa spul schoon te herinstalleren, maar dan doet ie het nog steeds niet

Het werkt! - Dit is hoe ik het gedaan heb:

Alles was kapot aan de alsa driver, ik had alles gemold volgens mij:

Maar toen stuitte ik hierop http://ubuntuforums.org/showthread.php?p=2396093

En volgde dit stukje

Installing the latest Alsa drivers

I'll show you how to install Alsa properly. First of all you should run
sudo /etc/init.d/alsa-utils stopThis stops the Alsa machinery. I didn't do this first time I installed the Alsa drivers, and got some severe problems because of it. It's important that you do not forget the above command. Now, download the latest development release of alsa-driver, alsa-lib and alsa-utils from the Alsa webpage, and do the following with all the tarballs in the order I listed the three tarballs:
tar xvf .tar.bz2
sudo ./configure --with-kernel=/usr/src/linux-headers-$(uname -r) --with-cards=hda-intel --with-oss=yes
sudo make
sudo make install
If you have any other cards (like an onboard card), you can add it to --with-cards seperated by commas. After the installation is finished, do a complete reboot. Then run

cat /proc/asound/versionto check if you successfully upgraded Alsa. The first time you reboot after upgrading Alsa or installing a new system, you must increase the volume of all channels in alsamixer.

En de koptelefoon-uitgang deed het ook meteen

Je moet dus de laatste drivers hebben (de development)
En die compile fout kwam dus doordat ik dit niet had gedaan voor het compileren:
sudo /etc/init.d/alsa-utils stop

Offline wutnubu

  • Lid
  • Steunpunt: Nee
Headphone uitgang geen geluid
« Reactie #5 Gepost op: 2007/04/24, 16:09:41 »
Gefeliciteerd...

Groet

Azalin

  • Gast
Headphone uitgang geen geluid
« Reactie #6 Gepost op: 2007/04/24, 20:04:51 »
:) Proficiat!

Fijs

  • Gast
Headphone uitgang geen geluid
« Reactie #7 Gepost op: 2007/05/01, 23:53:42 »
Ik zit met hetzelfde probleem, maar ik heb een andere geluidskaart, nl IXP SB400 AC'97 Audio Controller.
Wat moet ik dan precies ingeven bij --with-cards= ?
Edit: na lang googlen: atiixp

Jammer genoeg is mijn probleem nog niet opgelost: bij volumeregeling staat nog steeds:
De volumeregelaar kan geen elementen of apparaten vinden om te besturen. Dit betekent dat u of geen GStreamer uitbreidingen geïnstalleerd hebt, of dat u geen geluidskaart geconfigureerd heeft.

Iemand een idee?

Azalin

  • Gast
Headphone uitgang geen geluid
« Reactie #8 Gepost op: 2007/05/02, 08:58:50 »
Misschien niet de meest geweldig optie maar het is misschien een tijdelijke fix:

Citaat
I have the same soundcard. Adding acpi=off to the kernelparameters enables the sound. (but disables the battery state indicator)
(I had 6.10 installed and had to add the same parameters.) But with 7.04 I also loose the ability to set the CPU speed (Quiet'n Cool)
Bron: https://answers.launchpad.net/ubuntu/+question/5455

Een andere tip die ik ergens voorbij zag komen:
Citaat
Open a console, then run "alsamixer" (without the quotes). Use the right arrow to highlight IEC958, then hit the "m" key to mute it. tap escape twice to exit, then try your sound again.
Bron: http://ubuntuforums.org/showthread.php?t=251123

Deze tip zal overigens denk ik niet veel uitmaken bij jou. Margoed.

Nog een andere tip dan:

Citaat
Solution I found :

See bug report : http://bugzilla.kernel.org/show_bug.cgi?id=7467

Grab last patch : http://bugzilla.kernel.org/attachmen...15&action=view

Apply patch, rebuild kernel, reboot.

Dmesg cut-n-paste:

41.129764] Atiixp quirk for DFI RS482. Forcing codec 0

Success for analog sound, will test digital at a later time.
Bron: http://ubuntuforums.org/showthread.php?t=251123

Transporter

  • Gast
Headphone uitgang geen geluid
« Reactie #9 Gepost op: 2008/01/17, 00:24:40 »
ik heb ook dezelfde chipset denk ik... en mijn headphone werkt ook niet.

Maar wat moet je hier invullen ? : "tar xvf .tar.bz2"

Ook welke versie van alsa driver heb je ?

Azalin

  • Gast
Headphone uitgang geen geluid
« Reactie #10 Gepost op: 2008/01/19, 11:45:34 »