Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: bestandsbeheer toont steeds verborgen bestanden  (gelezen 342 keer)

Offline emvedeesje

  • Lid
  • Steunpunt: Nee
bestandsbeheer toont steeds verborgen bestanden
« Gepost op: 2016/04/03, 11:58:45 »
Ubuntu 14.04.4 64bit
Direct bij het opstarten van bestandsbeheer worden reeds de verborgen bestanden getoond.

Je kan ze natuurlijk verbergen met CTRL_H

Maar hoe komt het dat bestandsbeheer niet normaal opstart, en geen verborgen bestanden toont?
Ook al sluit je bestandsbeheer op een moment dat geen verborgen zaken te zien zijn, het helpt niet.
Dit komt hier slechts op 1 pc voor.
Mint Cinnamon fan
Desktop HP ProDesk 400G3 64bit I5 16gb multiboot: SSD Mint 18.2 Cinnamon Sonya + SSD Ubuntu 16.04.3 + HD Ubuntu 14.04.5 + HD W10 /// Laptop HP ProBook 6570b 64bit I5 4gb SSD multiboot Mint 18.2 Cinnamon Sonya + W10
TESTBAK Desktop HP-Compaq 8000 64bit 4gb

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: bestandsbeheer toont steeds verborgen bestanden
« Reactie #1 Gepost op: 2016/04/03, 12:46:18 »
Zou kunnen duiden op een rechtenprobleem.... Heb je bestandbeheer misschien ooit wel eens gestart met "sudo"?

Offline emvedeesje

  • Lid
  • Steunpunt: Nee
Re: bestandsbeheer toont steeds verborgen bestanden
« Reactie #2 Gepost op: 2016/04/04, 08:49:27 »
Inderdaad.
De reden herinner ik me niet meer.
Mint Cinnamon fan
Desktop HP ProDesk 400G3 64bit I5 16gb multiboot: SSD Mint 18.2 Cinnamon Sonya + SSD Ubuntu 16.04.3 + HD Ubuntu 14.04.5 + HD W10 /// Laptop HP ProBook 6570b 64bit I5 4gb SSD multiboot Mint 18.2 Cinnamon Sonya + W10
TESTBAK Desktop HP-Compaq 8000 64bit 4gb

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: bestandsbeheer toont steeds verborgen bestanden
« Reactie #3 Gepost op: 2016/04/04, 09:14:56 »
Start(bestandbeheer) nog eens met sudo en zet de rechten goed en sluit weer af.

Offline markba

  • Lid
    • http://markbaaijens.nl/
  • Steunpunt: Ja
Re: bestandsbeheer toont steeds verborgen bestanden
« Reactie #4 Gepost op: 2016/04/04, 10:13:27 »
In nautilus is het ook een instelling. Standaard staat de zichtbaarheid van verborgen bestasden uit, maar je kunt het ook aanzetten natuurlijk.

Offline emvedeesje

  • Lid
  • Steunpunt: Nee
Re: bestandsbeheer toont steeds verborgen bestanden
« Reactie #5 Gepost op: 2016/04/04, 10:43:13 »
Citaat
Start(bestandbeheer) nog eens met sudo en zet de rechten goed en sluit weer af.

Heb volgend commado gegeven:
sudo nautilus
doch op de terminal zie ja al dat er iets fout zit:

(nautilus:3297): Gtk-WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.
ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

vervolgens CTRL_H
bestandsbeheer afgesloten,
doch de terminal bleef actief en na een tijd wachten kwam hij pas weer vrij met opnieuw foutboodschappen:

sys:1: Warning: Source ID 113 was not found when attempting to remove it
sys:1: Warning: Source ID 114 was not found when attempting to remove it
sys:1: Warning: Source ID 115 was not found when attempting to remove it

En de verborgen bestanden worden nog steeds getoond.

Citaat
In nautilus is het ook een instelling.

Als hier bedoeld wordt met Beeld / Verborgen bestanden tonen:
Die stond dus AAN.
Heb ik AF gezet en bestandsbeheer herstart.
Ook hierna worden de verborgen bestanden nog steeds getoond.
Mint Cinnamon fan
Desktop HP ProDesk 400G3 64bit I5 16gb multiboot: SSD Mint 18.2 Cinnamon Sonya + SSD Ubuntu 16.04.3 + HD Ubuntu 14.04.5 + HD W10 /// Laptop HP ProBook 6570b 64bit I5 4gb SSD multiboot Mint 18.2 Cinnamon Sonya + W10
TESTBAK Desktop HP-Compaq 8000 64bit 4gb

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: bestandsbeheer toont steeds verborgen bestanden
« Reactie #6 Gepost op: 2016/04/04, 11:20:47 »
Start(bestandbeheer) nog eens met sudo en zet de rechten goed en sluit weer af.
Waar moet je dan precies die rechten goed zetten? Ik zie dat emvedeesje met deze uitleg toch niet vooruit raakt en ik zou het eerlijk gezegd ook niet weten.

Probeer het volgende eens: open gedit, type enkele letters, en bewaar dan het document: druk wanneer de dialoog voor het bewaren van het bestand verschijnt, op Ctrl+H om "toon verborgen bestanden" af te zetten. Klik dan op "Bewaar" om het bestand te bewaren (je mag het onmiddellijk terug wissen).

Achtergrond: bestandsbeheer (nautilus) kijkt nu naar de instelling van de "Bestand bewaren" dialoog. Als daar het tonen van verborgen bestanden aan stond, zal dat ook standaard aanstaan in nautilus.
« Laatst bewerkt op: 2016/04/04, 11:28:08 door vanadium »

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: bestandsbeheer toont steeds verborgen bestanden
« Reactie #7 Gepost op: 2016/04/04, 11:47:01 »
Ik bedoelde nautilus openen met sudo of gksudo,
dan de verborgen mappen uitzetten in nautilus,
dan nautilus sluiten.
Dan nautilus weer gewoon opstarten, en kijk of het helpt.

Anders google hier op,
ubuntu 14.04+nautilus config
of
nautilus config
« Laatst bewerkt op: 2016/04/04, 11:48:48 door jan11000 »

Offline markba

  • Lid
    • http://markbaaijens.nl/
  • Steunpunt: Ja
Re: bestandsbeheer toont steeds verborgen bestanden
« Reactie #8 Gepost op: 2016/04/04, 11:55:11 »
Ik bedoelde nautilus openen met sudo of gksudo,
dan de verborgen mappen uitzetten in nautilus,
dan nautilus sluiten.
Dan nautilus weer gewoon opstarten, en kijk of het helpt.
Het is een gebruikersinstelling. Dus als je dit onder een andere gebruiker aanpast (sudo = root), dan wordt dat ook dáár opgeslagen. En als je dan weer teruggaat naar de actuele gebruiker, zul je zien dat daar die instelling hetzelfde is gebleven.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: bestandsbeheer toont steeds verborgen bestanden
« Reactie #9 Gepost op: 2016/04/04, 11:55:32 »
Ik bedoelde nautilus openen met sudo of gksudo,
dan de verborgen mappen uitzetten in nautilus,
dan nautilus sluiten.
Dan nautilus weer gewoon opstarten, en kijk of het helpt.
Precies wat ik ook zou aanraden.

Door Nautilus te starten met "sudo", heb je waarschijnlijk de instellingen van Nautilus in je persoonlijke map, gezet op "eigendom root". Daardoor kun je die met gewone gebruikersrechten niet meer overschrijven met andere instellingen.

Je moet een grafisch programma als Nautilus, ook nooit opstarten met "sudo". Hooguit met "gksudo", waarvoor je eerst even "gksu" moet installeren. "sudo" is alleen bestemd voor terminalprogramma's.

Ik heb het schrappen van "gksu" uit de standaardinstallatie van Ubuntu, altijd beschouwd als een enorme vergissing. Naast andere vergissingen van mindere orde, zoals het schrappen van Synaptic en GDebi. Enfin, wie baas is bakt koek....
« Laatst bewerkt op: 2016/04/04, 12:01:06 door Pjotr »

Offline markba

  • Lid
    • http://markbaaijens.nl/
  • Steunpunt: Ja
Re: bestandsbeheer toont steeds verborgen bestanden
« Reactie #10 Gepost op: 2016/04/04, 12:03:05 »
Door Nautilus te starten met "sudo", heb je waarschijnlijk de instellingen van Nautilus in je persoonlijke map, gezet op "eigendom root".
Als dit zo is, zou je dat eenvoudig moeten kunnen controleren met het commando 'ls' in de map waar de instellingen worden opgeslagen. Weet helaas zo uit mn hoofd niet welke map dat zou moeten zijn (heb ook geen ubuntu bij de hand). Weet iemand dat?
« Laatst bewerkt op: 2016/04/04, 12:05:23 door markba »

Offline grizzler

  • Lid
  • Steunpunt: Nee
Re: bestandsbeheer toont steeds verborgen bestanden
« Reactie #11 Gepost op: 2016/04/04, 13:20:16 »
Als ik de dconf-editor open, vind ik nautilus-instellingen in /org/gnome/nautilus. Die gegevens staan in het bestand ~/.config/dconf/user. Controleer dus maar of dat nog van de user is.

Overigens, als dat bestand de user:group root:root heeft gekregen, moet je nog veel meer instellingen niet kunnen wijzigen.

Offline markba

  • Lid
    • http://markbaaijens.nl/
  • Steunpunt: Ja
Re: bestandsbeheer toont steeds verborgen bestanden
« Reactie #12 Gepost op: 2016/04/04, 13:22:46 »
Als ik de dconf-editor open, vind ik nautilus-instellingen in /org/gnome/nautilus. Die gegevens staan in het bestand ~/.config/dconf/user. Controleer dus maar of dat nog van de user is.
Hiermee wordt het controle-commando:
ls -la ~/.config/dconf/user

Offline emvedeesje

  • Lid
  • Steunpunt: Nee
Re: bestandsbeheer toont steeds verborgen bestanden
« Reactie #13 Gepost op: 2016/04/04, 17:59:14 »
Citaat
Als ik de dconf-editor open, vind ik nautilus-instellingen in /org/gnome/nautilus.

In dconf-editor bij /org/gnome/nautilus/preferences/show-hidden-files zie je volgende boodschap:

Deze sleutel is afgekeurd en wordt genegeerd.
De sleutel "show-hidden" van "org.gtk.Settings.FileChooser" wordt nu gebruikt in plaats daarvan.

En inderdaad, daar stond de vlag AAN.

Deze AF gezet, en het is OK.

Blijkbaar kan deze vlag aan gezet worden als je altijd de verborgen bestanden wil zien...

Met dank aan allen, jullie brachten het juiste spoor naar de oplossing!
Mint Cinnamon fan
Desktop HP ProDesk 400G3 64bit I5 16gb multiboot: SSD Mint 18.2 Cinnamon Sonya + SSD Ubuntu 16.04.3 + HD Ubuntu 14.04.5 + HD W10 /// Laptop HP ProBook 6570b 64bit I5 4gb SSD multiboot Mint 18.2 Cinnamon Sonya + W10
TESTBAK Desktop HP-Compaq 8000 64bit 4gb

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: bestandsbeheer toont steeds verborgen bestanden
« Reactie #14 Gepost op: 2016/04/04, 18:08:53 »
Daarom was dit de lowtech oplossing (geen dconf nodig). Door eens in een gtk bestandsdialoog je verborgen bestanden aan of uit te zetten, verzet je die sleutel. Door in nautilus zelf Control+H te drukken, verander je alleen de toestand voor het huidige venster - de instelling wordt niet (meer) opgeslagen. Niet consistent allemaal als je het mij vraagt, en zorgt voor verwarring.

Offline emvedeesje

  • Lid
  • Steunpunt: Nee
Re: bestandsbeheer toont steeds verborgen bestanden
« Reactie #15 Gepost op: 2016/04/04, 18:21:39 »
@vanadium

jouw truuk via gedit werkt eveneens.
En zo zal het gebeurd zijn: CTRL_H op het keuzescherm alvorens op te slaan zet de vlag "org.gtk.Settings.FileChooser", iets wat op dat moment eigenlijk niet moet/mag

inderdaad verwarrend en niet consistent...
Mint Cinnamon fan
Desktop HP ProDesk 400G3 64bit I5 16gb multiboot: SSD Mint 18.2 Cinnamon Sonya + SSD Ubuntu 16.04.3 + HD Ubuntu 14.04.5 + HD W10 /// Laptop HP ProBook 6570b 64bit I5 4gb SSD multiboot Mint 18.2 Cinnamon Sonya + W10
TESTBAK Desktop HP-Compaq 8000 64bit 4gb

Offline robindekker

  • Lid
  • Steunpunt: Nee
Re: bestandsbeheer toont steeds verborgen bestanden
« Reactie #16 Gepost op: 2016/04/04, 22:32:33 »
Hallo.
Ik had hetzelfde probleem met de verborgen bestanden.
Ik heb het als volgt opgelost:

Open Nautilus, kies bewerken->voorkeuren-> tabblad weergaven
Vink vervolgens het vakje voor " Verborgen en reservekopiebestanden tonen" uit.
Start Nautilus opnieuw en je probleem is als het goed is opgelost.

Zie de afbeelding.
Vriendelijke groet,

Robin


Offline emvedeesje

  • Lid
  • Steunpunt: Nee
Re: bestandsbeheer toont steeds verborgen bestanden
« Reactie #17 Gepost op: 2016/04/05, 09:21:17 »
Citaat
Ik had hetzelfde probleem met de verborgen bestanden.
Ik heb het als volgt opgelost:

Open Nautilus, kies bewerken->voorkeuren-> tabblad weergaven
Vink vervolgens het vakje voor " Verborgen en reservekopiebestanden tonen" uit.
Start Nautilus opnieuw en je probleem is als het goed is opgelost.

Dat is inderdaad het eerste waar je aan denkt, doch als de hierboven beschreven vlag "org.gtk.Settings.FileChooser" in dconf-editor AAN staat, mag je doen wat je wil: de verborgen bestanden worden sowieso getoond.
Mint Cinnamon fan
Desktop HP ProDesk 400G3 64bit I5 16gb multiboot: SSD Mint 18.2 Cinnamon Sonya + SSD Ubuntu 16.04.3 + HD Ubuntu 14.04.5 + HD W10 /// Laptop HP ProBook 6570b 64bit I5 4gb SSD multiboot Mint 18.2 Cinnamon Sonya + W10
TESTBAK Desktop HP-Compaq 8000 64bit 4gb

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: bestandsbeheer toont steeds verborgen bestanden
« Reactie #18 Gepost op: 2016/04/05, 10:42:45 »
Het lijkt er op dat, althans in Ubuntu 15.10, de dialoog van nautilus wel degelijk ook die gtk instelling bijwerkt. Door via de dialoog "Verborgen bestanden tonen" aan te zetten, worden verborgen bestanden getoond in nautilus, in gtk dialogen en dus ook na opstart van nautilus. Via Ctrl+H daarentegen wordt die instelling niet verzet: de instelling is slechts geldig voor je huidige nautilus venster. Mogelijk werkt het in Ubuntu 14 nog steeds net iets anders.