Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: X server uitschakelen voor NVIDIA drivers  (gelezen 2816 keer)

Michielvsb

  • Gast
X server uitschakelen voor NVIDIA drivers
« Gepost op: 2007/04/22, 09:16:32 »
Hallo,

Sorry dat ik weer een nieuw topic post. Gisteren ben ik dus begonnen met Kubuntu, maar ik heb een 19" breedbeeld en dat levert de nodige problemen in resoluties, dus heb ik de Linux driver van NVIDIA gedownload, die gestart in de terminal maar ik krijg telkens het probleem dat ik mijn "X server" moet uitschakelen. Als beginnen weet ik niet hoe ik dit moet doen, ik heb al eens gezocht op internet, maar die informatie is altijd voor andere distributies. Dank bij voorbaat.

Michiel

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
X server uitschakelen voor NVIDIA drivers
« Reactie #1 Gepost op: 2007/04/22, 10:49:31 »
Vertel even welke versie van Kubuntu je gebruikt,
in Feisty kan je met systeem > Beheer > Restricted Driver Manager alles instellen.
Je schrijft dat je een driver hebt gedownload, dat is niet de juiste manier onder (K)Ubuntu !

Geef even meer informatie,
Ron
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

Michielvsb

  • Gast
X server uitschakelen voor NVIDIA drivers
« Reactie #2 Gepost op: 2007/04/22, 10:55:39 »
Ik gebruik Kubuntu 7.04 (de volledige feisty, degene die donderdag uitgekomen is). Het probleem is dat ik een breedbeeld scherm heb, maar geen hoge breedbeeldresolutie kan instellen. Ik heb langs mijn beeld ook een zwarte balk van ca. 50 pixels en aan de andere kant van mijn beeld zie ik niet alles. Ik zou resolutie 1440x900 moeten kunnen kiezen om goed te zijn.

Offline mcgyver

  • Lid
  • Steunpunt: Nee
X server uitschakelen voor NVIDIA drivers
« Reactie #3 Gepost op: 2007/04/22, 12:15:18 »
probeer even niet met die nvidia driver te werken, gewoon met alles in ubuntu.

Welke nvidia kaart heb je?

ik ken KDE niet zo goed, maar doe gewoon "sudo dpkg-reconfigure xserver-xorg" (kopieren en plakken, aanhalingstekens weglaten)

op alles ja klikken. ergens zal je alle resoluties zien. Degene die je wil moet je kiezen (er naar scrollen met pijltjestoets en selecteren met spatiebalk). Hier kan je ook je refreshrate met de hand wijzigen. Kijk wel eerst naar wat de  fabrikant voorschrijft.

Ik hoor wel of het gaat of niet.

Michielvsb

  • Gast
X server uitschakelen voor NVIDIA drivers
« Reactie #4 Gepost op: 2007/04/22, 20:39:46 »
De wizard werkt, maar achteraf geeft hij een fout:

http://img119.imageshack.us/img119/1277/schermafdruk3lg3.png

Pensacola

  • Gast
X server uitschakelen voor NVIDIA drivers
« Reactie #5 Gepost op: 2007/04/22, 20:42:27 »
Ik vraag mij al lang af waar de restricted driver manager staat in kubuntu, ik log speciaal in in gnome om dit te kunnen doen :)

Michielvsb

  • Gast
X server uitschakelen voor NVIDIA drivers
« Reactie #6 Gepost op: 2007/04/22, 20:51:33 »
Daar kan ik het ook niet doen, heb momenteel geen ubuntu op mijn computer staan. Zal moeten wachten tot volgende maand, anders kom ik in de problemen met het transfervolume...

Offline DennisB

  • Lid
  • Steunpunt: Nee
X server uitschakelen voor NVIDIA drivers
« Reactie #7 Gepost op: 2007/04/22, 23:55:30 »
ergens verder in het forum wordt dit ook besproken. Ik heb hetzelfde probleem gisteren gehad. Ik moest de xorg.conf aanpassen door er een handmatig een resolutie tussen te zetten. (1440x900). Daarna kon ik de goede resolutie terug vinden in het rijtje.

Michielvsb

  • Gast
X server uitschakelen voor NVIDIA drivers
« Reactie #8 Gepost op: 2007/04/23, 07:54:50 »
En waar is dat xorf bestand ergens te vinden? Sorry, ben een beginner.

DPC

  • Gast
X server uitschakelen voor NVIDIA drivers
« Reactie #9 Gepost op: 2007/04/23, 08:03:42 »
/etc/X11/xorg.conf

Offline KenSentMe

  • Lid
    • http://www.vandenieuwenhof.nl
  • Steunpunt: Nee
X server uitschakelen voor NVIDIA drivers
« Reactie #10 Gepost op: 2007/04/23, 08:06:22 »
Je vindt het bestand in /etc/X11/xorg.conf. Daarin kom je de volgende regels tegen:

 SubSection "Display"
                Depth   1
                Modes           "1280x800"      "1024x768"      "800x600"       "640x480"
        EndSubSection

Hier voeg je dus nog jouw resolutie aan toe in de regel Modes. Doe dit voor iedere regel die je tegenkomt.

Je kunt het bestand bewerken door in terminal dit uit de voeren:

gksudo gedit /etc/X11/xorg.conf

Offline Jelle

  • Lid
  • Steunpunt: Nee
X server uitschakelen voor NVIDIA drivers
« Reactie #11 Gepost op: 2007/04/23, 08:55:37 »
is het voor Kubuntu niet:

kdesu kate /etc/X11/xorg.conf  ?

Michielvsb

  • Gast
X server uitschakelen voor NVIDIA drivers
« Reactie #12 Gepost op: 2007/04/23, 12:53:45 »
Alle beschikbare resolutie  zitten in dat bestand, maar ik kan ze niet kiezen via de Systeeminstellingen. Ook 1440x900 staat ertussen maar ook die kan ik niet kiezen via Systeeminstellingen -> .........

Michielvsb

  • Gast
X server uitschakelen voor NVIDIA drivers
« Reactie #13 Gepost op: 2007/04/24, 12:50:58 »
Niemand die weet hoe het komt? Misschien een beetje ongeduldig, maar als een topic op de tweede pagina komt kijkt er niemand meer naar, sorry.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
X server uitschakelen voor NVIDIA drivers
« Reactie #14 Gepost op: 2007/04/24, 12:55:41 »
Wat is het type van je grafische kaart?
Heb je de drivers van de Nvidia site geïnstalleerd, of via synaptic nvidia-glx of nvidia-glx-new geïnstalleerd?

Plaats het /etc/X11/xorg.conf bestand eens hier.

Michielvsb

  • Gast
X server uitschakelen voor NVIDIA drivers
« Reactie #15 Gepost op: 2007/04/27, 07:35:30 »
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   FontPath   "/usr/share/fonts/X11/misc"
   FontPath   "/usr/share/fonts/X11/cyrillic"
   FontPath   "/usr/share/fonts/X11/100dpi/:unscaled"
   FontPath   "/usr/share/fonts/X11/75dpi/:unscaled"
   FontPath   "/usr/share/fonts/X11/Type1"
   FontPath   "/usr/share/fonts/X11/100dpi"
   FontPath   "/usr/share/fonts/X11/75dpi"
   # path to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load   "bitmap"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "be"
   Option      "XkbVariant"   "sundeadkeys"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ImPS/2"
   Option      "ZAxisMapping"      "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "stylus"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "stylus"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "eraser"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "eraser"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "cursor"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "cursor"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "NVIDIA 7200 GS"
   Driver      "vesa"
   BusID      "PCI:1:0:0"
   Option      "UseFBDev"      "true"
EndSection

Section "Monitor"
   Identifier   "Mirai"
   Option      "DPMS"
   HorizSync   28-96
   VertRefresh   43-60
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "NVIDIA 7200 GS"
   Monitor      "Mirai"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1920x1440" "1920x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1920x1440" "1920x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1920x1440" "1920x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1920x1440" "1920x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1920x1440" "1920x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1920x1440" "1920x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   InputDevice     "stylus"   "SendCoreEvents"
   InputDevice     "cursor"   "SendCoreEvents"
   InputDevice     "eraser"   "SendCoreEvents"
EndSection

Section "DRI"
   Mode   0666
EndSection

steefjeqv

  • Gast
X server uitschakelen voor NVIDIA drivers
« Reactie #16 Gepost op: 2007/04/27, 09:23:30 »
Hoi,

In "Section Device" van je xorg.conf de driver van "vesa" naar "nv" veranderen.
Daarmee installeer je de openbrondriver voor je nvidiakaart.

Je kan ook het envy-script gebruiken. Dit kan je installeren via Synaptic.
Als je dit scriptje wil gebruiken moet je de X-server afsluiten.
Dit doe je met de toetsencombinatie ctrl-alt-f1.
Tik het volgende in : sudo envy
De nvidia-drivers worden nu geinstalleerd.

Probeer misschien eerst je xorg.conf aan te passen. Als dit lukt kan je later nog altijd de closed-source driver van nvidia uitproberen.



Groetjes,
Steven

Michielvsb

  • Gast
X server uitschakelen voor NVIDIA drivers
« Reactie #17 Gepost op: 2007/04/27, 16:44:47 »
De eerste mogelijkheid werkt al niet, in de gewone modus als ik het bestand open via Konqueror (ofzo iets, de browser in Kubuntu), dan krijg ik een melding dat ik niet de juiste rechten heb om op te slaan. Als ik de toetsencombinatie invoer bij de tweede optie krijg ik een groot zwarts scherm waar een fout op komt, iets van pci die niet kan laden ofzo iets. Als ik het in de terminal uitvoer, dat commando, vraagt hij om mijn wachtwoord, en als ik dat invoer, zegt hij dat het niet juist is. Ik heb het al tien keer geprobeerd, en telkens komt opnieuw dat het niet juist is, terwijl ik datzelfde wachtwoord invoer als hij ergens anders in grafische modus om mijn root-password vraagt, en dan werkt het wel...