Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: 7.04 geen geluid/ lage schermresolutie  (gelezen 4273 keer)

NickK

  • Gast
7.04 geen geluid/ lage schermresolutie
« Gepost op: 2007/04/21, 22:20:25 »
Ubuntu 7.04 geeft geen geluid. Hoe kan ik dat fixen?
Daarnaast heeft het een zeer lage resolutie, van 1024 bij 768, ik heb een 19 inch scherm, dus dit zou veel hoger moeten kunnen. Hoe kan ik dat instellen (bij schermresolutie geeft ie dat als maximum).

Bij voorbaat dank voor de moeite.

Offline mcgyver

  • Lid
  • Steunpunt: Nee
7.04 geen geluid/ lage schermresolutie
« Reactie #1 Gepost op: 2007/04/21, 22:40:35 »
Zoek op dit forum naar codecs of zo, is heel simpel en er is heel veel over geschreven.

osc4r

  • Gast
7.04 geen geluid/ lage schermresolutie
« Reactie #2 Gepost op: 2007/04/21, 22:43:39 »
Wat je kunt doen om je scherm resolutie aan te passen:

Ga naar de terminal en typ in: sudo gedit /etc/X11/xorg.conf

scroll down naar beneden tot je bij een stuk beland wat er ongeveer zo uitziet:

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation G70 [GeForce 7600 GS]"
Monitor "Generieke beeldscherm"
Defaultdepth 24
SubSection "Display"
Depth 1
Modes "1680x1050" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1680x1050" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1680x1050" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1680x1050" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1680x1050" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1680x1050" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
Zoals je ziet heb ik voor mijn eigen breedbeeld hier ook zelf 1680x1050 bij gezet, en dat zou in jou geval denk ik (tenminste, als je geen breedbeeld hebt) 1280x1024 moeten zijn! Pas het even aan, sla het bestand op en restart X met ctrl + alt + backspace

Je geluid weet ik even niet, succes!

BigRonnyV

  • Gast
7.04 geen geluid/ lage schermresolutie
« Reactie #3 Gepost op: 2007/04/21, 23:19:02 »
Mmmm, ik heb deze oplossing geprobeerd, maar ik blijf zwarte randen (+/-4cm) rondom mijn scherm houden. Ook kan ik geen hogere resolutie kiesen .Ik heb 1400X1050 toegevoegd voor mijn laptop. (Acer 630). Wat doe ik niet goed?

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
7.04 geen geluid/ lage schermresolutie
« Reactie #4 Gepost op: 2007/04/21, 23:22:10 »
1400X1050 zal niet goed zijn
1280X1024 toch?

NickK

  • Gast
7.04 geen geluid/ lage schermresolutie
« Reactie #5 Gepost op: 2007/04/22, 06:29:41 »
Section "Screen"
   Identifier   "Default Screen"
   Device      "nVidia Corporation G80 [GeForce 8800 GTS]"
   Monitor      "Generic Monitor"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
EndSection




Echter, hij system, voorkeuren, schermresolutie, kan ik nog steeds niet meer dan 1024x768 instellen.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
7.04 geen geluid/ lage schermresolutie
« Reactie #6 Gepost op: 2007/04/22, 08:53:55 »
"800x600" "640x480" kunnen weg in het rijtje, dan rebooten.

BigRonnyV

  • Gast
7.04 geen geluid/ lage schermresolutie
« Reactie #7 Gepost op: 2007/04/22, 09:15:39 »
Na het weghalen van 800x600 en 1024*768 en een reboor blijven deze keuze aanwezig. Een hogere resolutie is niet te kiezen.

Info:

Section "Device"
   Identifier   "nVidia Corporation NV11 [GeForce2 Go]"
   Driver      "nv"
   BusID      "PCI:1:0:0"
EndSection

Section "Monitor"
   Identifier   "Generic Monitor"
   Option      "DPMS"
   HorizSync   28-51
   VertRefresh   43-60
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "nVidia Corporation NV11 [GeForce2 Go]"
   Monitor      "Generic Monitor"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1400x1050" "1024x768"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1280X1024" "1024x768"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1280X1024" "1024x768"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1280X1024" "1024x768"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1280X1024" "1024x768"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1280X1024" "1024x768"
   EndSubSection
EndSection


Wat doe ik niet goed??

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
7.04 geen geluid/ lage schermresolutie
« Reactie #8 Gepost op: 2007/04/22, 09:18:30 »
Modes        "1400x1050" "1024x768"
    EndSubSection
    SubSection "Display"
        Depth        4
        Modes        "1280X1024" "1024x768"
    EndSubSection
    SubSection "Display"
        Depth        8
        Modes        "1280X1024" "1024x768"
    EndSubSection
    SubSection "Display"
        Depth        15
        Modes        "1280X1024" "1024x768"
    EndSubSection
    SubSection "Display"
        Depth        16
        Modes        "1280X1024" "1024x768"
    EndSubSection
    SubSection "Display"
        Depth        24
        Modes        "1280X1024" "1024x768"
    EndSubSection
EndSection
--------------------------------------------------------------------------------
de bovenste rij staat: "1400x1050"==>"1280X1024"
dat aanpassen, en rebooten.
--------------------------------------------------------------------------------

verder lopen er twee draadjes door dit topic, @BigRonnyV:
1) Section "Device"
    Identifier    "nVidia Corporation NV11 [GeForce2 Go]"
    Driver        "nv"
    BusID        "PCI:1:0:0"
je driver= nv. je zal eerst de juiste drivers moeten installeren,
via de restr. drivers manager, als je feisty hebt.

2) je graf. kaart is redelijk oud.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
7.04 geen geluid/ lage schermresolutie
« Reactie #9 Gepost op: 2007/04/22, 09:22:12 »
@ NickK

als het weer niet lukt:
Citaat
sudo dpkg-reconfigure xserver-xorg
in de terminal. op alle vragen ja antwoorden echter bij resolutie kies je/dwing je het systeem jou voorkeurs-resolutie.
maak wel eerst een backup van je xorg conf bestand.

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup

mocht dan je desktop niet meer op komen en krijg je een dos achtige omgeving dan kan je weer met het volgende commando je configuratie terug zetten:
sudo cp /etc/X11/xorg.conf_backup /etc/X11/xorg.conf

Offline mcgyver

  • Lid
  • Steunpunt: Nee
7.04 geen geluid/ lage schermresolutie
« Reactie #10 Gepost op: 2007/04/22, 10:03:41 »
toevoeging/verduidelijking aan relaas van leo:

doe dpkg-reconfigure... . Zeg op alles ja. Ergens kom je een scroll scherm tegen waar de resoluties staan aangegeven. Een aantal zijn niet aangevinkt (geen sterretje) Dat doe je door er met de pijltjestoets op te gaan staan. Selecteren doe je je met je spatiebalk. (@Leo : Nick is pas gisteren of eergisteren herboren dacht ik)

BigRonnyV

  • Gast
7.04 geen geluid/ lage schermresolutie
« Reactie #11 Gepost op: 2007/04/22, 13:12:13 »
@leo, ja de laptop is ook al redelijk oud, maar ja een gegeven paard.....
Met sudo dpkg-reconfigure xserver-xorg heb ik nu een redelijk scherm nog even de juiste resolutie uitvogelen.
Bedankt voor de steun igg.

NickK

  • Gast
7.04 geen geluid/ lage schermresolutie
« Reactie #12 Gepost op: 2007/04/22, 15:08:22 »
Ik krijg, als ik die opdracht uitvoer. Een blauwe achtergrond met een grijs scherm, waarop staat:
Opdat het grafische systeem (X Window System) juist zou functioneren dient u het door de x-server voor de videokaart te gebruiken stuurprogramma aan te geven.

Stuurprogramma-namen verwijzen meestal naar de fabrikant van hetzij de videokaart, hetzij de gebruikte chipset, of naar een chipsetfamilie.
X-server stuurprogramma:
Apm
Ark
ati
chips
cirrus
cyrix
fbdev
glint
i128
i740
i810
imstt
mga
neomagic
newport
nsc
nv
rendition
s3
s3virge
savage
siliconmotion
sis
sisusb
tdfx
tga
trident
tseng
versa
vga
via
vmware
voodoo

Geen ja-nee vraag dus, maar welke daarvan moet ik kiezen. (Ik heb een 8800GTS, van asus).

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
7.04 geen geluid/ lage schermresolutie
« Reactie #13 Gepost op: 2007/04/22, 15:33:12 »
Als je Feisty draait:
Installeer via synaptic het programma "nvidia-glx-new"

Voer daarna in een terminalvenster het volgende commando uit:
sudo dpkg-reconfigure -p high xserver-xorg
(dit kan je gewoon kopieren en plakken vanuit firefox naar de terminal)

Kies bij de vraag over de driver "nvidia" en druk bij de rest van de vragen op enter.

Vervolgens open je /etc/X11/xorg.conf:
sudo gedit /etc/X11/xorg.conf

Pas daarin je resoluties aan, zoals osc4r in de 3e post beschreef.
Hierna opslaan en afsluiten.

Daarna je computer opnieuw opstarten.
Als het goed is, heb je nu een prima beeld :)

Offline mcgyver

  • Lid
  • Steunpunt: Nee
7.04 geen geluid/ lage schermresolutie
« Reactie #14 Gepost op: 2007/04/22, 15:37:20 »
Citaat van: NickK
Geen ja-nee vraag dus, maar welke daarvan moet ik kiezen. (Ik heb een 8800GTS, van asus).
Is nvidia, en wat Johan zegt is prima

NickK

  • Gast
7.04 geen geluid/ lage schermresolutie
« Reactie #15 Gepost op: 2007/04/22, 17:31:17 »
Tot nu toe levert het me alleen crashes op (een melding dat x-weetikhet niet werkt) en heb ik het systeem al een x-aantal keer opnieuw moeten installeren. Maar geen hogere resolutie.

Offline mcgyver

  • Lid
  • Steunpunt: Nee
7.04 geen geluid/ lage schermresolutie
« Reactie #16 Gepost op: 2007/04/22, 17:34:48 »
You've got mail.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
7.04 geen geluid/ lage schermresolutie
« Reactie #17 Gepost op: 2007/04/22, 17:34:58 »
Citaat van: NickK
Tot nu toe levert het me alleen crashes op (een melding dat x-weetikhet niet werkt) en heb ik het systeem al een x-aantal keer opnieuw moeten installeren. Maar geen hogere resolutie.
ik weet het echt niet meer. ik weet wel dat je graf.kaart super-(nieuw) is.
en je systeem waarschijnlijk ook.
werken je drivers wel?
doe eens glxgears in de terminal? of glxgears -printfps
post de uitkomst dan hier.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
7.04 geen geluid/ lage schermresolutie
« Reactie #18 Gepost op: 2007/04/22, 17:36:23 »
@mcgyver
sorry, ik wil er niet doorheen fietsen.  :)

NickK

  • Gast
7.04 geen geluid/ lage schermresolutie
« Reactie #19 Gepost op: 2007/04/22, 17:56:51 »
Citaat van: leoquant
Citaat van: NickK
Tot nu toe levert het me alleen crashes op (een melding dat x-weetikhet niet werkt) en heb ik het systeem al een x-aantal keer opnieuw moeten installeren. Maar geen hogere resolutie.
ik weet het echt niet meer. ik weet wel dat je graf.kaart super-(nieuw) is.
en je systeem waarschijnlijk ook.
werken je drivers wel?
doe eens glxgears in de terminal? of glxgears -printfps
post de uitkomst dan hier.
glxgears:
1351 frames in 5.4 seconds = 248.119 FPS
1200 frames in 5.0 seconds = 238.592 FPS
1200 frames in 5.0 seconds = 239.828 FPS
1200 frames in 5.0 seconds = 239.484 FPS
1233 frames in 5.2 seconds = 238.503 FPS
3360 frames in 5.1 seconds = 659.362 FPS
2953 frames in 5.0 seconds = 590.334 FPS
4746 frames in 5.2 seconds = 915.930 FPS
1243 frames in 5.2 seconds = 238.522 FPS

En ja de 3dkaart is gloednieuw, net als mijn systeem idd (ik heb het gekocht als gamesysteem, en het moet wat jaren mee, dus zodoende.)
De driver die je voor de effecten nodig hebt zorgt ervoor dat mijn systeem crashed.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
7.04 geen geluid/ lage schermresolutie
« Reactie #20 Gepost op: 2007/04/22, 18:52:58 »
Wat is de exacte foutmelding die je te zien krijgt bij de crash?

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
7.04 geen geluid/ lage schermresolutie
« Reactie #21 Gepost op: 2007/04/22, 18:55:56 »
je graf.kaart moet veel en veel beter kunnen presteren.
wil je eens bij procesbeheer kijken of er processen zijn die veel van je systeem eisen.
of anders doe eens
Citaat
top
in de terminal.
er is iets niet in de haak.

NickK

  • Gast
7.04 geen geluid/ lage schermresolutie
« Reactie #22 Gepost op: 2007/04/22, 19:03:27 »
Citaat van: Johanvd
Wat is de exacte foutmelding die je te zien krijgt bij de crash?
Dat zou ik zo niet kunnen zeggen, het systeem weigert op te starten, dus ik kan het niet kopi"eren.

NickK

  • Gast
7.04 geen geluid/ lage schermresolutie
« Reactie #23 Gepost op: 2007/04/22, 19:05:53 »
Citaat van: leoquant
je graf.kaart moet veel en veel beter kunnen presteren.
wil je eens bij procesbeheer kijken of er processen zijn die veel van je systeem eisen.
of anders doe eens
Citaat
top
in de terminal.
er is iets niet in de haak.
Tasks: 115 total,   1 running, 114 sleeping,   0 stopped,   0 zombie
Cpu(s):  1.3%us,  0.0%sy,  0.0%ni, 98.3%id,  0.0%wa,  0.4%hi,  0.0%si,  0.0%st
Mem:   2075652k total,   727900k used,  1347752k free,    67208k buffers
Swap:   658656k total,        0k used,   658656k free,   428540k cached

 PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                                                        
 5313 root      15   0  321m  42m 8712 S    2  2.1   6:56.25 Xorg                                                            
13465 nick      15   0 59808  16m  10m S    0  0.8   0:00.39 gnome-terminal                                                  
    1 root      18   0  2912 1844  524 S    0  0.1   0:01.07 init                                                            
    2 root      RT   0     0    0    0 S    0  0.0   0:00.00 migration/0                                                    
    3 root      34  19     0    0    0 S    0  0.0   0:00.00 ksoftirqd/0                                                    
    4 root      RT   0     0    0    0 S    0  0.0   0:00.00 watchdog/0                                                      
    5 root      RT   0     0    0    0 S    0  0.0   0:00.00 migration/1                                                    
    6 root      39  19     0    0    0 S    0  0.0   0:00.00 ksoftirqd/1                                                    
    7 root      RT   0     0    0    0 S    0  0.0   0:00.00 watchdog/1                                                      
    8 root      10  -5     0    0    0 S    0  0.0   0:11.70 events/0                                                        
    9 root      10  -5     0    0    0 S    0  0.0   0:11.38 events/1                                                        
   10 root      10  -5     0    0    0 S    0  0.0   0:00.00 khelper                                                        
   11 root      10  -5     0    0    0 S    0  0.0   0:00.00 kthread                                                        
   35 root      10  -5     0    0    0 S    0  0.0   0:00.00 kblockd/0                                                      
   36 root      10  -5     0    0    0 S    0  0.0   0:00.00 kblockd/1                                                      
   37 root      16  -5     0    0    0 S    0  0.0   0:00.00 kacpid                                                          
   38 root      16  -5     0    0    0 S    0  0.0   0:00.00 kacpi_notify                                                    
  154 root      14  -5     0    0    0 S    0  0.0   0:00.00 kseriod                                                        
  183 root      16   0     0    0    0 S    0  0.0   0:00.00 pdflush                                                        
  184 root      15   0     0    0    0 S    0  0.0   0:00.02 pdflush                                                        
  185 root      11  -5     0    0    0 S    0  0.0   0:00.00 kswapd0                                                        
  186 root      11  -5     0    0    0 S    0  0.0   0:00.00 aio/0                                                          
  187 root      11  -5     0    0    0 S    0  0.0   0:00.00 aio/1                                                          
  819 root      15   0     0    0    0 S    0  0.0   0:00.00 kirqd                                                          
 2039 root      10  -5     0    0    0 S    0  0.0   0:00.00 ksuspend_usbd                                                  
 2040 root      11  -5     0    0    0 S    0  0.0   0:00.00 khubd                                                          
 2073 root      10  -5     0    0    0 S    0  0.0   0:00.00 khpsbpkt                                                        
 2144 root      10  -5     0    0    0 S    0  0.0   0:00.48 ata/0                                                          
 2145 root      10  -5     0    0    0 S    0  0.0   0:00.03 ata/1                                                          
 2146 root      20  -5     0    0    0 S    0  0.0   0:00.00 ata_aux                                                        
 2222 root      10  -5     0    0    0 S    0  0.0   0:02.11 scsi_eh_0                                                      
 2223 root      11  -5     0    0    0 S    0  0.0   0:00.00 scsi_eh_1      


Dat was de opdracht top.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
7.04 geen geluid/ lage schermresolutie
« Reactie #24 Gepost op: 2007/04/22, 19:13:01 »
bedankt, verbazend normaal. had een hoog cpu-gebruik verwacht, of zombieprocessen.
kun je ons meer vertellen over je systeem, en over de iso die je hebt gebruikt.
desktop/alternate/32bit/64bit?
heb je via de restricted drivers manager de drivers geinstalleerd van je graf.kaart? wat staat er in die manager nu?