Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Mijn Line-In van mijn geluidskaart werkt niet - wat is er mis?  (gelezen 2628 keer)

adrpater

  • Gast
Beste UBuntuers,

Zo juist een upgrade naar Feisty uitgevoerd.
Ging als een tierelier.
Echter één probleempje.
Het lukt me op geen enkele manier om geluid te krijgen uit mijn Line-In of uit mijn Mic.

amixer staat volgens mij goed ingesteld:

 Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 216 [85%] [-7.80dB]
  Front Right: Playback 216 [85%] [-7.80dB]
Simple mixer control 'Front',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 51 [80%] [-13.00dB] [on]
  Front Right: Playback 51 [80%] [-13.00dB] [on]
Simple mixer control 'Surround',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 45 [70%] [-19.00dB] [on]
  Front Right: Playback 45 [70%] [-19.00dB] [on]
Simple mixer control 'Center',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 47 [73%] [-17.00dB] [off]
Simple mixer control 'LFE',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 46 [72%] [-18.00dB] [off]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65
  Mono:
  Front Left: Playback 48 [74%] [13.00dB] [on]
  Front Right: Playback 48 [74%] [13.00dB] [on]
Simple mixer control 'CD',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65
  Mono:
  Front Left: Playback 52 [80%] [17.00dB] [on]
  Front Right: Playback 52 [80%] [17.00dB] [on]
Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65
  Mono:
  Front Left: Playback 49 [75%] [14.00dB] [on]
  Front Right: Playback 49 [75%] [14.00dB] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 35
  Front Left: Capture 28 [80%] [28.00dB] [on]
  Front Right: Capture 28 [80%] [28.00dB] [on]
Simple mixer control 'Capture',1
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 35
  Front Left: Capture 27 [77%] [27.00dB] [on]
  Front Right: Capture 27 [77%] [27.00dB] [on]
Simple mixer control 'Capture',2
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 35
  Front Left: Capture 27 [77%] [27.00dB] [on]
  Front Right: Capture 27 [77%] [27.00dB] [on]
Simple mixer control 'Channel Mode',0
  Capabilities: enum
  Items: '2ch' '6ch'
  Item0: '6ch'
Simple mixer control 'Input Source',0
  Capabilities: enum
  Items: 'Mic' 'Front Mic' 'Line' 'CD'
  Item0: 'Line'
Simple mixer control 'Input Source',1
  Capabilities: enum
  Items: 'Mic' 'Front Mic' 'Line' 'CD'
  Item0: 'Mic'
Simple mixer control 'Input Source',2
  Capabilities: enum
  Items: 'Mic' 'Front Mic' 'Line' 'CD'
  Item0: 'Front Mic'
Mijn geluidskaart is een HDA codec Realtek ALC861 (met 6 jacks achter en 2 jacks voor)
aan boord van mijn ASUS P5GD1-VM moederbord.

lspci | grep Audio

geeft:

00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)cat /proc/asound/oss/sndstat

geeft:

Sound Driver:3.8.1a-980706 (ALSA v1.0.14rc1 emulation code)
Kernel: Linux desktop 2.6.20-15-386 #2 Sun Apr 15 07:34:00 UTC 2007 i686
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
HDA Intel at 0xcfef8000 irq 16

Audio devices:
0: ALC880 Analog (DUPLEX)

Synth devices: NOT ENABLED IN CONFIG

Midi devices: NOT ENABLED IN CONFIG

Timers:
31: system timer

Mixers:
0: Realtek ALC880
Dat vond ik wel wat vreemd want ik zou Realtek ALC861 verwachten.

Ik ben er nu een uur of 8 mee bezig en ik kom er echt niet uit.
Kan iemand me helpen?

Bijvoorbaat hartelijk dank!

Groetjes,

Adriaan.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Mijn Line-In van mijn geluidskaart werkt niet - wat is er mis?
« Reactie #1 Gepost op: 2007/04/21, 22:50:31 »
Doe eens dit:
Systeem - Beheer - Synaptic pakketbeheer
zoekterm: alsamixergui
aanvinken en toepassen

Open daarna alsamixergui eens en experimenteer wat met het openen van schuifjes. Let op: niet alle schuifjes tegelijk, en geen enkele voor meer dan 90 % openzetten.

Helpt dit?

Groet, Pjotr.

adrpater

  • Gast
Mijn Line-In van mijn geluidskaart werkt niet - wat is er mis?
« Reactie #2 Gepost op: 2007/04/23, 11:19:15 »
Beste Pjotr,

Hartelijk dank voor je advies.
Helaas helpt dit niet.
Geen geluid vanaf mijn line-in.

Ondertussen begin ik de indruk te krijgen dat het gewoon een ALSA / driver bug is.

Onder een besturingssysteem van een bedrijf uit Redmond, waar ik, voordat ik Linux ontdekte, flink poen voor neer heb gelegd (no MS bashing intended), lukt het me wel om geluid vanaf mijn line-in op te nemen.
Ook op mijn zeer oude laptopje waar ik Xubuntu draai is het geluid vanaf mijn line-in hoorbaar.

Nog meer ideeën?

Groet,

Adriaan.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Mijn Line-In van mijn geluidskaart werkt niet - wat is er mis?
« Reactie #3 Gepost op: 2007/04/23, 17:20:24 »
Kijk ook eens in system>preferences>sound.
Speel vooral met de instellingen voor audio conferencing.

Je kan ook dubbelklikken op het luidsprekertje in je terminal.
Dan krijg je een venster waarin je met de schuifjes kan spelen.
Met edit>preferences kan je meer schuifjes toevoegen.
Kijk ook in het tabje switches, waar onder andere de mic boost interessant kan zijn.
Verder kan je onder file>change device ook een andere mixer instellen.
Ga daar ook alle schuifjes even langs.

adrpater

  • Gast
Mijn Line-In van mijn geluidskaart werkt niet - wat is er mis?
« Reactie #4 Gepost op: 2007/04/24, 09:20:16 »
Beste Johanvd,

Hartelijk dank voor je reactie.
Ik vind het wel zo tof dat er mensen zijn die de moeite nemen om je te helpen op dit forum.

Wel is het zo dat ik al je tips al (lang) had geprobeerd.
Opmerkelijk is dat als ik onder system>preferences>sound de instellingen voor audio conferencing,
de geluidsopname test (op het knopje test druk) ik niets hoor! Welke instellingen ik ook kies.
Ook als ik de instelling "Testgeluid" kies hoor ik niets.
Dat is natuurlijk niet goed.
Betekent dat, dat er een pijplijn gebroken is?
Want Ubuntu zegt: pijplijn testen.

Groet,

Adriaan

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Mijn Line-In van mijn geluidskaart werkt niet - wat is er mis?
« Reactie #5 Gepost op: 2007/04/24, 13:37:44 »
http://forum.ubuntu-nl.org/message/98295#p98295
Probeer dit eens, wel eerst een backup maken van het bestand dat je aanpast.
Backup maken:
sudo cp /etc/modprobe.d/alsa-base /etc/modprobe.d/alsa-base.backup

Daarna bewerken:
sudo gedit /etc/modprobe.d/alsa-base

Na het bewerken je computer opnieuw opstarten.

Werkt het na het opstarten nog steeds niet, dan moet je even je backup terugzetten:
sudo cp /etc/modprobe.d/alsa-base.backup /etc/modprobe.d/alsa-base

Deze commando's kan je kopiëren en plakken in een terminalvenster.

Minardus

  • Gast
Mijn Line-In van mijn geluidskaart werkt niet - wat is er mis?
« Reactie #6 Gepost op: 2007/04/24, 14:25:34 »
Probeer anders eens dit, het heeft mij geholpen aan mijn headphone uitgang:

Installing the latest Alsa drivers

I'll show you how to install Alsa properly. First of all you should run
sudo /etc/init.d/alsa-utils stopThis stops the Alsa machinery. I didn't do this first time I installed the Alsa drivers, and got some severe problems because of it. It's important that you do not forget the above command. Now, download the latest development release of alsa-driver, alsa-lib and alsa-utils from the Alsa webpage, and do the following with all the tarballs in the order I listed the three tarballs:
tar xvf .tar.bz2
sudo ./configure --with-kernel=/usr/src/linux-headers-$(uname -r) --with-cards=hda-intel --with-oss=yes
sudo make
sudo make install
If you have any other cards (like an onboard card), you can add it to --with-cards seperated by commas. After the installation is finished, do a complete reboot. Then run

cat /proc/asound/versionto check if you successfully upgraded Alsa. The first time you reboot after upgrading Alsa or installing a new system, you must increase the volume of all channels in alsamixer.

adrpater

  • Gast
Mijn Line-In van mijn geluidskaart werkt niet - wat is er mis?
« Reactie #7 Gepost op: 2007/04/25, 07:17:57 »
Hij doet het!
Jullie zijn geweldig!

De oplossing van Johanvd werkte!
Ik had aan alsa-base al toegevoegd:
options snd-hda-intel model=6stack

maar nu heb ik daar ook nog die "position_fix=1" aan toe gevoegd
hoewel ik in mijn dmesg niet dezelfde fout tegenkwam als in
http://forum.ubuntu-nl.org/message/98295#p98295

Hartelijk dank Johanvd

Ook minardus hartelijk dank voor de reactie!