Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Gebroken pakketsysteem ?  (gelezen 1147 keer)

Offline lacer

  • Lid
    • dDbJn3Y
  • Steunpunt: Ja
Gebroken pakketsysteem ?
« Gepost op: 2016/01/23, 13:51:40 »
Bij een recente automatische update voor Ubuntu 14.04 van kernel 3.19.0-43 naar 3.19.0-47 stuit ik op volgende melding:

Citaat
Het pakketsysteem is gebroken
Controleer of u softwarebronnen van een derde partij gebruikt. Als dat zo is, schakel ze dan uit, omdat ze een veelvoorkomende bron van problemen zijn.
Voer ook de volgende opdracht uit in een Terminalvenster: apt-get install -f

In het systeemvak staat ook een rood verkeersbordje dat wijst op een fout.

Doe ik: sudo apt-get install -f

luc@luc-Vaio:~$ sudo apt-get install -f
[sudo] password for luc:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
Vereisten worden gecorrigeerd... Klaar
De volgende pakketten zijn automatisch geïnstalleerd en zijn niet langer nodig:
  linux-headers-3.19.0-39 linux-headers-3.19.0-39-generic
  linux-image-3.19.0-39-generic linux-image-extra-3.19.0-39-generic
Use 'apt-get autoremove' to remove them.
De volgende extra pakketten zullen geïnstalleerd worden:
  linux-image-3.19.0-47-generic
Voorgestelde pakketten:
  fdutils linux-lts-vivid-tools
De volgende NIEUWE pakketten zullen geïnstalleerd worden:
  linux-image-3.19.0-47-generic
0 pakketten opgewaardeerd, 1 pakketten nieuw geïnstalleerd, 0 te verwijderen en 11 niet opgewaardeerd.
3 pakketten niet volledig geïnstalleerd of verwijderd.
Er moeten 0 B/16,7 MB aan archieven opgehaald worden.
Door deze operatie zal er 47,5 MB extra schijfruimte gebruikt worden.
Wilt u doorgaan? [J/n]
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/Debconf/DbDriver/File.pm line 49, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value in -e at /usr/share/perl5/Debconf/DbDriver/File.pm line 51, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value in sysopen at /usr/share/perl5/Debconf/DbDriver/File.pm line 53, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/Debconf/DbDriver/File.pm line 53, <DEBCONF_CONFIG> chunk 3.
debconf: DbDriver "config": could not open
(Database inlezen ... 265388 bestanden en mappen momenteel geïnstalleerd.)
Uitpakken van .../linux-image-3.19.0-47-generic_3.19.0-47.53~14.04.1_amd64.deb wordt voorbereid...
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/Debconf/DbDriver/File.pm line 49, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value in -e at /usr/share/perl5/Debconf/DbDriver/File.pm line 51, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value in sysopen at /usr/share/perl5/Debconf/DbDriver/File.pm line 53, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/Debconf/DbDriver/File.pm line 53, <DEBCONF_CONFIG> chunk 3.
debconf: DbDriver "config": could not open
dpkg: fout bij verwerken van archief /var/cache/apt/archives/linux-image-3.19.0-47-generic_3.19.0-47.53~14.04.1_amd64.deb (--unpack):
 subproces nieuw pre-installation script gaf een foutwaarde 1 terug
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.19.0-47-generic /boot/vmlinuz-3.19.0-47-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.19.0-47-generic /boot/vmlinuz-3.19.0-47-generic
Fouten gevonden tijdens behandelen van:
 /var/cache/apt/archives/linux-image-3.19.0-47-generic_3.19.0-47.53~14.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
luc@luc-Vaio:~$

Ik zit beetje vast en weet niet wat gedaan.






1*Ubuntu Mate 16.04 + ElementaryOS + LinuxMint 13 op Dell 6000 laptop Intel Centrino 32bits
2* Ubuntu Mate 17.10 op Acer Aspire 7741z P6100 cpu 4GB ram
3* Ubuntu 14.04 + LinuxMint 13 + LinuxMint17 op Toshiba Satelite A300 Intel Core2Duo T5550 4GB ram
4° Ubuntu 16.04 op Sont Vaio VPCEB4M1E Intel i3 M380 4 GB ram

Offline lacer

  • Lid
    • dDbJn3Y
  • Steunpunt: Ja
Re: Gebroken pakketsysteem ?
« Reactie #1 Gepost op: 2016/01/23, 14:02:01 »
Vervolgens in Synaptic gezocht op defecte pakketten en deze verwijderd
Dit waren de linux-image-3.19.0-47-generic en linux-image-generic-lts-vivid.
Rode foutmelding in systeemvak is nu wel verdwenen.

Heb hier een soortgelijk probleem gevonden met kernel 3.19.0-47
http://ubuntuforums.org/showthread.php?t=2310948
1*Ubuntu Mate 16.04 + ElementaryOS + LinuxMint 13 op Dell 6000 laptop Intel Centrino 32bits
2* Ubuntu Mate 17.10 op Acer Aspire 7741z P6100 cpu 4GB ram
3* Ubuntu 14.04 + LinuxMint 13 + LinuxMint17 op Toshiba Satelite A300 Intel Core2Duo T5550 4GB ram
4° Ubuntu 16.04 op Sont Vaio VPCEB4M1E Intel i3 M380 4 GB ram

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Gebroken pakketsysteem ?
« Reactie #2 Gepost op: 2016/01/23, 15:40:03 »
Ik heb volgend "reparatierecept" staan: probeer het eens om te zien of alle foutmeldingen hierbij opgelost worden:

sudo apt-get update
sudo apt-get clean
sudo apt-get install -fy
sudo dpkg -i /var/cache/apt/archives/*.deb
sudo dpkg --configure -a
sudo apt-get install -fy
« Laatst bewerkt op: 2016/01/24, 12:44:15 door vanadium »

Offline lacer

  • Lid
    • dDbJn3Y
  • Steunpunt: Ja
Re: Gebroken pakketsysteem ?
« Reactie #3 Gepost op: 2016/01/23, 17:18:35 »
Nu krijg ik dit na de eerste commando:
luc@luc-Vaio:~$ sudo apt-get update
[sudo] password for luc:
sudo: kan /var/lib/sudo/luc/0 niet openen: Bestand of map bestaat niet
Genegeerd http://archive.canonical.com trusty InRelease
Genegeerd http://be.archive.ubuntu.com trusty InRelease                       
Genegeerd http://archive.canonical.com trusty Release.gpg                     
Geraakt http://archive.canonical.com trusty Release                           
W: Er wordt geen vergrendeling gebruikt voor het alleen-lezen-vergrendelingsbestand /var/lib/apt/lists/lock
E: Couldn't create temporary file to work with /var/lib/apt/lists/archive.canonical.com_ubuntu_dists_trusty_Release - mkstemp (30: Bestandssysteem is alleen-lezen)
W: Er wordt geen vergrendeling gebruikt voor het alleen-lezen-vergrendelingsbestand /var/lib/dpkg/lock
E: dpkg werd onderbroken; voer handmatig 'sudo dpkg --configure -a' uit om het probleem te verhelpen.
luc@luc-Vaio:~$ sudo dpkg --configure -a
[sudo] password for luc:
sudo: kan /var/lib/sudo/luc/0 niet openen: Bestand of map bestaat niet
dpkg: fout: kan niet binnen bij het statusgebied van dpkg: Bestandssysteem is alleen-lezen
luc@luc-Vaio:~$

1*Ubuntu Mate 16.04 + ElementaryOS + LinuxMint 13 op Dell 6000 laptop Intel Centrino 32bits
2* Ubuntu Mate 17.10 op Acer Aspire 7741z P6100 cpu 4GB ram
3* Ubuntu 14.04 + LinuxMint 13 + LinuxMint17 op Toshiba Satelite A300 Intel Core2Duo T5550 4GB ram
4° Ubuntu 16.04 op Sont Vaio VPCEB4M1E Intel i3 M380 4 GB ram

Offline TopGear

  • Forumteam
  • Steunpunt: Nee
Re: Gebroken pakketsysteem ?
« Reactie #4 Gepost op: 2016/01/24, 11:34:19 »
Volgens deze askubuntu-entry zou je de volgende commando's in een live-sessie (dus vanaf een opstartbare USB-stick of CD-ROM) moeten uitvoeren:
sudo fdisk -l
sudo fsck /dev/sd**
Waarin /dev/sd** de schijf en partitie is waar Ubuntu op staat (dus iets als /dev/sda1 bijvoorbeeld).

Offline lacer

  • Lid
    • dDbJn3Y
  • Steunpunt: Ja
Re: Gebroken pakketsysteem ?
« Reactie #5 Gepost op: 2016/01/24, 11:42:47 »
Bedankt, ik ga dat ook eens proberen.
Dat kan toch ook vanaf een andere partitie uit een dual boot installatie he ?
1*Ubuntu Mate 16.04 + ElementaryOS + LinuxMint 13 op Dell 6000 laptop Intel Centrino 32bits
2* Ubuntu Mate 17.10 op Acer Aspire 7741z P6100 cpu 4GB ram
3* Ubuntu 14.04 + LinuxMint 13 + LinuxMint17 op Toshiba Satelite A300 Intel Core2Duo T5550 4GB ram
4° Ubuntu 16.04 op Sont Vaio VPCEB4M1E Intel i3 M380 4 GB ram

Offline TopGear

  • Forumteam
  • Steunpunt: Nee
Re: Gebroken pakketsysteem ?
« Reactie #6 Gepost op: 2016/01/24, 12:23:02 »
Het liefste vanaf een compleet andere schijf eigenlijk, zodat niets van die harde schijf gemount is.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Gebroken pakketsysteem ?
« Reactie #7 Gepost op: 2016/01/24, 12:37:37 »
Of een recovery prompt met beheerderstoegang. Het zou inderdaad kunnen dat een storing in het bestandssysteem aan de grondslag ligt van het probleem. Dit kan een gevolg zijn van een faling in de software, of een op een verkeerde manier afzetten van de machine, maar zou ook kunnen wijzen op een falende harde schijf.

Als je dat goed krijgt, zal je wellicht vooralsnog het pakketsysteem moeten repareren voor zover dat nog zal kunnen. Lukt dat niet, dan zal het een herinstallatie worden. Keert het probleem binnen niet al te lange tijd terug, dan wordt het wellicht tijd om de harde schijf te vervangen.

Offline TopGear

  • Forumteam
  • Steunpunt: Nee
Re: Gebroken pakketsysteem ?
« Reactie #8 Gepost op: 2016/01/24, 12:42:47 »
Sowieso lijkt het me slim om de SMART-waarden eens te checken. Open het programma "gnome-disk-utility", navigeer naar de harde schijf met problemen, druk dan op het tandwieltje rechtsboven en kies "SMART Data & self tests". Daar zal iets staan van "Self-test Result", "Self-test assessment" en "Overall assessment". Wat zijn de waarden hiervan? En wat staat er bij de Value van de Attribute met naam "Reallocated Sector Count"?

Offline lacer

  • Lid
    • dDbJn3Y
  • Steunpunt: Ja
Re: Gebroken pakketsysteem ?
« Reactie #9 Gepost op: 2016/01/24, 13:49:16 »
Het betreft een Samsung EVO 850 SSD van 120 GB en is nog geen jaar oud.
Heb wel enkele maanden geleden ook al eens rare verschijnselen gehad zoald gedit die niet meer wilde opstarten en ook eens simple-scan en nog wat andere software problemen. Heb al 1 x een herinstallatie moeten doen, de tweede maal Ubuntu volledig terug gezet naar z'n beginwaarden begin december van vorig jaar met volgend commando:
sudo apt-get install --reinstall ubuntu-desktop
Telkens trim, noatime en swapiness aangepast volgends de uitstekende beschrijvingen van Pjotr :-)

Hier zijn de smart gegevens, maar ik zie er niks die zou kunnen wijzen op falen...
« Laatst bewerkt op: 2016/01/24, 13:52:49 door lacer »
1*Ubuntu Mate 16.04 + ElementaryOS + LinuxMint 13 op Dell 6000 laptop Intel Centrino 32bits
2* Ubuntu Mate 17.10 op Acer Aspire 7741z P6100 cpu 4GB ram
3* Ubuntu 14.04 + LinuxMint 13 + LinuxMint17 op Toshiba Satelite A300 Intel Core2Duo T5550 4GB ram
4° Ubuntu 16.04 op Sont Vaio VPCEB4M1E Intel i3 M380 4 GB ram

Offline Nike

  • Lid
  • Steunpunt: Nee
Re: Gebroken pakketsysteem ?
« Reactie #10 Gepost op: 2016/01/25, 07:39:56 »
Ik had hetzelfde probleem en heb dit inmiddels op kunnen lossen door ongebruikte restanten van verwijderde programma's weg te gooien wat duidelijk is beschreven in https://sites.google.com/site/computertip/schoon. Update werkt weer prima!

Offline lacer

  • Lid
    • dDbJn3Y
  • Steunpunt: Ja
Re: Gebroken pakketsysteem ?
« Reactie #11 Gepost op: 2016/01/25, 10:03:50 »
Handleiding gevolgd in Synaptic maar na het op toepassen klikken volgende fout:
(synaptic:2340): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/Debconf/DbDriver/File.pm line 49, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value in -e at /usr/share/perl5/Debconf/DbDriver/File.pm line 51, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value in sysopen at /usr/share/perl5/Debconf/DbDriver/File.pm line 53, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/Debconf/DbDriver/File.pm line 53, <DEBCONF_CONFIG> chunk 3.
debconf: DbDriver "config": could not open
dpkg: onherstelbare fatale fout; er wordt gestopt:
 bestandenlijst-bestand voor pakket `ghostscript-x' bevat een lege bestandsnaam
E: Sub-process /usr/bin/dpkg returned an error code (2)
Een pakket kon niet geïnstalleerd worden. Aan het proberen om te herstellen:

Voor de rest werkt mijn installatie nog goed, krijg dus steeds een fout bij verwijderen en installeren van paketten.

Het volgende heb ik wel nog niet gedaan:
sudo fdisk -l
sudo fsck /dev/sd**
« Laatst bewerkt op: 2016/01/25, 10:05:47 door lacer »
1*Ubuntu Mate 16.04 + ElementaryOS + LinuxMint 13 op Dell 6000 laptop Intel Centrino 32bits
2* Ubuntu Mate 17.10 op Acer Aspire 7741z P6100 cpu 4GB ram
3* Ubuntu 14.04 + LinuxMint 13 + LinuxMint17 op Toshiba Satelite A300 Intel Core2Duo T5550 4GB ram
4° Ubuntu 16.04 op Sont Vaio VPCEB4M1E Intel i3 M380 4 GB ram

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Re: Gebroken pakketsysteem ?
« Reactie #12 Gepost op: 2016/01/25, 10:40:34 »
/usr/share/debconf/fix_db.plvond ik ergens.

Offline lacer

  • Lid
    • dDbJn3Y
  • Steunpunt: Ja
Re: Gebroken pakketsysteem ?
« Reactie #13 Gepost op: 2016/01/25, 10:53:47 »
met toevoeging van  "sudo gedit" kon ik het bestandje openen, maar werd geadviseerd daar niks in te wijzigen.
#!/usr/bin/perl -w
# This file was preprocessed, do not edit!
use strict;
use Debconf::Db;
use Debconf::Log q{warn};

Debconf::Db->load;

if (! @ARGV || $ARGV[0] ne 'end') {
my $fix=0;
my $ok;
my $counter=0;
do {
$ok=1;

my %templates=();
my $ti=$Debconf::Db::templates->iterator;
while (my $t=$ti->iterate) {
$templates{$t}=Debconf::Template->get($t);
}

my %questions=();
my $qi=Debconf::Question->iterator;
while (my $q=$qi->iterate) {
if (! defined $q->template) {
warn "question \"".$q->name."\" has no template field; removing it.";
$q->addowner("killme",""); # make sure it has one owner at least, so removal is triggered
foreach my $owner (split(/, /, $q->owners)) {
$q->removeowner($owner);
}
$ok=0;
$fix=1;
}
elsif (! exists $templates{$q->template->template}) {
warn "question \"".$q->name."\" uses nonexistant template ".$q->template->template."; removing it.";
foreach my $owner (split(/, /, $q->owners)) {
$q->removeowner($owner);
}
$ok=0;
$fix=1;
}
else {
$questions{$q->name}=$q;
}
}

foreach my $t (keys %templates) {
my @owners=$Debconf::Db::templates->owners($t);
if (! @owners) {
warn "template \"$t\" has no owners; removing it.";
$Debconf::Db::templates->addowner($t, "killme","");
$Debconf::Db::templates->removeowner($t, "killme");
$fix=1;
}
foreach my $q (@owners) {
if (! exists $questions{$q}) {
warn "template \"$t\" claims to be used by nonexistant question \"$q\"; removing that.";
$Debconf::Db::templates->removeowner($t, $q);
$ok=0;
$fix=1;
}
}
}
$counter++;
} until ($ok || $counter > 20);

if ($fix) {
Debconf::Db->save;
exec($0, "end");
die "exec of self failed";
}
}

foreach my $templatefile (glob("/var/lib/dpkg/info/*.templates")) {
my ($package) = $templatefile =~ m:/var/lib/dpkg/info/(.*?).templates:;
        Debconf::Template->load($templatefile, $package);
}

Debconf::Db->save;
1*Ubuntu Mate 16.04 + ElementaryOS + LinuxMint 13 op Dell 6000 laptop Intel Centrino 32bits
2* Ubuntu Mate 17.10 op Acer Aspire 7741z P6100 cpu 4GB ram
3* Ubuntu 14.04 + LinuxMint 13 + LinuxMint17 op Toshiba Satelite A300 Intel Core2Duo T5550 4GB ram
4° Ubuntu 16.04 op Sont Vaio VPCEB4M1E Intel i3 M380 4 GB ram

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Gebroken pakketsysteem ?
« Reactie #14 Gepost op: 2016/01/25, 11:01:11 »
Die moet je niet bewerken, maar uitvoeren met sudo.

Maar er is duidelijk iets niet goed met de database waarin het pakketbeheersysteem allerlei instellingen opslaat. Hopelijk lost het script de fouten op, maar de kans is groot dat je een backup terug moet zetten of je systeem opnieuw installeren.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Re: Gebroken pakketsysteem ?
« Reactie #15 Gepost op: 2016/01/25, 11:16:59 »
idd een perl scriptje.
« Laatst bewerkt op: 2016/01/25, 11:19:36 door Soul-Sing »

Offline lacer

  • Lid
    • dDbJn3Y
  • Steunpunt: Ja
Re: Gebroken pakketsysteem ?
« Reactie #16 Gepost op: 2016/02/06, 13:53:40 »
Met een live usb stick fsck gedaan
sudo fsck /dev/sda1Clean...
Ondertussen draai ik erop verder, zonder herinstallatie, maar het is niet mogelijk updates of nieuwe pakketten te installeren.
Ik draai in dualboot ook 16.04 en na een update gisteren wilde die niet meer opstarten.
Ook een sudo fsck /dev/sda4 gedaan en een 30 tal fouten hersteld.
Er was nadien wel enig inconsistentie in nautilus, maar dat is dan ook een ontwikkelversie  :)
De zaken in beide installaties hebben, denk ik, geen verband met elkaar.
1*Ubuntu Mate 16.04 + ElementaryOS + LinuxMint 13 op Dell 6000 laptop Intel Centrino 32bits
2* Ubuntu Mate 17.10 op Acer Aspire 7741z P6100 cpu 4GB ram
3* Ubuntu 14.04 + LinuxMint 13 + LinuxMint17 op Toshiba Satelite A300 Intel Core2Duo T5550 4GB ram
4° Ubuntu 16.04 op Sont Vaio VPCEB4M1E Intel i3 M380 4 GB ram