Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: modsecurity verwijderen/uitzetten in Ubuntu 15.10  (gelezen 163 keer)

Offline tuxpower

  • Lid
  • Steunpunt: Nee
modsecurity verwijderen/uitzetten in Ubuntu 15.10
« Gepost op: 2016/01/13, 17:47:31 »
Hallo Allemaal.

Ik had Ubuntu 12.10 op mijn VPS server  , nu heb ik Ubuntu 15.10 nu werkt mijn PHP site niet meer.

Het lukt niet om modsecurity te  verwijderen/uitzetten in Ubuntu 15.10 , ik krijg steeds de foutmelding op mijn site  The requested URL /login/ was not found on this server.

Mijn .htaccess file is.
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteBase /
RewriteRule ^embed/([^/]*)/$ /embed.php?id=$1 [L]
RewriteRule ^feed(.*)$ feed.php [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)/?$ index.php?rp=$1 [L]
</IfModule>
<ifModule mod_headers.c>
    Header set Access-Control-Allow-Origin: *
</ifModule>

<ifmodule mod_security.c>

SecFilterEngine Off
SecFilterScanPOST Off

</ifmodule>

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

Wie kan mij helpen :)

Alvast bedankt.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: modsecurity verwijderen/uitzetten in Ubuntu 15.10
« Reactie #1 Gepost op: 2016/01/14, 08:18:59 »
Waarom denk je dat dit te maken heeft met modsecurity? Je geeft geen enkele foutmelding die daarop wijst.
Mocht je hem toch uit willen zetten: verwijder het pakket libapache2-modsecurity.

Wat de fout betreft zou je eerst eens moeten kijken naar een aantal wijzigingen die zijn doorgevoerd sinds Ubuntu 14.04.
Zie o.a. hier: http://httpd.apache.org/docs/2.4/upgrading.html
En op je server via dit commando: zless /usr/share/doc/apache2/NEWS.Debian.gz

In het kort: Apache is geüpdatet van 2.2 naar 2.4 en er zijn nogal wat wijzigingen doorgevoerd in de configuratiebestanden, locaties waar je website moet staan enz. In de /usr/share/doc/apache2 dir staat een script dat kan helpen met het omzetten hiervan.