Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Canon MG5550 Scanner  (gelezen 453 keer)

Offline Nero

  • Lid
  • Steunpunt: Ja
Canon MG5550 Scanner
« Gepost op: 2016/01/10, 15:52:23 »
Eigenaardig probleem: tot voor kort (< 2 maand) werkte de scanner probleemloos via Wifi. Nu wordt de scanner niet meer gevonden. scanimage -L geeft geen resultaat. nmap -p 6566 192.168.0.200 antwoordt 6566/tcp closed sane-port. Uitgeprobeerd met Live USB Lubuntu/Ubuntu/Xubuntu 14.04.3 en Mint 17.3.

Doe ik hetzelfde met Debian Stable LXDE dan wordt de scanner wel gevonden, zowel met Simple Scan als met scanimage -L en nmap 192.168.0.200. De scanner werkt dan ook, zonder installatie van bijkomende drivers.

Wat kan hiervan de oorzaak/verklaring zijn? Scannen heeft dus tot voor 2 maand probleemloos gewerkt in Lubuntu 14.04.

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: Canon MG5550 Scanner
« Reactie #1 Gepost op: 2016/01/11, 20:38:27 »
Nero,

Controleer uw FireWall instellingen, desnoods even uit zetten.
Je schrijf dat de sane-poort 6566/tcp dicht staat.
Kijk ook eens in de configuratie bestand /etc/sane.d/net.conf of er iets is veranderd.
MvG,
MauRice
Registered Linux user: 473556

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Canon MG5550 Scanner
« Reactie #2 Gepost op: 2016/01/11, 20:51:51 »
De tests werden allemaal gedaan vanuit een Live medium. Ergo: geen veranderingen noch firewall. Enige "verandering" is in de Live run nmap en sane-utils installeren.

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: Canon MG5550 Scanner
« Reactie #3 Gepost op: 2016/01/11, 21:09:23 »
Nero,

Als je aan testen bent via een Live Medium.
Dan zal ik als eerste scanimage -L eentje zonder en eentje met sudo.
Als je met sudo wel de scanner ziet ....
Dan heb je als gebruiker geen rechten op die device.

Als je met beiden geen scanner ziet... dan zal je dus verder moeten zoeken.

Mocht je Live Medium de instellingen niet kunnen bewaren is het wel zonde van de tijd.
Maar wel leerzaam voor de volgende 'echte' keer wat je moet doen.

MvG,
MauRice
Registered Linux user: 473556

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Canon MG5550 Scanner
« Reactie #4 Gepost op: 2016/01/11, 22:28:27 »
Als je met beiden geen scanner ziet... dan zal je dus verder moeten zoeken.
Zover zitten we dus  ;)

Ik heb het voor deze gebruiker (tijdelijk) opgelost door naast Lubuntu op z'n pc ook Debian LXDE te plaatsen. Daarin werk het dus wel probleemloos.

Daarmee zitten we dus weer bij de kernvraag: waarom werkt het niet meer (het heeft dus wel gewerkt) in *buntu - ook niet via USB koppeling - en wel in Debian?

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: Canon MG5550 Scanner
« Reactie #5 Gepost op: 2016/01/12, 07:37:41 »
.....
Daarmee zitten we dus weer bij de kernvraag: waarom werkt het niet meer (het heeft dus wel gewerkt) in *buntu - ook niet via USB koppeling - en wel in Debian?
Nero,

De kernantwoorden blijven.....
- Instellingen in Firewall ....
- Is het IP-adres van de scanner (192.168.0.200) bekend via /etc/sane.d/net.conf .....
- Zijn die Cannon driver voor MG5550 standaard aanwezig in Debian en niet meer in *buntu ...

Je werkt via een Live Medium. ik neem aan 14.04.3

Misschien zeg den uitkomst van dmesg op de verschilende systemen meer, voor en na als je die scanner aanroep.
MvG,
MauRice
Registered Linux user: 473556

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Canon MG5550 Scanner
« Reactie #6 Gepost op: 2016/01/12, 09:32:57 »
- ufw disabled in alle gevallen.
- zelfde /etc/sane.d/ in alle gevallen

... en alle configuraties op dezelfde manier ingesteld in alle gevallen.

Blijft vreemd waarom het plots niet meer werkt, in geen enkele *buntu, terwijl het tot voor 2 maanden wel ging.

Edit: waarom ziet nmap de poort wel in Debian en niet in *buntu?

Btw, ook Linux Mint 17.3 doet het niet.
« Laatst bewerkt op: 2016/01/12, 09:34:39 door Nero »

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: Canon MG5550 Scanner
« Reactie #7 Gepost op: 2016/01/12, 11:21:38 »
......

Edit: waarom ziet nmap de poort wel in Debian en niet in *buntu?

Btw, ook Linux Mint 17.3 doet het niet.
Nero,

Ik zal me toch eens verdiepen in poort 6566 zowel Client als Server zijde.
Volgens mij kan niets anders dat daar iets bij *buntu/Mint geblokkeerd wordt.

Toch zeker zoals je beschrijf dat het voorheen wel werkte.

PS:
Situatie bijmij thuis:
Scanner, een Brother DCP-165C USB is verbonden aan een PC die ook als Print-server dient (Ubuntu Server).
Poort 6566 staat open op de Server.
Gebruiker heeft de nodige rechten en het IP-adres (vast DHCP) van de Server is bekent op de Client

Bijmij geeft scanimage -L regelmatig een foutieve uitkomst (Mint 17.3)
Citaat
Fout:
Segmentation fault

*** Error in `scanimage': double free or corruption (!prev): 0x00000000023c0eb0 ***
Aborted

Goed:
device `net:192.168.0.10:brother3:bus4;dev1' is a Brother DCP-165C USB scanner

Deel van dmesg als het fout ging:
Citaat
[  279.149102] scanimage[2584]: segfault at 7fa4093c7507 ip 00007fa408c6e820 sp 00007ffda4a97ac8 error 4 in libc-2.19.so[7fa408bdd000+1bb000]
[  289.934020] scanimage[2592]: segfault at 7fcfa4ec4270 ip 00007fcfa4764c88 sp 00007fcf97c15fa8 error 4 in libc-2.19.so[7fcfa46d9000+1bb000]
[  357.609738] scanimage[2608]: segfault at 7fb2aa5ee498 ip 00007fb2a9e94852 sp 00007ffe982327b8 error 4 in libc-2.19.so[7fb2a9e03000+1bb000]
[  374.773762] scanimage[2612]: segfault at 7f3ae0f23c2a ip 00007f3ae07c3c38 sp 00007ffce398eee8 error 4 in libc-2.19.so[7f3ae0738000+1bb000]

Waar het aan ligt dat scanimage -L fout gaat, een vraagteken.
Scannen werkt zowel via XSane als SimpleScan.
MvG,
MauRice
Registered Linux user: 473556