Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Feisty x server  (gelezen 2392 keer)

Offline Blackdrive

  • Lid
  • Steunpunt: Nee
Feisty x server
« Gepost op: 2007/04/21, 16:32:10 »
Welwel, nog nooit problemen gehad met een Ubuntu installatie. Maar nu met Feisty...

Ik download en brand de iso (gewoon rechtsklikken - 'write to disk' in edgy), op de laagste snelheid.
Maar bij het opstarten is er iets mis met xserver instellingen, hij kan gnome niet starten. Als ik dan 'startx' doe geeft hij ook een error, hij kan mijn beeldscherm niet vinden ofzo. Het gaat over een laptop.

Ik dacht, misschien toch een foutje bij het branden, maar ook met de alternate lukt het niet. Ik doorloop de hele installatie, maar dan bij het opstarten weer die xserver fout.

Niet door het branden dan? Mja, ik probeer het op een andere laptop hier en het lukt ook niet. Idd, ook dat van xserver.

Vreemd vind ik dit...
iemand die weet hoe dit komt?

De .iso's zijn trouwens gedownload van ubuntu.com, daar mag het dus niet aan liggen.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Feisty x server
« Reactie #1 Gepost op: 2007/04/21, 16:55:41 »
Als je opstart van de cd, kan je in het allereerste menu kiezen om de cd op fouten te controleren.
Als er geen fouten gevonden worden kan je doorgaan.

Druk na de foutmeldingen op control-alt-F2
Type het volgende commando in:
sudo dpkg-reconfigure -p high xserver-xorg

Kies bij de driver nv als je een nvidia kaart hebt, en ati als je een ati kaart hebt.
Bij de rest van de vragen die je krijgt kan je volgens mij gewoon op enter drukken.
Als dit klaar is type je het volgende commando in:
sudo /etc/init.d/gdm restart

Nu moet het wel gewoon werken.
Werkt het nog steeds niet, dan moet je weer het eerste commando uitvoeren, maar dan als driver "vesa" kiezen.

Offline Blackdrive

  • Lid
  • Steunpunt: Nee
Feisty x server
« Reactie #2 Gepost op: 2007/04/21, 18:00:00 »
ik controleer op fouten:
Citaat
check finished: no errors found
Press any key to reboot your system
als ik dan control-alt-F2 doe krijg ik een zwart scherm met knipperende cursor, maar ik kan niets typen.

als ik gewoon opstart en dan na de foutmelding die commando's ingeef:
na het eerste commando kan ik enkel de driver en schermresolutie ingeven (normaal moet je toch veel meer ingeven?) en dan zegt hij iets
Citaat
xserver-xorg postinst warning: overwriting possibly-customised configuration file; backup in ...
als ik de ati driver kies zegt hij wel dat 'start gnome' gelukt is, wordt het scherm een paar keer zwart (probeert gnome te laden?) maar hij geeft hij toch weer de error (zo'n blauw scherm)
Citaat
Failed to start the Xserver. It is likely that it is not set up correctly.Would you like to view the X server output to ...
het lijkt me dus dat ik jouw commando's inderdaad voor het eigelijke opstarten moet ingeven, maar hoe?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Feisty x server
« Reactie #3 Gepost op: 2007/04/21, 18:20:40 »
Als je je systeem helemaal opnieuw hebt opgestart, druk dan in het eerste menu op F4 en kies een veilige resolutie, 800x600 ofzo.
Kies daarna de bovenste optie: start or install ubuntu.

Dan moet de live cd gewoon opstarten

Krijg je dan weer die foutmeldingen, probeer het dan nog eens met control-alt-f2, en dan die commando's.
Kies dan de vesa driver

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Feisty x server
« Reactie #4 Gepost op: 2007/04/21, 18:22:55 »
Werkt het na het bovenstaande nog steeds niet, download en brand dan de alternate cd.
Met deze handleiding moet je er wel uit komen denk ik:
https://wiki.ubuntu.com/NlInstallatieHandleiding/Alternate
Let er wel op dat je de evt. partitie waar windows op staat niet verwijdert.

Offline Blackdrive

  • Lid
  • Steunpunt: Nee
Feisty x server
« Reactie #5 Gepost op: 2007/04/21, 18:36:46 »
Citaat van: blackdrive
Ik dacht, misschien toch een foutje bij het branden, maar ook met de alternate lukt het niet. Ik doorloop de hele installatie, maar dan bij het opstarten weer die xserver fout.
De alternate heb ik geprobeerd. Dat is net het vreemde, dat die ook dezelfde fout gaf.


Met mijn laaste cd probeer ik hem anders nog eens te branden op een andere manier :)
als dat niet lukt heb ik een probleem...

Offline Blackdrive

  • Lid
  • Steunpunt: Nee
Feisty x server
« Reactie #6 Gepost op: 2007/04/22, 02:46:30 »
Aw, de iso natuurlijk niet gebackuped.
Het zal voor maandag zijn.

Offline Blackdrive

  • Lid
  • Steunpunt: Nee
Feisty x server
« Reactie #7 Gepost op: 2007/04/22, 23:59:35 »
Ok, ik heb de iso opnieuw gedownload en deze keer gebrand in windows.
Resultaat: dezelfde fout

ik ben nogal ontgoocheld eigenlijk... dapper, edgy, beiden installeren wél goed. Waarom Feisty niet? Ga ik dan nooit van Ubuntu 7.04 kunnen genieten? Mijn laptop is nochtans recent. Ik weet het ook niet meer...

mijn vertrouwen in Ubuntu krijgt toch wel een ferme deuk nu

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Feisty x server
« Reactie #8 Gepost op: 2007/04/23, 02:30:29 »
Wat voor laptop heb je eigenlijk?
Zie je ook dezelfde problemen als je het typenummer van je laptop in google invoert in combinatie met feisty?
Staan daar ook oplossingen tussen?

DPC

  • Gast
Feisty x server
« Reactie #9 Gepost op: 2007/04/23, 09:03:33 »
Wordt je videokaart herkend als PCI of AGP?
Kijk eens met ¨lspci -v¨ of je videokaart daartussen staat?

Ik moet mijn kaart namelijk zelf op 02:09.0 zetten (via ¨dpkg-reconfigure xserver-xorg¨), aangezien mijn PCI kaart niet automatisch wordt herkend, en kom ook niet verder dan ¨Failed to start the Xserver¨ in dat geval.

02:09.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1) (prog-if 00 [VGA])
        Flags: bus master, VGA palette snoop, 66MHz, medium devsel, latency 248, IRQ 16

Offline Blackdrive

  • Lid
  • Steunpunt: Nee
Feisty x server
« Reactie #10 Gepost op: 2007/04/23, 11:44:41 »
Ik heb een Asus A6JA.
Er zit een ati X1600 mobility in.
Maar anders dan wat gebrabbel in vage talen vind ik niet veel op google :)

Ik zal nog eens installeren met de alternate, dan kan ik wel xserver-xorg configureren (zoals DPC zei).

Offline Blackdrive

  • Lid
  • Steunpunt: Nee
Feisty x server
« Reactie #11 Gepost op: 2007/04/23, 12:51:49 »
Een beetje dom nu, maar de output van lspci is te lang natuurlijk. Hoe zorg ik ervoor dat ik deze wel kan lezen?
In terminal kan je scrollen, maar hoe gaat dat in textmode?

agresionpower

  • Gast
Feisty x server
« Reactie #12 Gepost op: 2007/04/23, 13:04:48 »
Citaat van: blackdrive
Een beetje dom nu, maar de output van lspci is te lang natuurlijk. Hoe zorg ik ervoor dat ik deze wel kan lezen?
In terminal kan je scrollen, maar hoe gaat dat in textmode?
shift pageup/down

Offline Blackdrive

  • Lid
  • Steunpunt: Nee
Feisty x server
« Reactie #13 Gepost op: 2007/04/23, 13:25:18 »
dank je
ok, ze staat ertussen:
Citaat
01:00.0 VGA compatible controller: ATI Technologies Inc M56P [Radeon Mobility X1600] (prog-if 00 [VGA])
enz...
hoe zet ik hem dan op 01:00.0?
want PCI:01:00.0 is geen geldig formaat (en de paar variaties die ik geprobeerd heb ook niet :))

DPC

  • Gast
Feisty x server
« Reactie #14 Gepost op: 2007/04/23, 13:52:21 »
Probeer eens 01:00:00 of 01:00:0


Pierre1

  • Gast
Feisty x server
« Reactie #15 Gepost op: 2007/04/24, 20:52:14 »
Ik heb exact hetzelfde probleem met m'n dell inspiron met een x1400 mobility in.  
Ik heb het handmatig proberen in te stellen met het commando sudo dpkg-reconfigure -p high xserver-xorg maar dat heeft niets opgelost.  

Ik heb DPC's suggesties dan gevolgd en 'k heb gezien dat m'n videokaart inderdaad als PCI wordt herkend. Het commando dpkg-reconfigure xserver-xorg (zoals DPC aangeeft) werkt bij mij niet want hij zegt dat het als root moet uitgevoerd worden.  Zou er iemand suggesties en commando's kunnen geven zodat ik feisty eens kan testen?
Ik ben wel een linux noob dus het zou wel stap voor stap moeten uitgelegd worden:(

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Feisty x server
« Reactie #16 Gepost op: 2007/04/24, 21:00:19 »
sudo dpkg-reconfigure -p high xserver-xorg
Met het woord sudo er voor dus.
Dan krijg je geen foutmeldingen over dat je root moet zijn.

Pierre1

  • Gast
Feisty x server
« Reactie #17 Gepost op: 2007/04/24, 21:38:54 »
nog een vraagje.  als ik dan sudo dpkg-reconfigure -p high xserver-xorg ingeef moet ik een aantal configuratievragen invullen.  IK moet zo telkens OK drukken of iets kiezen en dan gaat hij verder.  Maar op een bepaald moment krijg ik een waarschuwing dat er een configuratiebestand gewijzigd wordt en dat er een backbestand op ... locatie staat.  Die melding gebeurt in de console onderdaan.  

Hoe kan ik dan terug verder gaan met het oplossen van die vraagjes?  En zo de configuratie afwerken?  Ik zit vanaf dat moment in de console en ik kan niet meer op OK/volgende klikken en verdergaan.  Is er een commando die mij uit de console en terug naar die configuratie brengt?

ps.  Linux wordt nu meer en meer genoemd als vervanger voor vista maar als ik al die problemen hier zie kan ik dat toch moeilijk geloven.  Dit probleempje heeft mij al een paar uur googelen en zoeken/experimenteren gekost:(

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Feisty x server
« Reactie #18 Gepost op: 2007/04/25, 04:00:46 »
Als je die melding krijgt heb je alle vragen beantwoord.
Nu kan je je computer opnieuw opstarten door sudo reboot in te typen.
De volgende keer dat je opstart zou alles gewoon moeten werken.