Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: geluidskaart wordt niet meer herkend  (gelezen 250 keer)

Offline neerke62

  • Lid
geluidskaart wordt niet meer herkend
« Gepost op: 2015/12/29, 13:58:00 »
Hallo,
Ik heb een nieuwe installatie uitgevoerd via 12.04LTS naar 14.04.3LTS . Na de installatie van 12.04 LTS, en de updates hiervan, wordt de geluidskaart van mijn oude Medion desktop nog herkend en heb ik ook gewoon geluid. Wel wordt aangegeven dat na okt. 2014 sommige hardware van mijn desktop niet meer wordt ondersteund.
Na de upgrade van 12.04 naar 14.04 werkt het geluid niet meer, ten minste als ik via kernel Linux 3.13.0-74-gen. opstart. Als ik via kernel 3.8.0-44-gen. opstart is er wel geluid.
Is er een mogelijkheid om de geluidsondersteuning van kernel 3.8.0-44 "over te zetten" naar kernel 3.13.0-74?
Indien dit niet mogelijk of te gecompliceerd is, is het dan mogelijk om de desktop standaard via kernel 3.8.0-44 te laten opstarten?
Type geluidskaart is VT8237A/VT8251

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: geluidskaart wordt niet meer herkend
« Reactie #1 Gepost op: 2015/12/29, 16:33:07 »
Neerke,

Neen, ja kan geen modules van kernel 3.8.x overplaatsen naar 3.13.x.

Wat ik heb gevonden over geluidskaart VT8237A/VT8251 en kernel 3.13.x zijn bugs meldingen.
Ubuntu 14.04.3 heeft ook de mogelijkheid om kernel 3.16.x - 3.19.x en 4.2.x te installeren.
Vooral als je je weg kent met synaptic pakkette beheerder.
De kans is groot dat het bij een nog hogere kernel weer is opgelost.

Het is mogelijk om standaard met kernel 3.8.x opstarten.
Dat is een kwestie van aanpassingen in GRUB, wat en waar moet ik helaas schuldig blijven.

PS:
Plaats eens de uitkomst van de onderstaande terminal opdracht.
Het zal voor velen hier meer inzicht geven wat in deze Medion zit en welke kernel-module er wordt geladen.
inxi -Fxz

Mocht inxi het nog niet zijn ge-installeerd:
sudo apt-get install inxi
MvG,
MauRice
Registered Linux user: 473556

Offline neerke62

  • Lid
Re: geluidskaart wordt niet meer herkend
« Reactie #2 Gepost op: 2015/12/30, 10:27:36 »
Hallo MauRice2

bedankt voor je reactie. Ik had al zo'n vermoeden dat niets overgeplaatst kon worden.  bijgevoegd de uitkomst van de inxi-opdracht.

ik heb er nu weer een probleem bij, het opstarten via 3.8.0-44-generic lukt niet meer. ik krijg wel het inlogscherm maar zodra ik het wachtwoord heb ingevoerd probeert ie door te starten maar komt dan weer terug bij het inlogscherm.  :(

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: geluidskaart wordt niet meer herkend
« Reactie #3 Gepost op: 2015/12/30, 16:18:25 »
Neerke,

Zit er toevalig ook een TV-kaart ontvanger in deze PC.

Citaat
Audio:     Card: VIA VT8237A/VT8251 HDA Controller driver: SAA7134 bus-ID: 04:01.0 Sound: ALSA ver: k3.13.0-74-generic

De driver saa7134 is voor zo'n TV-kaart ontvanger.
Als je deze niet nodig heb, haal die eruit en kijk dan eens of je dan geluid heb.

Deze TV-kaart ontvanger zal hoogst waarschijnelijk via een /etc/modprobe.d/saa7134.conf bestand aan de praat te krijgen zijn....
Een nadeel er zijn wel 10-tallen verschillenden typen.
Misschien haal via dmesg welke type je exact heb:
dmesg | grep saa7134

Voorbeeld van zo'n  saa7134.conf bestand voor een type kaart (9):
# TV-card kernel configuration file

options saa7134 card=9 audio_clock_override=0x200000
MvG,
MauRice
Registered Linux user: 473556

Offline neerke62

  • Lid
Re: geluidskaart wordt niet meer herkend
« Reactie #4 Gepost op: 2015/12/31, 14:27:48 »
MauRice2,

Ik heb de tv-kaart losgekoppeld maar dit had niet het gewenste resultaat; geen geluid in 3.13.0-74.

het resultaat van dmesg | grep saa7134 is:

[   30.377444] saa7134 ALSA driver for DMA sound loaded
[   30.448077] saa7134 0000:07:09.0: DVB: registering adapter 0 frontend 0 (Philips TDA10046H DVB-T)...
Ik weet niet wat ik hier nu verder mee kan  :(

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: geluidskaart wordt niet meer herkend
« Reactie #5 Gepost op: 2015/12/31, 15:57:57 »
In principe zou een tv-kaart geen invloed behoren te hebben op de geluidskaart. (Ikzelf heb namelijk nog een oude pc liggen, met een SAA7134  tv-kaart. Waarvan het geluid gewoon werkt. Daar had ik alleen een probleem mee in 2005. Dus niet met (X)ubuntu 14.04.)

Omdat in je inxi ouput geen geluidskaart wordt getoond, zou je ook nog de output kunnen posten van terminalcommando
sudo lshw -c multimedia [Enter]

Verder zou je nog uit deze Ubuntu Sound Troubleshooting stap 1 t/m 6 kunnen checken.
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: geluidskaart wordt niet meer herkend
« Reactie #6 Gepost op: 2015/12/31, 16:02:40 »
MauRice2,

Ik heb de tv-kaart losgekoppeld maar dit had niet het gewenste resultaat; geen geluid in 3.13.0-74.

het resultaat van dmesg | grep saa7134 is:

[   30.377444] saa7134 ALSA driver for DMA sound loaded
[   30.448077] saa7134 0000:07:09.0: DVB: registering adapter 0 frontend 0 (Philips TDA10046H DVB-T)...
Ik weet niet wat ik hier nu verder mee kan  :(

Neerke,

Niet echt zo 123(45).
Maar als alleen dit twee regel zijn, vermoed ik dat de TV-kaart ontvanger goed herkent wordt.
Dan heb je dus twee geluids kaarten eentje van de TV-kaart en de geluids-kaart zelf.
Kan zijn dat de geluids kaart nu op 'tweede' zit ipv 'eerste'.
Kijks eens bij de geluids instellingen hoe het een en ander precies zit.

Wat ik nog extra heb gevonden, hopen dat uw Duits beter is dan van mij:
https://forum.ubuntuusers.de/topic/vt8237a-vt8251-hda-kein-sound/

Kijks een ook welke kernel-module's geladen zijn, terminal opdracht:
lsmod
Vooral die voor geluid, deze beginnen met snd
Als daar tussen snd_hda_intel staat, kijks eens of je hiermee ook geholpen wordt:
https://sites.google.com/site/computertip/geengeluid



MvG,
MauRice
Registered Linux user: 473556

Offline neerke62

  • Lid
Re: geluidskaart wordt niet meer herkend
« Reactie #7 Gepost op: 2016/01/03, 10:50:06 »
MauRice2,

Bedankt voor de link naar het duitse forum.
Ik heb de daarin beschreven opdrachten uitgevoerd en na het herstarten werkte het geluid.

De opdrachten waren:
~$: cat /proc/asound/cards
~$: dmesg | egrep -i "snd|hda|vt8"
~$: sudo bash -c "echo 'snd-hda-intel single_cmd=1' >> /etc/modules"

na het herstarten heb ik nog de volgende opdrachten uitgevoerd:
~$: dmesg | egrep -i "snd|hda|vt8"
~$: cat /proc/asound/cards
Nu werden alle aanwezige geluidskaarten zichtbaar.

De vragensteller op het duitse forum gaf aan dat na updates het geluid weer weg kan zijn maar na het uitvoeren bovenstaande opdrachten was dat dan weer snel hersteld.

Nogmaals bedankt voor je hulp en het uitgebreid zoeken naar een oplossing. :)


Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: geluidskaart wordt niet meer herkend
« Reactie #8 Gepost op: 2016/01/03, 11:27:33 »
Neerke,

De beste wensen voor 2016.
Geen dank graag gedaan.

Persoonlijk zal ik het opladen van kernel-module snd-hda-intel met parameter niet via /etc/modules
Citaat
sudo bash -c "echo 'snd-hda-intel single_cmd=1' >> /etc/modules"
Maar eerder via een conf bestandje in /etc/modprobe.d/...
Bijvoorbeeld geluid.conf, met daarin:
options snd-hda-intel single_cmd=1

Aanmaken van en het bestandje:
gksu gedit /etc/modprobe.d/geluid.conf
Kopieer en plak de boven genoemde regel, opslaan.

Aanpassen en herstellen van /etc/modules, dus verwijderen van die regel "snd-hda-intel single_cmd=1"
gksu gedit /etc/modules
Opslaan en herstarten.

Hiermee ben ik 99,99% zeker van dat bij een update het blijft werken.
Het bestand /etc/modules wordt meestal gebruikt om kernel-module zonder extra parameters
die niet standaard worden geladen te laden.
Met parameters wordt er in algemeen gebruikt gemaakt via een conf bestand in /etc/modprobe.d/...
En aangezien het een exotische naam heeft 'geluid.conf' zal het niet 123(45) overschreven en/of aangepast worden bij een update.
MvG,
MauRice
Registered Linux user: 473556

Offline neerke62

  • Lid
Re: geluidskaart wordt niet meer herkend
« Reactie #9 Gepost op: 2016/01/03, 17:36:38 »
MauRice2,

Jij, en alle andere forumlezers, ook de beste wensen voor een gezond 2016.

Ik heb je raad opgevolgd en de voorgestelde aanpassingen uitgevoerd. Alles blijft naar behoren werken. Beetje bij beetje wordt ik wat meer wegwijs in Ubuntu en wordt de drempel iets lager.

Nogmaals bedankt voor je hulp.