Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: netwerkaart disabled  (gelezen 363 keer)

netwerkaart disabled
« Gepost op: 2015/12/19, 12:16:28 »
hulp gevraagd.

waarom laat ubuntu server maar 1 netwerkkaart toe
een tweede netwerkkart gekocht en in de server gezet opnieuw opgestart is  deze gedisabled??
google me al helemaal wezenloos om een oplossing te vinden

opdat de server nog maar niet geinstaleerd was maar nog niet geconfigureerd heb ik deze maar helemaal opnew laten instaleren
wat blijkt? de oorsprongkelijke netwerk kaart is nu disabled en die nieuwe doet het?
heb al vanalles geprobeerd.
weet iemand raad?

hier wat info en  details van het probleem---------------------------------------------------------------------------------------------------
sudo lshw -C network
[sudo] password for poweruser:
*-network DISABLED <<---------- this is de problem!!
description: Ethernet interface
product: NetXtreme BCM5755 Gigabit Ethernet PCI Express
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:3f:00.0
logical name: eth1
version: 02
serial: 00:1c:c4:66:5c:5d
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.137 firmware=5755-v3.17 latency=0 link=no multicast=yes port=twisted pair
resources: irq:19 memory:d8400000-d840ffff
*-network
description: Ethernet interface
product: RTL8169 PCI Gigabit Ethernet Controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 9
bus info: pci@0000:07:09.0
logical name: eth0
version: 10
serial: 00:e0:53:17:58:1f
size: 1Gbit/s
capacity: 1Gbit/s
width: 32 bits
clock: 66MHz
capabilities: pm bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.2.139 latency=64 link=yes maxlatency=64 mingnt=32 multicast=yes port=MII speed=1Gbit/s
resources: irq:21 ioport:1100(size=256) memory:d8b00000-d8b000ff memory:80000000-8001ffff
poweruser@mainserver:~$
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
poweruser@mainserver:~$ lspci -nnk | grep -i net -A2
07:09.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8169 PCI Gigabit Ethernet Controller [10ec:8169] (rev 10)
Subsystem: Realtek Semiconductor Co., Ltd. RTL8169/8110 Family PCI Gigabit Ethernet NIC [10ec:8169]
Kernel driver in use: r8169
3f:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5755 Gigabit Ethernet PCI Express [14e4:167b] (rev 02)
Subsystem: Hewlett-Packard Company DC5750 Microtower [103c:280a]
Kernel driver in use: tg3
poweruser@mainserver:~$
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
poweruser@mainserver:~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether 00:e0:53:17:58:1f brd ff:ff:ff:ff:ff:ff
inet 192.168.2.139/24 brd 192.168.2.255 scope global eth0
valid_lft forever preferred_lft forever
inet6 fe80::2e0:53ff:fe17:581f/64 scope link
valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether 00:1c:c4:66:5c:5d brd ff:ff:ff:ff:ff:ff
poweruser@mainserver:~$
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
poweruser@mainserver:~$ sudo ifup eth1
Ignoring unknown interface eth1=eth1.
poweruser@mainserver:~$
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
dmesg | grep eth
[ 0.170472] reboot: HP Compaq Laptop series board detected. Selecting BIOS-method for reboots.
[ 0.192528] ACPI Error: Method parse/execution failed [\_SB_.PCI0._OSC] (Node ffff8800754a2b18), AE_ALREADY_EXISTS (20141107/psparse-536)
[ 1.950198] r8169 0000:07:09.0 eth0: RTL8169sb/8110sb at 0xffffc900044cc000, 00:e0:53:17:58:1f, XID 10000000 IRQ 21
[ 1.950209] r8169 0000:07:09.0 eth0: jumbo features [frames: 7152 bytes, tx checksumming: ok]
[ 2.026708] tg3 0000:3f:00.0 eth1: Tigon3 [partno(BCM95755) rev a002] (PCI Express) MAC address 00:1c:c4:66:5c:5d
[ 2.026725] tg3 0000:3f:00.0 eth1: attached PHY is 5755 (10/100/1000Base-T Ethernet) (WireSpeed[1], EEE[0])
[ 2.026730] tg3 0000:3f:00.0 eth1: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] TSOcap[1]
[ 2.026735] tg3 0000:3f:00.0 eth1: dma_rwctrl[76180000] dma_mask[64-bit]
[ 12.592613] r8169 0000:07:09.0 eth0: link down
[ 12.592665] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 12.592955] r8169 0000:07:09.0 eth0: link down
[ 16.084880] r8169 0000:07:09.0 eth0: link up
[ 16.084899] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
poweruser@mainserver:~$
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
poweruser@mainserver:~$ inxi -xF
System: Host: mainserver Kernel: 3.19.0-25-generic x86_64 (64 bit, gcc: 4.8.2) Console: tty 0 Distro: Ubuntu 14.04 trusty
Machine: System: Hewlett-Packard product: HP Compaq dc5750 Small Form Factor
Mobo: Hewlett-Packard model: 0A64h Bios: Hewlett-Packard version: 786E3 v02.22 date: 04/18/2007
CPU: Dual core AMD Athlon 64 X2 4400+ (-MCP-) cache: 1024 KB flags: (lm nx sse sse2 sse3 svm) bmips: 3990.2
Clock Speeds: 1: 1000.00 MHz 2: 1000.00 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] RS482/RS485 [Radeon Xpress 1100/1150] bus-ID: 01:05.0
X-Vendor: N/A driver: N/A tty size: 238x61 Advanced Data: N/A out of X
Audio: Card: Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel bus-ID: 00:14.2
Sound: Advanced Linux Sound Architecture ver: k3.19.0-25-generic
Network: Card-1: Broadcom NetXtreme BCM5755 Gigabit Ethernet PCI Express driver: tg3 ver: 3.137 bus-ID: 3f:00.0
IF: eth1 state: down mac: 00:1c:c4:66:5c:5d
Card-2: Realtek RTL8169 PCI Gigabit Ethernet Controller driver: r8169 ver: 2.3LK-NAPI port: 1100 bus-ID: 07:09.0
IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 00:e0:53:17:58:1f
Drives: HDD Total Size: 2000.4GB (0.1% used) 1: id: /dev/sda model: WDC_WD20EZRX size: 2000.4GB temp: 29C
Partition: ID: / size: 1.8T used: 1.7G (1%) fs: ext4 ID: /boot size: 236M used: 80M (36%) fs: ext2
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: System Temperatures: cpu: 21.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 109 Uptime: 1:56 Memory: 180.6/1873.9MB Runlevel: 2 Gcc sys: N/A
Client: Shell (bash 4.3.11) inxi: 1.9.17
poweruser@mainserver:~$
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
poweruser@mainserver:~$ cat /etc/udev/rules.d/70-persistent-net.rules
# This file was automatically generated by the /lib/udev/write_net_rules
# program, run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single
# line, and change only the value of the NAME= key.
# PCI device 0x10ec:0x8169 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:e0:53:17:58:1f", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
# PCI device 0x14e4:0x167b (tg3)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:1c:c4:66:5c:5d", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"
poweruser@mainserver:~$
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Moderator edit: code tags geplaatst
« Laatst bewerkt op: 2015/12/19, 16:33:01 door Ron »

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: netwerkaart disabled
« Reactie #1 Gepost op: 2015/12/19, 16:17:15 »

poweruser@mainserver:~$ sudo ifup eth1
Ik denk dat je hebt vergist in het commando. Dat  zou moeten zijn
sudo ifconfig eth1 up [Enter]

Als dat werkt, zou je de tweede netwerkkaart kunnen inschakelen via  /etc/network/interfaces

Voor een dynamisch IP adres

auto eth1
iface eth1 inet dhcp

Een voorbeeld van en statisch IP adres, vind je in http://www.howtogeek.com/howto/ubuntu/change-ubuntu-server-from-dhcp-to-a-static-ip-address/
Die zou je dan wel moeten aanpassen voor jouw netwerk.
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro