Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: iptables configureren voor dansguardian  (gelezen 2183 keer)

Offline Marc Duval

  • Lid
  • Steunpunt: Nee
iptables configureren voor dansguardian
« Gepost op: 2007/04/12, 22:17:55 »
Ik probeer mijn kinderen een beetje opgekuist internet aan te bieden met iptables, squid en dansguardian.

In een howto die ik vond moet ik iptables.conf aanpassen, maar die vind ik nergens.

Iemand een idee?

De howto's waar ik mee werk zijn:
http://software.newsforge.com/software/04/06/23/1521209.shtml?tid=2&tid=82&tid=90&tid=92&tid=94
en
http://www.kathmannlabs.net/mediawiki/index.php/Dansguardian_Ubuntu_Linux_Install_how-to

koos

  • Gast
iptables configureren voor dansguardian
« Reactie #1 Gepost op: 2007/04/12, 22:38:17 »
als ik in terminalvenster gedit iptables-config doe krijg ik een tekstbestand, maar is helemaal leeg.
als je wat moet veranderen zul je hem als root moeten openen, dus:
sudo iptables-config

ik vermoed dat je het zo moet doen.

Offline Marc Duval

  • Lid
  • Steunpunt: Nee
iptables configureren voor dansguardian
« Reactie #2 Gepost op: 2007/04/12, 22:40:38 »
command not found krijg ik dan

iptables is geïnstalleerd, dat heb ik nagekeken, maar ik weet niet waar de iptables.conf staat

koos

  • Gast
iptables configureren voor dansguardian
« Reactie #3 Gepost op: 2007/04/12, 22:43:09 »
het is iptables-conf met een streepje

Offline Marc Duval

  • Lid
  • Steunpunt: Nee
iptables configureren voor dansguardian
« Reactie #4 Gepost op: 2007/04/12, 22:55:13 »
root@Duron950:/# sudo iptables-config
sudo: iptables-config: command not found
root@Duron950:/#

koos

  • Gast
iptables configureren voor dansguardian
« Reactie #5 Gepost op: 2007/04/12, 22:56:35 »
sorry,

sudo gedit iptables-config

Offline Marc Duval

  • Lid
  • Steunpunt: Nee
iptables configureren voor dansguardian
« Reactie #6 Gepost op: 2007/04/12, 23:00:06 »
Ik heb al ontdekt dat een aantal settings in squid niet meer werken in de nieuwe versie 2.6 die bij feisty zit.

Nu nog zorgen dat de gebruiker squid schrijftoegang krijgt tot /var/log/squid/access.log.

De owner en group van die map zijn root en root. Zou het een oplossing zijn als ik de gebruiker squid lid maak van de groep root, en hoe doe ik dat? Ik zie dat in het gebruikersbeheer van ubuntu alleen de gewone gebruikers worden weergegeven.

koos

  • Gast
iptables configureren voor dansguardian
« Reactie #7 Gepost op: 2007/04/12, 23:36:29 »
sorry, ik ben enige gebruiker van deze comp, heb me daar dus nooit in verdiept.

Offline Pieterjan2

  • Lid
    • http://
  • Steunpunt: Nee
iptables configureren voor dansguardian
« Reactie #8 Gepost op: 2007/04/13, 21:34:11 »
iptables-config is een Fedora specifiek command volgens mij ... check je rulez met iptables -L op Ubuntu

Ge kunt ook chown -R squid:squid /var/log/squid doen.. dan is gebruiker squid hier eigenaar van ...

Ma waarom werkt ge gewoon nie mee squid en de acl's?

Offline Marc Duval

  • Lid
  • Steunpunt: Nee
iptables configureren voor dansguardian
« Reactie #9 Gepost op: 2007/04/13, 23:42:42 »
wat bedoel je met squid en de acl's?

Offline Pieterjan2

  • Lid
    • http://
  • Steunpunt: Nee
iptables configureren voor dansguardian
« Reactie #10 Gepost op: 2007/04/14, 09:46:00 »
awel, ge wilt bv. da uw kleine nie meer naar sex.com kan surfen bijvoorbeeld ;)

Ergens in uw /etc/squid.squid.conf is er een acl sectie,
acl bannedsite url_regex sex.com

En dan zet ge in http_acces sectie dit:
http_acces deny bannedsite